Jetzt kostenlos registrieren: Mitglieder surfen ohne Werbung!

Aktivierung des Root-Accounts

  • 90 Antworten
  • Neuester Beitrag
Diskutiere Aktivierung des Root-Accounts im Samsung Galaxy Young 2 (Duos) (S6310/S6310N) Forum im Bereich Weitere Samsung Geräte.
M

Moderith

Neues Mitglied
Hallo liebe Community,
Ich habe folgendes Problem:
Ich wollte mein Gerät rooten über Odin 3 mit der recovery.tar.md5 Datei.
Ich habe USB-Debugging Häkchen gesetzt. Bin dann in den Download Modus vom Handy, Odin hat es erkannt. Hab die folgende Datei angegeben und auf Start. Das Programm fängt an aber mein Handy kommt nach 5 Sekunden mit der Nachricht Signatur sivication failured oder sowas... dann fährt es herunter und startet neu... Wenn ich Jetzt wieder in den Download Modus gehe steht da noch dabei : CUSTOM BINARY DOWNLOAD: YES ( 7 counts) (mittlerweile) aber es bricht immer ab und tut sich nichts, Das Gerät lässt sich weiterhin normal benutzen. Ich habe diese Anleitung aus YouTube wo jemand das mit genau dem Gerät gemacht hat ich habe alles nachgemacht und bei ihm klappt's bei mir nicht.. Da ich keine Ahnung habe was ich machen soll um das Gerät zu rooten dachte ich das ihr mit evt helfen könntet.
Danke im Voraus! :thumbsup:

Hier noch der Link zu diesem Video:
 
Zuletzt bearbeitet von einem Moderator:
C

chess

Erfahrenes Mitglied
hey,
wenn ichs richtig verstehe ist das Rooten beim Young 2 nicht so easy wie beim alten Young?
gibts inzw eine zuverslääsige einfache Methode zum rooten?
vg
chess
 
E

email.filtering

Gast
Da es keine .zip-Datei fürs Samsung-Minibetriebssystem gibt und framaroot offensichtlich doch nicht funktioniert (vielleicht klappt es ja mittlerweiel mit den neueren Versionen), wird man wohl ein Minibetriebssystem der Community (wie z.B. den ClcokworkMod) flashen müssen.
 
G

Gernum

Neues Mitglied
Hallo,

ich habe das gleiche Problem wie Moderith.
Ich besitze ein GT-S6310N mit Android 4.1.2
Ich habe bisher insgesammt 8 mal versucht CWM zu flashen wie im 1.Post (und auf diversen anderen Seiten) beschrieben. Laut Odin wird die Instalation auch erfolgreich abgeschlossen, das Handy zeigt alerdings "signature verification failed" an, versuche ich nun durch drücken von Vol.Up + Power + Home ins CWM recovery zu gelangen lande ich immer wieder im "normalen" Android recovery ...
vielleicht hat ja hier wer ne Lösung für mein Problem :)

Schonmal Danke im Voraus
Gernum
 
E

email.filtering

Gast
Ruf doch bitte man *#1234# an und gib das Ergebnis durch.
 
G

guenni1404

Neues Mitglied
Hallo,

ich habe das gleiche Problem wie Gernum.
Beim flashen gibt es die Meldung "signature verification failed".
Die Daten vom Gerät sind:
AP: S6310NXXAMK1
CP: S6310NXXAMK1
CSC: S6310NOXXAMK1

Vielleicht kann mir einer helfen.
 
E

email.filtering

Gast
Keine Ahnung welche .zip-Datei Du da per Minibetriebssystem einspielen wolltest, aber wenn diese nicht von Samsung signiert wurde, wird daraus ohnedies nichts werden. Es sei denn, Du flashst vorab ein Minibetriebssystem der Community, z.B. den ClockworkMod.
 
T

Thorium

Neues Mitglied
Hallo Leute.
Ich lese schon ein paar Monate mit und hab mit Hilfe des Forums schon nein Galaxy Tab2 gerootet.
Danke schon mal dafür! !!!

Leider klappt es beim Handy garnicht.

Mit Odin3 hab ich das recovery aufgespielt und komme auch in das Menü.

Aber ich kann dann die superuser.zip nicht auswählen

Ein reboot im recovery Menü hab ich schon gemacht, aber iwas läuft falsch
 
E

email.filtering

Gast
Was genau hast Du mit Odin geflasht und wie äußert sich die Tatsache mit der Nichtauswählbarkeit der .zip-Datei?


Ach ja, und herzlich willkommen im Forum!
 
T

Thorium

Neues Mitglied
vorgegangen nach dieser Seite und den Dateien von dort
[GT-S6310/6312]ClockworkMod "6" by… | Android Development and Hacking | XDA Forums

Also, ich hab mit Odin3 die "recovery.tar.md5" draufgezogen.
Dann mit Vol UP+Home+Power in den Recovery Modus und wollte die Supersu.zip von der SD laden

Die datei ist sowohl auf der SD Karte, als auch auf dem Handy selbst im Grundverzeichnis.

Mein Handy steht genau im Profil, bei DL.-Modus steht

ODIN3
Product: GT-S6310N
VERSION:
HW REV:4
Custom Binary Download Yes (4)
Current Binary Custom
System Status Custom


Odin schrieb
<ID:0/003> Added!!
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> recovery.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/003> Odin v.3 engine (ID:3)..
<ID:0/003> File analysis..
<ID:0/003> SetupConnection..
<ID:0/003> Initialzation..
<ID:0/003> Get PIT for mapping..
<ID:0/003> Firmware update start..
<ID:0/003> recovery.img
<ID:0/003> NAND Write Start!!
<ID:0/003> Transmission Complete..
<ID:0/003> Now Writing.. Please wait about 2 minutes
<ID:0/003> Receive Response from boot-loader
<ID:0/003> RQT_CLOSE !!
<ID:0/003> RES OK !!
<ID:0/003> Completed..
<ID:0/003> Added!!
<OSM> All threads completed. (succeed 1 / failed 0)
<ID:0/003> Removed!!
 
E

email.filtering

Gast
Wie es aussieht, hat das Flashen ja geklappt und der ClockworkMod scheint auch der passende zu sein.

Also sollte das Booten ins Minibetriebssystem (mit Power & Home & Volume up) ja klappen, und wenn die .zip-Datei auch im Stammverzeichnis der (externen) Speicherkarte liegt, sollte auch deren Auswahl möglich sein.
 
T

Thorium

Neues Mitglied
Die .Zip liegt sowohl im stammverzeichnis der SD als auch vom Phone, also da wo die Ordner wie "android" sind, eben ohne Ordner, sondern als einzelne Datei

Aber ich kann nichts auswählen, wenn ich auf install zip von SD gehe.
da kommt nur
../

und unten in rot


E:unknown volume for path [/sdcard]
 
E

email.filtering

Gast
Gibt's vielleicht auch einen weiteren Punkt mit dem man eine .zip-Datei einspielen könnte (z.B. wenn man sie in update.zip umbenennt)?
 
T

Thorium

Neues Mitglied
Hab ein
-wipe data/factory reset-
gemacht und danach mit odin3 noch mal die recovery geflasht.

dann hats funktioniert, konnte die supersu.zip auf sd laden und habs nun gerootet
 
Zuletzt bearbeitet:
M

mausbln1991

Neues Mitglied
Hey

ich habe vorgestern mein Handy zurückgesetzt und dann mittels framaroot gerootet. Das hat super funktioniert.

da es andere probleme gab, habe ich gedacht, dass ich beim zurücksetzen nen fehler gemacht habe und hab es erneut zurückgesetzt.
aber seitdem kann ich mit framaroot nicht mehr rooten.

Ich habe SuperSu ausgewählt und dann auf gandalf geklickt.
Die Bestätigung, dass es geklappt hat, kam auch, dann habe ich neu gestartet, aber nichts ist passiert.

Woran kann das liegen?
Android-Version ist 4.1.2, das war beim letzten mal aber auch so...

Könnt ihr mir helfen?
 
E

email.filtering

Gast
Was hast Du bitte genau gemacht? :confused:

Ein factory reset (bisweilen auch als "Zurücksetzen auf die Werkseinstellungen" bezeichnet) formatiert schließlich nur die Cache- und Datenpartition, greift die Systempartition (mit dem darin befindlichen, allfällig bereits aktivierten Root-Account) aber gar nicht an!

Wenn überhaupt, muss also nach einem factory reset also noch die Root-Rechteverwaltungsapp (meist weisen diese Bezeichnungen wie SuperSU, Superuser usw. auf) installiert werden (natürlich nur dann, wenn diese nicht in die Systempartition integriert wurde) um den nach wie vor aktivierten Root-Account nutzen zu können.

Hast Du hingegen die (Gesamt)Software (erneut) geflasht, dann ist von den vorangegangenen Veränderungen an der Systempartition natürlich nichts mehr geblieben.

BTW, ein Anruf bei *#1234# verrät Dir welche drei Einzelkomponenten der (Gesamt)Software auf Deinem Gerät derzeit installiert sind. Solche Angaben erleichtern das Mitdenken der anderen bei Deinen Problemen meist ganz enorm.


Ach ja, und herzlich willkommen im Forum!
 
M

mausbln1991

Neues Mitglied
HEy

Danke für die schnelle Rückmeldung
also dann denke ich habe ich nur einen Factory-Reset gemacht...
Einstellungen -> sichern und zurücksetzen -> Aud werkseinstellungen zurücksetzen

Die Rückgabe bei *#1234# :
AP: S6312XXAMI1
CP: S6312XXAMD1
CSC: S6312XXAMJ1

hilft das?
Ich habe jetzt mal einen Root-Checker installiert (von joeykrim, 1. bei der play Store suche)
Der sagt: Sorry this device does not have root access
 
Zuletzt bearbeitet:
E

email.filtering

Gast
Wie bzw. womit hast Du vor dem factory reset den Root-Account aktiviert? Und hast Du nach dem factory reset immer noch die Root-Rechteverwaltungsapp in der App-Übersicht? Falls nicht, hast Du diese schon installiert? (Da das su-Binary und die Root-Rechteverwaltungsapp jeweils auf einander abgestimmt sein müssen, musst Du natürlich die selbe App installieren die zuvor drauf war.)

Ach ja, und wenn es beim ersten Mal mit framaroot geklappt hat, dann muss es das auch dieses Mal. Vorausgesetzt natürlich, dass sich zwischenzeitlich an der (Gesamt)Software nichts getan hat.
 
M

mausbln1991

Neues Mitglied
Hey
Ich habe über die Einstellungen resettet.

Framaroot war nicht mehr drauf, hab ich uber dieselbe apk Installiert.
Vorher ging das super und jetzt gehts.nicht mehr :(
 
E

email.filtering

Gast
Hast Du denn auch sicher zwischen der seinerzeitigen Nutzung von framaroot und dem jetzigen Versuch keine Aktualisierung an der (Gesamt)Software vorgenommen?