Nandroid Backup Sony / Fragen / Probleme

  • 8 Antworten
  • Neuester Beitrag
Diskutiere Nandroid Backup Sony / Fragen / Probleme im Sony Allgemein im Bereich Sony Forum.
A

Android beta gama D

Gast
Hi
Hab da mal ne Frage mir selber ist es schon passiert das ich von einer Custom ROM ein Nandroid Backup gemacht hab, und bei meinem ZL nach dem Herstellen des Backups die IMEI weg war.
Neu flashen der C-ROM hilft immer diese wieder zu bekommen, und auch Stock flashen hilft immer.
Nur die Frage die ich jetzt hab, da es auch schon beim Z der Fall war und auch beim ZL scheinbar vor kommt.
Warum ist das so ?
Egal wie man versucht das Backup einzuspielen es endet damit das die IMEI weg ist.
Die meisten Custom Roms benutzen alle CWM ist das ein Bug in der Recovery ? Vielleicht hat da ja jemand einen Tipp.
Und gibt es irgendwie ne möglichkeit das Recovery mal zu Updaten ? Auf denn Seiten von TWRP und CWM gibts nix fürs ZL.

Hier ein Beispiel denkfehler irgendwo drin ? https://www.android-hilfe.de/forum/...nach-restore-eines-backup-aus-cwm.566308.html
 
Zuletzt bearbeitet von einem Moderator:
Aaskereija

Aaskereija

Inventar
Direkte updates für die Recoverys wirds nicht geben denk ich mal weil jede Recovery an dessen Rom angepasst wird. Z.b. munjenis Touch-CWM ist wieder keine offizielle und funktioniert auch nur in verbindung mit seinen CM-Roms.

Und zum Thema IMEI... kann ich leider nicht viel sagen. Ist scheinbar ein Z-Reihe spezifisches Problem da ich sowas bei meinen 3 Sonys nie feststellen konnte.

Denke da aber weniger an einen Bug der Recovery als an einen Bug der Rom, das dort die IMEI nicht ordentlich deklariert oder richtig eingebunden ist.
 
A

Android beta gama D

Gast
Hm
Wie gesagt die IMEI ist bei allen Roms da es läuft alles. Erstellt man sich dann ein Nandroid davon, für später und man will es einspielen macht er das auch nur das dann keine IMEI mehr vorhanden ist was ich sehr seltsam finde.
Dann wäre das ja ein Bug in jeder Rom mit CWM beim ZL, glaub da er an einen Recovery Bug.
Naja ich kann mit leben, aber hätte das gerne anderen erspart das es dazu kommt.
 
G

girouno

Gast
Wenn ich das richtig überblicke, dann liegt die IMEI in der Trim Area, also eine Art versteckten Partition. CWM scheint dann beim Rückspielen dafür zu sorgen, dass auf die TA kein Zugriff mehr erfolgt (falsches Mounten? Keine Ahnung). Da SUS die TA m.W. nach nicht (niemals!) neu schreibt, erscheint es ausgeschlossen, dass die IMEI in solchen Fällen tatsächlich gelöscht und durch SUS wiederhergestellt wird. Also wäre das m.E. wahrscheinlich ein CWM-Bug.
 
A

Android beta gama D

Gast
Aha TA hab ich nämlich nicht gesichert, weil die mich nicht interessiert hat. Ok das bestätigt mein Eindruck davon das es ne CWM Macke ist.
Wie es mi TWRP aussieht weiß ich noch nicht, weil da hab ich es noch nicht versucht, und vor allem nutzen es nur ich glaub 2 Custom Roms.
Also nutzt es eigentlich hin wie her nix ein Backup zu machen da dies eh beschädigt erstellt wird zumindest bei CWM :winki:
 
G

girouno

Gast
naja, das direkte Einspielen macht wenig Sinn. Aber ein solcher Backup ließe sich ja zumindest wieder extrahieren um dann Apps oder Daten wieder manuell herauszufischen. Das ist deutlich weniger, als es sein sollte aber doch immer noch mehr als nichts.
 
A

Android beta gama D

Gast
Naja dann schenk ich mir das, weil die Apps hab ich als APK in einem Ordner auf der Speicherkarte gesichert :D
Außer die gekauften muss ich immer neu aus dem Playstore ziehen da hat sich die APK nicht sichern lassen.
Wie gesagt ich kann mit leben, hätte nur gerne ne Lösung für andere gehabt die sich da sicher drüber Ärgern werden.
 
TimeTurn

TimeTurn

Inventar
Ich hab jetzt zwar nbicht alle Antworten gelesen - von der Logik her macht aber folgendes Szenario sinn:

  • Du machst vom System ein Nandroid
  • Sony veröffentlicht ein Update, verändert darin aber das Modem derart, das ein altes System damit nicht mehr zurechtkommt. So war es etwa auch beim Update von Android 4.3 auf 4.4 beim Z Ultra.
  • Du speilst das Update ein, befindest es aber für Schrott
  • Du spielst das alte System ein per Nandroid (kein Modem mit drin), zack: keine IMEI, u.U. auch kein BT, WLAN, NFC, GPS
 
A

Android beta gama D

Gast
Es ging da nicht ums Stock sondern das passiert wenn man ein Nandroid zum Beispiel von ParanoidAndroid macht.
Probiert man was anderes und es gefällt einem nicht, und man geht zu PA zurück will aber sein Backup einspielen ist die IMEI weg.
Aber nur wenn man das Backup herstellen will sonst bei überhaupt nix. Das ist bei CM 11 so das ist bei PA so.
Scheinbar all bei denen die das CWM nutzen.

Edit: So hab jetzt mal ein Backup von meiner Omni die TWRP nutzt wiederhergestellt, und was soll ich sagen das läuft kein IMEI Problem also spinnt das CWM von der PA Rom so wie von CM 11
 
Zuletzt bearbeitet von einem Moderator: