1. krebs8, 07.05.2018 #1
    krebs8

    krebs8 Threadstarter Fortgeschrittenes Mitglied

    Mein st18i hat die Firmware 4.1.b.0.587 (Android 4.0.4), Bootloader ist unlocked und es ist gerootet.
    Habe verschiedene Anleitungen (auch hier) gefunden und versucht, bin aber immer gescheitert.
    Irgend eine Software o. Treiber gibt es meist nicht mehr o. funktionieren anders, PC Companion ist nicht online oder ähnliches. Aber es müßte doch immer noch gehen.

    Hat es jemand in letzter Zeit geschafft, diese o. eine andere Custom ROM zu installieren ?
     
    Zuletzt bearbeitet: 07.05.2018
  2. Aaskereija, 26.05.2018 #2
    Aaskereija

    Aaskereija Inventar

    Ich bezweifle dass das handy noch genügend power hat um cm13 inklusive apps ordentlich zu befeuern. Habs auf meinem XGO gesehen, reine ruckelparty. Flash dir cm11 oder ähnliches, glaub das ist das höchste dee Gefühle
     
  3. krebs8, 26.05.2018 #3
    krebs8

    krebs8 Threadstarter Fortgeschrittenes Mitglied

    CM13:
    Angeblich geht es ja, z.B. hier Update Xperia Play, Xperia Ray to Android 6.0.1 Marshmallow CM 13 Custom ROM beschrieben.
    Ich würde es daher mal probieren. Die Frage ist nur, wie es heutzutage klappen soll.
    Denn die Anleitungen verwenden immer einige mittlerweile nicht mehr verfügbare/funktionierende Dinge.

    CM11:
    Für Deinen Rat: Wie kann ich CM11 flashen ? Wo bekomme ich das her und gibt es da irgendwo eine Anleitung ? Danke.
     
  4. Aaskereija, 26.05.2018 #4
    Aaskereija

    Aaskereija Inventar

    Klar gehts, du kannst auch Windows auf dem Handy installieren, alles nur eine Frage des Willens und des Könnens. Aber ich kann dir jetz schon sagen, ohne es probiert zu haben, das CM13 bei Geräten die maximal 1GB RAM haben, ruckeln wird wie die Hölle, sobald sich alleine der Playstore etc. drauf befindet.

    CM11 kann ich dir tatsächlich grad nich anbieten, die hier sollte aber okay sein [ROM][Play/Neo L]KitKat 4.4.4][CM11.0]

    Ansonsten könnte ich dir noch CM10 und CM9 anbieten aus meinem eigenen Archiv. Beide stammen von FXP, also besser gehts nicht. Loading site please wait...


    Im Grunde isses immer der gleiche Ablauf;

    Flashtool installieren, treiber installieren
    Also im Grund einfach nur die ersten Schritte bis die Treiber installiert sind. Immer gut das Programm einsatzbereit zu haben weil dadurch kann man ein Sony auch ganz fix und einfach wieder reparieren

    1. TA.Sichern
    2. Bootloader öffnen
    4. gewünschte ROM, GApps und SuperSU (Root) auf die interne SD packen
    5. boot.img aus der ROM.zip rauskopieren, nach c:/flashtool/x10flasher_lib packen
    6. USB-Debugging aktivieren (Einstellungen > Über das Handy > 7x Build-Nummer antippen)
    7. Handy ausschalten und mit gedrückten Power + VOL UP an den PC anschließen
    7. CMD öffnen, cd c:\flashtool\x10flasher_lib danach fastboot flash boot boot.img danach fastboot reboot
    8. Es sollte dann eine abgeänderte Form des Bootscreens (SONY) erscheinen mit leuchtender LED, in dem Zeitraum per VOL UP die Recovery erreichen
    9. In der Recovery (CWM vermutlich) factory wipe, format Data, System, Cache und Dalvik-Cache
    10. ROM und GApps installieren, danach SuperSU
    11. Handy neu starten lassen. Der erste Start dauert ne weile
     
  5. krebs8, 27.08.2018 #5
    krebs8

    krebs8 Threadstarter Fortgeschrittenes Mitglied

    Hallo, danke für die Infos.

    Das verlinkte CM11 ist aber für das Play, ich habe ja das Ray.
    Auf androidfilhost sind auch neuere ROMs, wie z.B. das ResurrectionRemix-M-v5.7.0-20160622-urushi von 2016.
    Das hätte ich auch gerne mal probiert.

    Flashtool (0.9.23.1) und Treiber (mit Flashtool-drivers.exe in C:\Flashtool\drivers) habe ich schon installiert.
    [Habe Windows 10 Home. Erst kam bei den Treibern "Installation fehlgeschlagen", ging aber dann doch mit Start/Einstellungen/Update u. Sicherheit/Wiederherstellung/Erweiterter Start/Jetzt neu starten//Problembehandlung/Erweiterte Optionen/Weitere Wiederherst.optionen anzeigen/Starteinstellungen/Neu starten/F7 Erzwingen der Treibersignatur deaktivieren/Beim Installieren der Treiber dann mehrfach "Treibersoftware trotzdem installieren" drücken.]

    TA kann ich wohl nicht mehr sichern, da ich den Bootloader geöffnet habe, bevor ich das gelesen hatte.

    Welche GApps-Version muß ich denn (für CM13) verwenden ? Ich habe die ARM 6.0 nano genommen.

    SuperSU: Nimmt man eine APK (Link zu Play Store liefert aber keine APK) oder flashbare Zip-Version (Link geht aber nicht nehr) ?

    Heißt "boot.img ... nach c:/flashtool/x10flasher_lib packen" die boot.img in den Ordner "c:/flashtool/x10flasher_lib" kopieren ? (So habe ich es gemacht.)

    USB-Debugging war schon aktiviert.

    Wenn ich gleichzeitig Vol Up und Power (geht das beim Ray auch so ?) drücke, geht das Handy immer ganz normal an. Nur mit Vol Up hat es dann funktioniert.

    Im cmd-Fenster kam nur:
    c:\Flashtool\x10flasher_lib>fastboot flash boot boot.img
    sending 'boot' (5632 KB)...
    (bootloader) USB download speed was 9183kB/s
    OKAY [ 0.634s]
    writing 'boot'...
    (bootloader) Download buffer format: boot IMG
    (bootloader) Flash of partition 'boot' requested
    (bootloader) S1 partID 0x00000003, block 0x00000148-0x00000179
    (bootloader) Erase operation complete, 0 bad blocks encountered
    (bootloader) Flashing...
    (bootloader) Flash operation complete
    OKAY [ 1.056s]
    finished. total time: 1.693s

    aber noch kein Bootscreen bzw. Recovery-Oberfläche.

    Mußte Handy neu starten, es erscheint "LegacyXperia", dann gleich Vol Up drücken, um ins cyanogenmod-Recovery-Menu mit den Menupunkten "Reboot system now", "Apply update", "Factory reset" und "Advanced" zu kommen.
    Advanced hat die Untermenupunkte Reboot recovery, Reboot to bootloader, Mount /system, Wipe system partition, View recovery logs, Power off.
    Hoch und runter mit Vol Up bzw Down, Auswählen mit Power-Taste.

    Ich hoffe, das hat alles soweit gepaßt.
    Wie muß ich jetzt weitermachen ?
     
    Zuletzt bearbeitet: 27.08.2018
  6. Aaskereija, 29.08.2018 #6
    Aaskereija

    Aaskereija Inventar

    Jetzt solltest du unter Wipe system partition: system, data, cache löschen und unter advanced die "dalvik-cache". Danach (hab die genauen namen nicht mehr im kopf) zu deiner Custom-Rom zip navigieren und diese installieren, danach GApps und danach evtl. SuperSU zip
     
    krebs8 bedankt sich.
  7. krebs8, 10.09.2018 #7
    krebs8

    krebs8 Threadstarter Fortgeschrittenes Mitglied

    Alles gemacht. Bei der Installation der ROM (TWRP 2.4.3.0-Recovery) erscheint nach einer Weile beim Punkt "Updating partition table" die Meldung "Failed".
    Nach dem nochmaligen Drücken von "Wipe cache and calvik" gings weiter. Ob die ROM istalliert ist, weiß ich nun nicht.

    Die anschließende Gapps-Installation ist abgebrochen mit Error-Code 70.

    Habe es stattdessen nun mit dem Cyanogen-ROM "CyanogenMod-13.0-CustomROM-20161109-UNOFFICIAL-LegacyXperia-urushi" versucht. In dessen Recovery läßt sich das ROM aber nur per ADB Sideload installieren (Punkte 7. bis 8. oben).
    Das ROM hat funktioniert, nicht aber Gapps und SuperSu. Wie kann ich die nun installieren ?

    Edit: Habe im neuen ROM das USB-Debugging aktiviert und die beiden zip-Dateien auf den internen Speicher geschoben, dann hat die Installation per Recovery (Apply Update, emulated) flott geklappt. Die Gapps-"Vorbereitung" hat nach Geräte-Neustart lange gedauert.
    Allerdings kommt jetzt als Dauerschleife die Meldung "Setup-Assistent wurde beendet", egal ob ich die Nano oder Pico von Gapps verwendet habe,
    ROM funktioniert also, nach Gapps geht nichts mehr. Toll.

    Edit: Alles nochmal mit dem ROM "ResurrectionRemix-M-v5.7.0-20160622-urushi.zip" probiert.
    ROM-Installation geht, nach Gapps Pico genau das gleiche Problem!
    Mit "To fix this, run adb shell and enter: pm grant com.google.android.setupwizard android.permission.READ_PHONE_STATE"
    ging zwar die Fehlermeldung für den Setup-Assistenten weg, aber es kommt nun ständig eine mit AOSP-Tastatur.

    Edit: Angeblich geht bei diesem Setup-Assistent-Fehler auch "kurz nach dem Booten des Telefons kann man in die Einstellungen gehen, dort auf Apps, rechts oben auf die drei Punkte, dort auch Systemdienste anzeigen lassen und dann in der Apps-Liste den Setup Assistenten aussuchen. Im Untermenü kann man ihm dann die Rechte auf Kontakte und Telefon geben. Dann ist Ruhe mit der Fehlermeldung, und man kann das Telefon wieder benutzen."

    Edit: In der App unter Speicher die Daten löschen soll evtl. auch helfen.
     
    Zuletzt bearbeitet: 14.09.2018
  8. krebs8, 14.09.2018 #8
    krebs8

    krebs8 Threadstarter Fortgeschrittenes Mitglied

    Die Meldung "Setup-Assistent wurde beendet" bzw. später dann "Android-Tastatur (AOSP) wurde beendet" läuft trotz der o.g. Maßnahmen weiterhin in Dauerschleife und es lassen sich nach Bestätigen der Meldung mit Ok keinerlei Eingaben machen. So kann man keinen WLAN-Passwort eingegeben, man kommt also nicht ins Internet und kann auch keine andere Tastatur intallieren usw.

    CM13 (Cyanogen-ROM "CyanogenMod-13.0-CustomROM-20161109-UNOFFICIAL-LegacyXperia-urushi") läuft einwandfrei
    Man kann unter Entwickleroptionen sogar Root einfach aktivieren. (Mit einigen anderen Methoden habe ich es auch gar nicht geschafft)

    CM13 läuft aber nur ohne Gapps gut. Sobald die Gapps installiert sind, gehen die Probleme los. (Egal, ob ich nach der ROM-Installation Android erst eingerichtet habe oder ob ich gleich nach der Installation Gapps installiert habe. Egal, ob die Pico- oder Nano-Gapps. Habe dazu ARM 6.0 für das Xperia Ray mit CM13 genommen)
    Was kann ich hier noch versuchen ???
     
    Zuletzt bearbeitet: 14.09.2018
  9. krebs8, 14.09.2018 #9
    krebs8

    krebs8 Threadstarter Fortgeschrittenes Mitglied

    Habe folgendes anders gemacht:

    Bei Gapps die HDPI_miniGAPPS-6.0-20161024-tb-signed.zip verwendet
    und diese nach dem ROM-Flashen gleich hinterherinstalliert
    und dann vor dem Neustart sofort nochmal wipe cache in der Recovery ausgeführt.

    Nun kommen keine Fehlermeldungen mehr.

    Allerdings lief das Gerät vor der Gapps-Installation flüssig, jetzt ist es sehr langsam. Mist.
     
  10. Aaskereija, 15.09.2018 #10
    Aaskereija

    Aaskereija Inventar

    weil das Gerät von der Performance her nicht mehr dafür ausgelegt ist
     
  11. krebs8, 15.09.2018 #11
    krebs8

    krebs8 Threadstarter Fortgeschrittenes Mitglied

    Also das ganze OS für sich funktioniert flüssig, und die paar Gapps alleine machen es langsam.
    Hört sich trotzdem irgendwie komisch an.

    Versuch mit dem ResurrectionRemix-M-v5.7.0-20160622-urushi (Android 6.01):
    Gleiches Bild, aber die Ausführung von Apps geht eigentlich, nur die Installationen dauern ewig.
    Seltsam aber ist, daß kein Mobilfunknetz möglich ist !
     
    Zuletzt bearbeitet: 15.09.2018
  12. Aaskereija, 16.09.2018 #12
    Aaskereija

    Aaskereija Inventar

    Gapps sind leider mittlerweile auch so massiv gewachsen. Ansonsten würde es ja, wie du bemerkt hast, Einwandfrei funktionieren... leider auch etwas absichtlich von Google so gemacht
     
  13. krebs8, 26.09.2018 #13
    krebs8

    krebs8 Threadstarter Fortgeschrittenes Mitglied

    Bisherige Versuche:

    - CM13 ohne Gapps flüssig, mit Gapps 6 Nano o. Pico sehr langsam
    - RR5.7.0 ohne Gapps flüssig aber und ohne Mobilfunknetz, mit Gapps 6 Nano o. Pico sehr langsam und ohne Mobilfunknetz
    - CM12.1 hatte nach der Installation einen ewigen Start, habe nach 1,5 Stunden abgebrochen
    - CM11 ohne Gapps flüssig, mit Gapps 4.4 Pico funktionierte Playstore nicht, die Gapps 4.4 Nano Installation brach ab
    - CM10.2 Installation brach ab

    Diese bescheuerten Gapps.
     
    Zuletzt bearbeitet: 26.09.2018
  14. Aaskereija, 27.09.2018 #14
    Aaskereija

    Aaskereija Inventar

    probiers mal mit MicroG, ist eine alternative
     
  15. krebs8, 27.09.2018 #15
    krebs8

    krebs8 Threadstarter Fortgeschrittenes Mitglied

    LineageOS inkl. microG gibt es ja nicht für das Xperia Ray.
    Aber kann man microG alleine (anstatt der Gapps) installieren ?
    Wenn ja, weiß ich nicht, was ich davon installieren muß. Download - microG Project

    Und auch nochmal zum CM13:
    Hier Android 6.0 für Sony-Xperia-Smartphones aus 2011 - per Custom-ROM und hier LegacyXperia's Files :: BasketBuild wird CM10 bis CM13 auch für das Ray angeboten. Wenn die das schon entwickelt haben, so mußte es doch sicher auch mit den Gapps vernünftig lauffähig sein, oder ? Was anderes kann ich mir einfach nicht vorstellen. Aber was kleineres als die Pico-Version der Gapps geht halt nicht. Oder muß ich eine alte o. angepaßte Version nehmen ?
    Hier LegacyXperia/Wiki ist die Installation beschrieben inkl. spezieller Gapps- Müßte also gehen. Ich werde es nochmal genau danach versuchen. (Nur welche dpi-Aufösung habe ich mit 854x480 pixels - Size (diagonal) 3.3 inches - 16:9 ratio - ~297 ppi density: Die HDPI / hi-res screen / 240 dpi oder die MDPI / low-res screen / 160 dpi ?. Nehme mal die HDPI.)
    Edit: Genau nach deren Anleitung gemacht. Installiertes Whatsapp startet nicht. Manchmal kommt "Google Play Dienste wurde beendet."
     
    Zuletzt bearbeitet: 27.09.2018
  16. Aaskereija, 30.09.2018 #16
    Aaskereija

    Aaskereija Inventar

    Custom-Roms sind keine "Nur weil es das gibt, funktioniert das auch" Systeme. Das sind "Machbarkeitsstudien" . Ich kann auch Win95 auf meinem Xperia GO laufen lassen, weils jemand portiert hat. Das heißt aber noch lange nicht das man es tun sollte oder das es überhaupt im Ansatz stabil laufen wird. Custom-Roms sind in der Regel nie für den täglichen Gebrauch geeignet. Wieso glaubst du heißen die Versionen alle "Nightlies"? Das sind einfach nur Testversionen.

    Und auch wenn du es nicht akzeptieren möchtest. Dein Handy ist für GApps schlicht komplett veraltet und überfordert. Wie gesagt, versuch es mit MicroG, dazu gibt es genügend Anleitungen im Netz.

    Anders als in deinem Fall gibt es eben auch Nutzer die garkeine GApps auf ihren Geräten brauchen. Solche Leute können auf solche Geräten auch CM14, Lineage, PAC, AOKP oder sonstwas laufen lassen und sind glücklich^^

    HDPI passt bei dir
     
  17. krebs8, 03.10.2018 #17
    krebs8

    krebs8 Threadstarter Fortgeschrittenes Mitglied

    Ok, daß die jetzigen Gapps zu umfangreich sind. Dachte eben es geht, wenn man die miniGapps von damals installiert. Da geht aber auch nicht, was mich gewundert hat, da sie damals ja dazu empfohlen wurden. Aber wieso sollten die eine Anleitung usw machen für etwas, was praktisch gar nicht geht.

    Was ich nicht so recht verstehe: Mit MicroG kann ich dann z.B. gar keine PlayStore-Apps installieren ?
    Und aus der von mir genannten Anleitung zur Installation werde ich nicht schlau. Kennst Du was einfaches und deutsches ?
     

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. xperia ray st18i cyanogenmod

    ,
  2. custom rom st18i

    ,
  3. xperia ray custom rom

    ,
  4. cyanogenmod xperia ray,
  5. xperia ray marshmallow,
  6. läuft android 5 auf Xperia Ray stabil?,
  7. cm-13.0-20161109-UNOFFICIAL-LegacyXperia-urushi.zip,
  8. sony st18i android update,
  9. lineageos 16 urushi,
  10. st18i custom rom,
  11. sony so-03c rom android 6,
  12. sony ericsson xperia ray st18i software update,
  13. xperia ray cyanogenmod 13,
  14. sony xperiast18i software update download direkt auf Handy,
  15. marshmallow for xperia ray
Du betrachtest das Thema "Xperia Ray mit Android 6.0.1 Marshmallow CM 13 Custom ROM" im Forum "Sony Ericsson Xperia Ray Forum",
  1. Android-Hilfe.de verwendet Cookies um Inhalte zu personalisieren und dir den bestmöglichen Service zu gewährleisten. Wenn du auf der Seite weitersurfst stimmst du der Cookie-Nutzung zu.  Ich stimme zu.