Gerät kann keine Netzverbindung herstellen, vermutlich durch SIM Lock

  • 18 Antworten
  • Neuester Beitrag
Diskutiere Gerät kann keine Netzverbindung herstellen, vermutlich durch SIM Lock im Sony Xperia X Compact Forum im Bereich Sony Forum.
xpseekay

xpseekay

Neues Mitglied
Ist es möglich durch Root oder andere Methode eine SIM Sperre beim Xperia X Compact aufzuheben?

Meine Tests des gebraucht erworbenen Geräts ergaben:
Gerätehardware funktioniert einwandfrei
Gerät lt. IMEI Check nicht gestohlen
Abfrage SIM Lock durch *#*#7378423#*#* ergab: Alle Angaben (Network, Service Provider, SIM) = 0
Möglich, dass bei der Freischaltung der SIM Lock Sperre zu viele Fehlversuche erfolgten
Da es im Netz div. Hinweise darauf gibt, dass durch Upgrade auf Android 8 Sim Karten nicht mehr erkannt werden, habe ich das Gerät zurückgesetzt auf Android Build: 43.2.1.0..73
 
Spinatlasagne

Spinatlasagne

Experte
ist es ein deutsches?

durch rooten oder flashen lässt sich kein SIM-Lock entfernen.

was genau wird denn angezeigt? ist es ein (selbst eingestellter) Sperrcode?

hast mal nen reset probiert?

sonst den Verkäufer fragen, wenn es als freies Gerät erworben hast - evtl kommt ne Rückgabe in Frage.
 
xpseekay

xpseekay

Neues Mitglied
Gerät ist deutsch, sehr günstig gebraucht gekauft bereits vor Längerem, ohne Möglichkeit auf Rückgabe.
Fehler war bekannt, bin davon ausgegangen, dass durch Reset und flashen mit originalem Rom wieder alles funktioniert. Habe freien Zugang auf das Gerät kein Sperrcode oä.
Zwei verschiedene SIM Karten getestet, kein Netzzugang möglich. So sieht die Abrage der SIM aus:
 

Anhänge

Lenoid

Lenoid

Lexikon
Bei mir sieht das unter 8.0 genauso aus und ich habe keinen SIM-Lock.
 
A

Andi_K

Lexikon
Hi,
mal neugierig gefragt: woran machst Du das hier fest?
xpseekay schrieb:
Meine Tests des gebraucht erworbenen Geräts ergaben:
Gerätehardware funktioniert einwandfrei
Wenn zwei SIM-Karten nicht funktionieren, dann würde ich einen defekten Kartenslot als Möglichkeit durchaus in Betracht ziehen...

Schönen Gruß
Andi
 
Hangwire

Hangwire

Ehrenmitglied
Versuche doch mal die SIM-Karte zu testen. Unter Einstellungen / Support kann man das machen.
 
xpseekay

xpseekay

Neues Mitglied
- Die SIM Karten funktionieren in anderen Geräten problemlos, können als Ursache m.M. ausgeschlossen werden
- SIM-Lock liegt wohl auch nicht vor, wie ich durch den Hinweis von Andi noch mal nachgeprüft und verstanden habe. Wenn links vor Network kein [x] steht, ist es frei.
- Gerätehardware (außer Kartenslot) hab ich mit Software und mit Service Tests prüfen lassen ist alles ok.

Wie testet man leicht und sicher den Kartenslot auf Defekt? Bleibt als bedauerliche Ursache dann wohl nur noch übrig.
 
A

Andi_K

Lexikon
Hm,

ich fürchte dadurch dass Du zwei verschiedene Karten getestet hast die beide in anderen Geräten funktionieren, hast Du den naheliegenden Test schon gemacht. Klingt für mich leider nach defektem Slot.
Wird denn eigentlich bei einem Neustart die SIM-Pin abgefragt?

Ansonsten schaust Du am besten mal in der Werkstatt-Ecke vorbei. Da treiben sich die Hardware-Spezialisten rum, die haben vielleicht noch andere Ideen:
Werkstatt Sony

Schönen Gruß
Andi
 
xpseekay

xpseekay

Neues Mitglied
Die SIM-PIN wird gar nicht abgefragt.
Auf der offiziellen Sony Seite habe ich gerade sehr viele ähnliche Einträge entdeckt unter:
Sony X Compact no sim card error
 
A

Andi_K

Lexikon
Wenn die PIN nicht abgefragt wird, und das bei 2 Karten, dann merkt das Gerät offensichtlich nicht dass eine Karte eingelegt ist.
Für mich liegt ein Hardwaredefekt daher leider auf der Hand.

edit: Tippfehler korrigiert
 
Zuletzt bearbeitet:
xpseekay

xpseekay

Neues Mitglied
Lässt sich das beim X Compact 1. mit vertretbarem Aufwand eindeutig herausfinden und 2. evtl reparieren?
Merkwürdig bei der ganzen Sache ist, dass der Fehler/Defekt nach Angaben des Verkäufers direkt nach einem offiziellen Update der Firmware auftrat. Und das scheint auch bei anderen der Fall zu sein, und widerspricht dann eher der Annahme eines Hardwarefehlers.

-> Aus einer aktuellen ebay-kleinanzeige:
"Biete hier ein (leider) defektes Sony Xperia X Compact schwarz an. Es ist "nur" der SIM Slot defekt, d.h. es werden keine SIM Karten erkannt. Ist bei uns mit 2 identischen Geräten bereits passiert, scheint daher wohl ein generelles Problem bei dem Modell zu sein und ggf. für einen Bastler zu fixen."
 
A

Andi_K

Lexikon
Hier ist von einem ähnlichen Problem beim Xc die Rede, inkl Videoanleitung wie man es evtl lösen kann.
Dass es bei dem Gerät ein generelles Firmware-Problem gäbe wäre mir allerdings nicht bekannt. Wenn Du magst kannst Du ja mal nen Downgrade probieren.

Zwecks einer eventuellen Hardware-Reparatur fragst Du wie gesagt am besten mal im Werkstattforum nach.
 
A

Andi_K

Lexikon
In #3 schreibst Du dass Du die Original-FW nochmal geflasht hast. Da war ich davon ausgegangen, dass Du die aktuellste meinst, weil von einem Downgrade schreibst Du da nix.
Bist Du zurück auf Android 7 gegangen?
 
xpseekay

xpseekay

Neues Mitglied
Ja, Android 7 hatte ich aufgespielt.
Mit "originalem Rom" meinte ich das bei Auslieferung aufgespielte, zurück auf F5321_34.2.A.0.273
 
A

Andi_K

Lexikon
Ah, OK.

Also wenn es mit verschiedenen Firmwares und mit verschiedenen Sim Karten nicht funktioniert, und nachweislich kein Simlock vorhanden ist, dann sehe ich leider echt schwarz dass sich das softwareseitig lösen lässt
 
S

Sepp-Wurzel

Erfahrenes Mitglied
Ich hänge mich hier mal an, da ich ein ähnliches Problem habe.
Bei meinem Handy wurde Samstag die SIM-Karte nicht mehr erkannt und auch keine SIM-Pin abgefragt. Also ab in den O2 Laden und eine neue Simkarte holen. Leider war das Problem dann immer noch (fast) das gleiche. Die neue Karte wurde zunächst nicht erkannt, nach einiger Zeit kam aber dann die Aufforderung zur Eingabe der Sim-Pin. Danach hat sich das Handy aber nicht im Netz eingebucht. Klingt also eher nach HW-Defekt.
Nun hatte ich die neue Karte auch in einem alten Moto G3 probiert. Hier wurde ich zwar gleich nach der Sim-Pin abgefragt und das Gerät bucht sich ein, aber auch gern nach kurzer Zeit wieder aus. Richtig stabil ist die Verbindung somit nicht.
Das X Compact hatte ich zwischen drin auch auf Werkzustand zurück gesetzt, aber leider kein Erfolg.
Nun stellt sich mir die Frage, ob die neue Karte einen Defekt hat (eher unwahrscheinlich) oder beide Geräte ein Problem mit dem EInbuchen haben?
Hat von Euch einer eine Idee?
 
xpseekay

xpseekay

Neues Mitglied
Bei meinem Gerät war es sehr vermutlich ein Hardwaredefekt des SIM Slots, ein sehr, sehr neviger Wackelkontakt. Gelegentlich ging es kurz, nach Neustart dann wieder defekt. Dieser Defekt kommt offenbar häufiger beim X Compact vor wenn man die Anzeigen der Gebraucht Angebote verfolgt oder mal im Xperia Forum blättert. Der SIM Slot selbst ist fast nur mit medizinischer Präzision abzulöten oder zu tauschen. Das Öffnen des Geräts und Tausch der Hauptplatine (icl. SIM-Slot) oder Akku, Kamera und der USB-Buchse sind aber (mit youtube Anleitung) recht gut machbar. Aus einem Xperia X mit defektem Display, daraus die Hauptplatine ausgebaut und jetzt ein funktionierendes Gerät, bisher ohne Probleme.
 
Lenoid

Lenoid

Lexikon
Bei mir wurde die SIM Karte neulich angeblich auch nicht mehr erkannt. Auch nach einem Neustart ging auch nichts, zumindest kein Empfang. Ein paar Stunden gewartet und dann ging es wieder. Es gab wohl einen Netzausfall aufgrund der Sturmschäden.