Cyanogen Mod 12.1 (Port) auf THL 5000

  • 38 Antworten
  • Neuester Beitrag
Diskutiere Cyanogen Mod 12.1 (Port) auf THL 5000 im THL 5000 Forum im Bereich THL Forum.
schenkelklopfer

schenkelklopfer

Erfahrenes Mitglied
Da mein THL 5000 seit Tagen im Bootloop hängt, und ich das Gerät (logischerweise) wieder verwenden möchte, wird jetzt also geflashed.

Ich würde gern das Cyanogen Mod 12.1 (mit Android 5.1) installieren.

Download gibt es hier: ROM CyanogenMod 12.1 [Android 5.1.1] | [Custom]-[Updated] add the 08/27/2015 on Needrom

Laut Anleitung auf der Seite geht das ziemlich einfach:

  1. Download the ROM (1st Link)
  2. Download Micro GApps package (2nd Link) (optional) 2a. Download SuperSU package (3rd Link)
  3. Put the zip files on your SDCard
  4. Reboot in Recovery
  5. Wipe Data/Factory Reset
  6. Install CM12 zip file (cm-12.1-xxx-UNOFFICIAL-thl5000-vx.zip)
  7. Install GApps zip file (open_gapps-arm-5.1-micro-xxx.zip) (optional) 7a. Install SuperSU zip file (UPDATE-SuperSU-vx.zip)
  8. Reboot system
  9. Enjoy CyanogenMod 12

Mein Gerät ist ohne Root, in der Anleitung stand aber auch nichs von einem Root.

Ich geh also aus dem Bootloop ins Recovery, wipe alles (Normal + Cache) und versuche das Rom zu installieren, leider kommt da eine Fehlermeldung: "Installation aborted"

Ich hab mittlerweile auch das SP Flash Tool (Linux 64bit) auf meinem Rechner und würde auch darüber flashen, allerdings habe ich keine Ahnung wie (ich habe keine Scatter Datei) ... geht das mit dem Cyanogen überhaupt per Flash Tool?

Kann mir noch einer Tipps, bzw die richtigen Links geben?
Mein letztes Flashen auf andere Roms ist schon ein wenig her...
 
schenkelklopfer

schenkelklopfer

Erfahrenes Mitglied
Hallo @mblaster4711 - ist das nötig, bevor ich das Cyanogen Mod Rom drauf knallen kann?

THL 5000 Root Anleitung
 
Wattsolls

Wattsolls

Super-Moderator & Mediator
Teammitglied
Du hast keine Scatter Datei für CM. Ich habe zwar kein THL, aber meines Wissens gibt es keine per Flashtool installierbare Version. Du brauchst ein Custom Recovery ala TWRP oder CWM (je nachdem was es für das THL gibt). Von dort aus solltest Du auch CM flashen können. :)

Heisst, Du musst wahrscheinlich rooten und ein anderes Recovery aufs Gerät bringen.
 
schenkelklopfer

schenkelklopfer

Erfahrenes Mitglied
Wattsolls schrieb:
Heisst, Du musst wahrscheinlich rooten und ein anderes Recovery aufs Gerät bringen.
ok, ich hab's befürchtet und bin dabei ;)
 
schenkelklopfer

schenkelklopfer

Erfahrenes Mitglied
wenn ich mit SPFT bei Download Recovery + BootImg einstelle kommt folgende Fehlermeldung:

upload_2016-4-2_16-36-4.png

Im Log steht folgendes:
Code:
com portName is: /dev/ttyACM0

Total wait time = -1459607635.000000
USB port is obtained. path name(/dev/ttyACM0), port name(/dev/ttyACM0)
USB port detected: /dev/ttyACM0
Connect BROM failed: S_COM_PORT_OPEN_FAIL
Disconnect!
BROM Exception! ( BROM ERROR : S_COM_PORT_OPEN_FAIL (1013)

[COM] Failed to open COM port.
[HINT]:
)((ConnectBROM,../../../qt_flash_tool/Conn/Connection.cpp,85))
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Meine Fehlermeldung kommt auch leider immer dann, wenn das Handy dank Bootloop neustartet.

Ich gehe wie folgt vor: Handy aus.
Ich drücke Download und stecke dann ein.
Erst wenn das Handy dann Bootloop wieder neu startet, kommt die Fehlermeldung.

Jemand noch ein Tipp?

Hat jemand von euch Erfahrung mit dem rooten/custom Rom aufspielen unter Linux / Ubuntu?
 
Miss Montage

Miss Montage

Ehrenmitglied
Zu Linux Ubuntu: [Anleitung]SP_Flash_Tool_Linux (für MediaTek-SoC) einrichten
Die Fehlermeldung 1013 bekomme ich auch manchmal, wenn mein Handy zu schnell in den Lademodus geht. Einfach nochmal probieren, ggf. mit "Lauter-" oder "Leiser"-Taste während des Einstöpselns oder ohne Batterie (wenn die Verbindung hergestellt ist, bitte wieder einlegen).

edit: Die Superuser-App brauchst Du nicht zu installieren, aber Du brauchst die Custom Recovery (CWM), um CyanogenMod zu installieren.
 
Zuletzt bearbeitet:
schenkelklopfer

schenkelklopfer

Erfahrenes Mitglied
Cyanogen Mod läuft.

Jetzt habe ich nur ein Problem, ich benutze 2 Sims, eine zum telefonieren, eine für die Internetverbindung....
ich bekomme aber bei beiden kein Verbindung. ich hab es sowohl mit der 097a als auch mit der 095 probiert....

bei beiden das gleiche Ergebnis....

Hat noch jemand das gleiche Problem?
 
Miss Montage

Miss Montage

Ehrenmitglied
Hast Du die APN-Einstellungen kontrolliert?
 
schenkelklopfer

schenkelklopfer

Erfahrenes Mitglied
Für das normale Tefefonieren bzw SMS schreiben braucht man ja keine APNs oder?
Das ist doch nur für die Internet Verbindung, oder?
Ich bekomme leider bei beiden SIM Anbietern kein Signal.

edit: ok, bei der Internet SIM war es wohl die APN. aber bei der Telefonie SIM bekomme ich keinen Empfang

edit 2: beide SIM Karten werden aber erkannt..... also ich muss auch die PIN eingeben......
 
Zuletzt bearbeitet:
Miss Montage

Miss Montage

Ehrenmitglied
Stiimmt, die APN brauchst Du nur für mobiles Internet und MMS. Stimmt sonst alles? Deine IMEIs vor allem? Kannst Du Deine Anbieter vielleicht manuell auswählen?
 
schenkelklopfer

schenkelklopfer

Erfahrenes Mitglied
Miss Montage schrieb:
Deine IMEIs vor allem?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --


*#06# - ergibt auch nichts, unter Einstellungen schaut es komisch aus:


Miss Montage schrieb:
Kannst Du Deine Anbieter vielleicht manuell auswählen?
ja, aber ich bekomme dann nie eine Verbindung...
 
Zuletzt bearbeitet:
Miss Montage

Miss Montage

Ehrenmitglied
Autsch, das ist ärgerlich. Wusste ich auch noch nicht, dass sowas beim Flashen per Recovery passieren kann.
Hast Du vor dem Bootloop mal ein NVRAM-Backup gemacht?
Falls nicht, gibt es eine temporäre Methode, die IMEI per MTK Engineering Mode – Android-Apps auf Google Play wieder ins System zu schreiben (überlebt aber kein Werksreset oder erneutes Flashen):
Dauerhaft geht es mit Maui Meta 3G oder SN Write Tool (beide für Windows). Dazu brauchst Du je zwei Basisdateien (siehe Anhang).
 

Anhänge

  • MT6592.zip
    5,3 MB Aufrufe: 149
Zuletzt bearbeitet:
schenkelklopfer

schenkelklopfer

Erfahrenes Mitglied
Hmmm ich hab jetzt echt viel probiert......
Leider funktioniert hier kein einziger MTK Engineer Mode, weder über die Codes, *#7465625# bzw * # * # 3646633 # * # *
Beim Installieren der MTK Engineering Mode Start kommt beim Auswählen des MKT Settings die Fehlermeldung: "Can not find Engineer Mode App"

Windows ist hier nicht vorhanden :(
 
Miss Montage

Miss Montage

Ehrenmitglied
Möglich, dass der MTK Engineering Mode auf CyanogenMod nicht läuft. Du könntest versuchen, Maui Meta 3G oder das SN Write Tool unter Wine zu starten. Dazu muss Wine Zugriff auf den ttyACM0-Port bekommen:
Code:
ln -s /dev/ttyACM0 ~/.wine/dosdevices/com1
Ich habe es selbst aber noch nicht ausprobiert.
 
Zuletzt bearbeitet:
schenkelklopfer

schenkelklopfer

Erfahrenes Mitglied
Miss Montage schrieb:
Möglich, dass der MTK Engineering Mode auf CyanogenMod nicht läuft.
Gibt es sonst, über das Phone, noch irgendwelche Möglichkeiten?
Auf wine habe ich jetzt nur begrenzt Lust (mal schauen ob ich über eine VM das ganze schaffe)
 
Miss Montage

Miss Montage

Ehrenmitglied
Mir sind keine weiteren Möglichkeiten per Gerät bekannt.
 
schenkelklopfer

schenkelklopfer

Erfahrenes Mitglied
Kurz noch eine andere Frage: wenn ich jetzt ein anderes Rom drauf flashe, müssten dann die MTK Tools gehen?
 
Miss Montage

Miss Montage

Ehrenmitglied
Bei einer Stock ROM gehe ich davon aus. Es hat übrigens schon Nutzer gegeben, bei denen nach dem Flashen einer Stock ROM die IMEIs wie von Geisterhand wieder erschienen sind (aber nicht unbedingt die richtigen :p)
 
schenkelklopfer

schenkelklopfer

Erfahrenes Mitglied
Miss Montage schrieb:
bei denen nach dem Flashen einer Stock ROM die IMEIs wie von Geisterhand wieder erschienen sind (aber nicht unbedingt die richtigen :p)
das würde ja heißen, sollten die wider Erwarten wieder erscheinen, kann ich ein Backup machen, wieder Cyanogen Mod drauf spielen und dann kann ich das wieder zurück backupen?