Umi Diamond [Custom-ROM] - Umi V7 Kleenex Edition

  • 70 Antworten
  • Neuester Beitrag
Diskutiere Umi Diamond [Custom-ROM] - Umi V7 Kleenex Edition im Umi Diamond Forum im Bereich UMi/UMiDIGI Forum.
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Moin zusammen,

das erste Custom Rom für das Umi Diamond wäre damit auf den Weg gebracht.
Es wurde alles an Viren/Malware entfernt, die der Hersteller eingebaut hat.
Ferner ist es gerootet und alle GoogleApps aus dem Stock wurden durch
saubere Google Apps von opengapps.org ersetzt.
Wer mehr als die vorhandenen braucht kann jederzeit ein Paket von dort runterladen
und installieren, getesten wurden
Platform : ARM64 - Android : 6.0 - Package : Full/Super

Zu finden ist das ROM auf Needrom oder MediaFire

3 bebilderte Anleitungen im PDF Format sind dabei in denen alles zur Installation erklärt wird.

Ich wünsche euch viel Spass mit einem sauberen ROM.

Rom : Umi Diamond V7 – Kleenex Edition - based on original V7 Rom from Umi

Changes :
- removed any malware, viruses that i could find from stock

- patched the SystemUI.apk to got rid of the last bit of malware that was
included in this file.

- heavily debloated the ROM of almost all stock apps

- replaced all Google apps with original apps from OpenGapps
including the camera App

- rooted the ROM, changed kernel mode to permissive via su.d script
added busybox

- added AFWall+ to ROM
its disabled by default and can be uninstalled

- removed stock launcher and replaced with CM13 launcher
thanks to alesimula from xda Developer for the port.

- removed stock FileManager and replaced with CM13 FileManager
thanks to FaserF from xda Developer for the port.

- changed bootanim to the little flying SuperSU guy

Author : Ziggy
Status : stable
Date : 08.02.2017
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von Miss Montage - Grund: Thementitel bearbeitet. Gruß, Miss Montage
Volle

Volle

Ambitioniertes Mitglied
Aloha,

Danke für das rom.
da bei. Meiner Freundin inzwischen mehrmals täglich irgend etwas installiert wird werd ich das heute abend mal druberbügeln.

2 Fragen:
- in der Anleitung steht man soll nen full wipe machen. brauchts das zwingend?
- du hast geschrieben dass du die Camera app gegen die von google getauscht hast, d. H. die stock camera app ist danach weg?

Gruß
Chris
 
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Moin :)

Ich denke schon das der Fullwipe sinnvoll ist, da ich nicht weiß was sonst auf dem Tel. zurück bleibt, Du kannst es aber auch mal ohne probieren habe ich selbst aber nicht probiert.
Naja die Stock App ist im Prinzip auch nichts anderes als die alte camera app gewesen. Funktioniert aber tadellos imho sogar was den Focus angeht besser als die originale...
Ich hab versucht alles aus dem original rom zu löschen und durch original google versionen zu ersetzen weil das original rom wirklich voll mit scheisse war, teilweise bin rein in das boot.img
 
Volle

Volle

Ambitioniertes Mitglied
ok, haben jetzt zur Sicherheit auch alles platt gemacht.
läuft soweit ohne Probleme, sind aber noch am einrichten.
danke für die Arbeit!
 
U

umaster

Neues Mitglied
Hallo...vorab:ich bin absoluter Neuling bezüglich Handytechnik etc.hab mir das UMI Diamond als Testhandy geholt und finds ok..nur die Sache mit der Maleware stört mich doch sehr und bin deshalb nach Recherche hier auf diese Seite gelangt.
Ich finde es beeindruckend, was Menschen so können..und wollte mir deshalb auch das Custom Rom von Ziggy aufspielen..klappt aber leider nicht.:blushing:
Nach Ausführen aller Schritte komme ich nur bis Punkt10 bei Install TWRP...beim Anschließen des Handys an den PC versucht WIN7 die Treiber zu installieren...aber bricht mit dem Hinweis ab, das diese nicht installiert werden können...nun meine Frage:
Muß ich im Vorfeld irgendwelche Einstellungen am Handy vornehmen?(USB-Debugging oder so)?
Wenn nicht, woran könnte es sonst liegen, das es nicht funktioniert?
Ich habe übrigens gesehen, das auf meinem UMI die Firmware V7.0 20161208_194715 installiert ist...die Firmware hier aber mit -4714 endet...ist das ein Problem?
Über eine kurze Info würde ich mich freuen.
Danke im Voraus
umaster
 
R

RolandoMio

Neues Mitglied
Hallo Ziggy. Hallo an Alle.

Erstmal vielen Dank an Ziggy für die investierte Arbeit.
Ich habe mir das UMI Diamond als mein erstes Handy zugelegt (ich wollte noch schnell eins haben bevor ich 50 werde).
Seit ein paar Tagen habe ich auch das Problem mit den Apps. Ich würde mir auch zutrauen Ziggys ROM aufzuspielen... ich habe aber seit heute noch ein anderes Problem: Das Handy bootet nicht mehr. Damit will ich diesen Beitrag nicht zusauen.
Ziggy, du hast im UMI-Forum geschrieben du würdest ebventuell eine Anleitung in Deutsch machen. Das würde mir als Anfänger wahrscheinlich ebenfalls helfen. Oder hast du das wieder verworfen.

Ciao
Roland
 
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Verworfen nicht war nur leider noch nicht dazu gekommen. Ich versuche sie aber so schnell wie möglich fertig zu machen. Im Prinzip wenn Du den Bildern in meiner Anleitung folgst kannst Du aber recht wenig falsch machen. Aber wie gesagt versuche die deutsche heute im Laufe den späten Nachmittags online zu stellen, finden sich dann im selben Verzeichnis und werden noch ein _de anhängen haben.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
umaster schrieb:
Hallo...vorab:ich bin absoluter Neuling bezüglich Handytechnik etc.hab mir das UMI Diamond als Testhandy geholt und finds ok..nur die Sache mit der Maleware stört mich doch sehr und bin deshalb nach Recherche hier auf diese Seite gelangt.
Ich finde es beeindruckend, was Menschen so können..und wollte mir deshalb auch das Custom Rom von Ziggy aufspielen..klappt aber leider nicht.:blushing:
Nach Ausführen aller Schritte komme ich nur bis Punkt10 bei Install TWRP...beim Anschließen des Handys an den PC versucht WIN7 die Treiber zu installieren...aber bricht mit dem Hinweis ab, das diese nicht installiert werden können...nun meine Frage:
Muß ich im Vorfeld irgendwelche Einstellungen am Handy vornehmen?(USB-Debugging oder so)?
Wenn nicht, woran könnte es sonst liegen, das es nicht funktioniert?
Ich habe übrigens gesehen, das auf meinem UMI die Firmware V7.0 20161208_194715 installiert ist...die Firmware hier aber mit -4714 endet...ist das ein Problem?
Über eine kurze Info würde ich mich freuen.
Danke im Voraus
umaster
Das Problem klingt eher nach einem Windows Problem .. Hast Du die Mediatek-Drivers-Install.bat als Administrator ausgeführt oder als normaler User ? Das könnte ich mir noch vorstellen das da das Problem liegen kann.
Zu der Rom Version kann ich rel. wenig sagen vllt. ist es ein OTA Update gewesen und sie haben da die Versionsnummer um eins angehoben... Sollte aber im Prinzip keinen Unterschied machen.
 
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Moin zusammen,
die deutschsprachigen Versionen der Anleitungen liegen nun ebenfalls im Verzeichnis.
 
R

RolandoMio

Neues Mitglied
Hallo.
Nachdem sich mein Handy wieder einschalten läßt (war wohl tatsächlich der Akku komplett leer und es brauchte eine gewisse Zeit am Ladegerät), wollte ich natürlich die Kleenex-Version draufspielen.

Es hat eigentlich ganz gut funktioniert. Vielleicht hat es an diesen Stellen bei mir wegen kompletter Unwissenheit etwas gehakt... deswegen schreib ichs hier mal rein.

Mediatek-Treiber:
Den Mediatek Treiber habe ich bei mir (altes XP-Laptop, sorry) einfach durch anklicken der Install.bat installiert. Ich konnte das Handy dann per USB anstecken und es kamm das Audiosignal dass ein USB-Gerät am PC hängt und ich hatte Zugriff auf den Handy-Datenspeicher.
Flashtool startet nicht:
Beim Flashen der original UMI V7 bin ich nach Anleitung vorgegangen allerdings hat sich nach anstöpseln des Handys am USB-Port nichts an der Anzeige des Flashtools getan. Da in der Anleitung steht dass man auf keinen Fall das Kabel abziehen soll bevor das Fenster mit dem Fertig-Häkchen kommt, habe ich erstmal gewartet... ziemlich lang.
In einem Youtube-Video zum Flashtoll habe ich gesehen dass im unteren Bereich ein roter und ein gelber Farbbalken (Fortschrittsanzeige) erscheinen sollte. Bei mir nicht also USB-Kabel abgezogen, noch mal probiert... nichts. Versucht den Treiber als Admin über den Umweg einer Desktopverknüpfung zu installieren (da bin ich aber irgendwie auch zu alt dafür)... jedenfalls mußte ich vor dem anstecken des USB-Kabels den Akku herausnehmen. Dann hat es wunderbar geklappt.
Letzter Absatz der TWRP Anleitung:
==> "Nun könnt ihr Euer Telefon einschalten, dabei müsst ihr die Lautstärke+ Taste gedrückt halten. Nach ein paar Sekunden solltet Ihr den Hauptbildschirm vom TWRP sehen."
Bei mir kommt dann das Bootmenü, in dem ich erst auswählen muss zwischen Recovery, Fastboot (glaub ich) und Normal.
Da weiter unten in der Anleitung "Schaltet das Telefon nicht normal ein ohne vorher einmal im Recovery gewesen zu sein" habe ich im Bootmenü die Option Recovery ausgewählt.
ROM-Anleitung:
Dort steht dass man auf die micro-SD Karte das Kleenex.zip speichern soll. Blöderweise hatte ich die micro-SD Karte als internen Speicher formatiert und nach dem Einschalten des Handys kam immer die TWRP-Startseite und hatte Mühe da raus zu kommen. Irgendwie hats geklappt und ich habe die micro-SD als externen Speicher umgestellt. Da ich die microSDdann aber nicht im Explorer des PCs fand habe ich die Karte kurzerhand aus dem Handy genommen und mit einem Kartenadapter direkt an den PC gesteckt. Kleenex.zip drauf, wieder ins Handy rein. Mit Vol+ und EINschaltknopf gestartet und dann nach Anleitung weiter.

Nachdem das erledigt war habe ich mich natürlich gefragt ob auch die richtige Software am Gerät ist. Und ich schätze das ist so weil unter Einstellungen, über das Gerät, die Kleenex-Version angezeigt wird.

Ich schreibs nur falls sich andere Anfänger ähnliches Fragen.
Jedenfalls habe auch ich mich durchhangeln können.
Jetzt richte ich das Handy wieder ein und bin guter Dinge das jetzt Ruhe ist.

Besten Dank erstmal.
Ciao
Roland
 
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Hallo Roland,
sorry dachte ich hätte alles schon gut genug erklärt, wenn man das schon ein paar Jährchen macht gehen einem manche Schritte wie von selbst von der Hand, z.B. das mit dem Recovery auswählen wenn man mit vol+ gestartet hat und man denkt nicht mehr dran wie man das erste mal selbst davor gesessen hat :) Es freut mich aber das letztendlich trotzdem alles geklappt hat und hoffe Du hast Freude an dem ROM.
P.S: Ja wenn Du in den Einstellungen unter "Über das Telefon" bei Build-Nummer "Umi Diamond V7 Kleenex Edition" stehen hast hat alles geklappt :)
 
U

umaster

Neues Mitglied
Guten Morgen an alle hier,
ich als absoluter Anfänger ( ähnlich wie Roland) hab es nun gestern auch geschafft, mir das saubere System aufs Handy zu laden :thumbsup:.
Irgendwann hat mein Laptop dann doch die Mediathek-Treiber geladen und dann ging das flashen problemlos..nur hatte ich auch ein Riesenproblem:
Ich hab ne 64GB.Karte als Speicher( wurde auch problemlos erkannt :biggrin:) und darauf die Kleenex-edition als zip gespeichert...als ich dann aber zum Punkt kam, als die Zip-Datei von der SD-Karte entpackt werden sollte, sagte mein Handy, das auf der Karte 0 MB gespeichert waren..also nix drauf :eek::confused2:..
ich habs dann wie Roland gemacht und die Karte an PC gehängt und die Zip neu draufkopiert..hat zum Glück funktioniert und alles verlief dann super...musste nur leider die Karte formatieren...aber ich hatte schon vorher das komplette System auf dem PC gesichert...also alles was auf der SD-Karte war ist noch da..ich denke, das sollte man immer tun, weil es sonst weh tun kann...ich hab aber keine Ahnung, warum die Karte nicht mehr erkannt wurde..
noch ne Frage:
wenn und wie kann man jetzt - wenn nötig und möglich- damit Updates machen?also firmware oder so?

Jedenfalls von mir auch besten Dank für die tolle Anleitung..(hab irgendwo was wegen paypal gelesen..werd da ne Kleinigkeit wegen der Arbeit überweisen)
Gruß
Udo
 
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Wenn die Karte als interner Speicher formatiert wurde, wird sie anders partitioniert und formatiert, deswegen kann Windows leider erstmal nix damit anfangen.
Das mit den Updates ist so ne Sache... Wenn Du wirklich mal ein offizielles Update brauchst wird das nur über den Umweg gehen das Du vorher komplett mit der original V7 Software flashst. Danach ist Dein Handy praktisch wieder im Auslieferungszustand und Du kannst alle OTA Updates machen.
Den Ota Updater musste ich leider aus der Firmware entfernen, zum einen weil er ein Einfallstor für jegliche Manipulation wäre, zum anderen weil ein Update durch die Veränderung vom ROM ohnehin gegen die Wand fahren würde.
Natürlich werde ich solange ich selbst das Telefon habe und Updates kommen die ich für sicher halte, auch eine neue Version meines ROMs rausbringen denn auch ich will ja nicht mit veralteter Software arbeiten. Ich gebe allerdings zu bedenken das Umi meiner Meinung nach kein Interesse daran haben wird eine saubere neue Version rauszubringen, da sich mir stark der Verdacht aufdrängt das die Malware eine ganz gute Möglichkeit darstellt ein Handy das von der Hardware ansich unter Preis verkauft wird durch Werbeeinnahmen quer zu subventionieren.
 
U

umaster

Neues Mitglied
Guten Abend zusammen :biggrin:,
das mit der firmware war nur ne Frage..brauchen tue ich sowas nicht wirklich..aber ich wollte noch kurz was erwähnen:
Ich war heute unterwegs..immer an Orten mit wlan..alles ok..hab nichts Ungewöhnliches gemerkt...erst als ich am Abend im Auto gesessen bin, ist mir aufgefallen, das ich keinerlei Benachrichtigungen oder mails während der Fahrt bekommen habe..zuhause hab ich das mal gecheckt..ich hatte den ganzen Tag keinen Zugang zum mobilen Internet..nur über wlan..hab dann die ganzen Einstellungen geprüft..alles wie vorher..aber Internet über Tel ging nicht..hab dann mal die ganzen apps angeschaut..da ist mir diese AFWALL+ ins Auge gesprungen..hab die deaktiviert..und schon gings wieder :biggrin:..nur..
ich als Depp hab gar keine Ahnung, was das ist..lt. google ne ziemlich gute Firewall..hab mal da reingeschaut..nur böhmische Dörfer..
Ziggy..du hast geschrieben, das die deaktiviert ist..bei mir war sie es wohl nicht..kein Problem..habs ja gefunden...hat allerdings bissl Zeit gekostet :blushing:..naja..

für Hasenhirne wie mich kann das schon ziemlich nervendaufreibend sein, wenn das Handy unterwegs kein Internet hat und man nicht weiß warum..
wollte das nur als Tipp für ev. ähnlich gelagerte Fälle hier posten..
hab mal kurz überlesen,was diese firewall kann..aber hab keine ahnung, ob es irgendwelche Grundeinstellungen geben sollte..ich lass das Ding erstmal aus, damit ich überhaupt ins Netz komme :rolleyes2::rolleyes2:

dann noch einen schönen Abend an alle

Udo ( der sich jetzt einen Schluck Wein zur Beruhigung gönnt :cool: )
 
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Moin zusammen,

hab ein kleines Update gemacht mit dem man die Firewall deinstallieren kann, da sich diese nicht über den Playstore updaten lässt.
Im Installationverzeichnis auf Mediafire liegt nun noch das File "AFWallRemove.zip", spielt das einfach per TWRP ein. (_KEIN_ Wipe nötig) das löscht euch die Firewall aus dem System und Ihr könnt sie wenn ihr wollt wieder sauber aus dem Playstore neu installieren.
 
A

almo911

Neues Mitglied
Erstmal ein RIESEN Dankeschön für deine Arbeit.

Eine Frage: Was ist der Unterschied in der V2 Version vom 11.03.?

Danke
 
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Erstmal gerne :) In der V2 fehlt nur die AFWall+ ansonsten ist alles das gleiche
 
A

almo911

Neues Mitglied
Danke, also braucht man die Zip zum Entfernen der AFWall nicht, richtig?
Warum war die eigentlich eingebaut? Ich hatte die bisher, um den Traffic der SystemUI zu blockieren - das brauch ich doch mit deiner sauberen Rom nicht mehr, oder?
 
A

almo911

Neues Mitglied
@Ziggy815
Hast du die AFWall+ in der ersten Kleenex-Version irgendwie konfiguriert bzw. hast du damit Verbindungen bewusst gekappt?
Als Frage: Sollte die AFWall+ instaliert werden oder kann ich ohne Bedenken die Kleenex Version 2 (ohne AFWall+) nehmen?
 
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Also ich denke man braucht sie nicht mehr wirklich, ich persönlich habe auf jedem Android Gerät die Firewall installiert, weil ich einfach gerne selbst bestimme welche Apps über welchen Weg ins Internet dürfen.
Nein sie war garnicht konfiguriert, hat aber wohl trotzdem teilweise was geblockt wie mir berichtet wurde und war dummerweise als SystemApp ins Rom eingebaut, so das man sie nicht updaten oder deinstallieren konnte, deswegen hatte ich für alle die schon komplett die erste Version des Roms installiert hatten und die Firewall wieder los werden wollen die AFWallRemove.zip erstellt, da diese die FW aus dem laufenden System deinstalliert ohne das man komplett neu flashen muss.
Es gilt also folgendes :
Das normale Rom ist mit Firewall
Die V2 ist ohne Firewall
Die Remove.zip entfernt die Firewall, falls gewünscht aus einem laufenden Rom ohne das man neu flashen oder wipen muss.
 
A

almo911

Neues Mitglied
Alles klar. Vielen Dank.