Fragen und Probleme Gear Watch Designer - Watchfaces erstellen und übertragen

R

rabi1968

Neues Mitglied
Hallo Zusammen,

ich verwende die Programmversion 1.3.0 beta (Build id:161212) vom Gear Watch Designer, und möchte für die S3 ein Zifferblatt erstellen. Nun habe ich beim Erstellen folgerndes Problem. Das Pixelverhältnis (OPR) ist zu hoch. Selbst Versuche mit wenigen Farben bringen keinen Erfolg. Erst bei einem Zifferblatt mit nur einer Digitalanzeige liegt der OPR-Wert unter 15%. Die Bilder oder Zeiger die ich einfügen möchte, bearbeitet ich mit Corel Paint Shop. Versuche mit folgenden Formaten hab ich probiert ohne einen Unterschied festzustellen PNG und JPG. Die angezeigte Fehlermeldung hab ich angehängt weiß einer von euch Rat?

Vielen Dank im Vorausund Grüße

upload_2016-12-27_10-22-42.png
 
Oxo

Oxo

Gewerbliches Mitglied
Interessant wäre ein Screenshot von Deinem Watch Face. Es gibt verschiedene Möglichkeiten dem On Pixel Ratio entgegenzuwirken. Eine gute und effektive Möglichkeit ist die Verwendung eines transparenten Layers.
 
R

rabi1968

Neues Mitglied
Hallo Oxo, erst mal danke für die Antwort.


upload_2016-12-27_16-20-23.png

-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
upload_2016-12-27_16-25-8.png


upload_2016-12-27_16-25-55.png


Hallo Oxo,
was meinst Du genau mit dem transparenten Layers?
Ich hab mal einen Hintergrund eingefügt und ihn transparent gemacht. Der OPR-Wert hat sich nicht geändert.
Auch leichte Anhebungen vom Opacity-Wert führen zu keinerlein Veränderung.
 
Oxo

Oxo

Gewerbliches Mitglied
Der Hintergrund bringt Dich nicht weiter. Erstell einfach ein schwarzes 360x360px PNG und füge dieses als Image im GWD ein. Das legst Du dann als obersten Layer fest. Jetzt kannst Du mit der Transparenz spielen. Natürlich wird das Watch Face dann im Ambient Mode dunkler, aber es funktioniert.
Ansonsten bleibt Dir nur die Verkleinerung des Logos.
 
R

rabi1968

Neues Mitglied
Wie empfohlen, hab ich ein schwarzes Image als zusätzlichen Layer an oberster Stelle eingefügt. Es hat nichts gebracht der %-Wert hat sich nicht geändert. Gib es vielleicht Projekt- oder Programmeinstellungen die ich ändern muss?

upload_2016-12-28_16-11-27.png

-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Sogar bei einem mitinstalliertem (GWD) Watch Face bekomme ich einen zu hohen Wert.

upload_2016-12-28_16-18-44.png
 
ennoo

ennoo

Ambitioniertes Mitglied
Threadstarter
Diese Werte machen bei 1.3 Probleme.
Ich ignoriere es mit 1.2.1 keine Probleme, klappt super. Allerdings AOD HIGH color generieren speichern und übertragen
 
R

rabi1968

Neues Mitglied
hab den Fehler gefunden.
Unter Projekt / Always-on state war der Hacken auch bei Low-bit color gesetzt.
Nach dem entfernen geht es auch ohne Layer.

Vielen Dank für deine Hilfe Oxo

upload_2016-12-28_16-56-46.png
 
wiboNote

wiboNote

Stammgast
es wird moniert, das Java JRE 1.8 oder höher benötigt wird. Selbstverständlich habe ich die aktuellste Version installiert. Hat jemand eine Idee warum dieses Programm dies nicht erkennt?
 
wiboNote

wiboNote

Stammgast
falls es jemanden interessiert: hab es gefunden, es muss die 32-bit Version, unabhängig davon welches Windows man fährt...
 
wiboNote

wiboNote

Stammgast
ein gutes neues 2017 an alle hier...
ich habe mich gestern nun mit dem Designer gespielt und mir ein Ziffernblatt erstellt, aber: normaler Weise wird die Uhr auch im AOD-Modus dunkel beim schlafen. Das funktioniert mit den selbstgemachten Ziffernblatt leider nicht worauf sich 20% mehr Akkuverbrauch ergibt. Wo hinterlegt man im Designer das im Ruhezustand die Uhr dunkel wird?
 
Oxo

Oxo

Gewerbliches Mitglied
Bei meinen selbst erstellten Watch faces wird das Display dunkel wenn die Uhr abgelegt wird. Eine besondere Einstellung dafür gibt es nicht.
 
wiboNote

wiboNote

Stammgast
ja wird wohl jede S3 wenn man diese abnimmt aber sorry, darum geht es gar nicht.
 
Oxo

Oxo

Gewerbliches Mitglied
Funktioniert aber auch wenn man schläft und die Uhr dabei trägt. Es gibt aber weiterhin dafür keine keine Einstellung :winki:
 
V

Vinzent

Ambitioniertes Mitglied
Da ich immer noch keine Verbindung vom PC zu meiner S3 aufbauen kann, hab ich mich mal im developer Forum bei Samsung umgetan und siehe da, das Problem scheint kein Einzelfall zu sein.
Habs mittlerweile an 2 verschiedenen Laptops ausprobiert. Winmal mit Win10 und einmal mit Win7. Beide Male kein upload möglich weil das Passwort als falsch angesehen wird (was es nicht ist). Das berichten auch andere Nutzer. Die Frage ist, warum klappt es bei dem einen und dem anderen nicht.
 
wiboNote

wiboNote

Stammgast
versuche mal folgendes: wähle Dich auf der Uhr in Dein WLAN ein und mache das Bluetouth vorher aus.
Wenn das funktioniert machst Du die Uhr komplett aus und wieder an.
Jetzt gehst Du in die WLAN-Einstellungen auf Deiner Uhr und wählst die Option WLANS, dann wählst Du die vorhandene WLAN-Verbindung und holst Dir die verwendete IP-Adresse.
Im GWD bei F9 drückst Du auf das + und gibst dort Deine IP-Adressen ein.
Nun sollte GWD versuchen sich über WLAN mit Deiner Uhr zu vebinden.
Wenn es dabei nicht fertig wird beendest Du GWD im Task-Manager und startest es neu.
Wenn die Verbindung funktioniert hast Du einen zusätzlichen Button der S3... heißt, den drückst um das WF zu installieren.
 
ennoo

ennoo

Ambitioniertes Mitglied
Threadstarter
@Vinzent
wlan auf der GEAR IMMER EIN lassen
 
Subaru WRX STI

Subaru WRX STI

Erfahrenes Mitglied
Debugging muß auch auf der Uhr an sein. Einstellungen/Gera-Info/Debugging. Danach die Uhr neustarten, dann sollte es gehen.
 

Anhänge

B

blechverdreher

Neues Mitglied
So ich gebe es auf,habe mir einmal das Program für Mac und Win runtergeladen.
Auf den Mac kann ich erst garnicht installieren.
Auf den Win Rechner findet er die Uhr nicht,und ich kann mich nicht anmelden.(Bei Samsung)
Komisch
 
Pett

Pett

Ambitioniertes Mitglied
Hi,

Ich würde gerne wissen was ich für den Facewechsel brauche, es gibt eine png eine jpg ein Archiv?
Vg
Pett
 
Oben Unten