Root und Custom Recovery (TWRP) für das Wiko Rainbow Jam

  • 54 Antworten
  • Neuester Beitrag
Diskutiere Root und Custom Recovery (TWRP) für das Wiko Rainbow Jam im Wiko Rainbow Jam Forum im Bereich Wiko Forum.
schihu

schihu

Neues Mitglied
Hallo Leut,s

also langsam kommt der Punkt an dem ich das "Jam" an die Wand werfe! :blushing:

1. Klappt das Rooten einfach nicht und
2. Kann ich auch nicht die anderen Root-Lösungen (mit App) verwenden da ich mit dem Teil nicht ins Internet komme (ist ein Fehler mit der "Host" Datei die ich auch nicht löschen kann da ich eben keine Root rechte habe,...)

Folgendes Problem:

Nachdem "Driver_x_MTK" erfolgreich ausgeführt wurde und die "UPDATE-SuperSU-v2.46.zip" ordnungsgemäß auf dem Handy liegt läuft das "SP Flash Tool v5.1516" ohne Probleme durch bis das OK kommt.

Jetzt aber: Wenn ich ins "TWRP (Recovery)" möchte dann komme ich nur ins normale recovery menü. Was für mich heißt dass das flashen wohl doch nicht erfolgreich war?

Ich sitze nun schon sit 5 (!"!!!!!!) Stunden :cursing::cursing::confused2::cursing::cursing: an dem Problem und habe alles mögliche und unmögliche versucht (denke ich zumindest).
Hat einer von euch eine Idee was ich noch machen kann? Muss vielleicht im "SP Flash Tool v5.1516" noch etwas eingestellt werden was nicht in dem Tutorial hier steht (ein paar Kleinigkeiten passen da auch nicht, bzw. wurden weggelassen, ist aber nicht schlimm)?

Wäre echt super wenn jemand noch nen Tipp hierzu hat. Ich komme um das Flashen/Rooten nicht herum weil ich sonst auch dieses Problem mit der Host Datei (Fehler bei Netzerkverbindungen/Internet) nicht beheben kann. Und was ist ein Smartphone ohne Internet,....:blink:

Grüßle schihu.

Ach ja und @ Kiwi++Soft,:
Klar, wenn man das bedenkt hast du natürlich auch recht! :sleep:
 
Kiwi++Soft

Kiwi++Soft

Ehrenmitglied
Zum Thema es kommt immer das normale Recovery: Hast Du bedacht, dass Du nach dem Flashen mit dem SP-Flash-Tool sofort ins Recovery booten musst, den wenn Du erst ins normale Andorid bootest, überschreibt das Android das aTWRP wieder mit dem Standard-Recovery. Erst wenn Du einmal im TWRP gebootet hast, geht das TWRP hin, und patcht das Andorid so, dass es nicht mehr das TWRP überschreiben will.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Nachtrag zur Erklärung:

Beim Booten von Android wird u.a ein Script namens 'install-recovery.sh' ausgeführt, dieses Script installiert das Stock-Recovery in der Recovery-Partition.

Ein Custom-Recovery wie CWM, TWRP oder Kiwi-Recovery hat daher eine Funktion eingebaut, dieses Script zu modifizieren.

Daher muss nach dem Flashen eines Custom Recovery immer sofort ins Recovery gebootet werden.

Aber keine Sorge, ich vergesse das auch oft, und muss dann das Custom-Recovery zweimal flashen...:rolleyes2:
 
schihu

schihu

Neues Mitglied
Hallo Uwe,
tja, das habe ich schon verstanden, nur vielleicht kannst du mir ja sagen WIE ich ins TWRP boote?:huh:

Also ich hab die Anweisungen schon befolgt und auch immer erst nach dem Flashtool (Telefon war immer noch aus) eben mit "Power und Lautstärke hoch" gebootet. Hier kommt aber wie geschrieben nur das normale recovery und dort ist ja auch kein Menüpunkt install,...

Also 1. entweder zeigt das Flashtool OK an obwohl gar nichts geflasht ist, oder 2. es gibt einen anderen Weg ins TWRP zu booten den ich aber leider nicht kenne,...:confused2:

Oder was meinst du was ich (das Teil?) falsch mache?

Gruß Hubert.
 
schihu

schihu

Neues Mitglied
Hallo Uwe,
ich hänge leider immer noch fest. :crying:
Hast du oder irgend jemand anderer noch eine Idee was ich tun kann/muss?
Ist vielleicht an dem Flashtool doch noch irgendwas einzustellen (Häckchen bei Boot etc....???), also außer bei "Download"? Ich habe mich bisher noch nicht getraut daran herum zu probieren.

Ich muss die (beiden) Geräte rooten - mal davon abgesehen dass ich bisher alle meine Geräte gerootet habe,... Bei denen scheint irgendetwas mit der Hosts Datei zu sein denn ich komme (über Wlan) einfach nicht ins Internet, ja nicht mal ins Heimnetzwerk (trotz aktivem angemeldeten Wlan)...:blink:

Selbst der Wiko Support konnte mir dabei keine Hilfe geben (außer einschicken). Es ist aber mehr als unwahrscheinlich das zwei neue Geräte einen (gleichen) "Defekt" haben. Die org. Firmware habe ich nach einem Full-Wipe auch schon neu installiert,... Sogar meine evtl. in Frage kommenden Wlan-Sicherheits-, Funkkanal-, etc.... einstellungen in der Fritzboch habe ich durchprobiert, an dem kanns auch nicht liegen.

Dieses Problem wurde ja auch schon von anderen Usern behoben, - nur leider geht dies auch nur mit Root. Und ich scheitere einfach schon hierbei.... Was kann ich tun? Evtl. auch eine hilfreiche App (.apk) manuell installieren,...?

Wenn ich wenigstens dieses Problem gelöst bekomme dann könnte ich auch in den Playstore und die andere Root-Lösung hier versuchen, nur so geht halt im Moment gar nichts.:cursing: Was ist ein (zwei) Smartphone ohne Internetzugriff - denn nur zum Telefonieren täte es auch ein alter "Knochen",...:confused2:

Wäre echt toll wenn noch jemand eine Idee hätte, dann sonst kann ich beide neuen Geräte in die Tonne klopfen wie es aussieht. :thumbdn:

Gruß Hubert.
 
B

BongoFury

Neues Mitglied
Hallo,
ich bin bisher noch recht "unbelastet" von Smartphones, daher hätte ich ein paar dumme Fragen:

Ich habe mir ein Rainbow Jam mit 16G gekauft. Auf dem Handy ist von Hause aus Android 5.1 installiert (Lollipop?) und ich würde es gerne von jeglichem Driss befreien.

Abgesehen davon das ich vieles hier beim lesen erst mal gar nicht verstehe habe ich auch keine Windows Computer. Insofern habe ich ein paar generelle Fragen:

1. Kann ich das Handy auch ohne Windows Rechner "umfrickeln"? (Ich benutze Debian)
2. Kann man die erforderlichen Dateien nicht mit adb auf das Handy kopieren oder geht es noch um etwas anderes als das reine kopieren der Dateien auf das Handy?
3. Welche der hier erwähnten Programme um das rainbow zu rooten und custom roms aufzuspielen laufen nur unter Windows und wie kann man diese umgehen?

Ich merke gerade das es eigentlich nur eine Frage ist: Wie kann ich Cyanogenmod mit Linux auf dem Jam installeren?

Hacker16 schrieb:
1.Installiert die App King Root und startet sie.
Da hört es bei mir schon auf, mein Jam kann Kingroot nicht installieren, weder die verlinkte Version noch eine neuere. Rooten wäre ja schon mal ein wichtiger Schritt, was gibt es da noch für Möglichkeiten?

Ich würde mich freuen wenn jemand mich da erleuchten könnte. Mein Englisch ist ja nicht schlecht, aber um bei XDA mitzulesen habe ich einfach nicht genug Grundkenntnisse von der Materie an sich um denen folgen zu können...

Bis dahin,
Bongo

(Wenn unbedingt nötig kann ich natürlich auf der Arbeit Windows benutzen bzw. ne kleine Partition mit Windows erstellen.)
 
Kiwi++Soft

Kiwi++Soft

Ehrenmitglied
Ich würde Dir folgendes Anraten:

Lass die Finger von solchem Zeug wie 'King-Root', nimm die Anleitung aus dem Start-Post um das Gerät vernünftig zu rooten. Bei KingRoot wird ggf zusätlicher Dreck installiert, den kein Mensch braucht.

Es gibt zwar einen Post zum Thema CyanogenMOD für das Wiko Rainbow JAM, aber ich habe noch keinen vertrauneswürdigen Link zu dem ROM gefunden.

Was das Thema 'Driss loswerden' angeht gebe ich folgendes zu bedenken: Man könnte, wenn man Root-Rechte hat, die 'Bloatware-Apps' zwar vom Gerät runter löschen, aber davon rate ich eher ab. Wenn man die Bloatware einfach in den Einstellung->Apps deaktiviert, verbrauchen sie auch keine Resourcen mehr, aber man muss nicht in der /system-Partition rumfummeln, und das geht sogar ohne Root-Rechte.
 
B

BongoFury

Neues Mitglied
Hallo Uwe,
vielen Dank für die schnelle Antwort. Ich werde dann wohl abwarten bis es ein vertrauenswürdiges Rom gibt und bis dahin den Müll deaktivieren :)
Bongo
 
K

kirschm

Stammgast
Ich kann Euch bzgl. KingRoot beruhigen... habe insgesamt 4x Wiko Bloom damit gerootet, man bekommt alle Spuren/Dreck problemlos weg und auch SuperSU statt dem hauseigenen SuperUser-Dingens drauf -> How to Remove/Replace Kingroot (KingUser) with SuperSu - W0lfDroid


Hier meine eigene Anleitung für SuperSU statt KingRoot, plus KingRoot Müll beseitigen (nachdem das Gerät mit KingRoot erfolgreich gerootet wurde):

· Terminal Emulator installieren: Terminal Emulator for Android - Android Apps on Google Play

· Die Zip-File runterladen: Replace_Kinguser_with_SuperSU-v2.4.zip

· Den entpackten mrw-Folder im Root der 'SD-Karte' platzieren. In meinem Fall war es die physische SD-Karte, die man ins Telefon steckt, nicht 'interne SD' bzw. 'Phone'. Ist der mrw-Folder z.B. im Phone Speicher, dann passiert ausser einer Fehlermeldung nichts. Daran merkt man dann, dass der mrw-Folder an der falschen Stelle war.

· Terminal Emulator starten:

· erster Befehl: su (plus Enter, Root-Rechte-Abfrage zulassen)

· zweiter Befehl: sh /sdcard/mrw/root.sh (plus Enter, jetzt kamen bei mir einige Fehlermeldungen, scheint aber normal zu sein)

· Danach hat sich SuperSU selbst gestartet... SU-Binary wie üblich updaten lassen... (Weiter... Normal...)

· SuperSU meldet ggf., dass noch eine andere SuperUser App existiert... deinstallieren lassen... Root letztlich vorhanden... Unter 'Alle Apps' bzw. intern/data/data ist noch com.kingroot.user... einfach deinstallieren... auch mal Folder intern/data/data/com.cleanmaster.mguard löschen... auch mal leeren Folder intern/data/data/mcube löschen

· Wichtig (sonst rastet Titanium aus) in SuperSU Settings: "Namensbereichsabtrennung mounten" deaktivieren und Telefon neu starten!

· Ergebnis: Kingroot ist weg. SuperSU ist drauf. Root vorhanden.

Kingroot Bloatware deinstallieren (Purify)
 
Zuletzt bearbeitet:
K

kirschm

Stammgast
... Kingroot gerade mit meinem neuen Rainbow Jam gemacht... da ist jetzt nix mehr drauf, was an Kingroot erinnert... :biggrin:
 
Verpeilter Neuling

Verpeilter Neuling

Super-Moderator & Mediator
Teammitglied
Und beim nächsten OTA denkst du hoffentlich daran, dass das sehr wahrscheinlich trotzdem nicht mehr funktioniert und im Brick endet. Darum OTAs ab jetzt besser auslassen und manuell installieren ;)
 
K

kirschm

Stammgast
Habe 'Systemaktualisierungen' via Titanium eingefroren... dann geht's auch nicht mehr manuell via Menü... habe ich bei jedem Wiko so gemacht... :biggrin: Brauch nicht jede Neuerung, wenn's läuft...
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Verpeilter Neuling schrieb:
Und beim nächsten OTA denkst du hoffentlich daran, dass das sehr wahrscheinlich trotzdem nicht mehr funktioniert und im Brick endet...
Ist der Brick Lollipop spezifisch? Warum ich frage:

Ich habe 2 Stück Wiko Sunset2 mit Kitkat 4.4.2... ebenfalls alle mit KingRoot gerootet... kürzlich kam ein OTA... habe es laufen gelassen... Root war weg... Root wieder mit KingRoot drauf gemacht und gut war. Bei dem zweiten Sunset2 habe ich dann 'Systemaktualisierungen' eingefroren, weil das Update ziemlich nutzlos war... Zumindest beim Sunset2 4.4.2 passiert beim OTA also nix weiter, als dass der Root halt weg ist...
 
Verpeilter Neuling

Verpeilter Neuling

Super-Moderator & Mediator
Teammitglied
Glaube nicht, dass das LP-spezifisch ist. Wir haben aber sehr viele Themen in den von mir moderierten Foren (also sowohl Wiko als auch den Weiteren Herstellern) immer wieder Probleme mit gebrickten Geräten nach Kingroot und einem OTA-Update. Von daher ist in diesem Fall generell Vorsicht geboten.
 
K

kirschm

Stammgast
Verstehe... aber dann ist halt meine persönliche Erfahrung mit Wiko und KingRoot: beim OTA-Update passiert nix, ausser dass man wieder neu rooten muss...

Hier spielen wohl auch die Umstände eine Rolle... früher wollte ich TWRP etc. Recoveries mit drauf... das ganze Programm... heute reicht mir Root und sonst nichts... mit Titanium bin ich flexibel genug im Falle eines 'Recoveries'... habe bisher also nur gerootet und niemals Probleme gehabt mit KingRoot bei einem OTA-Update...
 
Zuletzt bearbeitet:
A

Akuto

Neues Mitglied
Hätte jemand einen link für die TWRP ich würde einem sehr dankbar sein wenn das schnell erfolgen würde
Ich find keinen link im Internet für eine kompatibele TWRP fürs Rainbow Jam
PS: 16GB version
 
Verpeilter Neuling

Verpeilter Neuling

Super-Moderator & Mediator
Teammitglied
Ich habe deinen Beitrag mal in das angepinnte Thema geschoben. Hier gibts auch ein Custom Recovery ;).