Kein WLAN (mehr) nach Neustart

  • 6 Antworten
  • Neuester Beitrag
Diskutiere Kein WLAN (mehr) nach Neustart im Xiaomi Allgemein im Bereich Xiaomi Forum.
L

linuxnutzer

Lexikon
@Mod bitte bei Bedarf in den vermutlich am besten passenden Bereich verschieben.

Nach einem Neustart habe ich nicht zuverlässig WLAN.

Es geht dabei sicher um Xiaomi-Handys und tritt bei verschiedenen Handys extrem selten, selten und fast immer auf. Bei einem von 2 Max2 tritt es selten auf, beim anderen Max2 tritt es fast immer auf. Da es bei den Max2 relativ gesehen am häufigsten auftritt, bei einem aber kaum und beim anderen sehr, fällt mir die Logik es auf das Custom ROM evolutionx_4.7_mimax2_qq3a.200905.001_10.0_final zu schieben, bei anderen Xiaomis ist es aber vergleichsweise viel seltener.

Es könnte eventuell auch ein Fritzbox-Problem bzw. DHCP-Problem sein. In der Fritzbox hat jedes Handy eine bestimmte IP-Adresse, die zwar per DHCP vergeben wird, aber es ist eingestellt, dass immer die gleiche IP-Adresse vergeben wird.

Screenshot_20210307-012407_WiFi_Overview_360_Pro.png

Es fällt auf, dass einige Zeit lang überhaupt keine Netze angezeigt werden, auch nicht solche in die man sich einwählen könnte. Irgendwann meint dann die App, dass das Handy mit der richtigen SSID verbunden ist, obwohl keine Wifi-Verbindung besteht, die nicht aktivierte WLAN-Verbindung meint auch eine andere App vom gleichen Programmierer. Dies nur zur Information. Ich vermute, da ist irgendwas gecacht und liefert falsche Informationen.

Screenshot_20210307-012459_Einstellungen.png

Die Systemeinstellungen meinen also WLAN ist aus und das meinen auch einige andere Apps.

Screenshot_20210307-012615_Einstellungen.png

Von Systemseite sollte aber WLAN automatisch aktiviert werden.

Screenshot_20210307-012648_Einstellungen.png

Es ändert auch nichts, wenn ich die Benachrichtigung von öffentlichen WLANs deaktiviere. Nach dem Neustart ist WLAN so gut wie aktiv, manchmal aber schon.

Screenshot_20210307-012911_WiFi_Overview_360_Pro.png

Das WLAN sollte ausreichend stark sein und schwankt zwischen -60 und -50dB, wobei es auch nichts bringt, sich bei einem AP mit -30dB anzumelden.

Ich vermute, dass das Handy beim Start zu lange braucht um das WLAN zu erkennen bzw. eine IP-Adresse zu bekommen. Ich habe einen Wifi ein/aus-Schalter auf den Hauptsrcreen geben und da ist die Verbindung bei Berührung sofort aktiv, das ist aber dann, nachdem das Handy bereits einige Zeit fertig gebootet hat. Mobile Daten sind (vorübergehend zum Testen) deaktiviert. Ist das Wifi nach dem Neustart einmal aktiviert, kann ich bzgl. Wifi nicht mehr klagen.

Es hat auch nichts gebracht den AP, der bei der Installation verwendet wurde, zu löschen und einen anderen AP anzugeben.
 
Zuletzt bearbeitet:
L

linuxnutzer

Lexikon
Ich vermute, dass man DHCP ausschließen kann, denn am Problem ändert sich nichts, wenn man die SSID am Handy löscht und alles neu mit einer statischen IP (gleiche wie in der FB) am Handy definiert. Ich würde mich aber nicht trauen, die Fritzbox als Verursacher auszuschließen.
 
Zuletzt bearbeitet:
Raz3r

Raz3r

Senior-Moderator
Teammitglied
Hallo @linuxnutzer,

Du nutzt auf allen Geräten die gleiche Custom-ROM?
 
L

linuxnutzer

Lexikon
Nein, es geht um verschiedene CustomROM. Aber vielleicht passt es nun in der Praxis.

Ich habe ein Max2 bei dem ist das WLAN in der Regel nach einem Neustart da.
Beim 2. Max2 ist das WLAN in der Regel nicht da.
Beide Max2 hatten bis heute Vormittag evolutionx_4.7_mimax2_qq3a.200905.001_10.0_final installiert, woraus man eigentlich schließen könnte, dass das Problem nicht durch das Custom ROM hervorgerufen wird.

Ich habe das Max2 bei dem WLAN nur ausnahmsweise nach einem Neustart da war, mit dem gleichen Evolution-ROM neu geflasht, bei allem ein Wipe, das bei TWRP anzuhaken war.

Danach das ROM initialisiert, alle Updates gemacht, mehree Neustarts, nie war WLAN nach dem Neustart aktiv. Andererseits war WLAN beim 2. Max2 mit gleichem ROM nach Neustarts heute immer aktiv.

Danach installierte ich miui_mimax2_v12.0.3.0.qddmixm_qkq1.200114.002_10.0-prime und mit diesem ROM war WLAN nach einem Neustart immer da, habe mindenstens 20x über den Tag einen Neustart gemacht.

Da werde einer schlau ...

Ich habe jetzt (vermutlich) alle Custom ROMs beim Max2 mit Android 10 und halbwegs aktuellem Sicherheitsupdates durch. die anderen 2 fallen wegen zu hohem Akkuverbrauch durch. Also es ist etwas stressig ein CustomROM für das Max2 ohne deutliche Probleme zu finden, wozu ich eben Akku und GPS zähle.

Problem beim MIUI-Port ist, dass es auf die Region Indien fest eingeschränkt ist. Ich bin mir noch nicht klar, ob das auf den GPS-Empfang Auwirkungen hat, gab da heute einige Merkwürdigkeiten. Das war nur eine Nebenbemerkung, bei Bedarf mache ich einen eigenen Thread dazu. Es ist jedenfalls verdammt schwierig eher zufällige Probleme einzugrenzen.

Bis jetzt habe ich WLAN bei den Handys einfach aktiviert, wenn es mal nicht aktiv war, aber nun stellt sich heraus, dass da mehr dahinter steckt und es wird teuer, wenn man es nicht merkt, wenn man nach MB zahlt.
 
Zuletzt bearbeitet:
MarioLemieux66

MarioLemieux66

Erfahrenes Mitglied
Vielleicht liegt es an Deinen Akkuoptimierungen, dass WLAN und GPS Probleme machen?
 
L

linuxnutzer

Lexikon
Vielleicht liegt es an Deinen Akkuoptimierungen
Keine Ahnung was du meinst? Ich habe den Akku nicht optimiert, außer beim Laden schalte ich bei 20% automatisch aus. Der MIUI-Port bringt nun jedes Mal WLAN nach dem Neustart / EInschalten und das andere Max2 schaltet WLAN jedes Mal ein. Zum Thema GPS bin ich gerade dabei einen Thread zu erstellen.
 
MarioLemieux66

MarioLemieux66

Erfahrenes Mitglied
Ich meine, dass Deine Optimierung des Stand-by Verbrauchs möglicherweise Auswirkungen auf gewisse Komponenten haben könnte.