Xiaomi Mi A1 [WLAN Verbindung ist ständig unterbrochen]

  • 33 Antworten
  • Neuster Beitrag
W

Whitcomb

Neues Mitglied
Threadstarter
Hallo,
habe seit längerem das Problem das mein Mi A1 Zuhause die Verbindung zum Wlan immer wieder unterbricht.
Der Router und das Wlan funktionieren einwandfrei.
Andere Personen welche das Wlan ebenfalls nutzen mit ihren Smartphones haben keinerlei Probleme.
Das Handy zeigt mir auch jedes mal mein WLAN Netz an wenn es wieder unterbrochen ist.
Aber es verbindet sich nicht erneut automatisch mit dem WLAN Netz.
Auch wenn ich versuche manuell neu zu verbinden braucht es einige Anläufe bis die WLAN Verbindung wieder aufgebaut wird.
Dann wird sie nach einiger Zeit wieder unterbrochen.

Kann mir bitte jemand eine Lösung für dieses lästige Problem nennen ?

@Offtopic
Zudem habe ich noch eine Frage was die "WLAN Automatik" betrifft. Im normalen Stock Android ist diese Option in den WLAN Einstellungen enthalten, jedoch bei dem M1 A1 nicht.
Diese muss laut Recherche manuell freigeschaltet werden.
Frage: Wie kann das sein wenn angegeben wird das dass A1 "Stock Android" nutzt ?

Bin bisher sehr begeistert von dem Gerät und finde es für den Preis einfach Klasse.
Jedoch stimmen mich so Dinge wie die "WLAN Problematik" und der qualitativ grotten schlechte Simkarten Slot, momentan eher negativ.
 
kugesch

kugesch

Fortgeschrittenes Mitglied
T

tka

Fortgeschrittenes Mitglied
@Whitcomb Welchen Router hast du? Unitymedia Connect Box?
 
kugesch

kugesch

Fortgeschrittenes Mitglied
@tka
es geht nicht um den WLAN-Router, sondern darum das Mi A1 zu "rooten"
 
W

Whitcomb

Neues Mitglied
Threadstarter
@Whitcomb Welchen Router hast du? Unitymedia Connect Box?
Ganz genau, wundert mich das du sofort darauf schließen konntest.
Kannst du mir den Grund verraten und mir sagen was ich tun kann?
 
T

tka

Fortgeschrittenes Mitglied
Es ist das selbe Problem, das wir und andere mit unseren Lenovo-Tablets haben bzw. in meinem Fall hatten. Bei mir steht jetzt eine Fritzbox, danach war es vorbei. Mag sein, das auch die Software auf dem Endgerät eine Rolle spielt, die Ursache würde ich aber im Router vermuten.
 
W

Whitcomb

Neues Mitglied
Threadstarter
Das Problem mit Xiaomi und Unity Media Connect Box ist anscheinend bekannt.
Lösungsansätze:
  • Band von 2,4 auf 5 Ghz stellen
  • Für 2,4 und 5Ghz eine einzelne SSID vergeben
  • Verschlüsselung ändern
Bei anderen hat das geholfen, bei mir jedoch nicht.
Ich weiß auch nicht was mir ein "Root" da helfen soll, wenn es ein Hardware Problem zu sein scheint.
Meine Vermutung ist das der Wlan Adapter von Xiaomi nicht mehr der neuste bzw. beste ist und er deswegen Probleme macht.
Bin sonst echt mega zufrieden mit dem Gerät aber das bringt mir wenig wenn ich kein Wlan nutzen kann.
 
W

Whitcomb

Neues Mitglied
Threadstarter
Update: Rooten ist ebenfalls nicht möglich. Recovery Modus gibt es nicht -> Der Screen des Recovery Modus enthält eine Meldung mit "No command".
Nochmaliges drücken von Power Taste + Volume UP/Down Key bringt auch nichts.
Sämtliche anderen Kombinationen funktionieren ebenfalls nicht.

Das Fastboot Zeug funktioniert auch nicht. Die Commands in Powershell werden nicht erkannt.

War ja ganz witzig mal ein billig China Handy auszuprobieren aber für die Zukunft werd ich mir doch wohl was vernünftiges holen.
 
Zuletzt bearbeitet:
B

bluestar60

Neues Mitglied
Hab Smartphones seit der Zeit da Vodafone noch Mannesmann geheißen hat. Das Xiaomi Mi A1 ist eins der besten Teile was das Preis / Leistung angeht. Sorry, da kann das Handy nichts dafür, für menschliche Unfähigkeit. Nichts schlecht machen, was nicht schlecht ist. Musste gesagt werden.

1. Kauf dir einen anständigen Router wie
eine Fritzbox. Selber eine 7412. Die
bekommst du schon für 50 € !
Null Probleme. Ganz im Gegenteil.

2. Man kommt sehr wohl ins Stock-Recovery. Nur richtig machen.
Ist halt ein gefummel. Nach " no command " Power u. Up mehrmals
drücken.

3. Auf XDA gibts z.B. aktuelle Modems zum flashen. Sollte aber nicht nötig sein.
Kommt darauf an, welche Version man hat.

4. Ich komme sogar mit meinem Tablet per fastboot drauf. Funktioniert sehr wohl.
Ohne Windows oder Linux.

5. Man könnte auch per fastboot das TWRP temporär auf dem Gerät booten und
das Teil dann rooten. Bootloader vorher entsperren. Einfachst Lösung.
" fastboot boot xxxxx.img "

Also.... aufgehts. Oder dann doch lieber ein überteuertes iPhone oder Samsung.
;-)
 
W

Whitcomb

Neues Mitglied
Threadstarter
@bluestar60

1. Kauf dir einen anständigen Router wie
eine Fritzbox. Selber eine 7412. Die
bekommst du schon für 50 € !
Null Probleme. Ganz im Gegenteil.
Du solltest ja im Thread mitbekommen haben das ich bei UnityMedia bin.
Heißt -> Internet gibts übers TV Kabel.
Das wiederum bedeutet das ich mit so popels 0815 Routern nichts anfangen kann, sondern einen Router mit integriertem Kabelmodem benötige.
Klar gibts da super Router von Firtzbox, heißen da Fritzbox 6490 oder 6590 und fangen bei 168€ an.

2. Man kommt sehr wohl ins Stock-Recovery. Nur richtig machen.
Ist halt ein gefummel. Nach " no command " Power u. Up mehrmals
drücken.
Zitat aus meinem vorherigen Post:
"Nochmaliges drücken von Power Taste + Volume UP/Down Key bringt auch nichts.
Sämtliche anderen Kombinationen funktionieren ebenfalls nicht."

Da ich nie Vodafone Kunde war hab ich keine Ahnung wann sie Mannensmann geschimpft wurden, jedoch habe ich seit dem Release des Iphone 3GS so ziemlich alles an Smartphone Typen ausprobiert die es gibt und habe diese auch immer gejailbreaked und gerooted bis auf zwei Ausnahmen wo von das M1 A1 eine ist.
Und soviel gefummel und Probleme wie bei dem M1 A1 hatte ich vorher noch nie.
Mag fairer Weise auch nicht nur am Gerät sondern auch an Oreo liegen, trotzdem trägt es nichts positives dazu bei.

Und wenn wir schon bei menschlicher Unfähigkeit sind... Wer lesen kann ist.... Oder wie war das nochmal ;-)

Ich bin ja schon selber überall am recherchieren, meistens sogar auf internationalen Seiten und Foren. Schaue mir sogar auf Youtube irgendwelche Videos von Indern an die auf englisch Hilfestellung geben.
Aber wenn nach 2 Stunden recherechiererei nichts dabei rummkommt, siehts düster aus.

Trotzdem danke für den Hilfeversuch.

Lg
Whitcomb

PS: Ich hab auch nie gesagt das dass Gerät Preis/Leistungs technisch schlecht sei.
Ganz im Gegenteil. Jedoch hat es keinen Nutzen für mich mit den Problemen die es mir momentan bereitet.
 
Zuletzt bearbeitet:
T

tka

Fortgeschrittenes Mitglied
Du haust ja ganz schön drauf auf die Leute, die sich Zeit nehmen, DEINE Probleme zu diskutieren. Ein letzter Tipp, dann bin ich hier raus:
Wenn die Einstellungen an der Connectbox keine Besserung bringen, kannst du dort das WLAN abschalten und einen günstigen Router daneben stellen, der das WLAN aufspannt. Die sollten ab 20€ aufwärts zu bekommen sein. Die beiden verbindest du mit einem Netzkabel.
 
W

Whitcomb

Neues Mitglied
Threadstarter
Du haust ja ganz schön drauf auf die Leute, die sich Zeit nehmen, DEINE Probleme zu diskutieren.
Moment mal, erstmal wurde ich als "unfähig" bezeichnet.
Darauf hin hab ich mir die Tipps und Schritte des Vorposters genau durchgelesen, nur um feststellen zu müssen das er sich anscheinend überhaupt nichts von mir durchgelesen hat.
Ich hab mich aber trotzdem bedankt, eben weil er sich die Zeit genommen hat mir zu antworten in der Diskussion.
Und dann kommt noch so ein (***)Kommentar von dir, den du dir echt sparen kannst.

Das mit dem Router könnte ich probieren, aber würde auch nicht das Problem lösen das ich nicht in den Recovery Modus komme.

Trotzdem auch an dir nochmal danke wegen des Tipps mit der Connect Box.

Aber ich glaube das war es auch hier für mich an der Stelle.
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von MSDroid - Grund: Unnötige Aussage entfernt (***) Gruß MSDroid
B

bluestar60

Neues Mitglied
Das mit dem Router vorschalten, war ja auch mein Gedanke, was die 7412 betrifft. Hat übrigends klasse Wlandurchsatz.

Aber: hast doch bestimmt irgendwo ein gerootetes Android.
Da am besten " Magisk " installieren, das Modul " adb & fastboot " installieren.

Per OTG das Xiaomi damit verbinden. Vorher natürlich mit Power + Down in den Bootloader. MUSS GEHEN !!!!! Ausser du hast das Teil total zusammen geschossen, was ich mir jetzt nicht vorstellen kann.

Am gerooteten Teil eine Shell auf und Bootloader frei schalten: fastboot oem unlock.

Dann das vorher heruntergeladene TWRP fürs Xiaomi temporär starten: fastboot boot twrp.xxxx.img

Dann kannst es zumindestens rooten. Darauf achten wegen den zwei Slots. Wenn du mit Magisk rooten willst, nach dem ersten flashen nochmal ins Recovery booten und die Prozedur nochmal wiederholen.
Ist wegen der aktiven u. passiven Bootpartition.

Tip: Mi A1 mit LineageOS und Moun-Kernel ein Traum. Wahnsinns Akkulaufzeit.

Und nicht immer alles so persönlich nehmen :)

Gruss.
 
MSDroid

MSDroid

Super-Moderator
Teammitglied
Bitte eröffnet für weitergehende Diskussionen zu Root und Co. doch einen neuen Thread, oder schaut, ob es in einem vorhandenen Thread besser passt, falls da Bedarf besteht. Hier soll es primär um das Thema WLAN Verbindung und Probleme in diesem Zusammenhang gehen ;)
 
F

FrunckelA1

Neues Mitglied
Hallo zusammen,

ich habe/hatte das gleiche Problem. Mein Router ist eine Fritz 7490. Ich habe mir aufgrund des AndroidOne das Mi A1 gekauft. Google verspricht das Betriebssystem aktuell zu halten. Inkl. Sicherheitspatches. Aus diesem Grund kommt ein Customer Rom für mich nicht in Frage.

Bis jetzt klappt folgendes Vorgehen bei mir:
1. Alle WLan Verbindungen löschen.
2. WLan Verbindungen manuell anlegen mit dem Button "Netzwerk hinzufügen"
3. SSID manuell eingeben
4. Bereich Sicherheit WPA/WPA2 PSK ausgewählt (habe im Router den WPA-Modus WPA2 (CCMP) eingestellt)
5. Passwort eintragen (Tipp, Checkbox Passwort anzeigen anklicken)
6. Erweiterte Optionen: nicht notwendig
7. Speichern.

Die Option "WLAN automatisch aktivieren" ist bei mir aus.

Danach ging es bei mir...

Grüße an Alle
 
B

Bonsairambo

Neues Mitglied
Hallo zusammen.

Ich habe das gleiche Problem. Ich habe vor 4 Wochen mein neues Mi A1 (Android One) bekommen und bei meinen Haus-Wlan, das von dem Gerät

Hersteller Hitron Technologies
Modell CVE-30360
Hardware Version 1C
Firmware Version 4.2.10.4-IMS-KDG
Boot Version PSPU-Boot 1.0.16.22-H2.9.1


aufgespannt wird, fliegt das Handy regelmäßig aus dem Netz. Ich merke es vor allem wenn ich bei Clash of Clans online bin. Nach ca. 10 min flieg ich ca. zweimal kurz hintereinander aus dem Netz bevor es einigermaßen dauerhaft stabil bleibt. Neulich war im Urlaub und in der Ferienwohnung bin ich im Minutentakt aus dem Wlan geflogen. Mit meinem alten Samsung A3 hatte ich nie Probleme. Ebenso hat meine Frau mit ihrem Samsung J5 keine Probleme und auch in der Ferienwohnung blieb sie problemlos mit dem Handy angemeldet. Den Tipp direkt über meinem Beitrag habe ich erfolglos ausprobiert. Weitere Tipps finde ich im Internet nicht.

Die anderen Tipps, ala Rooten etc. verstehe ich nur zu Hälfte und ich möchte eigentlich nicht im Betriebssystem rumwerkeln, da das Gerät komplett neu ist und ich möchte eigentlich auch nur Geld für zB einen neuen Router ausgeben, wenn ich sicher weiß, dass damit auch das Problem gelöst ist.

Vielen Dank im Voraus.
 
A

allien131

Neues Mitglied
ich habe schon überall im Internet nachgeschaut zwar wurde viel über den Fehler geschrieben aber eine lösng habe ich noch niergens gefunden Habe das MIA1 das im FEBruar 19 das Android Upgrade 9 pie erhalten hat.
Ich kann nicht sagen ob es gleich danach war aber seit einiger Zeit kann ich WLAN nicht mehr dauerhaft zuschalten immer nach 5-10 sekunden wird das W-Lan neu gesucht und kurz verankert (Schlösschen)
Habt Ihr eine Ahnung was da los ist und wie das gelös werden kann.
Kann zwar mittels Mobilen Daten (kosten extra) arbeiten aber das kann doch nicht die Lösung sein??
Grüsse noch an alle hier, werner
 
minidiegi

minidiegi

Ehrenmitglied
Versuche mal das WLan Passwort neu einzugeben, das Schlösschen zeigt an, dass du keinen Zugang hast.
 
A

allien131

Neues Mitglied
Hallo vielen Dank für die schnelle Reaktion. Es ist das MI A1
habe das alles x-mal versucht Passwort usw.
Die anderen Smartphones die ich hier habe funktionieren per WLAN einwandfrei.
Am Router scheint es demnach nicht zu liegen
hab jetzt alles auf Werkseinstellungen zurückgesetzt >>> das Gleiche
Damit Ihrs Euch noch genauer vorstellen könnt
was passiert genau?
wenn ich einschalte kommt die Anzeige WLAN mit Fragezeichen.
Gehe dann auf Einstellungen
kommt der Button Netzwerk¬Internet
klicke an kommt der Button WLAN nicht verbunden aber der Schalter ist on
klicke an zum verbinden kommt WLAN verwendensofort wird mein WLAN vebunden für ein paar sekunden
dannabschaltung
dazu unten WLAN wir automatisch wieder aktiviert
Das blöde ist das ich über mobile daten laufend bezahlen muss und keinen Ausweg sehe.
 
A

allien131

Neues Mitglied
Hallo allen xiaomi experten und Fans bin 72 und hoffe auf Euer Verständnis wegen meiner vielleicht nicht professionellen Fragerei,
habe genau dasselbe Problem WLAN wird alle paar Sekunden abgestellt und wieder verbunden unbrauchbar seit etwa einem Monat.
Zwei andere Smartphones (ältere Huawei) die ich hier habe, funktionieren mit meinem Router einwandfrei.
Hatte inzwischen auch das Androit 9 drauf gespielt bekommen und sehe einen Zusammenhang mit dem WLAN Problem
Mir würde vorgeschlagen doch mal das WLAN-Passwort neu einzugeben und und und alles schon vorher gemacht.>>> Erfolg null (auch auf Werkeinstellung bringen brachte nix )
Jetzt kam hier die Idee vom rooten des Gerätes und der Verweis auf eine englische Seite.
Muss Euch sagen verstehe weder genügend englisch noch die Verfahrensweise eines "rootens"
Ist es möglich, das so zu erklären das ein Laie das nachverfolgen kann und evtl. sogar den Fehler findet und ihn beheben kann?
Grüsse Werner
 
Ähnliche Themen - Xiaomi Mi A1 [WLAN Verbindung ist ständig unterbrochen] Antworten Datum
2
4
2
Oben Unten