1. geoo, 18.04.2011 #1
    geoo

    geoo Threadstarter Neuer Benutzer

    Hallo,

    ich habe Probleme mit Umlauten beim versenden von JSON Daten. Das versenden/Empfangen usw klappt alles wunderbar, jedoch scheint irgendwas mit dem encoding nicht zu stimmen...
    Es tritt sowohl beim empfangen als auch beim senden auf. Als Server benutze ich einen Java Server. Habe grade leider den Code nicht hier, aber vielleicht hat ja jemand schon so eine Idee, den Code werde ich dann nachher oder morgen posten.

    Hoffe mal das mir hier jemand helfen kann und vielen dank schonmal ;)
     
  2. computer_freak, 18.04.2011 #2
    computer_freak

    computer_freak Gewerbliches Mitglied

    Erstmal Willkommen im Forum, geoo!

    JSON benutzt als codierung UTFx (8)

    Pass auf, dass die kommunikation in UTF8 statt findet und auch deine dateien als utf8 dateien angelegt sind, nicht etwa ASCII, o. ae.

    Noch ein stueck besser waere gleich die encodierte version der umlaute zu verwenden:
    Ein "ö" entspricht demnach beispielsweise ein "\u00f6".
    Die UNICODE Werte fuer umlaute usw kannst du googeln.
     
Die Seite wird geladen...
Similar Threads Forum Datum
B390 Probleme mit Kalender verfielfachte Einträge. Honor 7 Forum 23.05.2017
Lifetab 10351 Touch Probleme Medion Allgemein 23.05.2017
Probleme bei der Datensynchronisieriung Huawei P10 Lite Forum Mittwoch um 06:35 Uhr
Lautsprecher Probleme LG G4 (H815) Forum Samstag um 17:23 Uhr
Probleme ZTE Axon7 NFC-Tag ZTE Axon 7 Forum Samstag um 18:57 Uhr
LE 2 X820 Softkey Probleme LeEco Le Max 2 (X820/X821/X822) Forum Samstag um 21:02 Uhr
[OFFEN] Probleme mit Action Floating Button Android App Entwicklung Samstag um 23:45 Uhr
Android 7 Nougat - Probleme Gesten Fingerabdrucksensor Huawei MediaPad M3 Forum Sonntag um 22:42 Uhr
Update Probleme von Apps über Playstore Sony Xperia Z5 Compact Forum Gestern um 09:05 Uhr
Probleme mit Sperrbildschirm Samsung Lockscreen Gestern um 19:32 Uhr