1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Ext Sd unter ICS

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy S" wurde erstellt von ilovemysgs, 05.01.2012.

  1. ilovemysgs, 05.01.2012 #1
    ilovemysgs

    ilovemysgs Threadstarter Android-Lexikon

    Beiträge:
    1,094
    Erhaltene Danke:
    156
    Registriert seit:
    26.08.2011
    Moin,

    Ist es möglich per adb oder einer Terminal app das mounten von emmc auf sd/external sd zu ändern

    Vllt. So :

    unmount /emmc
    mount/sdcard/external sd

    Danke fûr eure antworten

    Sent from my GT-I9000 using Tapatalk
     
  2. Illusionz, 05.01.2012 #2
    Illusionz

    Illusionz Android-Experte

    Beiträge:
    885
    Erhaltene Danke:
    98
    Registriert seit:
    26.09.2010
  3. PJF16, 05.01.2012 #3
    PJF16

    PJF16 Senior-Moderator Team-Mitglied

    Beiträge:
    13,857
    Erhaltene Danke:
    8,060
    Registriert seit:
    06.01.2011
    Phone:
    Xiaomi RedMi Note 4
    Tablet:
    Nexus 7 (2012), Nexus 10, iPad Air 2 Cellular
    Wearable:
    Motorola Moto 360
    Ich werde heute versuchen, ein CWM flashbares Package zu erstellen. ;)

    EDIT: Scheint wohl unter ICS anders zu funktionieren, denn die Einträge existieren in der build.prop gar nicht. ;)
     
    Zuletzt bearbeitet: 05.01.2012
  4. ilovemysgs, 05.01.2012 #4
    ilovemysgs

    ilovemysgs Threadstarter Android-Lexikon

    Beiträge:
    1,094
    Erhaltene Danke:
    156
    Registriert seit:
    26.08.2011
    Was von emmc steht im der Init.aries.ac

    Sent from my GT-I9000 using Tapatalk
     
  5. n0va, 05.01.2012 #5
    n0va

    n0va Fortgeschrittenes Mitglied

    Beiträge:
    280
    Erhaltene Danke:
    49
    Registriert seit:
    12.04.2010
    Phone:
    Sony Xperia Z1 Compact
    Kannst mal das im Terminal eingeben, hält aber nur bis zum Neustart:
    mount /mnt/emmc /mnt/sdcard/external_sd
    Der Ordner external_sd muss auf der internen Karte vorhanden sein.
     
  6. ilovemysgs, 05.01.2012 #6
    ilovemysgs

    ilovemysgs Threadstarter Android-Lexikon

    Beiträge:
    1,094
    Erhaltene Danke:
    156
    Registriert seit:
    26.08.2011
    @Nova geht net

    Sent from my GT-I9000 using Tapatalk
     
  7. n0va, 05.01.2012 #7
    n0va

    n0va Fortgeschrittenes Mitglied

    Beiträge:
    280
    Erhaltene Danke:
    49
    Registriert seit:
    12.04.2010
    Phone:
    Sony Xperia Z1 Compact
    Hab vorhin mal genau das eingegeben und bei mir ist die externe jetzt auch unter /sdcard/external_sd bzw. /mnt/sdcard/external_sd erreichbar..
     
  8. Illusionz, 05.01.2012 #8
    Illusionz

    Illusionz Android-Experte

    Beiträge:
    885
    Erhaltene Danke:
    98
    Registriert seit:
    26.09.2010
    Versuchs nochmal, wenn du "su" vorher eingibst.
     
  9. n0va, 05.01.2012 #9
    n0va

    n0va Fortgeschrittenes Mitglied

    Beiträge:
    280
    Erhaltene Danke:
    49
    Registriert seit:
    12.04.2010
    Phone:
    Sony Xperia Z1 Compact
    Daran könnte es liegen, starte bei mir standardmäßig den Emulator mit Rootrechten.
     
  10. ilovemysgs, 05.01.2012 #10
    ilovemysgs

    ilovemysgs Threadstarter Android-Lexikon

    Beiträge:
    1,094
    Erhaltene Danke:
    156
    Registriert seit:
    26.08.2011
    Alles bring nix
    Soll ich mal die der Teufel zip flashen (mountpoint tweak)

    Sent from my GT-I9000 using Tapatalk
     
  11. extralife, 05.01.2012 #11
    extralife

    extralife Android-Guru

    Beiträge:
    2,217
    Erhaltene Danke:
    818
    Registriert seit:
    22.09.2010
    Besser nicht

    ... using tapatalk
     
  12. ilovemysgs, 06.01.2012 #12
    ilovemysgs

    ilovemysgs Threadstarter Android-Lexikon

    Beiträge:
    1,094
    Erhaltene Danke:
    156
    Registriert seit:
    26.08.2011
    Ok extralife ;)

    Sent from my GT-I9000 using Tapatalk
     
  13. orangerot., 06.01.2012 #13
    orangerot.

    orangerot. Android-Guru

    Beiträge:
    2,281
    Erhaltene Danke:
    643
    Registriert seit:
    04.09.2011
    Phone:
    Samsung Galaxy S3
    Ich hab es grad auch probiert..

    Terminal emulatr:
    su [enter]
    dann deine zeilen
    exit[enter]

    Der emulator spuckt nach der eingabe folgendes aus: Usage: mount [-r] [-w] [-o options] [-t type] device directory. Das gleiche passiert wenn ich es über ADB probiere(ADB shell--> su--> deine zeile-->exit-->exit)

    leider kann ich über den Orndern die externe nicht errreichen, die ist immer noch nur unter emmc zu erreichen. Ich verwende build 12(mit perka mod falls das wichtig ist)

    Woran liegt es dass es bei dir klappt und bei mir nicht?
     
    Zuletzt bearbeitet: 06.01.2012
  14. n0va, 06.01.2012 #14
    n0va

    n0va Fortgeschrittenes Mitglied

    Beiträge:
    280
    Erhaltene Danke:
    49
    Registriert seit:
    12.04.2010
    Phone:
    Sony Xperia Z1 Compact
    Komisch, per ADB geht's bei mir auch nicht... Wenn ich's aber im Gerät mit dem Better Terminal Emulator Pro eingeb, funktioniert das ohne Probleme... Liegt wohl am Programm.

    Edit: Setz mal ein busybox vor den Befehl, dann geht's bei mir auch mit ADB:

    busybox mount /mnt/emmc /mnt/sdcard/external_sd
     
  15. orangerot., 06.01.2012 #15
    orangerot.

    orangerot. Android-Guru

    Beiträge:
    2,281
    Erhaltene Danke:
    643
    Registriert seit:
    04.09.2011
    Phone:
    Samsung Galaxy S3
    Ich habs jetzt mal mit dem busybox im Termianal Emulator probiert und siehe da es geht :) Aber es gibt ´s keine Option, dass es dauerhaft so bleibt und nicht nach jedem reboot des SGS erneut abgegeändert werden muss?(Ist zwar auch nicht so schlimm, da man es ja nicht all zu oft neustartet, aber es wäre um einiges bequemer :D)

    Aber nach der änderung wird das SGS nicht mehr am PC erkannt! Erst durch das installieren der Galaxy Nexus Treiber(statt wie vorher der Nexus Treiber) und einem Neustart des PC´s wird das SGS wieder im ADB und als MTP Gerät erkannt! Ist das immer so oder nur bei mir?
     
    Zuletzt bearbeitet: 06.01.2012
  16. boarder87, 29.01.2012 #16
    boarder87

    boarder87 Fortgeschrittenes Mitglied

    Beiträge:
    282
    Erhaltene Danke:
    51
    Registriert seit:
    08.06.2011
    ist da noch jemand dran zu versuchen wie man die externe SD wieder wie in den Stock Firmwares zu mounten?
     
  17. orangerot., 29.01.2012 #17
    orangerot.

    orangerot. Android-Guru

    Beiträge:
    2,281
    Erhaltene Danke:
    643
    Registriert seit:
    04.09.2011
    Phone:
    Samsung Galaxy S3
    So geht es einwandfrei! Du Musst den Befehl halt nur nach jedem Reboot neu ausführen. Einen anderen Weg gibt es glaube ich nicht.
     
  18. Gerhard_B, 28.09.2012 #18
    Gerhard_B

    Gerhard_B Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    28.09.2012
    Kann man den Mount-Befehl nicht in einem Script bei jedem booten aufrufen ?

    Ich hab schon so einiges versucht, jedoch ist nichts dabei gewesen, was nach dem Booten die /EMMC/ nach /SDCARD/EXTERNAL_SD mountet.


    • Den Mount-Befehl im Terminal eingeben - funktioniert bis zum nächsten Reboot
    • Rom-Toolbox Lite - die Befehle in ein Script eingetragen und dann ausgeführt, funktioniert bis zum nächsten Reboot
    • Directory Bind - funktioniert bis zum nächsten Reboot
    • RemountSD - ohne Wirkung obwohl die Pfade richtig eingetragen waren

    Mit dem AOKP - Milestone 6 was ich vorher installiert hatte, konnte ich wenigsten die External_SD einbinden.
    Mit dem Helly Bean bekomme ich das aber nicht hin.

    Daher wäre ich für ein Sript sowie eine Step by Step Anleitung was ich machen muß sehr dankbar.

    Problem gelöst: mit dem Script Manager aus dem Market kann man ein Script beim Booten starten. Mit den richtigen Rechten und Flags versehen wird die Sd-Karte jetzt wieder wie gewohnt unter sdcard/external_sd eingebunden.
     
    Zuletzt bearbeitet: 29.09.2012
  19. grinder777, 29.09.2012 #19
    grinder777

    grinder777 Android-Hilfe.de Mitglied

    Beiträge:
    61
    Erhaltene Danke:
    32
    Registriert seit:
    24.09.2012
    Warum nicht einfach unter

    Einstellung-Speicher - MENÜ TASTE - Speicherkonfiguratinon

    den internen Speicher deaktivieren?

    Gesendet von meinem GT-I9000 mit Tapatalk 2
     
  20. Gerhard_B, 29.09.2012 #20
    Gerhard_B

    Gerhard_B Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    28.09.2012
    Weil zum Einen, gibt es da nur die Möglichkeit die Art der PC-Verbindung umzustellen. Zum Anderen möchte ich die externe Karte zusätzlich einbinden und nicht entweder oder. Die Karte ist ja unter EMMC vorhanden aber ohne Freigabe des über geordneten Verzeichnisses durch den Datei-Explorer nicht erreichbar.

    Problem gelöst -> siehe vorletzten Post

    [​IMG][​IMG]
     
    Zuletzt bearbeitet: 30.09.2012

Diese Seite empfehlen