1. Möchtest Du unser Team im Android OS-Bereich unterstützen? Details dazu findest du hier!
  2. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

K9 Mail: Probleme mit IMAP und SSL-Zertifikaten

Dieses Thema im Forum "K9 / K-@ Mail / Kaiten Mail" wurde erstellt von COOGOR, 06.07.2012.

  1. COOGOR, 06.07.2012 #1
    COOGOR

    COOGOR Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    112
    Erhaltene Danke:
    1
    Registriert seit:
    31.05.2012
    Hi,

    ich habe unter K9 zwei IMAP-Konten eingerichtet, und rufe diese mit SSL (immer) ab. Zunächst ist mir aufgefallen, dass das nur bei Verbindung über WLAN geht, aber nicht über Mobilnetz. Sonstige Datentransfers (Browser...) gehen.

    Daraufhin habe ich die Einstellungen des Eingangsservers über prüft, und siehe da: er zeigt mir einen Zertifikatfehler: Im Konto A moniert er des Zertifikat von Konto B und umgekehrt, zumindest bei WLAN. Bei Mobilfunk gibts nen Timeout.
    Fragen....unterstützt die Telekom keinen Transport über SSL?
    Wo kann man die Zertifikate löschen, um ggf. neu zu beginnen?
    ...ist die Zertifikatsgeschichte ein bekannter Bug? Oder gar eine undetected feature?
     
  2. DrGregoryHouse, 06.07.2012 #2
    DrGregoryHouse

    DrGregoryHouse Android-Lexikon

    Beiträge:
    1,480
    Erhaltene Danke:
    258
    Registriert seit:
    16.11.2010
    Bist du dir ganz sicher das deine Einstellungen korrekt sind?, zwar besitze ich kein Telekom Konto das ich dort Mails abrufen moechte, aber ich nutze K9 (von der Website installiert, dort sind die Versionen aktueller als im Market) mit meinem eigenen Server der wobei dort alles ueber SSL/TLS laeuft und er an den Zertifikaten nur ein einziges mal moniert ob ich sie dennoch akzeptieren moechte, weil ich sie mir selbst ausgestellt habe. Erfahrungen mit Problemen habe ich bis jetzt immer auf "nicht korrekte" Einstellungen zurueckfuehren koennen.


    Gute Besserung

    House
     
  3. COOGOR, 06.07.2012 #3
    COOGOR

    COOGOR Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    112
    Erhaltene Danke:
    1
    Registriert seit:
    31.05.2012
    Ich habe auch keinen Telekom account, den ich abrufe - Telekom ist nur der Carrier.
    Ja, ich bin mir auch sicher was die Settings angeht - für eine Adresse auf @gmx.de nutzt der Server ein Zertifikat auf *gmx.net, für meinen Privaten Account läuft es über die Server des Providers, die zwar vertrauenswürdig, aber nicht unbedingt von einer Zertifizierungsstelle abgezeichnet sind....
     
  4. DrGregoryHouse, 07.07.2012 #4
    DrGregoryHouse

    DrGregoryHouse Android-Lexikon

    Beiträge:
    1,480
    Erhaltene Danke:
    258
    Registriert seit:
    16.11.2010
    Dann gehe mal in die Einstellungen und loesche Cache und Daten von K9, dann richtest du dein Konto nochmal ein, weil wenn das nicht der Fall ist mit deinen Zertifikaten dann bekommst du ein Popup wodrauf du extra hingewiesen wirst.


    House
     
  5. COOGOR, 09.07.2012 #5
    COOGOR

    COOGOR Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    112
    Erhaltene Danke:
    1
    Registriert seit:
    31.05.2012
    ...ich bin in de Problem etwas weiter - die Anzeige des falschen Zertifikates popt nur hoch, wenn ich SSL über die Mobilverbindung versuche (offensichtlich hat die DTAG da ein Problem...) - und statt klaglos das Fallback 'ohne SSL' zu nehmen zickt er halt rum....Ich hab mal einen Fehler bei der Community aufgemacht.
     

Diese Seite empfehlen