1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. 1zu0, 13.07.2012 #1
    1zu0

    1zu0 Threadstarter Junior Mitglied

    Moinmoin liebe Leute,

    Seit der eclipse Juno// 4.2.0 (64bit)//(auf win7 64bit) hab ich zZt ein kleines Problem, oder besser gesagt eine Unannehmlichkeit .

    Es ist so, dass teilweise Zeilen(JavaCode, AndroidProjekte) angemeckert werden, die im Grunde fehlerfrei sind.

    Denn wenn ich:

    - die betreffende/n Zeile/n mit strg+c kopiere

    - dann mit str+x lösche

    - dann mit strg+s das Dokument als solches speichere

    ist das Dokument nun, wie zu erwarten war, "fehlerfrei".

    Wenn ich nun aber die geloeschte Zeile(n) mit strg+v wieder einfüge, dann...alles wunderbar.
    Keine roten Kreuzchen mehr.Kein Fehler.nix
    .
    Das da vorher auch schon kein Fehler war, wusste ich, aber der Rechenr scheinbar nicht ;)

    Das Phänomen spielt sich übrigens sowohl hier als auch an einem ganz anderen Rechner
    (ebenfalls win7 64 bit//gleiches eclipse/android-SetUp)im Büro ab .

    Kennt das jmd? Was laeuft das verkehrt?

    Ist das ein Bug in der neuen eclipse, oder dem ebenfalls recht neuen android-sdk 20?
    Oder dem Zusammenspiel?

    Beste Grüße aus dem Norden...euch allen ein schönes Wochenende!
     
  2. keinbrain, 13.07.2012 #2
    keinbrain

    keinbrain Fortgeschrittenes Mitglied

    ich denke das ist ein 64 bit fehler, ich hab manchmal auch solche "eclipse-wehwehchen" ^^ nimm halt weiter indigo, da gehts einigermaßen
     
    1zu0 gefällt das.
  3. 1zu0, 13.07.2012 #3
    1zu0

    1zu0 Threadstarter Junior Mitglied

    ok, erstmal Danke für die Antwort.
    Kannst Du die "Wehwehchen" evt stichwortartig auflisten, damit man weiss, worauf man sich einstellen muss?
    Gibt es eine Sammelstelle für aktuell bekannte Bugs?
     
  4. keinbrain, 13.07.2012 #4
    keinbrain

    keinbrain Fortgeschrittenes Mitglied

    also fehler die bei 3.7 indigo ganz gerne auf 64 bit auftreten sind das in der xml datei zeilen verschmetzeln und verrutschen, sodass plötzlich etwas von 100 zeilen weiter unten ganz oben steht :S

    Auch dein Problem hatte ich schonmal , aber eben im 1/2 jahr nur 1 x . Joah und sonst, halt alles was sonst so in programmen existiert, abstürze, hängen bleiben, aber auch äußerst selten. Hast du direkt angefangen mit 4.2 zu programieren ? Neue versionen sind halt meist noch ziemlich verbugt.

    Alle aktuell bekannten Bugs findest du auf Eclipse - The Eclipse Foundation open source community website. unter dwonloads links neben jedem programm, also z.B. hier :
    Eclipse IDE for Java EE Developers | Eclipse Packages

    hoffe das hilft dir erstmal ^^ bei 4.2 sind übrigens noch keine bugs gemeldet, leigt wahrscheinlich daran dass das programm noch so neu ist
     
    1zu0 gefällt das.
  5. 1zu0, 13.07.2012 #5
    1zu0

    1zu0 Threadstarter Junior Mitglied

    naja, obwohl schon seit 2010 hier angemeldet ( da hab ich das phone frisch aus der Packung genommen),
    bin ich erst seit ein paar Wochen konkret dabei, Java und Android zu erlernen.
    In der Zwischenzeit war das Jobbedingt kaum möglich, da hab ich nur mal sporadisch in eclipse getüftelt.
    Die Vorgängerversion von juno hab ich also ein wenig genutzt, die letzten wochen, aber nur für sehr simplen java-code.
    Da kann ich keine AUssetzer von eclipse beklagen.

    Da ja nun auch das android-sdk recht frisch ist, möchte ich ungern zur alten eclipseVersion wechseln.

    Auf jeden Fall Dir erstmal Dankeschön für die Anworten.
     
  6. keinbrain, 13.07.2012 #6
    keinbrain

    keinbrain Fortgeschrittenes Mitglied

    Kein Problem :) Du sagst das android -sdk ist relativ neu, das ist doch kein Problem. Du kannst die gleiche sdk-version auch mit 3.7 benutzen. Oder meintest du etwas anderes?
     
  7. Tom299, 16.07.2012 #7
    Tom299

    Tom299 Android-Experte

    Am Fr hab ich Eclipse und ADT aktualisiert, hab nun ein ähnliches Phänomen:

    Ich mache gern mal -- in den Code, wenn ich ne Pause mache oder übers WE, damit ich gleich weiß, wo ich weitermachen wollte (wird ja ROT markiert).
    Wenn ich die -- nun wieder lösche, bleibt das rote X am Rand stehen, sogar nach dem Speichern der Java-Datei bleibt es bestehen. Wenn ich dann die App starten will, meckert Eclipse den Fehler im Projekt an!
    Es hilft dann nur ein Clean + Build, dann ist das rote Kreuzchen weg und ich kann die App starten ...

    Mir ist auch aufgefallen, daß Eclipse nun (manchmal?) nach dem Löschen eines XML-Abschnittes mit dem Cursor einfach an eine andere Stelle als erwartet springt ...
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
[Offen] Android Layout funktioniert nicht Android App Entwicklung 08.09.2017
[ERLEDIGT] LL zur Laufzeit erstellen, Abstand zwischen LL und LL möglich ? Android App Entwicklung 06.09.2017
[OFFEN] App schließt nach Öffnen sofort Android App Entwicklung 04.09.2017
[ERLEDIGT] Um einen Zusatz in einem Programm unter Android zu machen Android App Entwicklung 22.08.2017
[GESCHLOSSEN] Random ListItem ausgeben funktioniert nicht mehr Android App Entwicklung 13.08.2017
[OFFEN] Bild per Intent an ListView übergeben und anzeigen Android App Entwicklung 13.08.2017
[OFFEN] SVN Commit in Android Studio funktioniert nicht mehr Android App Entwicklung 07.08.2017
[ERLEDIGT] Android Studio Erste App-Programmierung Android App Entwicklung 02.08.2017
[ERLEDIGT] Android O Neue Fonts in XML Methode Android App Entwicklung 27.07.2017
[ERLEDIGT] Daten/Code meiner App speichern? Android App Entwicklung 27.07.2017
Du betrachtest das Thema "eclipse/android-sdk: ein bug? fehlerhafte fehlermeldungen quickNdirty ausmerzen" im Forum "Android App Entwicklung",