Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

[How-To] Android Factory Image ohne Datenverlust flashen

  • 56 Antworten
  • Neuester Beitrag
Diskutiere [How-To] Android Factory Image ohne Datenverlust flashen im Anleitungen für Google Nexus 5 im Bereich Root / Custom-ROMs / Modding für Google Nexus 5.
Eisbaer_1081

Eisbaer_1081

Fortgeschrittenes Mitglied
Ne immer Taste drücken!
Habe es hin bekommen.
Auf 5.0 gefälscht da auch bei 5.01 der fehle kam und dann Regulär ota auf 5.0.1 und dann ota vom 5.1 von Androidpit.de wipp und fertig der weg war lang aber ich habe es geschafft.:scared:
 
HM56

HM56

Fortgeschrittenes Mitglied
Ich habe mich auch an die Variante vom Eisbär gehalten.
5.0 drauf gemacht :thumbup:
5.01 drauf gemacht :thumbup:

und dann bei 5.1 habe ich diese Meldung bekommen.

wie kann ich den Fehler verstehen ?? Eine system.img ist mit dem Namen in keinem Paket drin :sad:

Die Dateien habe ich alle hier geholt: https://developers.google.com/android/nexus/images#hammerhead

Nachtrag:
in der image-hammerhead-lmy47d ist die system.img drin wie bei den vorigen Versionen auch.
 

Anhänge

Zuletzt bearbeitet:
M

mj084

Guru
manuell flashen sollte gehen oder?
 
qu4nd

qu4nd

Ehrenmitglied
Wie mj084 sagt, solltest du es dann manuell machen. Das klappt leider oft nicht per Batch...
 
HM56

HM56

Fortgeschrittenes Mitglied
Alles gut :smile:
Gerade hat es das 5.1 runtergeladen und macht es drauf.
Bei den bisherigen Versuchen lag immer der kleine Android beim Start des Update auf dem Bildschirm.

Root mache ich wieder mit den Nexus Root Toolkit drauf.
Mal schauen wenn es fertig ist.

Danke für eure schnelle Antworten

Läuft hoch, 5.1 ist drauf.
Kurz nachdem Start kommt "Google Play Dienste wurden beendet" aber ich kann keine Beeinträchtigung mit den PlayStore erkennen. Geht alles, meine Apps werden gezeigt, downloaden von Apps und starten tut ??
Mal sehen ob ich was finden kann ....
 
Zuletzt bearbeitet:
Sboarder

Sboarder

Fortgeschrittenes Mitglied
In dem Startpost steht, daß der Bootloader unlocked sein muß.

Woran sehe ich denn, ob der "Bootloader unlocked" ist? Wie stelle ich das fest?
 
J

jet

Experte
Beim Booten und bei gesperrtem Bildschirm wird ein Schloß angezeigt.
Offen = Bootloader offen
Geschlossen = Bootloader geschlossen.

Edit: Ich glaub das war Falsch. :unsure:
 
Zuletzt bearbeitet:
Sboarder

Sboarder

Fortgeschrittenes Mitglied
Danke Dir für die unfassbar schnelle Antwort. Dann setze ich mich auch mal ran...
 
J

jet

Experte
Ich hab's gerade getestet. Jetzt bin ich mir gar nicht mehr so sicher ob das stimmt, was ich gerade geschrieben habe. :lol:

Wo man es auf jeden Fall sieht ist im Fastboot-Modus (Gerät ausschalten, dann Power + Vol- gleichzeitig drücken und gedrückt halten bis es angeht). Dort steht ganz unten bei LOCK STATE entweder locked oder unlocked.

Achtung: Das Öffnen des Bootloaders löscht alle Daten!
 
Zuletzt bearbeitet:
Sboarder

Sboarder

Fortgeschrittenes Mitglied
Juhuuuu!!!
Hat alles ohne Murren und Knurren geklappt.
DANKE DANKE DANKE an alle Beteiligten!
 
Lion13

Lion13

Ehrenmitglied
jet schrieb:
Edit: Ich glaub das war Falsch. :unsure:
Nur halb falsch... :laugh:

Nein, im Ernst: Wenn ein Schloss zu sehen ist, dann ist der BL offen - wenn er geschlossen ist, dann sieht man keines.
 
SleepwalkDrive

SleepwalkDrive

Fortgeschrittenes Mitglied
Grad eben von 5.1.0 auf 5.1.1 geflasht nach dieser Anleitung funktioniert wie jedes mal einwandfrei! Klasse wenn man nicht auf OTA warten will =D
 
HM56

HM56

Fortgeschrittenes Mitglied
Das letzte mal auf die 5.1 habe ich es hin bekommen.

Diesmal klappt es auch nach 3 mal runterladen unter diesem Link: https://dl.google.com/dl/android/aosp/hammerhead-lmy48b-factory-596bb9c1.tgz nicht.

auch manuell versucht, also die Befehle der bat manuell ausgeführt. Wieder scheinen Dateien zu fehlen ?? Diese .sig sind auch nicht vorhanden ??

ich habe die "image-hammerhead-lmy48b.zip" auf das Nexus kopiert und diese ZIP mit TRWP versucht zu installieren, aber auch da wird mit einem Error abgebrochen.

Ich glaub echt langsam werde ich zu alt für das Zeug :confused2:
 

Anhänge

HM56

HM56

Fortgeschrittenes Mitglied
Einmal aufräumen ist doch immer gut :thumbsup:

Also komplett neu die 5.1.1 aufgesetzt und läuft wieder sauber.

Aber wieder nur 12,5 GB sind frei, das nervt echt :razz::razz:
 
Elting

Elting

Ehrenmitglied
Da weißt du ja, was zu tun ist... Factory Reset...
 
F

flyyy

Experte
Wenn ich von einer CustomROM zurück zu Stock möchte, dann würde ich eigentlich gerne wie üblich Data/System/Cache löschen, aber den Inhalt des internen Speichers ansonsten behalten.

Ist der richtige Weg Data/Sys/Cache vorher im CustomRecovery zu löschen und direkt danach die Anleitung hier zu befolgen?

edit: Es ist wohl gelungen. Wobei ich schon wieder fast gescheitert wäre. Die flash-all funktioniert anscheinend nicht, wenn man fastboot als SYSTEM_PATH hinterlegt, so dass man 'fastboot' überall einfach aufrufen kann. Es kommt dann immer die Meldung "cannot load bootlader ...". Mann muss einfach die fastboot.exe und die 1-2 Dateien, die dazugehören, in den Stock-Image-Folder direkt neben die flash-all.bat kopieren, dann geht's sofort (oder eben andersrum, den ganzen Inhalt des Stock-Images in den fastboot-Ordner). Dadurch hat das ganze nun wieder 60 Min statt 6 Min gedauert :D
 
Zuletzt bearbeitet: