[HowTo] Bootloader-Unlock mit HTCDev

  • 301 Antworten
  • Neuester Beitrag
Diskutiere [HowTo] Bootloader-Unlock mit HTCDev im Anleitungen für HTC Wildfire S im Bereich Root / Hacking / Modding für das HTC Wildfire S.
ONeill

ONeill

Ehrenmitglied
ja, du musst ja auch die plattform-tools erteinmal aus dem SDK-Manager herunterladen.
 
gagel83

gagel83

Neues Mitglied
ich habe angefangen, mich mit deiner tollen Anleitung auseinander zu setzen aber ich komme nicht ganz weit.
Habe mir die passende RUU runter geladen, öffne sie und dann sehe ich nur noch Zeichen und Hyroglyphen. ganz oben steht auch immer (This program cannot be run in DOS mode.)
Was kann ich da machen????
 
Schnello

Schnello

Lexikon
Sie unter Windows starten.
 
gagel83

gagel83

Neues Mitglied
Habe auf meinem Mac Firefox drauf und habs auch schon dort versucht, kommt aber das selbe bei rum
 
Schnello

Schnello

Lexikon
Firefox? Du brauchst eine Windows umgebung oder jemand sagt dir welche Teile du direkt auf die Sd Karte packen kannst.
 
gagel83

gagel83

Neues Mitglied
ok, habe schritt 1 erfolgreich beendet aber jetzt wirds schwer für mich!!!! Wo lade ich denn die adb.exe, adbWinAPI.dll sowie die fastboot.exe runter und wohin pack ich die dann???? Ich weiß ja leider nicht mal, was das alles bedeutet:tongue:
Was ist ein cmd-Fenster????
 
Schnello

Schnello

Lexikon
Sorry aber deine Frage wären nun wirklich auch für einen MAC User leicht selbst beantwortbar.

Aber in Summe wird dein Problem weiter sein das du keinen Windows PC hast...

Zb. Wo lade ich die Dateien runter.... siehe Post Nr.42
Was ist CMD.... Google: CMD = Kommandozeile in Windows


Also ich würde sagen: Druck die Anleitung aus und suche einen Freund auf der einen Windows PC hat und etwas Ahnung hat. Bei dem Wort CMD oder Kommandozeile sollte er bescheid wissen. :)
 
M

manule

Fortgeschrittenes Mitglied
hab mein wildfire s unlocked aber will auf 2.3.5 bekomm das nicht hin?
 
ONeill

ONeill

Ehrenmitglied
Hä? Zu was hast du es dann unlocked? Du hast dooch mit dem neuesten Softwareupdate 2.3.5.
Außerdem ist das der falsche Thread, hier geht es einzig und allein um das unlocken, und das hast du ja anscheinend hinbekommen ;)
 
E

elmdh

Neues Mitglied
Robotwalk schrieb:
Hat alles wunderbar geklappt. :thumbsup:
Ich bedanke mich.
Hallo, Robotwalk!

Wie hast du das gemacht? Ich habe dasselbe Problem: das RUU will, dass ich auf 2.13.401.2 aktualisiere, aber ich habe schon 2.13.401.3.

Ich habe alle Schritte von HTC Wildfire S/Downgrade mehrmals gemacht, und das RUU bittet doch weiterhin darum, dass ich auf 2.13.401.2 aktualisiere.

In der Datei /dev/mtd/mtd0 steht schon die Nummer 2.13.401.2

Im editor HxD.exe sehe ich davor eine Eins: 12.13.401.2. Ist das in Ordnung?

Danke!
 
ONeill

ONeill

Ehrenmitglied
wenn ich das richtig in erinnerung habe ist das richtig, aber am besten änderst du mal die SOftwarenummer auf 2.13.401.0 und probierst es dann noch mal.
 
E

elmdh

Neues Mitglied
Selbe Fehlermeldung mit 2.13.401.0.

Noch eine Idee?

Danke
 
ONeill

ONeill

Ehrenmitglied
Was kommt denn genau für ne Fehlermeldung, oder wirklich gar keine? Denn das ist eigentlich nicht mmöglich.
Wenn es nicht funktioniert, kannst du (AUF DEIN EIGENES RISIKO) im Tempordner nach den Dateien
rom_01.zip und rom_02.zip suchen und diese dnn über den Bootloader flashen!
 
E

elmdh

Neues Mitglied
Die Fehlermeldung ist dieselbe, wie im Beitrag #29 von diesem thread (zweites Bild): "Your ROM Version is not the latest version. Please upgrade to 2.13.401.2 to apply this RUU to be able to unlock your boatloader, usw."

Falls es hilft: Am Handy unter Einstellungen > Telefoninfo > Software-Informationen > Software-Nummer steht weiterhin 2.13.401.3

Könnte es an der goldcard liegen?

Die Dateien rom_01.zip und rom_02.zip finde ich nicht. Ich habe nur einen Tempordner gefunden: /data/local/tmp und dort gibt es nur drei Dateien: sh, boomsh, FDHttpd.apk

Danke!
 
Robotwalk

Robotwalk

Neues Mitglied
elmdh schrieb:
Hallo, Robotwalk!

Wie hast du das gemacht? Ich habe dasselbe Problem: das RUU will, dass ich auf 2.13.401.2 aktualisiere, aber ich habe schon 2.13.401.3.

Ich habe alle Schritte von HTC Wildfire S/Downgrade mehrmals gemacht, und das RUU bittet doch weiterhin darum, dass ich auf 2.13.401.2 aktualisiere.

In der Datei /dev/mtd/mtd0 steht schon die Nummer 2.13.401.2

Im editor HxD.exe sehe ich davor eine Eins: 12.13.401.2. Ist das in Ordnung?

Danke!
Wenn du die RUU aus dem Wiki Artikel nimmst, dann solltest du auch die die dort angegebene Versionsnummer zu 1.30.401.0 im Hex-Editor ändern. Das hab ich jedenfalls gemacht und es hat funktioniert.
 
Zuletzt bearbeitet:
E

elmdh

Neues Mitglied
Robotwalk schrieb:
Wenn du die RUU aus dem Wiki Artikel nimmst, dann solltest du auch die die dort angegebene Versionsnummer zu 1.30.401.0 im Hex-Editor ändern. Das hab ich jedenfalls gemacht und es hat funktioniert.
Ob ich es richtig verstehe - die Reihenfolge ist: a) mit der RUU aus dem Wiki downgraden, b) mit der RUU aus HTCDev bootloader updaten, c) bootloader entsperren.
Hast du alle drei Schritte gemacht?
 
Zuletzt bearbeitet:
X

xnoxa

Neues Mitglied
Abend,
ich habe ein Problem und zwar jedes mal wenn die RUU mit dem Bootloaderupdate startet kommt diese Fehlermeldung : Directupload.net - Dgciqhjbo.png . Ich bin mir aber sicher ,dass das HTC korrekt angeschlossen ist.
 
ONeill

ONeill

Ehrenmitglied
@xnova:
Du musst die USB-Treiber von HTC installiert haben und am Ws muss USB-Debugging eingeschalten sein!
 
T

Takoru

Fortgeschrittenes Mitglied
Hallo,

Mein Wildfire S ist von A1 Österreich.

Kann mir jemand sagen, welche RUU ich herunterladen muss? An der Stelle häng ich, ich will nix falsch machen. :(