[Anleitung] Bootanimation austauschen + Sammlung

  • 247 Antworten
  • Neuester Beitrag
Diskutiere [Anleitung] Bootanimation austauschen + Sammlung im Anleitungen für Samsung Galaxy S im Bereich Root / Hacking / Modding für Samsung Galaxy S.
N

NGX Soldier

Fortgeschrittenes Mitglied
ok sind die kernel unabhänging von der zuvor installierten kernel oder mus ich wieder auf meine derzeitigen kernel achten
 
dickerkarpfen

dickerkarpfen

Erfahrenes Mitglied
:blink: ?

Hat er doch gerade schon geschrieben und sogar verlinkt. Du brauchst einen Kernel auf dem Gerät installiert der bootanimationen unterstützt.
Was soll das bitte mit irgend einem vorherigen zu tun haben?
 
N

NGX Soldier

Fortgeschrittenes Mitglied
ach shit

habe mich da vertan lol :) ich meinte firmware abhänging da ich ics drauf habe sorry
 
dickerkarpfen

dickerkarpfen

Erfahrenes Mitglied
Dann schau doch in dem Thread wo du dein ICS Rom her hast ob es Bootanimationen unterstützt.
 
N

NGX Soldier

Fortgeschrittenes Mitglied
jo werde ich tuen :)

pas überschreibt der kernel nicht meinen cf root kernel womit ich dann meine roote rechte verlieren und der dazugehörige recovery modus ?

mfg
 
jna

jna

Ehrenmitglied
NGX Soldier schrieb:
überschreibt der kernel nicht meinen cf root kernel womit ich dann meine roote rechte verlieren und der dazugehörige recovery modus ?
Auch diese Frage gehört zur Antwort
dickerkarpfen schrieb:
Dann schau doch in dem Thread wo du dein ICS Rom her hast ob es Bootanimationen unterstützt.
In diesem Thread geht es um Bootanimationen, nicht im ICS-Kernel.
 
Hans Dampf

Hans Dampf

Neues Mitglied
Hallo,

Ich bekomme das mit der Bootanimation eigentlich hin. Eigentlich.

Ich hab Gingerbread 2.3.3 und den Speedmod k16-11 drauf ( Der ja Bootanimationen unterstützt ) und wollte die Bios Bootanimation.

Aber irgendwie kommt immer nur ein kleiner Android Schriftzug.

Kann mir da jemand behilflich sein?

Danke
 
Andeas_hu

Andeas_hu

Erfahrenes Mitglied
Hans Dampf schrieb:
Hallo,

Ich bekomme das mit der Bootanimation eigentlich hin. Eigentlich.

Ich hab Gingerbread 2.3.3 und den Speedmod k16-11 drauf ( Der ja Bootanimationen unterstützt ) und wollte die Bios Bootanimation.

Aber irgendwie kommt immer nur ein kleiner Android Schriftzug.

Kann mir da jemand behilflich sein?

Danke
Die Bootanimation.zip muss nach /system/media
Und dort dann der animation alle Rechte geben.
 
Hans Dampf

Hans Dampf

Neues Mitglied
Hat leider nichts gebracht. Wenn die Bootanimation in data/local ist spielt er sie ja ab. Aber halt nicht die Bios Animation, sondern einen Android Schriftzug.

Wenn die Bootanimation in System/Media liegt wird der "normale" Bootscreen abgespielt. Allerdings ohne Sound.

Mich würde mal interessieren wo der Android Schriftzug überhaupt herkommt.

Um noch was zu dem Kernel zu sagen: Ich hab erst den CF-Root drauf und danach den Speedmod geflasht. Da der Speedmod kein CWM mitbringt. Bei mir zumindest nicht.

Vielleicht liegt da der Hund begraben!?

:confused:
 
Andeas_hu

Andeas_hu

Erfahrenes Mitglied
Hans Dampf schrieb:
Hat leider nichts gebracht. Wenn die Bootanimation in data/local ist spielt er sie ja ab. Aber halt nicht die Bios Animation, sondern einen Android Schriftzug.

Wenn die Bootanimation in System/Media liegt wird der "normale" Bootscreen abgespielt. Allerdings ohne Sound.

Mich würde mal interessieren wo der Android Schriftzug überhaupt herkommt.

Um noch was zu dem Kernel zu sagen: Ich hab erst den CF-Root drauf und danach den Speedmod geflasht. Da der Speedmod kein CWM mitbringt. Bei mir zumindest nicht.

Vielleicht liegt da der Hund begraben!?

:confused:
Der Android Schriftzug ist intern, wird dann gezeigt, wenn "KEINE" Bootanimation.zip abgespielt wird.

Wenn in /system/media du etwas ablegst und dann nicht mehr der android schriftzug , sondern die "normale" bootanimation abgespielt wird, dann ist doch alles richtig.

du solltest darauf achten, das groß/kleinschreibung eingehalten wird.
Sonst wird nix abgespielt.
kannst auch mal in die zip schauen, dort liegen die bilder drin als jpg oder ogg, dann siehst du, um welche bootanimation es sich handelt.

Zum Thema boot Sound hab ich in einem anderen Tread was geschrieben, da muss ein script via Terminal gestartet werden, dann geht auch sound.

Brauchst dann eine mp3 als startsound.
 
Hans Dampf

Hans Dampf

Neues Mitglied
Die ist für's SGS2. Funktioniert die auch beim Einser?

Gesendet mit der Android-Hilfe.de-App
 
wemsinho

wemsinho

Lexikon
Ui, sorry. Natürlich nicht.
 
Hans Dampf

Hans Dampf

Neues Mitglied
Wenn ich die Bootanimation aufmach und mir die einelnen Bilder anschau, sind es die die ich möchte. Es werden aber andere abgespielt. Es funktioniert ja grundsätzlich.

Gesendet mit der Android-Hilfe.de-App
 
wemsinho

wemsinho

Lexikon
Bei CF-Root hast du keinen sound, da chainfire den Sound aus Platzgründen rausgeschmissen hat. Denke, dass ist beim Speedmod genauso. Ansonsten gilt (aus dem ersten Post)
Installation:

  • Die bootanimation.zip (die muss so heißen) kommt dann entweder nach system/media oder data/local (geht beides). Wenn sowohl in system/media als auch in data/local eine Bootanimation liegt, dann wird die aus data/local abgespielt
So funktioniert das definitiv. Ich pack die immer in data/local und fertig.
 
Andeas_hu

Andeas_hu

Erfahrenes Mitglied
Richtig, wenn eine Bootanimation.zip in /data/local liegt, wird diese bevorzugt abgespielt.

Liegt dort keine wird die abgespielt, die in /system/media liegt.

Ist auch da keine, kommt die android animation.

Zum Thema Sound.

du benötigst eine Datei mit dem Namen android_audio.mp3

Diese muss im Verzeichnis /system/media liegen.

Desweiteren muß ein script gestartet werden, das in der Datei build.prop einen
Eintrag hinzufügt.

Außerdem legt es in dem Verzeichnis init.d eine Datei mit dem Namen 99bootsound.ini an.

Suche hier im Forum mal nach bootsnd.sh

Dies ist das Script.

Dieses kopierst du nach /sdcard

Dann brauchst du ein Terminal Programm.

dieses Starten, dann folgendes eingeben

su (return)
cd /sdcard (return)
sh bootsnd.sh (return)

Dann läuft das script ab und erstellt alles nötige.

Dann

exit (return)
exit (return)

Terminal beenden.

Danach Reboot und du hast Sound !!

Alle ( return ) bedeuten "Enter" drücken.
 
Hans Dampf

Hans Dampf

Neues Mitglied
Also jetzt funktionierts.

Aber leider nicht mit dem Speedmod sondern mit dem Semaphore.

Naja der Kernel ist mir eigentlich egal. Von daher danke für die hilfe.
 
Hans Dampf

Hans Dampf

Neues Mitglied
Hallo Andreas,

Danke erstmal für Deine Mühe.

Das mit dem Sound klappt leider nicht. Ich hab alles gemacht aber leider wird kein Bootsound wiedergegeben.

Kann das vielleicht am Semaphor liegen?

:confused:
 
Andeas_hu

Andeas_hu

Erfahrenes Mitglied
Gesendet mit der Android-Hilfe.de-App
Schon möglich, versuche mal nen Teufel Kernel
Musst aber aufpassen, er kopiert alles aus /init.d in ein Backup verz.
Da musst du die 99bootsound.ini wieder per Hand zurück holen nach /init.d

Auch darauf achten, das die Sounddatei den richtigen Namen hat, groß & kleinschreibung vorhanden ist.

Auch überprüfen, ob die build.prop ganz unten einen Eintrag hat, wo bootsound=1 steht.
ebenso muss die 99bootsound.ini vorhanden sein.

Mit dem Stockkernel der 4.2er ICSSGS wird auch kein Sound abgespielt, mit den Devils klappts einwandfrei.
Dann muss es gehen.
 
Zuletzt bearbeitet:
tobi3

tobi3

Fortgeschrittenes Mitglied
Die 2te Bootanimation ist leider down :(