[Anleitung] Mein GPS Hardware Fix für I9000

  • 83 Antworten
  • Neuester Beitrag
Diskutiere [Anleitung] Mein GPS Hardware Fix für I9000 im Anleitungen für Samsung Galaxy S im Bereich Root / Hacking / Modding für Samsung Galaxy S.
E

Emjot

Stammgast
Nach einigen Problemen mit den Feinheiten funktioniert die Entlötlitzenmethode auch auf dem SGS+ I9001 perfekt.
Pegel von 40 werden zwar meist nur von einem Satelliten empfangen, aber einige andere befinden sich dann auch zwischen 30 - 40, was für eine genaue und anhaltende Positionsbestimmung locker ausreicht.

Fix dauert leider immernoch oft bis zu 60 Sekunden, obwohl viele Balken auch im "grauen Zustand" überwiegend über 30 liegen.

Im Anhang ein Beispiel.
 

Anhänge

Zuletzt bearbeitet:
E

Emjot

Stammgast
Ok, mittlerweile kann ich das Phänomen auch bestätigen, dass wenn man die Antenne mit bloßem Finger berührt, alle Empfangsstärken in die Höhe spriessen.

Und wenn ich 2 Tage lang kein GPS mehr genutzt habe, dauert der Sat Fix unter freiem, wolkenfreiem Himmel immer über eine Minute, obwohl mindestens 5 Satelliten im "Hellgrünen Bereich" wären (also Signalstärke über 30 [dbm?!]).

Meine gps.conf beinhaltet die Server:
de.pool.ntp.org
europe.pool.ntp.org

xtra1.gpsonextra.net/xtra.bin

supl.google.com

Gibt es irgendeinen Tipp?
 
H

hansimglueck

Neues Mitglied
Also ich habe 3 Hardwarefixe kombiniert! Das heisst GPS Empfänger hochbiegen + Litze + spanische Version!

Bei mir kommt max. 1 Satellit!

Was mache ich falsch????
 
E

Emjot

Stammgast
Die Empfänger stören sich gegenseitig! Man kann nicht einfach aus einer Antenne zwei machen!
Schmeiss die spanische Version raus und du wirst bis zu 14 Satelitten empfangen.
 
H

hansimglueck

Neues Mitglied
ok,

werd ich probieren!

auch ohne Softwarefix?
 
E

Emjot

Stammgast
Eigentlich schon.
Allerdings lies die Fix-Geschwindigkeit nach ein paar Tagen nach, ich hab dann FasterFix installiert und es ging wieder schnell.
 
P

peper0ni

Neues Mitglied
Hallo,

also ich habe auch die Lötlitze-Methode durchgeführt, nur sind die Ergebnisse noch nicht ganz so gut (Pegel 15-25). Komsich ists nur das der Pegel beim Autofahren (50-100km/h) besser wird bei den entgegen kommenden Satelliten.

Hatte auch LEENO-Thread(Vorsicht!!) gelesen und auch gleich den Gummi-Kontakt gegen den Metall-Kontakt getauscht. War aber ein Fehler denke ich.
Vermutlich hat der Gummikontakt eine isolierende Funktion (hochohmiger Widerstand mit Kapazität???).
Als ich die beiden Kontakte gebrückt hatte bekam ich im meienm Zimmer keine Satelliten. Also habe ich nun nur den einen Kontakt (original Metallkontakt) mit der Lötlitze kontaktiert.

Werde die nächsten Tage auch mal was mit Kupferfolie ausprobieren, denn mit der Litze und dem Klebeband drüber geht der Deckel nicht ganz zu ://.

Außerdem könnte man mit der Kupferfolie auch Lambda/2 = 9.525cm statt 4,7625cm verlegen. Damit sollten doch die Signale besser reinkommen oder?

Nadann.. mal sehen ob mein Handy noch funktioniert nach dem ganzen rumbasteln (wollte mir eh ein neues zulegen^^)
 
M

mike_galaxy_s

Gast
Vielleicht liegt es ja an deiner Firmware, dass das GPS nicht gut funktioniert. Versuch mal eine andere zu flashen.

Gesendet von meinem GT-I9000 mit Tapatalk 2
 
P

peper0ni

Neues Mitglied
mike_galaxy_s schrieb:
Vielleicht liegt es ja an deiner Firmware, dass das GPS nicht gut funktioniert. Versuch mal eine andere zu flashen.

Gesendet von meinem GT-I9000 mit Tapatalk 2
Naja .. bin gerade bei CM10.1 hängen geblieben und will vorerst auch kein anderes mehr :thumbup:.
 
peppermint

peppermint

Ambitioniertes Mitglied
Super Anleitung :thumbsup: GPS ist ja erste sahne nun :thumbsup:

Danke für die anleitung :thumbsup:

MFG
 
R

Rosenköpfchen

Fortgeschrittenes Mitglied
Hi, habe auch die Entlötlitzenmethode gewählt, auch mit kurzzeitigem Erfolg, dann wieder schlechter Empfang..Samsi geöffnet alles "zurechtgerückt" und dann waren die Sateliten wieder da. Nach ein paar Tagen wieder kein Empfang. Dann habe ich nach [FIX] i9000 i9001 gps final fix - xda-developers das "Gummi" entfernt und eine Drahtverbindung zur Entlötlitze gelötet. Damit für den Draht mehr Platz beim Zusammenbau ist, wurden die jetzt unnötigen Fixierungsnippel und etwas mehr von der "Antennenschale" rausgedrehmelt und schon konnte die Schale ohne Druck zusammengebaut werden. Seitdem konstanter Topempfang.

MFG
 
CarMan

CarMan

Neues Mitglied
hast du evtl. bilder?

ich habe es eigentlich fast aufgegeben was das gps angeht. ist bei mir mit verschiedenrn varianten immer wieder unter aller sau :(
 
R

Rosenköpfchen

Fortgeschrittenes Mitglied
Nein, Bilder habe ich nicht, aber beim angegebenen Link, gibt es ein Foto der den angelöteten Draht (isolierter flexibler Draht) zeigt. Nur bei mir hab ich ihn an
die Entlötlitze gelötet. Der Draht sollte auch so kurz wie möglich sein, da wenig Platz zu Verfügung steht (deshalb aus der Plasticschale etwas Kunststoff rausgedrehmelt).
Bis jetzt ist der Empfang stabil und ich bekomme sogar im Haus ein Satellit. :smile::smile:
 
schorsch36

schorsch36

Experte
Wenn die Entlötlitze mit doppelseitigen Klebeband innen fixiert ist gibt es keine Abbrüche und ich bin oft mit dem Rad unterwegs.

[size=-2]sent from my GT-I9000 using tapatalk 2[/size]
 
R

Rosenköpfchen

Fortgeschrittenes Mitglied
Hi Schorsch, das Hauptproblem ist die Preßverbindung der 2 Kontaktstellen zur Litze. Während die Federkontaktstelle ausreichende Reserven hat, ist die Kontaktstelle mit dem leitfähigen "Kunststoffklötzchen" sehr druckanfällig. Auch müssen die Kontaktstellen ausreichende Leitfähigkeit aufweisen. Ich hatte zB. im ersten Versuch die Kontaktstelle der Litze verzinnt, um Kontaktprobleme durch Fett etc. auszuschließen. Hier sichert aber eine Lötverbindung auf Dauer einfach den besseren Kontakt.

VG
 
0

0912pq

Erfahrenes Mitglied
Hallo,

ich habe bei mir die Entlötlitzenmethode probiert.
Da bei mir der Schlitz durch den die alte Antenne geht breit genug war, konnte ich die Litze auch noch durchschieben. Ich hab dann die alte Antenne einfach dran gelassen und die Litze drübergeklebt (also parallel).
Hat aber nicht den Erfolg gebracht.

Sollte ich die alte Antenne lieber doch entfernen und nur die Litze nehmen?

Wie ist das mit einer Lötverbindung von den beiden Kontakten zur Litze?
Wie stelle ich dann sicher, dass die Verbindung im Inneren des Smartphone richtig verläuft (von den Kontakten auf der Platine zur Litze auf dem Rahmen)?
 
R

Rosenköpfchen

Fortgeschrittenes Mitglied
Beide Antennen parallel zu betreiben, bringt meines Erachtens nichts, zumal die Kontaktproblematik dadurch nicht besser wird. Im Post 51 ist ein link, der zeigt, wie einen Draht an die Originalantenne gelötet wurde. Ich konnte dies nicht ausprobieren, weil ich gleich die Litzenmethode gewählt habe. Bei Unklarheiten einfach fragen.
Gruß

Der ursprüngliche Beitrag von 14:57 Uhr wurde um 15:06 Uhr ergänzt:

Sorry, link ist in Post 52 :smile:
 
0

0912pq

Erfahrenes Mitglied
Rosenköpfchen;5765813 schrieb:
Sorry, link ist in Post 52 :smile:
Danke für den Hinweis. Dieses Foto hatte ich noch gar nicht gesehen.

Ist aber mutig so eine Verbindung ohne Isolierung in ein Smartphone mit Platinen zu drücken.

Scheint dort aber mit der normalen Antenne zu funktionieren, nur mit einer besseren Verbindung!
 
R

Rosenköpfchen

Fortgeschrittenes Mitglied
Hi, ich habe eine isolierte Litze genommen:)
 
0

0912pq

Erfahrenes Mitglied
Rosenköpfchen;5770225 schrieb:
Hi, ich habe eine isolierte Litze genommen:)
Du hast also die alte Antenne entfernt,
eine Einlötlitze aufgeklebt und diese dann mit einer isolierten Leitung mit den Kontaktpunkten verbunden (angelötet)?