Android 9 Bluetooth-Berechtigung

  • 39 Antworten
  • Neuester Beitrag
Diskutiere Android 9 Bluetooth-Berechtigung im Automatisierung - Tasker im Bereich Tools.
T

tjg1

Neues Mitglied
Hallo,
seit Android 9 wird beim Ein- und Ausschalten von Bluetooth immer ein Fenster geöffnet
und um Berechtigung gefragt. Tasker hat (gefühlt) alle Berechtigungen.
*G* TJG1
 
N

NDausTue

Fortgeschrittenes Mitglied
Moin,
auch hier das Problem: tasker kann offenbar mit Pie den Bluetooth-Status nicht mehr aendern. Gibt es da einen workaround oder ist irgendwo eine versteckte permission, die gesetzt werden muss? honor 10, unrooted.

ND
 
N

NDausTue

Fortgeschrittenes Mitglied
Moin,

hilft alles nix. Secure settings bietet die bt-toggle Option nicht; ADB Berechtigung ist gesetzt. Irgendwas stimmt da nicht. Gibts ein tasker-plugin, welches bt aktiviert oder deaktiviert? Mit Bordmitteln geht das beim honor 10 offenbar nicht.

ND
 
N

NDausTue

Fortgeschrittenes Mitglied
Moin und Danke.
Das tool nuetzt nix. Ich habe diverse tasks, bei denen (z.B. im heimischen oder Buero-WLAN; Nachts etc.) BT ausgeschaltet wird. Das verweigert Pie mit der Systemrueckfrage.
Secure settings nutzt nix, dort gibt es die Option BT ein/ausschalten nicht.
ND
 
Zuletzt bearbeitet:
Spardas

Spardas

Experte
Kurze Anmerkung für alle die auf Android 9 Upgedatet haben.
Es wird eigenlich immer bei grossen Firmeware wechsel empfolen das Gerät danach zu Werksreseten.
Vorallem wenn irgendwelche Problem auftretten.

Es kann ohne Werksreset funktioniern muss aber nicht ;)
 
maxe

maxe

Ehrenmitglied
ist auch beim Huawei mit Pie (nach Werksreset) so.
 
Mathens

Mathens

Erfahrenes Mitglied
Haben das Problem nur Nutzer von Huawei/Honor oder ist es auch bei anderen Geräten?
Kann es bei mir leider nicht Testen, hab noch Android 8
 
qwoka

qwoka

Experte
Wie gesagt, auf meinem Mi 8 mit Pie lässt sich Bluetooth steuern. Dafür funktionieren andere Sachen mit Tasker nicht ;-)
 
N

NDausTue

Fortgeschrittenes Mitglied
Mathens schrieb:
Haben das Problem nur Nutzer von Huawei/Honor oder ist es auch bei anderen Geräten?
....
Im web gibt es diverse Hinweise, dass v.a. Huawei/honor-Geraete mit der fremdgesteuerten BT-Einstellung Probleme haben; es gibt aber auch Hinweise auf non-Huaweii-Geraete, bei denen das auftritt.

qwoka schrieb:
Wie gesagt, auf meinem Mi 8 mit Pie lässt sich Bluetooth steuern. Dafür funktionieren andere Sachen mit Tasker nicht ;-)
Was geht denn nicht? root-benoetigende tasks gehen halt nur mit root. Ein bug ist wohl, dass die WLAN-SSID-Erkennung nur funktioniert, wenn tasker die Berechtigung zum Auslesen des GPS (Zugriff auf Orte) hat. Das war bei mir auch so, dann habe ich halt die Berechtigung erteilt.

Doof, das mit BT. Ich merke klar, dass BT nachts deutlich Energie zieht, obwohl es nicht benoetigt wird. Und da ich faul bin, will ich sowas automatisieren und mich moeglichst nicht mit taeglichen Smartie-Settings rumschlagen. Wenn ich BT abends manuell ausschalte, faengt kurz nach der morgendlichen Abfahrt prompt das Gefingere am Smartie an, wenn es mal wieder klingelt....
Beim honor 9 hatte ich das so eingestellt, dass BT beim ersten Klingeln oder beim Beginn eines ausgehenden Anrufs angeht, dann baute sich die Verbindung zur Freispreche auf und das Gespraech wurde auf die FSE geleitet. Nach Gespraechsende wurde BT wieder automatisch deaktiviert. Hat in allen drei Fahrzeugen immer bestens funktioniert.

ND
 
qwoka

qwoka

Experte
NDausTue schrieb:
Was geht denn nicht? root-benoetigende tasks gehen halt nur mit root ...
ND
Zum Beispiel kann ich mit Tasker keine Apps mehr starten.
 
N

NDausTue

Fortgeschrittenes Mitglied
Gerade mal mit anderen Automatisierungstools gespielt. Das BT-Problem taucht auch bei anderen Apps auf, die BT schalten sollen. Das scheint also eher ein Huaweii/honor Problem zu sein, wenn das auf anderen Pie-Geraeten funktioniert....

ND

Geloest.

Die neueste Tasker Version 5.5 schaltet BT nun wieder einwandfrei.
Da auch Android Auto diese bloede Zwischenfrage stellt, habe ich per tasker kurzerhand einen task erstellt, der automatisch bei Start von AA auch BT aktiviert, falls dieses nicht schon aktiv war. Die autimatische BT-Einschaltoption in AA ist deaktiviert, dann kommt auch das popup nimmer.

ND
 
Zuletzt bearbeitet von einem Moderator:
N

NDausTue

Fortgeschrittenes Mitglied
Moin,

Geloest - doch nicht geloest.

:1f621: Seit heute frueh (wahrscheinlich seit dem letzten Neustart) geht das automatische Deaktivieren von Bluetooth nun wieder nur noch nach Bestaetigung des nervigen popups.
Honor Support stellt sich unfaehig an; man meint, das sei normal und diene zur Sicherheit, ob BT wirklich eingeschaltet werden soll. Bei WLAN etc. ist das aber offenbar nicht notwendig.

ND
 
Zuletzt bearbeitet:
N

NDausTue

Fortgeschrittenes Mitglied
Moin,

nach diversen mails mit dem honor Service hat man mir recht unwillig mitgeteilt, dass diese dussliege Abfrage ein ´feature´ sei, um sicher zu stellen, dass man BT wirklich einschalten will. Die Erklaerung ist mehr als fragwuerdig; WLAN und diverse aehnliche settings lassen sich problemlos ohne dieses popup aktivieren. Ich muss also den Eindruck haben, dass man kein Interesse an einer Loesung hat. Bleibt zu hoffen, dass sich viele user (insbesondere von AndroidAuto) beschweren, um doch noch einen bugfix auszugeben.

Fazit: BT laesst sich bei vielen huawei/honor Geraeten mit EMUI 9.0.0 nicht automatisch oder App-gesteuert aktivieren/deaktivieren, man muss das manuell machen. Das ist in pkto Energie sparen und Komfort ein deutlicher Rueckschritt. In diesem Fall scheint es ausnahmsweise mal nicht Google zu sein, die solche Kastrationen an Funktionalitaet einbauen.

Schade, ich wollte mir fuer den Fuhrpark ein paar honor 10 lite besorgen; ich brauche hier Dual-SIM und eine reibungslos funktionierende AndroidAuto App, so wird das nix, liebe honor-Leute....

ND
 
O

One8se7en

Ambitioniertes Mitglied
Ich weiß nicht wie tief ihr in Tasker seid, aber lässt sich das nicht einfach mit Autoinput lösen?

hab erst gestern geupdated, arbeite jetzt kurz an einem workaround
 
N

NDausTue

Fortgeschrittenes Mitglied
Moin,

ich hatte das mit Autoinput versucht, bin aber nicht soweit gekommen, dass ein workaround geklappt hat. Waere schoen, wenn es hierfuer eine Loesung gaebe und diese hier mitgeteilt werden koennte. BT zieht ordentlich Strom, auch wenn es ungenutzt ist.

ND
 
O

One8se7en

Ambitioniertes Mitglied
also bei mir funktioniert es mit display an, kostet nur ein bisschen zeit, weil Bluetooth 10 oder 20sek timeout hat.
hast du es mal über die shell versucht?

im anhang findesst du mein einfachen task. brauchst halt autoinput. aber ohne das macht tasker sowieso kein spaß :)

€: Über das terminal (root) sollten auch
Aktivieren:
pm enable com.android.bluetooth
service call bluetooth_manager 6


Deaktivieren:
pm disable com.android.bluetooth

ohne zusätzliche "zulassen" aufforderung funktionieren. (source)


Frage:
Funktioniert es über den google assistant ohne zulassungsaufforderung? ("okay google, bluetooth aktivieren")
 

Anhänge

  • Bt_test.tsk.xml
    3,4 KB Aufrufe: 43
Zuletzt bearbeitet:
N

NDausTue

Fortgeschrittenes Mitglied
Moin,

soweit war ich auch schon. Dann kam ich nicht weiter, weil die Abfrage voraussetzt, dass das Display an und entsperrt ist.
In meinem Fall hatte ich das bis Android 8 so geschaltet, dass BT automatisch deaktiviert wird, wenn ich in ein (bekanntes) WLAN-Netz einlogge und BT nicht verbunden war. Dadurch war BT im Buero und zu Hause sowie an Orten mit WLAN, an denen ich mich oft und laenger aufhalte, deaktiviert. Insbesondere zu Hause ueber Nacht und im Buero war es dann aus, was deutlich Akku sparte. Das Ganze lief brav im Hintergrund ab.

Evtl. kann und muss man noch vorschalten, dass beim Eintritt in ein bekanntes WLAN das Display kurz angeht und entsperrt wird; da hoeren fuer mich aber die Programmierkenntnisse mit Tasker, Autotools und Autoinput auf....

Zudem wird seit Android 9 auch immer gefragt, welche SIM-Karte ich nutzen will, wenn tasker automatisch eine Rufnummer anwaehlen soll und die SIM-Wahl auf manuell steht. Unter Android 8 wurde da immer die SIM 1 gewaehlt. Wozu das Ganze? In zwei meiner Fahrzeuge ist noch ein klassisches Festeinbaugeraet drin; die Nummer des Androiden wurde beim Verbinden mit dem BT des Autoradios automatisch auf die Nummer des jeweiligen Festeinbaus umgeleitet; beim Trennen der BT-Verbindung wurde die Rufumleitung geloescht. Hier behelfe ich mir mittlerweile damit, dass ich SIM-Wahl immer auf SIM 1 habe; ich muss halt ab und zu mitdenken, wenn ich die SIM 2 nutzen muss/will.

Ich gebe zu, das ist ein Luxusproblem; ich bin halt faul und will den Androiden so weit wie moeglich automatisieren.

ND
 
O

One8se7en

Ambitioniertes Mitglied
Also wenn du root hast, versuch es über die shell mit den befehlen. das müsste so passen (beim einschalten brauchst du zwei)
Autotools macht ja auch nichts anderes, als den shell befehl auszuführen.

ich nutze bluetooth auch nur im auto, mein profil triggert es so, dass wenn die bluetooth verbindung unterbrochen wird, deaktiviert er auch blueooth. also als exit task zum "bluetooth verbunden"
 
Ähnliche Themen - Android 9 Bluetooth-Berechtigung Antworten Datum
1
24
8