WLAN dauerhaft aktiv trotz Flugmodus etc. ?[bq Aquaris X5 Plus]

  • 43 Antworten
  • Neuester Beitrag
Diskutiere WLAN dauerhaft aktiv trotz Flugmodus etc. ?[bq Aquaris X5 Plus] im bq Aquaris X5 Plus Forum im Bereich bq Forum.
A

arno-nym

Neues Mitglied
Hallo,
ich bin von dem Gerät an sich ja recht angetan, auch bzw va beim Akku (was ich hier sehe und bisher bei meinem).
Allerdings hab ich eine Frage bezüglich dem Verbrauch. Ich hab das Gerät vor 12 Tage bekommen, aufgeladen und mich kurz mit dem Gerät vertraut gemacht, aber nochts nichts an Einstellungen oder Software (Android 1.3.1) geändert. Dann kam das RL und das Gerät lan 9 Tage im Flugmodus auf dem Schreibtisch und wurde erst vor 3 Tage wieder anefasst. Soweit, so gut - erfreuliche Ausdaue und im Akkuverlauf auch alles gut: beim Verbrauch alles aus und deutlich zu erkennen, wenn das Gerät benutzt wurde.
Jetzt hab ich mich drangemacht, das Gerät in Betrieb zu nehmen. Also den 1.5.1 aufgespielt, dann den 1.6 der kurz drauf verfügbar war. Da hatte sich inzwischen bemerkbar gemacht, dass das wlan, trotz Abschaltung bzw Flugmodus durchgehend als aktiv angezeigt wurde. Durchforsten sämtlicher Einstellungen & beschränken von Zugriffsrechten etc hat nichts gebracht. Downgrade auch nicht, einzige Veränderung: in 1.3 und 1.5 schaltet sich das wlan in sleep irgendwann aus. Manuelles ausschalten oder Flugmodus (mit deaktiviertem wlan) wird inzwischen ignoriert, was mich nicht wirklich begeistert- grad das der Flugmodus 0 Effekt hat. (alle ROM-Änderungen immer nach factory reset).
Macht es da Sinn das Gerät einzurichten? Oder schick ich es besser gleich zurück zum Händler?
Ich fand mich da bei ein paar der hier besprochenen Probleme teilweise wieder bzw an den wlanbug aus der Frühphase von Marshmallow erinnert...

Anbei noch die Akkustats (von heute) zur Veranschaulichung:
Stats.png
 
Zuletzt bearbeitet:
wolder

wolder

Guru
Also, dass WLAN als immer an angezeigt wird, ist von Anfang an bei MM, auch bei anderen Handys. Da scheint die Anzeige ein "Problem" zu haben.
Da aber der Akku quasi überhaupt nicht abnimmt, würde ich da großzügig drüber hinweg sehen. Du hast quasi kein Problem.
 
M

MatzeD

Neues Mitglied
Bei mir ist die Anzeige zum WLAN korrekt.
Heute war WLAN tagsüber aus, genaue Standortbestimmung an. Ist auch im Graph zu erkennen.
Screenshot_20170113-184559.png

Edit: Kann man auf dem Screenshot nicht erkennen, aber es gibt beim WLAN über den Tag verteilt 3 kurze graue Markierungen. Ich vermute für die Standortbestimmung.
 
Zuletzt bearbeitet:
Bearbeitet von loopiCB - Grund: Thema ausgegliedert, Grüße loopiCB
A

arno-nym

Neues Mitglied
Danke für das Feedback.
Was mich eben wundert ist, dass ich nun auch bei 1.3 und 1.5 (nach downgrade), das Wlan so angezeigt bekomme. Hier geht das Wlan aber zumindest noch im sleep-Modus aus, wenn "never" eingestellt ist & wenn ich eine fixe Wlanfrequenz ausgewählt habe (alles was man bei stock einschränken kann ist abgeschaltet & überflüssige Apps deaktiviert). Sonst läuft der Wlanbalken durch (zB mit automatischer Frequenzwahl oder "wlan on, when plugged in" und eben nirgends angeschlossen), auch wenn alle anderen Funktionen keinen Mucks machen. Da ich so zumindest kurze Pausen in der Wlananzeige hab bin ich mir eben nicht sicher, ob es nur an der Darstellung liegt.
Und da muss ich dann sicher sein, weil ich auf der Arbeit das Gerät auch mal komplett inaktiv schalten können muss. Aber auch prinzipiell, wenn ich das Gerät komplett von der Aussenwelt trenne, dann hat mir da kein Programm dazwischen zu funken - nicht wenn ich die software-Version des mechanischen Ein-/Aus-Schalters verwende...
 
L

Lurtz

Erfahrenes Mitglied
Bei mir schaltet sich das WLAN laut Anzeige auch immer wieder ein. Sowohl beim alten als auch beim neuen Gerät. Sehr seltsam.
 
loopi

loopi

Ehrenmitglied
Also ich habe das Gefühl es ist ein Anzeigebug wie es schon einige angedeutet haben. Ich merke nichts was auf erhöhten Akkuverbrauch schließen lässt.
 
S

spyro2008

Erfahrenes Mitglied
Bei mir ,mit version 1.6 ist das Wlan aus und schaltet sich nicht automatisch ein.Im ganzen läuft die 1.6 bei mir fehlerfrei.Muß aber auch sagen,das ich mir bei jedem Update ,die mühe mache und alles neu Flashe,halte von OTA nix.So habe ich immer ein frisches System.Dauert bei mir nur 5 min,OTA dauert bestimmt genau so lange oder länger.Flashe erst ,Trwp flashen dann Root.Zum Schluß das alte Backup also nur die Daten vom Trwpbackup rauf ,und fertig.So habe ich nie Probleme,selbst der Bootloader ist somit auch immer aktuel.
 
A

arno-nym

Neues Mitglied
Ich glaub ich bin dem Problem mit dem daueraktiven Wlan auf der Spur.

Hatte zuerst auch gedacht, dass es eine der Apps war, die bei Stock mit dabei sind (andere hat mein X5+ seit dem es bei mir ist noch nicht gesehen) und hab mich ganz tief in sämtliche Berechtigungen & Appeinstellungen gegraben & abgeschaltet was ging. Wlan lies sich dann tatsächlich abschalten und blieb die ganze Nacht über im Flugmodus und heute vormittag im sleep aus. Wollte einrichten, wurde gestört, beim 2. Anlauf vorhin: wieder Dauerwlan.
Wieder rumprobiert, bis ich das ganze halbwegs hab reproduzieren können (ganz genau klappt es noch nicht):
Das Problem hat anscheindend etwas damit zu tun, wenn das Gerät am Rechner hängt und ausgeschaltet, neu gestartet oder in den sleepmodus geht. Anscheinend kann es passieren, dass sich da das Wlan dann auf aktiv & immer on stellt bzw bleibt und sich nicht mehr zurück stellen lässt.

Wenn ich das X5+ mit aktivem wlan, ohne Flugmodus und den Einstellungen "on while plugged in" & auto Frequenzwahl, in aktivem Zustand (inkl. Display) sicher entferne und abstecke tritt das Problem nicht mehr auf und das wlan lässt sich ganz normal an- und abschalten.

Ich werd heute abend beobachten, ob das so bleibt, wie der Verbrauch jetzt ist & spätestens morgen testen, ob das Problem auch beim Laden über Steckdose auftritt. Bleibt nur noch die Frage, ob es ein Anzeigenbug ist, ein Softwarebug bei der Wlansteuerung oder an meiner Hardware liegt.. :confused2:

Edit: kleine Korrektur: das Wlan manuell normal kontrollieren funktioniert nach obiger Methode nur wenn "on while plugged in" bei den erweiterten Einstellungen ausgewählt ist...
Ich glaub ich versuch mein Glück mit neuer Hardware
 
Zuletzt bearbeitet:
L

Lurtz

Erfahrenes Mitglied
Mein Gerät war noch nie am Rechner und hat dennoch das Problem.
 
A

arno-nym

Neues Mitglied
Bei mir blieb das wlan heute Nacht aus, der Akkuverbrauch war dann 1% ggnüber 4% die Nacht zuvor.
Dann laden über Steckdose versucht, wieder das Problem gehbt. Als letzten Versuch mit Umweg über cm die 1.6er aufgespielt und jetzt sind ein Großteil der Probleme weg.
Der einzige Fall, bei dem es noch Probleme gibt ist, wenn wlan-Netze vorhanden sind, das Gerät sich aber in keines einbuchen kann... kann wird das wlan weiterhin als aktiv angezeigt, selbst im Flugmodus. Schalte ich das Gerät dann frei bucht es sich nicht selbstständig ein (bei abgeschaltetem wlan - schon mal gut) und muss manuell mit dem Netz verbunden werden (wenn das wlan aktiviert wird). Danach ist Ruhe und alles funktioniert wie es soll.

Irgendwas versucht da wohl permanent das Gerät mit dem wlan zu verbinden (auch wenn es so aussieht, als würde am Ende kein Signal vom Gerät abgehen).
Werde heute nach schauen, ob sich das auch wieder auf den Akku auswirkt und morgen auf der Arbeit probieren, ob das nur der Fall ist, wenn kein Zugang zu bekannten Netzen möglich ist, die aktiv sind oder ob das immer passiert, sobald Netze vorhanden sind (oder ob ein fehlgeschlagener Versuch mit einem Netz zu verbinden das Problem auslöst).

Gibt es unter Android eigentlich die Möglichkeit das automatische Verbinden mit (gespeicherten) Netzen abzustellen um sich, wie beim PC möglich, immer manuell verbinden zu können/müssen ohne das wlan-Modul gleich auszuschalten? Das dürfte wohl die einfachste Lösung für das Problem sein....
 
Skyhigh

Skyhigh

Guru
arno-nym schrieb:
Gibt es unter Android eigentlich die Möglichkeit das automatische Verbinden mit (gespeicherten) Netzen abzustellen um sich, wie beim PC möglich, immer manuell verbinden zu können/müssen ohne das wlan-Modul gleich auszuschalten? Das dürfte wohl die einfachste Lösung für das Problem sein....

Nicht das ich wüsste. Allerdings könntest du als Notlösung dein WLAN Passwort auf einem NFC Tag, NFC Sticker, NFC Schlüsselanhänger oder ner NFC Karte speichern und das gespeicherte WLAN Netz entfernen wenn es nicht verbunden werden soll.
 
A

arno-nym

Neues Mitglied
@Skyhigh
Sobald das der Fall ist (kein Passwort) oder ich am Router den Zugang sperre kommt es bei mir zu dem daueraktiven wlan. Irgendwas setzt da einen Teufelskreis in Gang. Das will ich ja grad vermeiden.
Zuhause ist das weniger ein Problem, aber auf Arbeit oder wenn man mal unterwegs ist und andere Netze nutzt/ nutzen muss, kann so eine Situation schnell mal vorkommen. Und da sollte das Gerät dann schon das machen, was ich will, wann ich will. :)
 
loopi

loopi

Ehrenmitglied
Ich habe das Thema mal ausgelagert da es doch mittlerweile nicht mehr viel mit dem allgemeinen Akku Thread zu tun hat.
 
E

eggman

Stammgast
Zählt der Flugmodus nur für den Mobilfunk?
Wie kann es sein, dass sich WLAN und BT im Flugmodus aktivieren lassen?
Ist mir ganz neu, dachte immer da ist ganz Ruhe mit Funk.

UPDATE: Es wird nicht nur angezeigt, ich bin auch aktiv mit der Fritz!Box verbunden,
Auch kann ich Musik über BT hören, nur angerufen werden geht nicht (Teilnehmer nicht erreichbar).
Das hatte ich so noch bei keinem Handy, da war wirklich Ruhe. Liegt das vielleicht an der Software?
 

Anhänge

Zuletzt bearbeitet:
C

copy&paste

Experte
Wenn du eine App anweist die Funkverbindungen (Telefon, BT, WLAN) zu Uhrzeit x zu deaktivieren, dann killt diese, meiner Erfahrung nach (zumindest hat das Llama (mit root-Rechten) so gemacht) auch gnadenlos die Connection. Das heißt aber nicht, dass sich (bis auf Telefon natürlich) die anderen Kontaktwege nicht wieder aktivieren lassen. Schaltest du manuell in den Flugmodus (ich mach das z.B. mit der App Power Toggles) dann wird auch alles gekillt. BT und WLAN lassen sich trotzdem wieder aktivieren. Wenn du das vorher noch nicht hattest, hattest du entweder noch nicht so viele Androiden oder dir ist es schlicht nicht aufgefallen. Ich kenne das seit Anbeginn meiner Androidzeit. Auf jeden Fall kein neues Feature ;)
 
Subaru WRX STI

Subaru WRX STI

Erfahrenes Mitglied
@eggman

Wenn ich den Flugmodus anschalte ist W-LAN, Mobilfunk/Daten und BT aus, basta. Und da schaltet sich auch nichts automatisch wieder an.
 
E

eggman

Stammgast
copy&paste schrieb:
..... oder dir ist es schlicht nicht aufgefallen....
Nun ja, bin erst hier durch diesen Thread aufmerksam geworden. Den Flugmodus nutze ich eigentlich nie, dachte wirklich das es ein Bug ist.
 
C

copy&paste

Experte
Ich verbuche das unter einem der vielen ranzigen Probleme die Android einfach hat ... manchmal ... und dann garantiert nicht bei allen. Aber eben manchen :flapper:
Android ist und bleibt ein Abenteuerspielplatz. Manchmal entdeckt man harmloses und manches was nicht harmlos ist bleibt (lange) unentdeckt.
 
loopi

loopi

Ehrenmitglied
Das mit dem manuell WiFi aktiveren ist kein Bug im Flugmodus, das ist so gewollt.

Es gibt Situationen wie im Flugzeug, da soll das Funkmodul aus bleiben aber eine Verbindung mit dem WiFi Boardnetz ist erlaubt. Das ist schon immer so und nicht nur bei Android möglich. Auch ein iOS Gerät lässt sich ebenso benutzen.

Deswegen werden erstmal alle Verbindungen gekappt, manuell lässt sich aber WIFI oder GPS wieder aktivieren.
 
A

arno-nym

Neues Mitglied
So, ich hab jetzt mal auf Arbeit mit weiteren Wlan-Netzen testen können.
Mein Problem stellt sich definitv so dar, dass mein X5+ das wlan daueraktiv lässt, sobald es sich mit einem Netz verbinden will/soll, der Vorgang aber scheitert. Dabei ist egal, ob der Grund dafür auf Client- oder Serverseite liegt. Erst eine erfolgreiche Verbindung oder das Verlassen der Reichweite bekannter Netze (ohne Zugriffsmöglichkeit) behebt das Problem (im 2. Fall allerdings nur solange das Gerät das Netz nicht wieder entdeckt). Eine Internetverbindung ist allerdings nicht notwendig.

Weder gespeicherte Netze vergessen, noch ein reset der Netzwerkeinstellungen, "wipe cache" oder factory reset schafft Abhilfe. Auch ein Wechsel auf das Lollipop-DHCP-Protokoll ändert nichts.

Das Verhalten kann ich weder mit meinem alten Ace II mit CM 11, noch mit dem Lollipop-Xperia oder Marshmallow-P8 von Kollegen reproduzieren.

Ich werde noch die Vorschläge von bmaupin (How to reset Wi-Fi settings?) versuchen.
Tritt so ein Verhalten auch bei anderen X5+ auf oder liegt es an meiner Hard- bzw. Software?
Dann wäre das der endgültig letzte Versuch das noch bei diesem Gerät, auch wenn ich die Hardware eigentlich gerne behalten würde (gut verarbeitet, keine der kleineren Mängel, die bei anderen bisher vereinzelt aufgetreten sind) und auch gerne verstehen würde, was der Grund ist. Aber irgendwann ist auch mal Schluss.