Magisk Hide vs SecureGo (VR-Bank)

  • 70 Antworten
  • Neuester Beitrag
Diskutiere Magisk Hide vs SecureGo (VR-Bank) im Finanz-Apps im Bereich Business und Organisation.
O

Oberpas

Neues Mitglied
Hi,
habe mir vorgestern die EU ROM aufgespielt.
Bisher funktioniert auch alles inklusive GPay.
Die einzige Hürde vor der ich momentan noch stehe, ist die SecureGo App.
Hier bekomme ich es bisher nicht hin, den Root zu verstecken.

Hat vielleicht schon jemand Erfahrungen, was die App oder allgemein Banking Apps angeht?
Die Suche und googeln haben bisher leider nicht geholfen.

Viele Grüße und danke für die Hilfe
 
Empfohlene Antwort(en)
dcdead

dcdead

Erfahrenes Mitglied
Hast du auch den Magisk Manager mit neuem Paketnamen reinstalliert (ist ein Menüpunkt in den Magisk-Einstellungen)?

Dazu dann Magisk Hide für die SecureGo app aktivieren.

Manche apps sind auch empfindlich, wenn man Ad-Blocker benutzte, welche die hosts liste austauschen (AdAway bspw.), die muss dann ganz entfernen.
 
Alle Antworten (70)
Jimmy78

Jimmy78

Stammgast
Ich habe die ING-DIBA- und die VR-Bank-App installiert. Beides klappt trotz ROOT mit Magisk.
Gpay nutze ich nicht.

Magisk-hide ist in den allgemeinen Einstellungen aktiviert, jedoch nicht speziell für die Banking-Apps.
 
O

Oberpas

Neues Mitglied
Nutzt du auch die SecureGo App?
Die Standard banking app der VR Bank funktioniert bei mir nämlich auch.
Lediglich kann ich keine TANs empfangen, da diese über SecureGo abgerufen werden
 
dcdead

dcdead

Erfahrenes Mitglied
Hast du auch den Magisk Manager mit neuem Paketnamen reinstalliert (ist ein Menüpunkt in den Magisk-Einstellungen)?

Dazu dann Magisk Hide für die SecureGo app aktivieren.

Manche apps sind auch empfindlich, wenn man Ad-Blocker benutzte, welche die hosts liste austauschen (AdAway bspw.), die muss dann ganz entfernen.
 
O

Oberpas

Neues Mitglied
dcdead schrieb:
Hast du auch den Magisk Manager mit neuem Paketnamen reinstalliert (ist ein Menüpunkt in den Magisk-Einstellungen)?
Mega. Das war es.
Vielen Dank. Die App startet jetzt wieder
 
P

pandoraGUFSZ

Fortgeschrittenes Mitglied
Zur Info die sich auch mit dem Problem herumschlagen, bei mir ging es erst mit Magisk 20.0 auf dem dem S7 mit Oreo 8.1. Mit den 19.x - Versionen ging gar nichts.
 
S

Scunkaneli

Neues Mitglied
Kleines Update:
VR-SecureGo 20.13.1 (aktuellste Version April 2020) erkennt Magisk 20.4 mit Manager 7.5.1 (mit zufälligem Packetnamen) trotz aktiviertem MagiskHide und auch, wenn Magisk im Core-Only Modus gestartet wird. Lösung: Magisk Manager deinstallieren und optional die Canary-Version des Managers installieren, dann geht die App wieder.
 
Zuletzt bearbeitet:
hara74

hara74

Lexikon
top, viele Dank, hat einwandfrei funktioniert 😁
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von Fulano - Grund: Direktes Vollzitat gelöscht. Nutze bitte die "Antworten" Funktion und markiere, sofern nötig, mit @Benutzername. Gruß Fulano
T

tramp20

Fortgeschrittenes Mitglied
Scunkaneli schrieb:
Lösung: Magisk Manager deinstallieren und optional die Canary-Version des Managers installieren, dann geht die App wieder.
Danke, funktioniert bei mir leider nicht:
AICP 16
Magisk 20.4
aktuelle Canary 87de0e7a installiert
SecureGo installiert und noch nicht gestartet
diese App im Magisk Manager versteckt
SecureGo gestartet, läuft aber nicht (Browserfenster geht dafür auf)
zusätzlich Magisk Manager verborgen und neu gestartet, auch mal neu gebootet, ebenfalls kein Erfolg.
 
S

Scunkaneli

Neues Mitglied
Und mit deinstalliertem Magisk Manager? Oder hast du vielleicht EdXposed, FDE.AI oder so etwas ähnliches installiert? Ich habe auch die Manager Canary 87de0e7a und bei mir geht es weiterhin. Neuinstallieren musste ich SecureGo nach dem Deinstallieren des Magisk Managers nicht, die App ging direkt.
Leider kenne ich mich nicht mit deiner Custom ROM aus, vielleicht ist da noch irgendwas dabei was erkannt wird. SafetyNet jedenfalls dürfte egal sein, bei mir geht es auch mit basicIntegrity und ctsProfile auf false.
 
T

tramp20

Fortgeschrittenes Mitglied
Zum Custom ROM: es ist egal, ob AICP 16 oder Lineage 17.1 (beides Android 10)
Auch ohne (Magisk) Manager und ohne Edxposed geht SecureGo nicht.

Meine früheren Versuche mit neu aufgesetztem Systemen ergaben, dass alleine das Rooten mit Magisk (ohne weitere Apps) das Starten der SecureGo (egal ob von VR oder PSD) verhinderten.
 
S

Scunkaneli

Neues Mitglied
Bitte entschuldige, meine Antwort hängt seit gestern 14 Uhr bei der Moderation fest und wird nicht freigeschaltet. Ich versuche es nochmal ohne Link:

Ja stimmt, früher hat schon alleine das Rooten mit Magisk ausgereicht, damit SecureGo nicht mehr funktioniert, weil scheinbar unter anderem auf den Manager getestet wird. Aber mit dem neuen Manager scheint es ja zumindest bei hara74 und mir zu klappen. Leider habe ich keine andere Erklärung, was bei dir erkannt wird, was bei hara74 und mir nicht vorhanden ist.
Zeigt die App RootbeerFresh bei dir irgendwelche Auffälligkeiten (mit MagiskHide aktiviert)?

Theoretisch denkbar wäre das Erkennen von Custom Recoverys, aber zumindest mein TWRP wird nicht erkannt. Sollte das der Fall sein bei dir, dann sollte aber eine komplette Deinstallion von Magisk nicht ausreichen.
 
T

tramp20

Fortgeschrittenes Mitglied
Vielen Dank für Deine Bemühungen.
Ich habe heute ein wipe all gemacht, das AICP Rom Q10 mit OpenGAPPS geflasht (sonst nichts) und dann SecureGo PSD Bank installiert.
Schon jetzt kommt immer beim Start diese Browsermeldung (siehe Screenshots):

Diese Meldung kommt auch bei installiertem Magisk/Edxposed usw.

Weiß jemand, was das bedeuten soll?
Beitrag automatisch zusammengefügt:

Scunkaneli schrieb:
Theoretisch denkbar wäre das Erkennen von Custom Recoverys, aber zumindest mein TWRP wird nicht erkannt.
Ich habe mir extra ein weiteres Z1c mit AICP ROM Q10 eingerichtet, ohne Root, um wenigstens immer eine funktionierende SecureGo zu haben.
Hier spielt TWRP keine Rolle und auch auf den SDCards intern und extern sind Verzeichnisse und Daten von Magisk und Edxposed vorhanden, die nicht beanstandet werden.
 

Anhänge

Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Guru
Zuletzt bearbeitet:
T

tramp20

Fortgeschrittenes Mitglied
BOotnoOB schrieb:
@tramp20 Mit einer Custom ROM hast du keine Chance, solche Apps ans Laufen zu bekommen.
Aber sie läuft ja problemlos auf einem weiteren Gerät mit dem selben Custom ROM seit Monaten.
Die Google Play Protect-Zertifizierung steht überall auf zertifiziert.

Ich bräuchte eine Erklärung für die Browsermeldung (siehe die Screenshots).
Auf diesen beiden Geräten ist KEIN Root vorhanden, kein Magisk, kein Edxposed usw.
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Guru
@tramp20 Ist denn der Bootloader offen?
Beitrag automatisch zusammengefügt:

Noch kurz zu der Custom ROM: Hast du da die aktuelle Version der App installiert? In den letzten Wochen haben nämlich so ziemlich alle Bankingapps nachgerüstet und lassen sich wirklich nur noch sehr schwer mit root starten. Was die da genau gemacht haben, ist mir auch ein Rätsel. Jedenfalls sind die simplen root-Checks wie z.B. das Gerät nach bestimmten Verzeichnissen oder Paketnamen abzusuchen durch eine wesentlich aufwendigere Prozeduren ersetzt worden.
 
Zuletzt bearbeitet:
T

tramp20

Fortgeschrittenes Mitglied
Bootloader ist bei beiden Geräten offen, auf beiden ist die neueste Version 20.13.1 drauf.

Ich habe auch mal zwei ältere Versionen installiert, 18.23.0 und 19.23.0. ohne Erfolg.
 
BOotnoOB

BOotnoOB

Guru
@tramp20 Wenn der Bootloader offen ist, aber kein Magisk installiert wurde, ist das grundsätzlich schlecht. Eigentlich dürfte bei dieser Konstellation der Play Store nicht zertifiziert sein.
 
S

Scunkaneli

Neues Mitglied
Mein Gerät ist ebenfalls nicht Play Store verifiziert, dennoch läuft SecureGo einwandfrei. Dieser Status sollte also, genau wie der SafetyNet Status selbst, egal sein.

BOotnoOB schrieb:
Mit einer Custom ROM hast du keine Chance, solche Apps ans Laufen zu bekommen.
Ob es auf allen Custom ROMs läuft kann ich natürlich nicht abschätzen, aber zumindest auf meiner xiaomi.eu Custom ROM läuft es.

BOotnoOB schrieb:
Du kannst dieses Problem ganz leicht mit Magisk Hide Props lösen, wenn du möchtest:
Vielen Dank für den Vorschlag, aber dieses Modul habe ich bereits installiert. Der Grund für den SafetyNet-Fehler ist bei mir meine alte EdXposed-Version. Ein Update auf die neuste Version oder das Deaktivieren von EdXposed in Magisk würden zu einem positiven SafetyNet-Status führen.

tramp20 schrieb:
Browsermeldung (siehe Screenshots)
Ich habe, bevor ich den Manager deinstalliert habe, genau die selbe Meldung (ebenfalls "flavour=VERSIONFALVOUR") erhalten. Offensichtlich erkennt die App irgendetwas auf deinem Gerät, was sie mit Root in Verbindung bringt.

Was unterscheidet denn deine beiden Geräte? So wie ich dich verstehe ist auf beiden der AICP Rom Q10 installiert und keines der Geräte ist aktuell gerootet. Der einzige Unterschied scheint zu sein, dass auf dem ersten Gerät OpenGApps installiert ist und auf dem zweiten nicht? Besteht die Möglichkeit, dass SecureGo die OpenGApps nicht mag?
Wenn tatsächlich der Fehler auf einem ungerooteten Gerät auftritt, dann ist Magisk/EdXposed als Schuldiger wohl raus. Leider kenne ich mich dann zu wenig aus, um dabei weiterhelfen zu können. Erklären kann ich mir die Fehlermeldung dann absolut nicht.

Meine Erfahrung:
Ich habe nun zum Testen die PSD Banking App in der neusten Version 20.13.1 heruntergeladen (Manager 87de0e7a). Ohne MagiskHide kommt genau die selbe Fehlermeldung wie bei dir. Mit aktiviertem MagiskHide für de.psd.banking.privat und de.psd.banking.privat:phoenix erhalte ich weiterhin die selbe Fehlermeldung wie auf deinen Screenshots. Bei meinem Gerät liegt dies offensichtlich am installierten EdXposed. Sobald ich in EdXposed die App Blacklist aktiviere und PSD Banking dort der Blacklist hinzufüge, startet die App auf meinem Gerät ohne Probleme.
 
Zuletzt bearbeitet:
BOotnoOB

BOotnoOB

Guru
Scunkaneli schrieb:
Ob es auf allen Custom ROMs läuft kann ich natürlich nicht abschätzen, aber zumindest auf meiner xiaomi.eu Custom ROM läuft es.
Mithilfe von EdXposed?
Beitrag automatisch zusammengefügt:

Wenn du nämlich Xposed verwendest, um die App starten zu können, ist alles egal. Ob SafetyNet oder Zertifizierung spielt dann keine Rolle mehr.
 
Zuletzt bearbeitet:
Ähnliche Themen - Magisk Hide vs SecureGo (VR-Bank) Antworten Datum
1
4