1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. BennyB, 31.01.2011 #21
    BennyB

    BennyB Erfahrener Benutzer

    Ich schließe mich mal an.
     
  2. Flycs, 31.01.2011 #22
    Flycs

    Flycs Fortgeschrittenes Mitglied

    Ich werds ebenfalls testen, bei mir tritt das auch täglich auf.
     
  3. anx

    anx Junior Mitglied

    Bin ebenfalls am testen. Funktioniert bisher ohne Nebeneffekte.
     
  4. matze91, 01.02.2011 #24
    matze91

    matze91 Fortgeschrittenes Mitglied

    Im ersten Test hat die App erfolgreich funktioniert!

    War ~2,5h im WLAN und es wurde sofort auf Mobiles Netzwerk umgeschalten, nach dem das WLAN weg war.
    Ich berichte wie es weiterhin läuft ;)

    Aber... Das wäre eine der allerbesten Apps für das Nexus One - zumindest sehe ich das so =)
     
  5. BennyB, 02.02.2011 #25
    BennyB

    BennyB Erfahrener Benutzer

    Also bei mir hat's jetzt in beiden Tests (gestern und heute) hervorragend funktioniert. Bin sofort wieder im Mobilnetz gewesen als das WLAN weg war. Auch das "Reset configured wifis" scheint zu funktionieren - auch wenn ich noch nicht ganz verstanden habe, was das deaktivieren verursacht.

    Wenn deine App jetzt noch das "aufhängen" des Phones verhindern könnte (tritt auch im Zusammenhang mit WLAN auf - der Touchscreen reagiert dann nicht mehr und das WLAN wird aus- und wieder eingeschaltet) wäre es perfekt :D
     
  6. Flycs, 02.02.2011 #26
    Flycs

    Flycs Fortgeschrittenes Mitglied

    Ich kann bis heute auch nur Positives berichten: der automatische Wechsel zu 2G/3G hat bisher jedesmal geklappt, auch nach einer Nacht mit durchgehender WLAN-Verbindung. :thumbsup:

    Zeit für nen Market-Kommentar und -Bewertung!
     
  7. matze91, 02.02.2011 #27
    matze91

    matze91 Fortgeschrittenes Mitglied

    Aktuell:
    Trigger Interval: 60
    Network Mode: enableMMS
    Events = active

    Test über Nacht = Erfolgreich, Wechsel zu Mobilen Daten ohne Probleme, WLAN war ganze Nacht aktiv
    Test nach 2,5 h = Erfolgreich

    System:
    N1
    2.2.1
    Baseband: 5.12.00.08
    Mod: CM 6.1.1
    Build: FRG83D


    Event Notification, habe ich jetzt mal ausgestellt und teste es mal so. Hat schon jemand 2.3 also mit CM 7 Erfahrungen?!
     
  8. anx

    anx Junior Mitglied

    Ich habe CM7 nightly. Keine Probleme feststellbar.
     
    Zuletzt bearbeitet: 02.02.2011
  9. Flycs, 02.02.2011 #29
    Flycs

    Flycs Fortgeschrittenes Mitglied

    Ich bin auch auf CM7 nightly.
     
  10. TheChaos, 02.02.2011 #30
    TheChaos

    TheChaos Junior Mitglied

    sehr schön. ich habe eben die v0.8.1 rausgehauen. Ist eigentlich mehr ein GUI-Update, ein paar Beschriftungen verdeutlicht und vor allem eine Hilfe-Seite ist jetzt aufrufbar, die hoffentlich alles ausführlichst erklärt.

    @BennyB: "Reset configured wifis" bedeutet, dass bei mir damit ein weiterer Bug behoben werden soll, der sehr selten auftritt: wenn ich manchmal das WLAN verlasse und ich irgendwann wieder in den WLAN-Bereich zurückkomme hat sich mein N1 nicht mehr mit dem WLAN verbunden (obwohl gefunden). Das WLAN stand auf "deaktiviert". Aus irgendeinem Grund deaktiviert er manchmal ein bekanntes WLAN. Der Schalter macht nun nichts anderes als beim Disconnect zu prüfen, ob ein WLAN deaktiviert ist und dieses dann wieder anschalten.

    Momentan nervt mich nur noch ein Bug, der auch ab und an auftritt, dass sich mich mein WLAN scheinbar manchmal "aufhängt", d.h. er zeigt in der WLAN Liste keine neuen an, obwohl ich direkt neben dem AP bin. Im DebugLog steht nur permanent "disconnected" im Sekundentakt. Mir schwebt da eine weitere Option vor Augen, die nur in solchen Fällen das WLAN kurz an und abschaltet. Das mache ich in dem Fall noch händisch.

    Falls jemand anderem noch irgendwas auffallen sollte, dann einfach hier schreiben. Dass die aktuellen Features so funktionieren wie sie sollen haben wir nun, glaube ich, bestätigt :)
     
    Flycs gefällt das.
  11. BennyB, 02.02.2011 #31
    BennyB

    BennyB Erfahrener Benutzer

    Der Fehler mit dem deaktivierten WLAN ansich war mir klar, mich hätte nur interessiert ob es dafür auch eine "Erklärung" gibt (und evtl. ein Commitment von Google sich des Bugs anzunehmen). Gibt es dazu einen offiziellen Bug-Report?
     
  12. TheChaos, 04.02.2011 #32
    TheChaos

    TheChaos Junior Mitglied

    Also ich denke du stimmst mir zu dass das ganz schön Off-Topic ist. Das ist ein vollständig eigenes Problem und gehört in ein eigenes Thema. Prinzipiell würde ich dir aber empfehlen, mal das Debug-Log überprüfen, posten und mal das original ROM zu testen. Mein Tool kann dir da speziell (noch) nicht helfen
     
  13. Katz@Magic, 07.02.2011 #33
    Katz@Magic

    Katz@Magic Erfahrener Benutzer

    So hab das ganze mal getestet und bin zu unterschiedlichen Ergebnissen gekommen:

    Zum einen killt eine Größere App wie z.B. ein Spiel dein Tool.
    Was bewirkt das man es wieder starten muss und wenn man es vergisst... naja angeschmiert wie immer.... :D

    Desweiteren bin ich mit 180 gut gefahren - mit 250 eher weniger.

    Manchmal, wenn ich heimkomme ist mein Netzwerk deaktiviert wenn ich aus der Uni komme und dort im Eduroam war. Und das trotz dem aktivierten Reset.

    Letzte Woche liefs noch gut - seit Freitag eher befriedigend... Kann aber an "Game Dev Story" liegen das ich ausgiebig spiele :D
     
  14. matze91, 07.02.2011 #34
    matze91

    matze91 Fortgeschrittenes Mitglied

    Kann ich nicht bestätigen. App hat sogar Autostart und dann muss ich mich nie wieder drum kümmern.

    Mal noch ne Frage...
    Ist es sinnvoll die Intervalle hochzusetzen? Habe sie jetzt bei 60....
     
  15. Katz@Magic, 07.02.2011 #35
    Katz@Magic

    Katz@Magic Erfahrener Benutzer

    Besteht die Möglichkeit nen Log zu erstellen?

    Logcat bringt ja nicht viel, da ich nicht weiß wann das Problem auftritt...
     
  16. TheChaos, 07.02.2011 #36
    TheChaos

    TheChaos Junior Mitglied

    Also das kann ich fast nicht glauben, da, wie schon von Matze angemerkt, diese Trigger werden eigentlich auch dann gefeuert, wenn die App nicht da ist, quasi Autostart. Kannst du das reproduzieren und wenn ja mir mal mitteilen?

    Wenn du auch bei O2 bist, dann ist der "Rauswurf" genau bei 180m, das könnte also etwas zu knapp sein, 170m ist besser, ich persönlich nehm zur Sicherheit 150m.

    Der Fehler ist wird gerade von mir untersucht. Dieser Reset ist leider noch nicht zuverlässig. Ich war am Wochenende in zwei WLANs unterwegs, die per Repeater das Netz vergrößern. Genau in diesen Beispielen versagt der Reset der gespeicherten Netze. Das überarbeite ich die nächsten Tage

    Danke aber erstmal für die Hinweise.

    Meiner Erfahrung nach ja, denn dieser Timer stellt eine mobile Datenverbindung her, die bekannter Maßen mehr Strom braucht. Je kleiner also der Intervall, umso mehr Verbindungsversuche werden unternommen. Der Wert sollte also immer in Richtung eigentlicher Bug-Grenze verschoben werden, bei O2 wie gesagt aus eigener Erfahrung genau bei 3h. Also wie empfohlen die 150m mal testen.

    du meinst ein Log um festzustellen wann der Bug auftritt? Das habe ich auf Seite 2 mal geschrieben, steht im Logcat
     
    Zuletzt bearbeitet: 07.02.2011
  17. Katz@Magic, 08.02.2011 #37
    Katz@Magic

    Katz@Magic Erfahrener Benutzer

    dann installier ich mir mal LogCat und filtere nach "ConnectivityService" - ich hoffe das bringt weitere Hinweise.

    Vielen Dank
     
  18. BennyB, 25.02.2011 #38
    BennyB

    BennyB Erfahrener Benutzer

    Ich habe dein Tool nach dem 2.3.3 Update gestern (Stock) mal deaktiviert, und hatte heute morgen dennoch kein Problem beim Verlassen des WLANs - es sieht also fast so aus als wäre das Problem gelöst. Ich werd's mal die nächsten Tage weiter beobachten, natürlich auch die Sache mit dem disabled WLAN.
     
  19. Katz@Magic, 25.02.2011 #39
    Katz@Magic

    Katz@Magic Erfahrener Benutzer

    Meine Probleme sind verschwunden deswegen konnte ich (leider) nichts loggen...

    Hab deine App nun auch mal ausgeschaltet und werde schauen wie sich Gingerbread verhält...

    Gruß

    Gesendet mit der Android-Hilfe.de-App
     
  20. TheChaos, 25.02.2011 #40
    TheChaos

    TheChaos Junior Mitglied

    Ja so ein Mist, und das bevor ich eine Bezahlfunktion eingebaut habe :D Ich hab noch kein 2.3 drauf, werds aber natürlich testen. Zum Glück gibts noch Geräte mit 2.2 ;)
     
Du betrachtest das Thema "Umschalten WLAN/Mobiles Internet" im Forum "Google Nexus One Forum",