Umschalten WLAN/Mobiles Internet

N

nexusone

Fortgeschrittenes Mitglied
Threadstarter
Hallo,

ich habe ein Problem. Oftmals, wenn ich morgens aus dem Haus gehe stellt sich mein Nexus nicht auf 3G/2G um, sondern hat einfach keine Verbindung.
Eine Verbindung habe ich erst wieder, wenn ich 2G/3G im Menü kurz umschalte und es deswegen reconnected.

Gleiches Spiel auch wenn ich nach einiger Zeit wieder heimkomme. Manchmal muss ich auch hier WLAN manuell aus/an machen, um ins WLAN zu wechseln. Meist reicht es hier aber, den Bildschirm zu aktivieren und er geht aus dem Mobilen Inet inst WLAN.

Wie kann man diesen Bug - oder ist es etwa ein Feature :D - beheben?
 
Deanna

Deanna

Lexikon
Ist Dein Nexus noch so, wie Google es schuf? Da hatte ich das Problem auch. Aber mit den CR hatte ich das schon lange nicht mehr.
 
N

nexusone

Fortgeschrittenes Mitglied
Threadstarter
CR=Cyogen?

Ja meins ist noch so wie Google (und vllt auch VF) es schuf.
 
J

jojoger

Ambitioniertes Mitglied
Ich habe das selbe Problem mit der Stock Rom. Ich schalte das Handy immer kurz auf Flugmodus und wieder zurück, weil ich zu faul bin durchs Menü zu gehen. Ist aber trotzdem nervig...
 
Deanna

Deanna

Lexikon
nexusone schrieb:
CR=Cyogen?

Ja meins ist noch so wie Google (und vllt auch VF) es schuf.
CR= Custom Rom (z.B. Cyanogen oder MoDaCo)

Also, dann fürchte ich, wirst Du damit leben müssen. Oder Dich von den Fesseln des Stock Roms befreien :D
 
N

nexusone

Fortgeschrittenes Mitglied
Threadstarter
Na super... vllt ist es ja in Froyo gefixed... wenn es dann auch endlich mal kommt....
 
B

BavariaR

Fortgeschrittenes Mitglied
nee in Froyo gibt es das Problem auch noch immer... mit dem Unterschied dass ich das Problem nur von 2G/3G nach WLAN habe aber nicht umgekehrt. Manchmal will er partout nicht ins WLAN wechseln und bleibt auf MobileNetwork außer ich schalte für 5 Minuten aus und wieder an. Echt nervig.
 
N

nexusone

Fortgeschrittenes Mitglied
Threadstarter
Schon ein Fortschritt... bis Gingerbread wirds gehen... :D
 
Falkenfluegel

Falkenfluegel

Stammgast
Also bei Froyo tritt das Problem jedenfalls wesentlich weniger häufig auf. Also kannste dich darauf schon mal freuen ;)
 
T

TheChaos

Neues Mitglied
Also der Bug wird hier wild umschrieben.
Nachdem ich am Wochenende einem Googler den vollständigen Bugreport gemailt habe und auch ihm die Vorgehensweise zur Reproduktion mitgeteilt habe, wird dieser Fehler nun scheinbar als interner Radio-Bug geführt. Er machte mir Hoffnung, dass das Problem gelöst wird im nächsten Update. Scheinbar haben in den Issue-Comments mehrere leute auch noch ein DNS Problem, das ist aber bei mir nicht der Fall.

Kurz zum Reproduzieren des Fehlers:
1. Einwählen in ein WLAN und im Standby auch verbunden bleiben
2. Nach ein paar Stunden einfach mal den Accesspoint aussschalten oder WLAN-Bereich verlassen > Telefon verliert komplett die Verbindung. Telefon geht noch, aber keine Datendienste mehr bis zum Umschalten in 2G oder Flugmodus.

Ich gehe mal davon aus, dass nicht alle Telefone/Netzprovider oder was weiss ich für Kombinationen betroffen sind, betrifft aber scheinbar auch das Desire.
 
N

nexusone

Fortgeschrittenes Mitglied
Threadstarter
TheChaos schrieb:
Also der Bug wird hier wild umschrieben.
Nachdem ich am Wochenende einem Googler den vollständigen Bugreport gemailt habe und auch ihm die Vorgehensweise zur Reproduktion mitgeteilt habe, wird dieser Fehler nun scheinbar als interner Radio-Bug geführt. Er machte mir Hoffnung, dass das Problem gelöst wird im nächsten Update. Scheinbar haben in den Issue-Comments mehrere leute auch noch ein DNS Problem, das ist aber bei mir nicht der Fall.

Kurz zum Reproduzieren des Fehlers:
1. Einwählen in ein WLAN und im Standby auch verbunden bleiben
2. Nach ein paar Stunden einfach mal den Accesspoint aussschalten oder WLAN-Bereich verlassen > Telefon verliert komplett die Verbindung. Telefon geht noch, aber keine Datendienste mehr bis zum Umschalten in 2G oder Flugmodus.

Ich gehe mal davon aus, dass nicht alle Telefone/Netzprovider oder was weiss ich für Kombinationen betroffen sind, betrifft aber scheinbar auch das Desire.
Cool. Dann besteht ja Hoffnung
 
T

TheChaos

Neues Mitglied
Ich hab das gestern Abend nochmal reproduziert und auch noch mal mit dem Entwickler Rücksprache gehalten. Es würde viel zur Problemlösung beitragen, wenn jeder der das Problem hat an dem Bugreport einen Kommentar hinterlässt mit "device name, build and carrier". Bitte, das hilft uns allen!

Nochmal zum "adb bugreport". Ihr solltet sowas im Report finden
Code:
07-08 19:26:27.193 D/ConnectivityService(   82): Dropping ConnectivityChange for WIFI: CONNECTING/AUTHENTICATING

07-08 19:26:27.233 D/ConnectivityService(   82): Dropping ConnectivityChange for WIFI: CONNECTING/OBTAINING_IPADDR

07-08 19:26:29.263 D/ConnectivityService(   82): ConnectivityChange for WIFI: CONNECTED/CONNECTED 

07-08 22:26:31.056 I/gsm_service_state_change(  174): [0,0,0,1]
Bei mir tritt der Fehler exakt nach 3h im heimischen WLAN auf, und zwar immer!
 
HAse

HAse

Lexikon
ja hi

Ich hab das Problem mit meinem Nexus auch.

Mit dem CM 6.0.0 RC1 sowie mit dem RC2.

Aber komischerweise erst seit ich als Provider bei Netzclub also O2 bin. Schon sehr komisch.
 
HAse

HAse

Lexikon

Gibts denn schon irgendwelche Neuigkeiten?

Es nervt mich schon etwas. Habs auch weiterhin mit Cyanogen nightly
 
T

TheChaos

Neues Mitglied
Hi,

ich hol das Thema mal wieder hoch. Ich hab momentan neben meinem N1 noch ein paar Samsung Galaxy 3 in der Familie aktiv (Froyo) und auch eins zum entwickeln (Eclair). Ich habe nun festgestellt, dass dieser "WLAN immer verbunden und dann kein 2/3G mehr"-Bug auf dem Samsung sowohl mit Eclair und Froyo existiert.

Für mich steht folgendes fest:

1. definitiv nach 3h Dauer-Verbindung im Wifi keine Verbindung mehr
2. dieses Problem tritt hier nur mit O2-Sims auf. Mit Base-Sim war es nicht zu reproduzieren

Fakt ist, das Telefon braucht (N1 wie G3) braucht mit Dauer-Wlan wesentlich weniger Strom bei mir. Ich habe nachts nur noch 5-10% Akkuverlust im Gegensatz zu 20% früher.
Da der Bug aber nervig ist, hab ich eine App in der Entwicklung, die quasi alle 3h (oder weniger) ein "Ping" per 2G/3G sendet und somit dieses nervige Problem unterbindet.
Lange Rede kurzer Sinn: ich bräuchte ein paar Betatester, die auch genervt davon sind und auch ein wenig Feedback geben können/wollen.
 
HAse

HAse

Lexikon
Wenn du das hinbekommst, würde ich gerne testen.

Zur zeit mach ich einfach vorm schlafen gehen auf nur 2g Benutzen und in der Früh schalt ich 3g wieder an. insgesamt 3 klicks
 
Katz@Magic

Katz@Magic

Fortgeschrittenes Mitglied
Hab das gleiche Problem und wäre bei einem Beta Test mit Feedback dabei :D
 
T

TheChaos

Neues Mitglied
So, ich habs getan: Market-Link oder im Market nach "WifiFixerFree" suchen

Ich hab die Anwendung gleich mal im Market hochgeladen, damit ich erstens sehe wie oft das genutzt wird und dort auch gleich Fehler getrackt werden.

Da die App noch keine eingebaute Hilfe hat, hier kurz die Vorgehensweise:

1. Mit WLAN verbinden
2. App öffnen
3. "Use auto reconnect" anwählen
4. in der DropDown-Liste den passenden "network mode" auswählen. Der Standard-Mode "enableMMS" funktioniert bei mir.
5. während ihr noch im WLAN seid, einmal auf "Start test" drücken. Jetzt sollte eure Datenverbindung starten. WLAN ist weiter verbunden
6. "Stop test" auswählen, das beendet die Verbindung wieder (wenn beides nicht funktionierte, einfach einen anderen Network mode testen)
7. "Trigger interval" auswählen. Bei mir fällt exakt nach 3h WLAN die Mobilverbindung aus. Momentan steht der Intervall bei mir auf 150 Minuten. Am besten mal klein anfangen und schauen obs geht
8. Anwendung ist nun konfiguriert. Einfach kurz neu mit dem WLAN verbinden und schon läuft der Timer.

Optional:
1. Benachrichtigungen ausschalten. Zur Überprüfung der Funktionstüchtigkeit sind mehrere Notifications eingebaut. Vor allem immer wenn sich das Telefon neu mit dem WLAN verbindet wird die Restzeit angezeigt.
2. "Reset configured wifis" - Diese Option habe ich eingebau, weil bei mir zusätzlich zu dem beschriebenen Bug hin und wieder beim Verlassen des WLANs mein konfiguriertes WLAN auf "deaktiviert" stand. Diese Option soll sicherstellen, dass beim Verlust der WLAN-Verbindung kein WLAN auf "deaktiviert" zurückbleibt.

HAse und Katz@Magic, euer Feedback wäre mir sehr wichtig. Danke schonmal
 
Katz@Magic

Katz@Magic

Fortgeschrittenes Mitglied
so installiert ist es und es läuft... werde die Woche mal drauf achten und das Ding laufen lasse.

Ich melde mich dann so gegen freitag wieder, früher wirds wohl keinen sinn machen :D
 
HAse

HAse

Lexikon
Ich habs auch mal installiert.

Werde dann berichten.

Danke schon mal
 
Oben Unten