Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

Jiayu G4: GPS

  • 250 Antworten
  • Neuester Beitrag
Diskutiere Jiayu G4: GPS im Jiayu G4 Forum im Bereich Jiayu Forum.
S

slkater

Neues Mitglied
Ich kenne nur ein Gerät mit MTK Chip wo GPS geht. Das ist das Hongmi. Alle anderen sind leider Schrott. Ich habe mit meinem G5S damals alles probiert. Leider ohne Erfolg. Auch das war ein Grund es zu verkaufen.
 
papa-nundo

papa-nundo

Erfahrenes Mitglied
Bin mit GPS sehr zufrieden bei meinem G2F.
 
H

Herb_

Fortgeschrittenes Mitglied
Bei meinem G4T lief es immer perfekt bis vor ca. 2 Wochen irgendein Defekt aufgetreten ist. Es sieht die Satelliten an den korrekten Stellen bekommt aber keinen Fix mehr zu Stande.

Ich kann das exakt mit gleicher SW und Konfiguration auf meinem G4S daneben halten und dort geht es wie immer.
 
P

pybcu

Erfahrenes Mitglied
Schau mal unter Einstellungen → Standortzugriff → GPS-Satelliten → EPO-Einstellungen nach, ob die EPO-Dateien noch gültig sind.

"Vor zwei Wochen" ~= Monatswechsel / Ablaufdatum der alten Dateien.

Die Server von Mediatek sind leider oft überlastet/schlecht erreichbar, so dass der Download öfter mal fehlschlägt. Wenn Du Geduld hast, dann einfach an die 20 mal manuell den Download anstoßen, bzw. wenn du ungeduldig bist, die Dateien von einer anderen URL laden (https://www.android-hilfe.de/forum/root-custom-roms-modding-fuer-jiayu-g4.1815/epo-daten.551890.html) oder vom G4S rüberkopieren.
 
H

Herb_

Fortgeschrittenes Mitglied
pybcu schrieb:
... vom G4S rüberkopieren.
Genau das hab ich auch gemacht. Unabhängig davon hatte der Download vorher auch schon geklappt.
MT-GPS, Mobile-Uncle Tools und GPS Status neu installiert, das ganze Programm 2 mal durchgespielt, es will nicht mehr.

Das Satelliten-Bild bei GPS Status ist exakt das gleiche wie beim G4S, heißt es sieht die aktiven Satelliten, nur der Fix kommt nicht. Die Geräte liegen nebeneinander draussen auf dem Tisch, WLAN hat volle Power. Das S-Modell fixed in weniger als 10 Sekunden, das T-Modell hatte das früher auch, scheint als wärs jetzt nur noch ein cleverer Stadtplanhalter :(
 
Ora

Ora

Ehrenmitglied
@Herb_:
- Falls Dein Gerät gerootet ist, dann installieren meinen GPS Tweak.
- erhälst Du immer noch keinen Fix, dann lösche mit einem Rootexplorer oder ADB dieses Verzeichnis /data/nvram und boote neu.
 
Zuletzt bearbeitet:
H

Herb_

Fortgeschrittenes Mitglied
Nach dem Fix hatte ich den Eindruck das er 2 Sats kurzfristig hat, aber das Signal ist dann wieder weggesackt und tot. Selbst die roten Positionen im MUT sind nun alle weg.

Ein data\nvram Verzeichnis finde ich nicht nur ein sys\virtual\dumchar\nvram mit ziemlich viel Inhalt. Da hab ich erst mal die Finger von gelassen weil ich keine Ahnung habe was da alles hintersteckt.

Handy kriegt meine Frau, wenn die sich verläuft kann sie mich immer noch anrufen ;)
 
Ora

Ora

Ehrenmitglied
@herb_:
Du hast richtig gesucht?
uploadfromtaptalk1411052847745.jpg

Dieses Verzeichnis sollte auf jedem MTK Androiden verhandeln sein!

WLAN Empfang hat das Handy?
Hast Du vielleicht mal versucht ein Recovery Programm auf das Handy zu bringen?

Wenn das GPS File bei Dir nicht vorhanden ist, dann kann es auch nie funktionieren!
 

Anhänge

Zuletzt bearbeitet:
H

Herb_

Fortgeschrittenes Mitglied



So schauts aus bei beiden Geräten und funktioniert trotzdem zumindest beim G4S.
In dem oben von mir genannten Directory ist jedenfalls ein komplett anderer Inhalt als von Dir gezeigt.

Beide haben noch jeweils Stock-Rom unverändert(17 Monate,5 Monate alt) , lediglich die Launcher sind unterschiedlich. Die Verzeichnisstruktur ist beim G4S etwas umfangreicher.
 
Ora

Ora

Ehrenmitglied
Du suchst falsch.
Es wäre das erste Mal, dass ein MTK kein /data/nvram hat!
Hast du root Rechte?
 
H

Herb_

Fortgeschrittenes Mitglied
Ja, der ES-Explorer startet mit der Meldung SU-Recht erteilt, aber an :ohmy: die versteckten Dateien habe ich nicht gedacht. Dachte sowas gibt es nur bei Windoof. Mach mich jetzt wieder an die Arbeit. Melde mich wieder, Danke :)

Nachtrag: kein Erfolg, das GPS-Modul scheint wohl beschädigt zu sein. Naja haben ja noch 2 andere funktionierende Navis.
 
Zuletzt bearbeitet: