HOW-TO: Manuelles Firmware aufspielen (hängt im Emergency-Modus oder Logo-Bootloop)

  • 127 Antworten
  • Neuester Beitrag
Diskutiere HOW-TO: Manuelles Firmware aufspielen (hängt im Emergency-Modus oder Logo-Bootloop) im LG Optimus One (P500) Forum im Bereich Weitere LG Geräte.
norbert

norbert

Ehrenmitglied
leider lässt sich das P500 nicht im fastboot ansprechen. Der Anschluss über USB wird nur erkannt, wenn es im Emergency ist. Ich denke daran scheitert es letztlich auch beim KDZ-Update, denn wahrscheinlich sollte das Gerät dort beim zwischenzeitlichen Neustart bereits ansprechbar sein per USB.

und im Emergency-Modus geht weder adb noch fastboot
 
fragi

fragi

Dauergast
Hast du mal versucht ein anderes Rom über KDZ zu flashen? Also 10 statt 20 oder c statt e? So lange du noch in den Emergency Mode kommst, sollte doch eigentlich was machbar sein.
Ich bin auch erst im zweiten oder dritten Versuch erfolgreich gewesen ;-)
 
norbert

norbert

Ehrenmitglied
10c
10e
20e

alles versucht :)
 
fragi

fragi

Dauergast
Auch schon versucht ein Custom Recovery auf das Handy zu bekommen?
 
norbert

norbert

Ehrenmitglied
hab gerade versucht, das Recovery von MDK mit lgmdp zu flashen, aber auch da scheiterts beim Versuch in's Recovery zu booten.

mir gehen schön langsam echt die Ideen aus.

wenn ich das Gerät mit einer anderen Tastenkombi als Emergency starte, blinken nach ein paar Sekunden die Tasten mal kurz, und dann hab ich nur mehr das LG-Logo. Keine USB-Verbindung, und sonst auch nichts.
 
P

perpe

Gast
Lese ich richtig heraus, dass das flashen ansich durchläuft und es am reboot dann scheitert? Hast einen Hardreset mal versucht?
 
norbert

norbert

Ehrenmitglied
bei flashen ist es so:
Code:
21:08:18 : Smart : wParam = 205, lParam = 100
21:08:18 : Smart : wParam = 205, lParam = 100
21:08:18 : Smart : wParam = 8, lParam = 0
an dieser Stelle startet das Handy neu.
wenn ich nichts mache, kommt nach ein paar Minuten
Code:
20:43:42 : Smart : wParam = 100, lParam = 6
20:43:42 : Step : Upgrade Error error code = 6
und das Update ist gescheitert.

wenn ich aber rechtzeitig VolUp+Zurück drücke, kommt
Code:
21:08:58 : Smart : wParam = 12, lParam = 0
21:09:00 : Step Complete : UPDATE FINISHED!     
21:09:00 : ResetStartInfo() Call
21:09:00 : _DetachDLL Call
21:09:00 : _DetachDLL Call End
21:09:00 : FreeLibrary Call
21:09:00 : FreeLibrary Call End
21:09:00 : ResetStartInfo() Call End
21:09:00 : OnModelDllMsg(OnMsgFromModelDll3GQCT_PDA) delete m_pLGCyonUpdate
21:09:00 : ===FINISHED===
was ich im Prinzip als erfolgreichen Flash-vorgang ansehen würde. Das Handy bleibt aber danach im Emergency-Modus, bis ich es abstecke.

Jeder Versuch, das Handy dann mit VolUp+Home+Power (oder VolDown+Home+Power) zu starten, führt mich nur zu einem schon langweilig werdenden LG-Logo, von wo aus nichts weiter geht. Die Tasten blinken kurz mal, und fertig, kein Fortschritt.
 
P

perpe

Gast
Eigentlich müsste es glatt durchlaufen ohne irgendwelche Tastenkombinationen.
Hast du noch mal alles kontrolliert? Bei error code 6 und stecken bleiben beim LG Logo spuckt mir google modellunabhängig aus, dass das man die Treiber säubern soll, am besten alles, auch nicht lg Handy Treiber, deinstallieren, die Treiber für kdz installieren, lg Modem deaktivieren und mal einen anderen USB Port nehmen(bei einem Desktop PC die hinteren)
Meist steht wohl das nicht deaktiviertem Modem damit in Verbindung.
 
norbert

norbert

Ehrenmitglied
hab es jetzt noch am Netbook (WinXP) versucht - selbes Spiel. Sobald neu gestartet wird kommt das LG-Logo, und vom PC wird kein USB-Gerät mehr erkannt. Und wenn kein USB-Gerät erkannt wird, funktioniert wohl das einspielen der Software nicht so recht.
 
P

perpe

Gast
Hmmm... Noch was gefunden, war der Akku voll? Blinkend buttons sollen,im Normalfall, ein Zeichen für leeren Akku sein. lg optimus wont respon or turn on - Android Forums (ist zwar nicht für den oo aber die Modelle werden sicher ähnlich gestrickt sein)
 
Zuletzt bearbeitet von einem Moderator:
norbert

norbert

Ehrenmitglied
ich denke nicht, daß der Akku leer war, als der Fehler kam - soweit denkt meine Frau schon mit daß der Akku nicht leer wird :)
Und üblicherweise fährt Android ja runter, wenn der Akku bei ~1% ist.

Die Flashvorgänge hab ich üblicherweise komplett ohne Akku durchgeführt.

Wenn ich das Gerät am Ladegerät anstecke, kommt auch sofort das LG-Logo. Also auch keine Chance zu erkennen ob der Akku vielleicht mal voll ist.
 
P

perpe

Gast
Ich geb nur Lösungsmöglichkeiten/Fehlerquellen wieder, die mir google ausgespuckt hat, ohne irgendwie zu werten...bzw. dachte mir vor dem posten, schon das du diese Dinge sicher gestellt hast, aber mal alles zusammenragen, nochmal checken schadet ja nie ;)

Aber mehr hab ich auch nicht dazu gefunden :-/
 
norbert

norbert

Ehrenmitglied
bin ja auch dankbar für alle Lösungsversuche die mir angeboten werden.
Aber jetzt muß ich mich wohl damit abfinden, daß ich auch mal ein defektes Gerät habe. Hat immerhin 3 Jahre gedauert :)
 
Fietze

Fietze

Dauergast
Zuletzt bearbeitet:
norbert

norbert

Ehrenmitglied
lieb gemeint, aber wie weiter oben angeführt, hab ich auch lgmdp schon versucht - ohne brauchbares Ergebnis.

Gerät ist inzwischen bei w.support eingetroffen, ich denke Ende nächster Woche sollte es wieder bei uns eintreffen :)
 
Fietze

Fietze

Dauergast
Jep, so kam ich wenigsten wieder zum Clockworkmod, da nur dieser geflasht wurde. Und konnte so wieder Miks CM7 Rom aufspielen.

Was ich allerdings nicht wusste, da ich ja die neueste LG Firmware (20E?) per KDZ geflasht hatte, dass diese ein neueres Baseband als die CM7 Roms hat. Und so funktionierte das Telefon dann doch nicht. Wieder Bootloop! :cursing:
Dann per LGPMP nur den Clockworkmod geflasht, danach mit CWM ein Customrom und bzw. Backups, funzte nur nicht da falsches Baseband.

Habe aber eben erfolgreich das alte Baseband geflasht.
Nun kann ich auch wieder telefonieren.
https://www.android-hilfe.de/forum/...m-gingerbread.84010-page-12.html#post-2144113

Hat mich ja nur ein paar Stunden Recherche gekostet. :unsure:

Die Beachtung der Basebandversion sollte man in dem Howto von Seite 1 vielleicht noch hinzufügen.

Gruß Fietze
 
Zuletzt bearbeitet:
norbert

norbert

Ehrenmitglied
Fietze schrieb:
Die Beachtung der Basebandversion sollte man in dem Howto von Seite 1 vielleicht noch hinzufügen.
Für das How-To, wenn das Gerät hängt hat das Baseband doch keine Auswirkung. Mit dem KDZ wird ja auch das entsprechende Baseband (RadioROM) eingespielt.

Wenn man mittels KDZ die letzte Version einspielt und dann ein Rom drüber bügelt, daß noch eine alte Version benötigt, sollte man doch im jeweiligen Rom-Thread den Hinweis auf das Baseband beachten und ggfs. die entsprechende KDZ wählen :)

Aber wie gesagt, das Einspielen einer Custom-Rom ist ja nicht Thema des Threads, daher würde ich die Erwähnung im 1. Post unterlassen. Das verwirrt nur die Leute, die mit CustomRom nichts am Hut haben ;)
 
G

genoobt

Neues Mitglied
hallo :/,

also folgendes.. nachdem ich der meinung war, dass ich mein handy mal wieder säubern muss, hing ich im bootlogo fest nachdem ich es zurückgesetzt hab.. mir war dann auch leider recht schnell klar wieso.. zuvor hab ich es schonmal hinbekommen (aufgrund eines custom-roms) und eben auf die selbige weise wieder zum laufen gekriegt. danach hatte ich dann auch das customrom (erfolgreich..-.-) installiert. nun hab ich mich monate nichtmehr damit beschäftigt und weiss über die ganze geschichte nichts mehr und mir schwebt halt nur im kopf, dass es eben an dem custom-rom liegen muss, dass das zurücksetzen des handys irgendwie schief ging..soweit so gut, jetzt hab ich es immernich nach pc-wechsel mit anderen betriebssystem etc pp. geschafft das firmware erfolgreich aufzuspielen (ich hab die version aus der dropbox genommen), jedoch besteht nun halt noch selbiges problem und jetzt bin ich mit meinem laien-latein halt am ende, weil ich nun mehr keine ahnung hab was der fehler an der geschichte ist..

wäre euch sehr verbunden, falls ihr mir weiterhelfen könntet.

gruß,

alex.

edit: habs hingekriegt..*whew*
 
Zuletzt bearbeitet:
T

Toni89

Neues Mitglied
Hallo Norbert,

hab die gleichen Probleme mit dem LG P500 und dem Aufspielen der firmware.
Ist das Problem von LG gelöst worden? Gab's einen Hinweis woran's lag?

Beste Grüße u frohe Feiertage,

Toni
 
norbert

norbert

Ehrenmitglied
@genoobt: deine Problembeschreibung ist leider äußerst dürftig - außer das du im Bootlogo fest hängst, mit irgendeiner Custom-Rom, kann ich daraus nichts erkennen. So könnte man dir wohl kaum helfen.
Das du es selbst geschafft hast, ist auch schön für dich. Aber wenn du uns an der Lösung hättest auch teilhaben lassen, wäre es wenigstens noch halbwegs sinnvoll gewesen ;)

@Toni89: bei mir dürfte das Problem schlicht an einem defekt an der Hardware gelegen haben. Lt. Reparaturbeschreibung wurde ein Elektronikteil getauscht und die neueste Firmware aufgespielt. War auch zu erwarten, da sich das Gerät geweigert hat sich von mir wieder beleben zu lassen :)