Aquaris X Pro ctsProfile

  • 98 Antworten
  • Neuester Beitrag
Diskutiere ctsProfile im LineageOS Forum im Bereich Root / Custom-ROMs / Modding für bq Aquaris X / X Pro.
Farron

Farron

Experte
@lilax
Manche Apps wollen einfach nicht. Sie überprüfen dann den offenen Bootloader und stellen die Arbeit ein. Leider kann man einen offenen Bootloader imho nicht maskieren und schließen kann man ihn auch nicht, dann läuft LOS nicht mehr.
Versuchen könnte man Magisk einfach zu deinstallieren also ohne Rootrechte fortzufahren. Beeinträchtigt LOS nicht aber der Loader wäre dann immer noch offen.
 
H

Henning_H

Fortgeschrittenes Mitglied
@lilax ,
noch ein Hinweis. Wenn ich mich richtig erinnere, war eine Zertifizierung des Playstores entscheidend, ob kritische Banking Apps laufen oder nicht.
 
Farron

Farron

Experte
lilax

lilax

Ambitioniertes Mitglied
Yo danke, aber nach dem Clean Install kriege ich den Store nicht mehr zertifiziert. Alles beachtet, x mal Daten bzw. Cache gelöscht etc.

Naja nicht so dramatisch. Mein Hauptkonto ist bei der ING und die App läuft. Wie alles weitere auch. Und bevor ich mir jetzt für teuer Geld nen ChipTAN-Generator nur für mein Zweitkonto hole, kündige ich das lieber xD
 
A

Apfelmann

Neues Mitglied
@lilax Ich habe eine schmutzige Aktualisierung von LOS16 auf ein inoffizielles und dann offizielles LOS17.1 hinter mir, und bei mir läuft die DKB-TAN2go nach wie vor. Hast du sowohl Patch-Level als auch Fingerabdruck in MagiskHide Props Config angepasst?
 
lilax

lilax

Ambitioniertes Mitglied
Hatte auch zunächst die schmutzig geflashte LOS17.1-Version drauf. Alles beachtet wie immer und DKB TAN2go lief. Aus verschiedenen Gründen hatte ich vor 2-3 Tagen dann nochmal nen Clean Install gemacht. Alles beachtet wie immer und TAN2go lief.
Heute morgen wurde mir über den Play Store ein Update für TAN2go angeboten - habe es installiert und die App startet nicht mehr.

Mit den Fingerprints hatte ich mich vorher nie beschäftigt, habe aber gerade wie in deinem Beitrag beschrieben die Fingerprints überprüft und sie sind korrekt, wie auch hier schon vermeldet wurde.

Hatte bislang mehrmals TAN2go runtergeschmissen und wieder neu installiert, Diverse Google-Caches gelöscht, Magisk unter normalem Paketnamen wiederhergestellt und erneut zufällig gepackt. Habe noch viel mehr Anwendungen und Dienste als sonst mit Magisk Hide getarnt (natürlich auch TAN2go) und naja ich hab mein bestes getan, aber den Play Store kriege ich nicht zertifiziert. Aber gestern war der Play Store auch nicht zertifiziert und da lief die TAN2go-App noch.

PS. SafetyNet-Check wird weiterhin vollumfänglich bestanden.

///edit: FW und LOS so aktuell wie möglich. OpenGapps Pico von 12.04.20.
 
Zuletzt bearbeitet:
A

Apfelmann

Neues Mitglied
Ich schreib einfach mal, was mir noch so einfällt: Cache und Daten von Google Play-Store und Google Play Services gelöscht? Ich hab in Magisk Hide nur Folgendes aktiviert: Google Play Services, Google Play-Store, Google Services Framework und TAN2go.
 
lilax

lilax

Ambitioniertes Mitglied
Apfelmann schrieb:
Cache und Daten von Google Play-Store und Google Play Services gelöscht?
Mehrmals. Auch mehrmal das Handy neu gestartet danach etc.
Apfelmann schrieb:
Ich hab in Magisk Hide nur Folgendes aktiviert: Google Play Services, Google Play-Store, Google Services Framework und TAN2go.
Just4fun hab ich mein Magisk Hide gerade mal genau wie deins eingestellt, Restart (auch wenn das meines Wissens gar nicht nötig ist), und erneut TAN2go probiert. Nada.
Ich bin mit meinem Latein am Ende. Woran das wohl liegt? Falls hier jemand mitliest, der zwingend auf TAN2go angewiesen ist: also mit Updates sämtlicher Art wäre ich aktuell vorsichtig...

///edit: übrigens mittlerweile bin ich in Sachen Play Store-Zertifzierung so weit, dass mir der Zertifizierungsstatus nicht mehr angezeigt wird. Das hatte ich schon mal. Kurze Zeit danach war er zertifiziert. Vielleicht passiert es ja wieder so.

///edit2: ist tatsächlich jetzt - wenige Minuten später - zertifziert. Ändert aber nichts an meinem Problem mit TAN2go.

///edit3: Ich hab übrigens TAN2go Version 2.5.1 installiert, wie gesagt Update heute (wird bei mir in meinem Play Store auf dem bq als Update vom 06.04.2020 angezeigt). Im Play Store (nicht eingeloggt über Desktop) wird als aktuelle Version 2.5.0 mit Update vom 14.04.2020 angezeigt.
 
Zuletzt bearbeitet:
A

Apfelmann

Neues Mitglied
Ich habe noch kein Update für die TAN2go-App erhalten, bin immer noch auf der 2.5.0 vom (laut meiner Play Store-App) 09.12.2019. Noch geht alles...

Update mit Version 2.5.1:
Nun habe auch ich das Update erhalten - mit dem Ergebnis, dass die App auf meinem BQ nicht mehr startet. Auf einem anderen Gerät (Motorola Moto G), auf dem Lineage 14.1 ohne Root/Magisk läuft, lässt sich die App dagegen nach wie vor benutzen. Nun ja, die DKB ist glücklicherweise nicht meine Hauptbank. Warum wohl 🤷‍♂️.
 
Zuletzt bearbeitet:
Vespertilio

Vespertilio

Neues Mitglied
Hallo,

habe das selbe auftreten wie lilax. Heute auf 17.1 von 16 geflasht. Danach ging Tan2go noch. Kurz später update und nun startet App nicht mehr sauber und wird gleich wieder beendet.
 
T

Tr1v1um

Neues Mitglied
Gibt es eine Möglichkeit die build.prop aus TWRP zu editieren ?
Habe leider übers Terminal die ganze zeile gelöscht und nun bootet er nur ins recovery. 🧐
 
lilax

lilax

Ambitioniertes Mitglied
Das mit DKB TAN2go ist natürlich doof für euch bzw. uns alle, aber irgendwie beruhigt es mich, dass das Problem nicht an meinem Setup liegt. Meine Kündigung an die DKB ist schon als Entwurf im Ausgangsordner, müsste nur noch abgeschickt werden :)
 
Vespertilio

Vespertilio

Neues Mitglied
Auf xda-developers unter DKB-TAN2go app on rooted device wird von einer App Names "Shelter" geschrieben, mit welcher man die TAN2GO in eine Sandbox packen soll. Kennt werd ie App?
Habe die APP im F-Droid gefunden. App installiert, dann TAN2GO beendet und geclont. App startet.
 
Zuletzt bearbeitet:
Farron

Farron

Experte
Farron schrieb:
Und hier die Seite dazu: Anmelden – Google Konten
Könnte allerdings nicht behaupten, dass das bei mir geklappt hätte.
Muss mich mal selbst zitieren ... hier, praktisch nebenan ist ein spezielles MagiskModul erwähnt worden. Ob es was mit der plötzlichen Zertifizierung meines Gerätes zu tun hat oder im Zusammenspiel mit der Zerifizierungsseite im Net und dem Zurücksetzen des Playstores > k.A. aber wie dort erwähnt kann ich z.B. die Netflix App laden eben weil das Gerät jetzt zertifiziert ist.
Das müsste doch der DKB App praktisch einen Schub geben, oder ?
 
lilax

lilax

Ambitioniertes Mitglied
@Vespertilio Super! Es klappt!
Die TAN2go startet nicht nur, ich konnte die App auch neu verifizieren und TANs generieren! (hatte zufällig noch nen Registrierungsbrief hier)
Es läuft!
Ich war jetzt ne Dreiviertelstunde damit beschäftigt, das lief alles andere als reibungslos. Mike Kuketz hat zur App Shelter auch einen umfangreichen Beitrag geschrieben.

///edit: Mein Hauptproblem bestand darin, dass ich bei der Benutzung von Shelter die Apps nicht in die Sandbox verschieben konnte. Egal was ich versucht habe. Bin dann einen Umweg gegangen und habe mit Apk Extractor eine Apk von TAN2go erstellt und diese über Shelter direkt in die Sandbox installiert. Das ging. Wie gesagt die App startet dann. Für AFWall+ gilt:
Mike Kuketz schrieb:
Eine App im Arbeitsprofil kann aufgrund der Firewall-App AFWall+ nicht ohne weiteres Daten mit der Außenwelt austauschen. Damit eine App aus dem Arbeitsprofil überhaupt in AFWall+ zur Freigabe sichtbar wird, muss unter »Einstellungen -> Experimentell« zunächst ein Häkchen bei der Option Unterstützung für Dual Apps gesetzt werden. Erst danach erscheint die App in der AFWall+-Auflistung und kann entsprechend für den Internetzugriff freigeschaltet werden. Zur Unterscheidung innerhalb AFWall+ erhält die App im Arbeitsprofil das Suffix bzw. die Endung (M).
Ich denke der einfachste Weg ist dann tatsächlich eine Neuregistrierung der App mittels Initialisierungsbrief. Wendet euch dazu einfach per Mail an die DKB.
 
Zuletzt bearbeitet:
Vespertilio

Vespertilio

Neues Mitglied
@lilax ich habe TAN2GO über "App-Info" -> "Beenden erzwingen" beendet. Dann konnte ich diese Clonen. Ich konnte aber nur durch deinen Tipp mit AFWall+ die App nutzen. Danke
 
lilax

lilax

Ambitioniertes Mitglied
Hmm, ich kann dieses Verhalten für viele Apps reproduzieren und "Beenden erzwingen" hilft bei mir leider nicht. Ganz selten mal klappt es zufällig für eine zufällige App.
Aber ist ja auch total egal, das Endergebnis ist entscheidend.

Hast du die App ohne Brief ans Laufen gekriegt über die SMS-Aktivierung? Hätte jetzt gedacht, dass das total kompliziert ist und dass man verschiedene zusätzliche Systemanwendungen in die Sandbox verschieben muss...
 
Vespertilio

Vespertilio

Neues Mitglied
lilax schrieb:
Hast du die App ohne Brief ans Laufen gekriegt über die SMS-Aktivierung? Hätte jetzt gedacht, dass das total kompliziert ist und dass man verschiedene zusätzliche Systemanwendungen in die Sandbox verschieben muss...
Nein ich habe zwei Geräte authorisiert. Ein ausrangiertes iPhone noch. Damit konnte ich online das Gerät wechseln und die APP auf dem BQ aktivieren.
 
lilax

lilax

Ambitioniertes Mitglied
DKB TAN2go hat ein Update bekommen und ich kriege es mit dem Shelter-Workaround auch nicht mehr ans Laufen. Ich hab keine Lust mehr. Ich habe die DKB-Apps alle deinstalliert und schicke in wenigen Minuten die Kündigung raus.