SDImage Ubuntu 12.04 mit 3.0.8 Kernel (keine Modifikation am Xelio notwendig)

  • 83 Antworten
  • Neuester Beitrag
Diskutiere SDImage Ubuntu 12.04 mit 3.0.8 Kernel (keine Modifikation am Xelio notwendig) im Linux auf Android Forum im Bereich Weitere Betriebssysteme.
B

br3zzer

Fortgeschrittenes Mitglied
ArchLinux verwende ich hier an meinem richtigen Rechner und bin sehr zu frieden damit, jedoch meinete ich nicht die Distribution sondern Umgebung(d.h gnome, unity, lxde) welche noch "leichter" ist :).

Von arch linux gibt es übrigens auch eine ARM Variante: Arch Linux ARM | Arch Linux ARM

Wäre evtl wirklich mal einen Versuch wert damit das Ubuntu zu ersetzen.
 
MrProper

MrProper

Fortgeschrittenes Mitglied
Ich hatte mal Arch auf meinem kleinen EEEPC installiert, war echt flott winzig und mächtig ,Arch machte einen guten Eindruck.
Nun ist aber schon etwas her, falls du so so was auf die Beine bringen kannst, und Arch auf Xelios installierst, das wäre ja mal toll.:thumbup:
 
MrProper

MrProper

Fortgeschrittenes Mitglied
So nochmals zurück zu LXDE, wie kann man das eigentlich eindeutschen?, hab da nichts gefunden, bin schon froh das Tastatur nun deutsch ist.

Und ja was mach ich falsch beim Sound,? ich höre keinen Ton?

Ansonsten ist LXDE gar nicht so schlecht hab Synaptic und Software-center nachinstalliert, somit kann man schon gut arbeiten.:biggrin:

sudu apt-get install synaptic

sudo apt-get install software-center

sudo apt-get install lxkemap :Tastatur auf deutsch umstellen

Der ursprüngliche Beitrag von 21:51 Uhr wurde um 22:50 Uhr ergänzt:

Ok nun ist auch alles auf deutsch.:smile:

sudo dpkg-reconfigure keyboard-configuration

Somit kann man Tastatur umstellen
 
Zuletzt bearbeitet:
T

tsalin

Neues Mitglied
erstmal herzlichen Dank für die Mühe mit dem Image!

Ich bastele gerade daran, mir eine gnome-shell zu spendieren nachdem ich festgestellt habe, dass der klassische gnome eigentlich recht flott läuft und vor allem besser mit den Figern zu bedienen ist, als lxde.

Dummerweise braucht gnome-shell aber wohl ernsthafte hardware-Beschleunigung..

Jetzt das Problem:

  • mali.ko liegt bei und lässt sich laden
  • einen zugehörigen xorg-treiber habe ich noch nicht hinbekommen :(
  • die gles-libs natürlich auch nicht.

ich geh auch mal davon aus, dass das alles proprietär ist, zumindestens scheint mir der freie Treiber noch nicht so weit zu sein: [Phoronix] Open-Source ARM Mali Driver Update (Lima)

Tja.. nun die Fragen:
Liegen die benötigten proprietären Dateien bereits irgendwo herum? Oder gibt es vielleicht andere Varianten die gnome-shell zum fliegen zu bekommen?

Hilfe ist sehr willkommen...

Der ursprüngliche Beitrag von 12:23 Uhr wurde um 12:43 Uhr ergänzt:

gawl schrieb:
Wäre es nicht einfacher, direkt den Kernel zu befragen?
Ich habe den Eindruck, dass der Ladestand als Prozentzahl in der (Pseudo-)Textdatei

/sys/devices/platform/sun4i-i2c.0/i2c-0/0-0034/axp20-supplyer.28/power_supply/battery/capacity

steht bzw. daraus auslesbar ist.
sinnigerweise hier:

Code:
root@tablet:/sys/devices/platform/sun4i-i2c.0/i2c-0/0-0034/axp20-supplyer.28/pow
er_supply/battery# cat uevent
POWER_SUPPLY_NAME=battery
POWER_SUPPLY_MODEL_NAME=battery
POWER_SUPPLY_STATUS=Discharging
POWER_SUPPLY_PRESENT=1
POWER_SUPPLY_ONLINE=1
POWER_SUPPLY_HEALTH=Good
POWER_SUPPLY_TECHNOLOGY=LiFe
POWER_SUPPLY_VOLTAGE_MAX_DESIGN=4200000
POWER_SUPPLY_VOLTAGE_MIN_DESIGN=3300
POWER_SUPPLY_VOLTAGE_NOW=3940000
POWER_SUPPLY_CURRENT_NOW=758000
POWER_SUPPLY_ENERGY_FULL_DESIGN=2600
POWER_SUPPLY_CAPACITY=74
POWER_SUPPLY_TEMP=300
gnome zeigt das an manchen Stellen sogar schon richtig an. Keine Ahnung, warum nicht überall..
 
S

sauferkel

Neues Mitglied
Guten Abend,
habe mir jetz auch das Xelio gekauft, und musste direkt Ubuntu austesten. Läuft echt schön.

Habe versucht Unity-2d und die Gnome-Shell zu installieren. Ersteres klappte erstmal nicht, nach installation der Gnome-Shell ging es aber. Die Shell läuft halt leider nur im fallback 2d modus....

Teste grade die installation von ubuntu-desktop :)
 
G

gawl

Neues Mitglied
MrProper schrieb:
Und ja was mach ich falsch beim Sound,? ich höre keinen Ton?
Ich habe auch keinen Ton (mehr). Etwas merkwürdig, denn ganz zu Anfang funktionierte Sound zunächst noch. Vielleicht hat irgendein anschließender Update da nicht gut getan?
Bei mir sieht es sogar so aus, dass z.B. der mpg321 mit Segmentation Fault abschmiert, und alle anderen getesten Audio-Player (mplayer, aplay, aqualung, quodlibet) direkt vor dem ersten Ton "feststecken".
Wie sieht es bei Euch aus? Ähnliche Beobachtungen?
Vielleicht sogar jemand eine Idee, was man noch testen/tun könnte?
 
B

br3zzer

Fortgeschrittenes Mitglied
evtl mal versuchen alsa oder pulse-audio zu installieren.
 
P

Papa Curry

Neues Mitglied
Hallo,

Hab mich jetzt extra angemeldet um mich für das Ubuntu image zu bedanken. :thumbsup:

Ich kann euch allen nur empfehlen den enlightenment WM zu installieren.
Läuft auf dem Xelio richtig klasse und es gibt eine eigene Oberfläche für mobile Geräte (illume home wählen), samt eigenem Keyboard. Sound geht dann auch wieder.

Einfach über Synaptic nach enlightenment suchen, installieren und beim nächsten Reboot als Desktop auswählen.

Btw. mit dem Programm easystroke könnt ihr mit der Maus Gesten zeichnen und Zusatzfunktionen belegen. Ich mach z.B ein kleines V und simuliere damit die rechte Maustaste. Oder einen kleinen Kreis für Pagescroll. recht praktisch
Auch über Synaptic.

Schöne Grüße
Papa Curry
 
B

br3zzer

Fortgeschrittenes Mitglied
Hallo Papa Curry,

freut mich das du Spaß am Ubuntu hast :).
Enlightenment habe ich auch schon angetestet und als nicht schlecht befunden.
Man muss sich halt ein wenig einarbeiten. Außerdem ist er sehr performant.
Easystroke kannte ich noch nicht. Danke dafür, werde ich mal testen.
 
G

gawl

Neues Mitglied
Hallo, (fast) schäme ich mich ein wenig, daß ich nach Schilderung meines Sound-Problems jetzt erst wieder dazu komme, mich hier zu melden, aber ich bin jetzt erst wieder von einer Dienstreise zurück...

Der Tipp mit enlightenment ist super, ich mag die "illume home"-Oberfläche sehr, gerade auch dank der integrierten (virtuellen) Tastatur. Wieder ein Schritt in Richtung "echter Benutzbarkeit" des Xelio :)

Sound habe ich leider immer noch nicht. Ja, ich habe alsa und pulseaudio installiert (letzteres nicht bewußt, kam anscheinend mit irgendeinem Anwenderprogramm mit dazu). Mir scheint allerdings, als laufe pulseaudio bei mir nicht richtig, denn es wird beim Booten kein Daemon gestartet, obwohl /etc/rc2.d/pulseaudio existiert. (Auch dessen Aufruf von Hand startet nichts.) Ich werde etwas mehr Zeit brauchen, um einmal nachzuschauen, wo hier das Problem liegt. Aber vielleicht hilft es ja sogar zu prüfen, mit welchem Programm das mitkam, und alles (außer alsa) wieder zu entfernen...

Nachtrag [einige Minuten später :cool2:] Sound ist da, jippieee! :thumbsup:
Ich habe ganz einfach aqualung und quodlibet und pulseaudio deinstalliert. Jetzt ist zwar "nur noch" mplayer übrig, der aber dafür mit funktionierendem Sound. Evtl. kann ich mich demnächst auch noch in Ruhe umsehen nach weiteren (evtl graphischen) Audio Playern (ohne pulseaudio und ohne Schnickschnack, den ich eh' nicht brauche).
 
Zuletzt bearbeitet:
S

sauferkel

Neues Mitglied
Danke für den Hinweis mit dem Enlightenment Desktop, der ist echt gut.

Gibt es dort eine möglichkeit, dass die Tastatur sich automatisch einblendet wenn benötigt?

Das wäre echt was feines, so finde ich es eindeutig noch zu umständlich.


Noch was anderes. Hat irgendwer es geschafft GPU Unterstützung für Videos zu aktivieren ? Unter Android spielt das Xelio so wunderschön 1080p Videos, das fehlt mir akut in dem Ubuntu....
 
MrProper

MrProper

Fortgeschrittenes Mitglied
@sauferkel
Noch was anderes. Hat irgendwer es geschafft GPU Unterstützung für Videos zu aktivieren ? Unter Android spielt das Xelio so wunderschön 1080p Videos, das fehlt mir akut in dem Ubuntu...
Dafür fehlt leider unter Linux noch der richtige GPU-Treiber(Mali400). Wenn der mal fertig ist dann dürfte auch Linux um einiges flotter rennen, und Ubuntu Unity würde auch funktionieren wegen OpenGL .
Hab mal gelesen darin wird gearbeitet, vielleicht wird es ja noch zu Weihnachten.
 
A

alwi

Neues Mitglied
Hallo br3zzer,

erstmal vielen Dank für das Ubuntu-image. ich hoffe, ich komme bei den nächsten Schritten weiter als nur bis zum Login. Wegen der kleinen Tastatur habe ich mir 5 x große Mühe gegeben, die Eingabe hinzukriegen.
Ob das PW richtig ist. Als User wählte ich ...(ubuntu) aus.

br3zzer schrieb:
1.Menü unten links->Universal Access-> CellWriter

Da Cellwriter eigentlich auch zur Handschrifterkennung ist siehst du nicht direkt die Tastatur.
Du musst unten links auf Train und dann rechts auf Keys.:)
Wenn die Anmeldung nicht klappt, bleibt das Login-Feld sichtbar, aber die Tastatur bleibt verschwunden. Unten links ist bis auf "Desktop" nichts zu sehen.

br3zzer schrieb:
Etwas umständlich so, deshalb am besten eine Verknüpfung anlegen:

/usr/bin/cellwriter --keyboard-only

Dann startet Cellwriter direkt in der Keyboard Ansicht.

Falls ich nochmal ein Image erstelle mache ich das auch gleich so :)
Da ich nicht eingelogged bin. kann ich auch unter /user... nichts machen.
Hilf mal bitte aus der Klemme. Oder hast Du schon ein neues Image?

Gruß
alwi
p.s. ich bin langjähiger Linux-user (Ubuntu/Debian/KDE) und will mich über Android eigentlich nicht mit Goggle verheiraten.
 
B

br3zzer

Fortgeschrittenes Mitglied
Ich starte die Tastatur in dem ich in /etc/lxdm/LoginReady folgendes eingetragen habe.

/usr/bin/cellwriter --keyboard-only --show-window --dock-window=1 &

Geschlossen wird Sie nach Loginversuch in: /etc/lxdm/PreLogin

pkill -u root cellwriter

Wenn du die Zeile entfernst bleibt es auch nach Fehllogin geöffnet. Du solltest es dann halt an geeigneter stelle beenden :).

Momentan habe ich Klausuren und mache deshalb nichts am Xelio :)
 
A

alwi

Neues Mitglied
Bei soviel Erfolgsmeldungen über das Probieren mit der Ubuntuversion von br3zzer bin ich richtig traurig, ich kann mich mit dem Kennwort "ubuntu" nicht anmelden.
 
B

br3zzer

Fortgeschrittenes Mitglied
Muss aber gehen :)

Hast du als Benutzer auch sicher ubuntu ausgewählt?
 
äxl

äxl

Neues Mitglied
MrProper schrieb:
sudo apt-get install lxkemap
sudo dpkg-reconfigure keyboard-configuration
Ach, lxkeYmap. Gibt's leider nur für Ubuntu ... Scheint aber allgemein ein Problem des Images zu sein das ich verwende: UPDATED Debian Sid armhf rootfs and SD images are now here!

tsalin schrieb:
sinnigerweise hier:
root@tablet:/sys/devices/platform/sun4i-i2c.0/i2c-0/0-0034/axp20-supplyer.28/pow
er_supply/battery# cat uevent
Oder einfacher hier: /sys/class/power_supply/battery

br3zzer schrieb:
Ich starte die Tastatur in dem ich in /etc/lxdm/LoginReady folgendes eingetragen habe.
Hat jemand ne Ahnung wie das unter LightDM geht?

Danke für den Tipp mit Enlightenment, Papa Curry. Werd ich demnächst mal ausprobieren ... E17 auch als armhf unter Debian.
 
Zuletzt bearbeitet:
R

ronnysc

Neues Mitglied
Hallo,
ich habe eine Frage zum Image auf SD. Wenn Änderungen vorgenommen werden im laufenden Betrieb z.B. Pakete noch installiert werden diese mit auf die SD Karte geschrieben? Oder sind diese beim nächsten Booten verschwunden.

Danke
 
B

br3zzer

Fortgeschrittenes Mitglied
Werden auf SD Karte geschrieben
 
R

ronnysc

Neues Mitglied
Vielen Dank für das Ubuntu SD-Image, läuft prima.:thumbup:

Habe heute mal versucht meine GPS-Mouse und mein USB/Seriell Adapter zu nutzen. Leider werden beide zwar erkannt (lsusb zeigt sie an) aber nicht eingebunden. (dmesg | grep usb zeigt kein "attached to ttyUSB0")
Es fehlen wohl die Pakete usbcore, usbserial und ftdi_sio bzw. pl2303.
Wie bzw.wo kann ich die nachladen. In den custom ROMs sind sie ja angeblich vorhanden.

Grüsse Ronny

EDIT: usbcore ist natürlich da. Würde ja sonst keine Maus und Tastatur funktionieren.
 
Zuletzt bearbeitet:
Ähnliche Themen - SDImage Ubuntu 12.04 mit 3.0.8 Kernel (keine Modifikation am Xelio notwendig) Antworten Datum
6
9