KitKat 4.4.2 für Cynus F3 re-portieren

JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter


Hallo zusammen,

wie der Titel schon sagt, geht es hier um KitKat 4.4.2 re-portierung. Gibt es unter euch Interessenten an KitKat (JoWi81-Mod) wie aus dem Cynus T1 Thread (mit Entstehungsverlauf) und Cynus T2 Thread?


Hierfür benötige mindestens einen Testfreudigen :rolleyes2:

Bei Cynus T2 re-portierung hat es bis auf den AROMA-Installationsassistenten auf Anhieb geklappt :winki:

MfG, JoWi81
 

Anhänge

Zuletzt bearbeitet:
G

genatic

Neues Mitglied
Ja, hab hier zwei F3 im Einsatz und würde mich über die neue Version freuen und natürlich testen. Grüße Peter
 
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
Hallo genatic,

ich möchte mich schon mal für die Bereitschaft im Voraus bedanken!

Grundlegendes möchte ich zu der Re-Portierung loswerden. Es handelt sich um eine bereits von dem russischen Entwickler qus1 portierte Kernel für ein Vergleichsgerät mit hoher Kompatibilitätswahrscheinlichkeit mit dem Cynus F3. Sollten die später folgenden Anpassungen direkt die Kernel betreffen, so möchte ich schon mal im Voraus mitteilen, dass in diesem Fall ggf. der direkte Weg zu dem o.g. Entwickler gesucht werden müsste.

So, nun zum Eigentlichen. Mit folgender kurzer Anleitung werde ich versuchen dir den Weg von originalen Recovery bis zum benutzerdefinierten OS zu beschreiben und zwei weitere Anleitungen für den Fall, dass du dir wieder den früheren oder originalen Zustand wünschst.

Anleitung für KitKat 4.4.2 JoWi81-Mod
  1. Benutzerdefiniertes Recovery herunterladen und nach dieser Anleitung aufspielen: Recovery_CWM_6.0.3.0, Cynus_F3_Drivers und SP_Flash_Tool_v3.1344.0.212 herunterladen.

  2. CWM-Recovery starten: Die Tasten Vol+ und Power gleichzeitig gedrückt halten.

  3. Backup vom bestehenden OS erstellen: [backup and restore]->[backup].

  4. USB-Speicher (SD Karte) mounten: [mounts and storage]->[mount USB storage].

  5. Benutzerdefiniertes OS herunterladen und auf USB-Speicher kopieren: KK_4.4.2_JoWi81-Mod herunterladen.

  6. USB-Speicher wieder trennen: [mounts and storage]->[mount USB storage]->[Unmount].

  7. Benutzerdefiniertes OS installieren: [install zip from sdcard]->[choose ...]->[...]->[Yes - ...].

  8. Android starten: [reboot system now]->[No]->[No]. Wenn beim Neustarten eine Abfrage "Disable recovery flash?" und/oder "Fix root?" kommt, so wähle bitte [No] aus! Sonst funktioniert anschließend Super-User nicht mehr. Der erste Start kann einige Minuten dauern und äußert sich währenddessen mit einer Boot-Animation.

  9. Funktionstests durchführen: Bitte alle dir einfallenden gerätespezifischen Funktionen testen (Touch-Screen, LED-Benachrichtigung, WLAN, Bluetooth, GPS, …) und bitte natürlich anschließend berichten :winki:

Anleitung für früheren Zustand
  1. CWM-Recovery starten: Die Tasten Vol+ und Power gleichzeitig gedrückt halten.

  2. Backup von der früheren OS wiederherstellen: [backup and restore]->[restore]->[...]->[Yes - ...].

  3. Android starten: [reboot system now]->[No]->[No].

Anleitung für originalen Zustand
  1. CWM-Recovery starten: Die Tasten Vol+ und Power gleichzeitig gedrückt halten.

  2. USB-Speicher (SD Karte) mounten: [mounts and storage]->[mount USB storage].

  3. Originales OS herunterladen und auf USB-Speicher kopieren: JB_4.1.1_Stock herunterladen.

  4. USB-Speicher wieder trennen: [mounts and storage]->[mount USB storage]->[Unmount].

  5. Originales OS installieren: [install zip from sdcard]->[choose ...]->[...]->[Yes - ...].

  6. Originales Recovery herunterladen und nach dieser Anleitung aufspielen: Recovery_Stock, Cynus_F3_Drivers und SP_Flash_Tool_v3.1344.0.212 herunterladen.

  7. Android starten: Power-Taste. Der erste Start kann einige Minuten dauern und äußert sich währenddessen mit einer Boot-Animation.

Benutzte Quellen

MfG, JoWi81
 
G

genatic

Neues Mitglied
Hi JoWi81,

erstmal Danke für diese Version.

Erster Bericht zum Update:
1. Bootversuch nach Update: nur dunkler aber beleuchteter Bildschirm. Nach 20min Batterie entfernt.
2. Bootversuch nach Zurücksetzen auf Werkseinstellung im Recovery: Android-Männchen. Nach 20min Batterie entfernt.
3. Bootversuch nach erneutem einspielen der Zip per Recovery: System hat gestartet! Es gibt aber Probleme mit der Bildschirmaktualisierung/Darstellung. Teilweise waren Buttons nicht sichtbar und die Farben waren komisch (siehe Bild im Anhang). Nach setzen in Standby und erneutem Aufwecken haben sich die Farben normalisiert. Ganz unten am Bildschirmrand flackert aber immerzu eine kleine Linie und die Masken aktualisieren sich nicht immer oder auch viel zu oft.
Die Frage ist, ob das ein Kernel-Problem ist... In dem aktuellen Zustand möchte das System so aber sicher niemand einsetzen.

Die Grundfunktionen scheinen ansonsten zu funktionieren, bin aber noch am testen. Ich melde mich wieder.

Grüße
 

Anhänge

JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
@genatic

genatic schrieb:
...Bootversuch nach Zurücksetzen auf Werkseinstellung im Recovery...
Formatierung der kompletten /data-Partition vor der Installation eines ganz anderen OS ist nie verkehrt.

genatic schrieb:
Ganz unten am Bildschirmrand flackert aber immerzu eine kleine Linie...
Dies tendiert schon eher zum Kernel-Problem...

Probiere mal bitte das System mit der aktivierten virtuellen Navigationsleiste hochzufahren und schaue, ob die Linie unter der Leiste erscheint. Ändere hierzu die Zeile "ro.jowi81. virtualnavbar=0" nach "1" mittels integrierten Prop-Edit-App (Speichern und Neustart nicht vergessen) oder Root-Explorer die Datei "/system/buil.prop" editieren. Desweiteren habe ich in der buil.prop eine falsch konfigurierte Property "fmradio.driver.chip=1" festgestellt, welche für den Combo-Chip MT6628 nach "3" geändert werden soll.

Schaltet sich diese Linie im Standby mit ab?

genatic schrieb:
... Masken aktualisieren sich nicht immer oder auch viel zu oft.
Was meinst du mit "Masken"?
 
G

genatic

Neues Mitglied
Mit Masken meine ich die Apps bzw die Fenster, Hinweismeldungen etc... Hab das Verhalten mal aufgenommen und angehängt.
Irgendwie aktualisiert sich die Anzeige mehrfach bzw alte Werte vermischen sich mit neuen. Schwer zu erklären - ist aber extrem nervig :)

Im Standby ist die untere Flacker-Linie nicht sichtbar. Nach Aktivieren der VirtualNavbar flackert die Linie immer noch unterhalb der Navbar.

Hast du da noch eine Idee, woran das Flackern liegen könnte?
Grüße
 

Anhänge

  • Flackern.zip
    852.5 KB Aufrufe: 123
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
Hallo genatic,

alle Zeichen sprechen für ein Kernel-Problem. Kannst du bitte von allen Grafikfehlern (16 Farben-, Flackerfehler, ...) mal richtige Screenshots machen (Tasten "Power" und "Vol -" gleichzeitig gedrückt halten)? Anschließend versuche ich den Kernel-Portierer qus1 höflich darum bitten dieses Problem zu beheben.

Du kannst ja noch folgende zwei Einstellungen versuchen:
  1. Erzwinge GPU-Rendering unter [Einstellungen]->[Entwickleroptionen*]->[GPU-Rendering erzwingen].
  2. Deaktiviere HW-Overlays unter [Einstellungen]->[Entwickleroptionen*]->[HW-Overlays deaktivieren].
*) Entwickleroptionen sind erst sichtbar wenn du mehrmals hintereinander auf Build-Number unter [Einstellungen]->[Über das Telefon]->[Build-Number] klickst.
 
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
@genatic

Wie sieht es bei dir mit der automatischen Datum/Uhrzeit Erkennung aus? Ich habe gelesen, dass einige diese manuell einstellen mussten.

EDIT:
Eine Sache könnten wir bezüglich Grafikfehler noch testen! Folgende 3 Fixe habe ich hochgeladen:
Graphic-Fix1_Test
Graphic-Fix2_Test
Graphic-Fix3_Test

Wäre schön wenn du diese noch testen und anschließend sagen könntest, ob und welche von denen funktioniert hat.

MfG, JoWi81
 
Zuletzt bearbeitet:
G

genatic

Neues Mitglied
Die Einstellungen in den Entwicklungsoptionen brachten keine Änderung.
Habe auch alle drei deiner Grafik-Fixes getestet: Keine Änderung. Evtl. flackert jetzt die Linie unten am Bildschirm noch schneller als vorher, das könnte aber auch Einbildung sein :)
Wenn ich einen Screenshot mache, sieht der leider immer perfekt aus, somit bringt das leider nichts. Die Grafikfehler sind immer nur von kurzer Dauer.

Datum/Uhrzeit wurde bei mir per WLAN aktualisiert.

Weitere Ideen? Gibts vielleicht einen Alternativ-Kernel, den man mal probieren könnte? Mit dem Originalkernel funktioniert das nicht, oder?

Habe aktuell recht wenig Zeit und bin ab Donnerstag eine Woche im Urlaub. Aber danach kann ich gerne weitertesten. Grüße.
 
JoWi81

JoWi81

Fortgeschrittenes Mitglied
Threadstarter
Hallo genatic,

ich habe das höchstwahrscheinliche Kernel-Problem im russischen Forum für das Vergleichsgerät IQ445 aufgezeigt und jetzt müssen wir mal schauen, ob der Kernel-Portierer qus1 für uns noch etwas Zeit findet.

Falls jemand Interesse hat, kann sich in dem o.g. Forum ein wenig (auf Russisch) einlesen. Dort entstammt die bei mir verwendete Kernel aus dem blanken KitKat 4.4.2 OS. Bei einer Gelegenheit könntest du ja auch mal diesen KitKat testen. Desweiteren bin ich dort zufällig an einen Beitrag vom Kernel-Portierer cyclon1978 gestoßen, in dem er auf kleine Unterschiede zwischen Cynus F3 und IQ445 eingeht.
 
Oben Unten