ADB connecten

N

Neumi

Neues Mitglied
Aber eigentlich müsste doch dann so eine ähnliche Meldung kommen wie folgende....

Waiting for device...
List of devices attached
0123456789ABCDEF device

Hab ich einen Punkt übersehen oder was mache ich falsch?
 
Weissi46

Weissi46

Erfahrenes Mitglied
Bei mir kommt zuerst das eine und dan das andere :D

Gesendet von meinem GT-I9000 mit Tapatalk 2
 
N

Neumi

Neues Mitglied
Also irgendwas mache ich falsch. Ich habe die Schritte 1-4 von Seite 1 genau so gemacht,aber wenn ich jetzt Schritt 5 durchführe passiert nix. Entweder es steht
"Waiting for device....." aber es geht nicht weiter
oder es steht
"Waiting for device.....
* daemon not running.starting it now on port 5037 *
* daemon startet successfully *

aber auch hier geht es nicht mehr weiter
 
W

wofris

Fortgeschrittenes Mitglied
Neumi schrieb:
Entweder es steht
"Waiting for device....." aber es geht nicht weiter
oder es steht
"Waiting for device.....
* daemon not running.starting it now on port 5037 *
* daemon startet successfully *

aber auch hier geht es nicht mehr weiter
Kommt mir bekannt vor.
Lese dir in Post1 (von wusel) das Edit genau durch - Thema ADB_AddVendor.vbs
Mach ein Doppelklick auf dir Datei - starte den PC neu - und freue dich :)
 
N

Neumi

Neues Mitglied
Wunderbar,endlich wird es erkannt! Vielen Dank!
 
Zuletzt bearbeitet:
Stryke

Stryke

Fortgeschrittenes Mitglied
Hey wusel,

mir ist ein kleiner Fehler im mkroot.bat aufgefallen. In Zeile 11 müsste "adb root" stehen, bei dir steht aber "aadb root".
 
wusel

wusel

Stammgast
Threadstarter
Stryke schrieb:
mir ist ein kleiner Fehler im mkroot.bat aufgefallen. In Zeile 11 müsste "adb root" stehen, bei dir steht aber "aadb root".
verdammt - keine Ahnung wie sich der so heimlich einschleichen konnte :razz:
gerade gefixt und Archiv neu gepackt - bitte teste nochmal gegen ob er sich nun weggeschlichen hat ... :tongue:
 
Stryke

Stryke

Fortgeschrittenes Mitglied
Hat seltsamerweiße auch mit Fehler funktioniert ;)
 
wusel

wusel

Stammgast
Threadstarter
Stryke schrieb:
Hat seltsamerweiße auch mit Fehler funktioniert ;)
ja, aber nur bei Tablets die in der default.prop:
Code:
ro.secure=0
gesetzt haben - da ist der Befehl überflüssig; aber andere Tablets brauchen es ... :winki:
 
äxl

äxl

Neues Mitglied
Vielen Dank, wusel! Konnte mich auf Win 7 (Pro 64) endlich verbinden.
Nur wozu ist eigentlich fastboot im Archiv? Es wird in keiner Datei gebraucht und Du schreibst hier leider auch nichts dazu. Sollte ich es auf meinem Allwinner Tablet mal schaffen in diesen Modus zu kommen, erschließt sich für mich der Sinn dieses Programms vielleicht.
DDMS finde ich da schon "nützlicher" - für Screenshots! :D
 
wusel

wusel

Stammgast
Threadstarter
äxl;3697204 schrieb:
Nur wozu ist eigentlich fastboot im Archiv? Es wird in keiner Datei gebraucht und Du schreibst hier leider auch nichts dazu.
es gehört ganz einfach zu dem ADB Krams dazu - will heissen da ist alles dabei was Google in dieses Verzeichnis gepackt hat ... :laugh:
manche Devices unterstützen eben den Fastboot-Mode, und mein ADB-Paket ist allgemein gehalten ...

äxl;3697204 schrieb:
DDMS finde ich da schon "nützlicher" - für Screenshots! :D
Na denn viel Spaß damit ...
Was Du aber auch mal ausprobieren solltest ist der Android Commander - der hat auch eine Screenshot Funktion im Menue (und mehr wie reboot in Flashmodus was auch bei einigen Tabs klappt) ...
Außerdem unterstützt ICS standardmäßig bereits Screenshots - sollte normalerweise mit 'ner Tasten-Combo gehen (aber was ist schon normal mit den Odys Tablets ...); mit sowas sollte man den Odys-Support quälen damit das endlich mal gefixt wird ... (vorausgesetzt es geht auch nicht bei Deinem Allwinner; bei dem Cosmo gehts jedenfalls nicht) ...
was aber auf jeden Fall auch geht: von der Commandline Shell kann man Screenshots machen ...
 
äxl

äxl

Neues Mitglied
wishmasterf schrieb:
Für ADB habe ich noch nie einen Treiber gebraucht. Einfach udev-regel erstellen und pasta. Geht naturlich nur mit guten Betriebsystemen, ;-)
Beziehst Du Dich auf Linux? Wenn mein Tab an ist kann ich es ja ganz normal mounten. Wenn es aber im recovery- oder fastboot-Modus ist, wird es nur unter /sys/bus/usb ... angezeigt, oder? Wie kann ich denn jetzt daraus "Profit schlagen"?

wusel schrieb:
es gehört ganz einfach zu dem ADB Krams dazu - will heissen da ist alles dabei was Google in dieses Verzeichnis gepackt hat ...
Schon nicht schlecht so ein selbstpackendes Archiv. :D Nee, nochmal Respekt dafür. Das was ich bis jetzt gelesen habe, verwies eher auf PDAnet und so n Blödsinn.
manche Devices unterstützen eben den Fastboot-Mode, und mein ADB-Paket ist allgemein gehalten ...
Ich mein ja bloß. Ohne Weiteres kam ich da jedenfalls nicht rein. ;)

Na denn viel Spaß damit ...
Also das reicht "mindestens" für Screenshots: DepositFiles :D (für Linux - obwohl die libs auch für Win reichen sollten)
Was Du aber auch mal ausprobieren solltest ist der Android Commander - der hat auch eine Screenshot Funktion im Menue (und mehr wie reboot in Flashmodus was auch bei einigen Tabs klappt) ...
Hab da aber auf Anhieb keine Reboot-Option gesehen. Ne Anleitung scheint's auch nicht zu geben.
Außerdem unterstützt ICS standardmäßig bereits Screenshots - sollte normalerweise mit 'ner Tasten-Combo gehen (aber was ist schon normal mit den Odys Tablets ...); mit sowas sollte man den Odys-Support quälen damit das endlich mal gefixt wird ... (vorausgesetzt es geht auch nicht bei Deinem Allwinner; bei dem Cosmo gehts jedenfalls nicht) ...
Jop, funktioniert bei mir (erst Power, dann Menu zusammen halten). Aber dann muss ich ja sowieso wieder verbinden. Und wenn ich schon mal dabei bin ... Hat alles seine Vor- und Nachteile. :D
was aber auf jeden Fall auch geht: von der Commandline Shell kann man Screenshots machen ...
Exzellent. Kann ich bei Android eigentlich selbst einfache Desktopverknüpfungen/Widgets auf z.B. Skripte erstellen?

Obwohl Tastenkombination plus ADB Konnect scheint wohl die einfache Lösung zu sein. Oder per Dropbox ...
 
Zuletzt bearbeitet:
wusel

wusel

Stammgast
Threadstarter
Habe soeben die ADB-Archive (siehe ersten Post) upgedatet mit einem Script MkScreenshot.[vbs|sh] (siehe Anhang) mit dem man auf Geräten mit ICS via ADB Screenshots erstellen kann. Das Script nutzt dazu per default das ICS-Tool /system/bin/screencap - alternativ kann es aber auch /system/bin/screenshot nutzen (je nach Gerät kann das eine oder andere Tool besser funktionieren). Das Script startet - wie empfohlen - screencap als Background-Prozess und wartet dann 5 Sekunden bevor der Screenshot zur lokalen Festplatte kopiert wird; je nach Gerät reichen auch schon 3 Sekunden - mit dem Wert könnt Ihr ja mal experimentieren, läßt sich einfach am Anfang des Scripts modifizieren. Der Screenshot wird zuerst auf der internen SD-Card unter /screenshots gespeichert und dann mit ADB kopiert; das Script kann auch den Screenshot nach dem Kopieren sofort wieder auf dem Android-Device löschen - lässt sich ebenfalls im Script konfigurieren.

Edit: habe das ICS-Tool screenshot (siehe Anhang) nun auch auf Gingerbread erfolgreich getestet! Das angehängte Archiv enthält Pfade für ein system-rw - das heisst die Binary wird nach /system/bin/screenshot extrahiert; es ist aber wahrscheinlich auch möglich diese Binary ohne root unter /data zu speichern und auszuführen ...; extrahieren mit:
Code:
busybox tar xvzf screenshot_bin.tar.gz -C /
ein Shell-Script myscreenshot ist ebenfalls im Archiv dabei womit man von der Shell aus testen kann; die oben genannten Scripte müssen modifiziert werden um screenshot anstatt screencap zu verwenden (ist aber schon vorbereitet; einfach die Zeile mit screencap kommentieren und die Zeile mit screenshot aktivieren).

have Fun :smile:
 

Anhänge

Zuletzt bearbeitet:
M

maxxarius

Neues Mitglied
Hy Leute ! Hey Wusel !

Also ich bin grad fleißig am Rooten von meinem Ody Cosmo mit Android 4.0.3,
Lieber Wusel bei schritt 5 der ADB connection Anleitung also nach doppelklick auf die devices.bat schreibt er mir : "Waiting for device ...
Der Befehl "adb" ist entweder falsch geschrieben oder
konnte nicht gefunden werden."
??? was ist da los??
Danke für deine/eure Antworten....

MFG Maxx
 
hävksitol

hävksitol

Ehrenmitglied
Hallo maxxarius, willkommen im Forum.

"Waiting for device ...
Der Befehl "adb ist entweder falsch geschrieben oder konnte nicht gefunden werden."

Das klingt für mich (ohne Cosmo) so, also ob Du devices.bat aus einem Ordner heraus gestartet hast, in welchem sich adb.exe (& alle anderen von Wusel bereitgestellten Dateien) nicht ebenfalls befinden.
 
wusel

wusel

Stammgast
Threadstarter
hävksitol;3900292 schrieb:
Das klingt für mich (ohne Cosmo) so, also ob Du devices.bat aus einem Ordner heraus gestartet hast, in welchem sich adb.exe (& alle anderen von Wusel bereitgestellten Dateien) nicht ebenfalls befinden.
Genau! Daher habe ich gerade das Archiv upgedatet mit überarbeiteten Batches die nun für ADB den vollen Pfad benutzen wo auch die Batch liegt - sollte also in Zukunft nicht mehr vorkommen ...
 
M

maxxarius

Neues Mitglied
Hey Leute, hy Wusel,

viiielen dank für eure raschen Antworten ;)
hmmm.. das mit der falsch geschrieben oder nicht gefunden meldung hat sich mal erledigt ;)
Dafür hab ich jetzt das vor mir :

C:\Users\Markus>adb shell
adb server is out of date. killing...
* daemon started successfully *
root@android:/ # busybox mount -w -o remount /system
busybox cp /sdcard/Superuser.apk /system/app/
busybox chmod 6775 /system/app/Superuser.apk
bbusybox cp /sdcard/su /system/bin/
usybox mount -w -o remount /system
busybox chmod 6775 /system/bin/subusybox cp /sdcard/Superuser.apk /system/app/
busybox chmod 6775 /system/app/Superuser.apk
busybox cp /sdcard/su /system/bin/
root@android:/ # busybox cp /sdcard/Superuser.apk /system/app/
cp: cannot stat '/sdcard/Superuser.apk': No such file or directory
1|root@android:/ # busybox chmod 6775 /system/app/Superuser.apk
chmod: /system/app/Superuser.apk: No such file or directory
1|root@android:/ # busybox cp /sdcard/su /system/bin/
cp: cannot stat '/sdcard/su': No such file or directory
1|root@android:/ #

Hmmm ich kann mich nur wiederholen....was ist da los?? :rolleyes2:

da stimmt doch was nicht :confused:

Viiielen Dank schon mal...
 
wusel

wusel

Stammgast
Threadstarter
Hallo Markus,
maxxarius schrieb:
Hey Leute, hy Wusel,

viiielen dank für eure raschen Antworten ;)
hmmm.. das mit der falsch geschrieben oder nicht gefunden meldung hat sich mal erledigt ;)
Dafür hab ich jetzt das vor mir :
...
Hmmm ich kann mich nur wiederholen....was ist da los?? :rolleyes2:
da stimmt doch was nicht :confused:
ja, ich schätze mal Du kannst nicht von open nach unten lesen sondern nur diagonal :flapper:
benutze einfach mkroot.bat und gut is!
 
F

fenestro

Neues Mitglied
Kann mir bitte jmd. erklären wie ich die adb_usb.ini ans Tablet "binden" kann ?

meinte die "android_winusb.inf"
 
Zuletzt bearbeitet:
Oben Unten