1. Android-Hilfe.de ist morgen (Mittwoch, 18.09.) nicht oder nur eingeschränkt erreichbar, mehr Informationen.
  1. wusel, 19.08.2012 #41
    wusel

    wusel Threadstarter Stammgast

    mit dem Geräte-Manager - welches Betriebssystem hast Du denn? :rolleyes2:
    (eins vorweg: mit WinXP gehts meist einfacher als mit Win7)
     
    fenestro bedankt sich.
  2. fenestro, 19.08.2012 #42
    fenestro

    fenestro Neues Mitglied

    Ich hab Win7 kann aber auch Ubuntu von der Live CD verwenden.
    Leider wird mir das Tablet im Gerätemanager nicht angezeigt.
     
  3. wusel, 19.08.2012 #43
    wusel

    wusel Threadstarter Stammgast

    ja, das wäre ein Ausweg; ich habe auch irgendwo die Tage einen Thread dazu gelesen wo einer Step-by-Step erklärt wie er mit meinem ADB-Linux-Paket vorgegangen ist ... - aber leider finde ich den nicht im Moment; war für Xelio oder Visio - aber das ist ja egal ...
    ja. das ist sau-blöde; bei manchen gehts, und bei manchen nicht; ich vermute mal wenn das Tablet bereits mal mit Gingerbread verbunden war dann gehts mit ICS nicht mehr - Windoof hält dann an dem alten Treiber fest, installiert den automatisch und fällt dann auf die Nase = gar kein Device mehr ...
    hast Du auch nochmals geprüft ob Du USB-Debugging eingeschaltet hast?
     
    fenestro bedankt sich.
  4. fenestro, 19.08.2012 #44
    fenestro

    fenestro Neues Mitglied

    ich hab bereits über eine stunde versucht ůber linux zu connecten.
    ohne erfolg.

    usb debugging ist natürlich eingeschaltet.

    würde es sinn machen downzugraden und den treiber zu deinstallieren und danach wieder upzugraden?

    mfg
    fenestro
     
  5. wusel, 19.08.2012 #45
    wusel

    wusel Threadstarter Stammgast

    hast Du mein Linux-ADB-Paket genommen? Und besonders auch die ADB_AddVendor.sh augeführt? Siehst Du das Tablet mit lsusb ?

    ne - glaube ich nicht; ist eben Windoof .....
    nimm mal diese App und check mal ob das Tablet damit sichtbar ist ...; damit kann man auch Treiber de-installieren;
    oder kannst auch mal diese App probieren vom selben Author ...
     
    fenestro bedankt sich.
  6. fenestro, 19.08.2012 #46
    fenestro

    fenestro Neues Mitglied

    ja ich hab dein paket + addvendor benutzt aber was ist isusb?

    die apps probier ich nachher.

    //e

    dAs zweite ist doch keine app oder?
     
    Zuletzt bearbeitet: 19.08.2012
  7. wusel, 19.08.2012 #47
    wusel

    wusel Threadstarter Stammgast

    nicht i sondern l (kleines L), also Tablet anstecken, dann Konsole öffnen und eingeben:
    Code:
    lsusb
    die Ausgabe sieht dann in etwa so aus:
    Code:
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    .....
    
    und da sollte dann das Tablet auftauchen mit ID 2207:0000 ... (bitte poste hier Deine Ausgabe)
    doch, beides; die erste ist speziell für USB-Geräte, die zweite allgemein.
     
    fenestro bedankt sich.
  8. fenestro, 19.08.2012 #48
    fenestro

    fenestro Neues Mitglied

    C:\Users\Stefan>lsusb
    Der Befehl "lsusb" ist entweder falsch geschrieben oder
    konnte nicht gefunden werden.

    oder ist das für Linux?

    auf jedenfall werden jetzt die Apps getestet :)

    //edit:
    eine idee nach was ich beim 1. prog suchen soll?

    //edit2:
    ich hab jetzt den treiber deinstalliert, welchen soll ich jetzt installieren?

    //edit3:
    jetzt hat windoof automatisch irgendeinen treiber installiert und jetzt gehts :)

    danke für alles wusel :)
     
    Zuletzt bearbeitet: 19.08.2012
  9. wusel, 19.08.2012 #49
    wusel

    wusel Threadstarter Stammgast

    yep - war die Antwort auf Deine Linux-Versuche ;)
    für Windoof findest Du ein sehr ähnliches Commandline-Tool listdevs.exe im rkflashtool-Ordner.
    Wunderbar! Schön dass es jetzt klappt!

    Der ursprüngliche Beitrag von 19:06 Uhr wurde um 20:16 Uhr ergänzt:

    Habe heute mein Android-SDK nach Updates suchen lassen ...
    dabei wurden unter anderem auch die ADB-Dateien erneuert :)
    die ADB.EXE meldet sich zwar weiterhin mit der Version 1.0.29, ist aber ~30kb größer - also definitiv eine neuere Version. Daher habe ich mal wieder mein ADB-Paket upgedatet mit den neuen Dateien, den Namen des Archivs jedoch nicht geändert - somit gilt der Link im ersten Post weiterhin. Sollte jemand mit dieser neuen Version Probleme haben (ich hatte keine bei meinen Tests) dann kann hier weiterhin die vorherige Version heruntergeladen werden.
    Derzeit habe ich nur das Windows-Archiv erneuert - Linux wird noch folgen und werde ich dann hier ankündigen.
     
    Zuletzt bearbeitet: 19.08.2012
    Gallierobelix bedankt sich.
  10. pedasen, 25.08.2012 #50
    pedasen

    pedasen Neues Mitglied

    Moin Leute! Ich hab folgendes Problem:

    Ich hab meiner Ma ein Odys Cosmo und eine Hardwaretastatur geschenkt. Problem ist, dass man nicht das deutsche Tastaturlayout auswählen kann. Hier kommt nun die Lösung, rooten und ein mod installieren. Bis jetzt habe ich nur mit meinem Galaxy S rumgespielt. Und dafür nie ADB benutzt.

    So folgendes: Ich hab von wusels Odys Cosmo Rootanleitung die Superuser und SU geladen und von diesem Thread die ADB gezogen. Das Cosmo auf Debugging gestellt und angschlossen. Windows hat blöderweise gleich alle Treiber installiert. Jedoch hab ich es irgendwie hingekriegt, bei meinem PC (Laptop hat nicht funktioniert) beim Hardwaremanager ganz oben "ADB Inteface" steht. Da habe ich die Treiber aus dem ADB-Ordner aktualisiert. Jedoch wenn ich eine Shell öffne über Desktop und die ersten Komandos eingebe, wirft er mir vor "error: device not found".
    Jemand einen Lösungsvorschlag?

    EDIT: Im Hardwaremanager ist unter "ADB Interface" nur "Android Composite ADB Interface" angezeigt. Wenn ich nun über Legacyhardware versuche weitere Komponente zu installieren, sagt der am Ende immer "Das Gerät kann nicht gestartet werden. (Code 10)"

    Achja, super, dass ihr euch alle so eine Mühe macht!
     
    Zuletzt bearbeitet: 25.08.2012
  11. wusel, 26.08.2012 #51
    wusel

    wusel Threadstarter Stammgast

    Hi pedasen,
    tja, Windoof nach XP ist schon zu so einem Problem-OS geworden ... :D
    Nur? Was braucht man denn noch mehr als das "Android Composite ADB Interface" ?? Ich denke Du suchst an der verkehrten Stelle - der Treiber ist schon richtig installiert denke ich mal, aber ADB will nicht weil Du nicht ADB_AddVendor.vbs benutzt hast :winki:
    Sollte das auch noch nicht helfen dann lies doch bitte hier nochmal die letzten Posts vor Deinem um ein paar Möglichkeiten zur Fehlersuche kennenzulernen, z.B. die Tools die ich vorgeschlagen habe um zu überprüfen welche Treiber aktiv sind und um falsch gebundene eventuell deinstallieren zu können ...
     
  12. mardon, 04.09.2012 #52
    mardon

    mardon Experte

    Moin hab mir das Odys NEO X8 gekauft und nun das Problem das adb nicht richtig will. Der adb treiber ist installiert habe jedoch dieBbefürchtung das der nicht kompatibel ist weil keine verbindung zum gerät möglich ist. Weder auf xp noch win7 funzt es.
     
  13. netlars, 04.09.2012 #53
    netlars

    netlars Erfahrenes Mitglied


    Hey, der Debugmodus ist aktiviert? und es muss zusätzlich unter ICS in der Speicherverwaltung MTP ausgwählt sein.

    LG
     
  14. mardon, 04.09.2012 #54
    mardon

    mardon Experte

    Logisch ist der debugmodus an was n das für ne frage......

    Habs inzw. gelöst das adb paket von hier funzt nicht mit dem x8. Das Original android sdk schon (wird jetzt als Original Android ADB Device erkannt)
     
  15. netlars, 04.09.2012 #55
    netlars

    netlars Erfahrenes Mitglied


    Logisch ist nicht alles hier.
    Hier erlebt man viele Dinge.
    Wenn nur ungenaue Angaben gemacht werden, muss man ja Ursachenforschung betreiben.
     
  16. wusel, 04.09.2012 #56
    wusel

    wusel Threadstarter Stammgast

    hattest Du denn auch die USB Vendor ID mit Hilfe von ADB_AddVendor.vbs hinzugefügt?
    Und hast Du mal die neue android_winusb.inf vom SDK gecheckt ob da ventuell mehr IDs drin sind?
    Welche ID hat das X8?
     
  17. wusel, 09.09.2012 #57
    wusel

    wusel Threadstarter Stammgast

    So, es ist mal wieder Zeit die ADB-Pakete aufzufrischen .... :smile:
    Änderungen zu vorherigen Versionen des ADB-Pakets:

    • es wird jetzt automatisch die aktuelle Version Superuser-3.1.3-arm-signed.zip heruntergeladen wenn nicht bereits eine Version im Verzeichnis vorhanden ist
    • die (meist) vorhande /system/xbin/su wird nicht mehr gelöscht sondern in /system/xbin/su.orig umbenannt (somit kann man auch ohne Flashen wieder das Rooten deinstallieren)
    • mkroot.bat (Windows): ADB_AddVendor.vbs wird nun automatisch aufgerufen und die USB Vendor ID 0x2207 wird hinzugefügt zu adb_usb.ini
    • mkroot.sh (Linux): ADB_AddVendor.sh wird nun automatisch aufgerufen im interactive-Mode
    • Linux: Die USB Vendor ID kann jetzt wenn nötig interaktiv eingegeben werden (ADB_AddVendor.sh -i)
    • neues Script modbuidprop.[bat|sh] hinzugefügt zum Modifizieren der build.prop für Lokale DE (sehr hilfreich bei Android-Devices die bei Auslieferung auf andere Sprachen als EN oder DE eingestellt sind); außerdem ist danach auch nach einem Zurücksetzen des Systems gleich wieder DE eingestellt
    • neues Script reboot-device.[bat|sh] hinzugefügt zum Rebooten
    • alle Scripte wurden überarbeitet und Fehlerabfang-Routinen hinzugefügt sowie Ausgaben farblich abgesetzt
    wiederholtes Ausführen der Root-Prozedur mit mkroot.[bat|sh] sollte nichts schädliches bewirken - allerdings wird dann beim 2. Mal die /system/xbin/su.orig mit der Version die beim 1. Mal kopiert wurde überschrieben; wer also die originale /system/xbin/su.orig sichern möchte vor einem 2. Aufruf des Scripts mkroot.sh sollte dies manuell tun; allerdings ist das nur für diejenigen die noch nicht gerootet haben interessant - mein altes Script mkroot.[bat|sh] hat die original su einfach gelöscht ...

    Die neue Download-Funktion der SU-Dateien erfordert natürlich dass der Rechner mit dem Internet verbunden ist - sollte dies nicht zutreffen dann müssen wie bisher Superuser.apk und su manuell in das ADB-Verzeichnis kopiert werden bevor mkroot.[bat|sh] aufgerufen wird ...

    Speziell zum Rooten unter Linux habe ich ein selbst-extrahierendes Archiv adb-1.0.29.run erstellt womit sich das Rooten nun auf 2 Kommandos beschränkt (in einem Konsolenfenster eingeben):
    Code:
    wget http://svwe10.itex.at/~android/adb-1.0.29.run
    sh adb-1.0.29.run
    
    Experimentell: speziell zum Rooten unter Windows habe ich ein selbst-extrahierendes Archiv adb-1.0.29.exe erstellt womit das Rooten auf den Download und anschließenden Doppelklick beschränkt wird;
    allerdings kann dies nur dann klappen wenn bereits der richtige ADB-USB-Treiber installiert ist !!
    An diesem Archiv muss also noch etwas gefeilt werden um die Treiber-Installation zu ermöglichen ...

    Hier nochmal direkte Links zu den Archiven:

     
    Zuletzt bearbeitet: 24.02.2013
    Gallierobelix bedankt sich.
  18. feuervogel.eva, 14.09.2012 #58
    feuervogel.eva

    feuervogel.eva Neues Mitglied

    hallo hab nun x mal versucht zu rooten mit window7 zip, odys next wird im gerätemanager angezeigt, doch wenn ich mit titanium backup nachsehe kommt nicht gerootet.
    hab es vorher mit ADB versucht auch mit adminrechten, es klappt einfach nicht.
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully * weiter geht es nicht.
    Ansonsten:
    Modellnummer: Next
    Kernel: 3.0.8+zhp@fac #69
    Build Nr: RK2918_Android4.0.3 SDK ODYS NEXT V2.11 20120426


    habe noch ein cat nova da klappt das rooten bestens
     
  19. wusel, 14.09.2012 #59
    wusel

    wusel Threadstarter Stammgast

    und genau sowas wird dann Dein Problem sein: Windoof hat den Treiber automatisch installiert und das Next wird nicht eingebunden weil es nicht in der *.inf drin ist ...
    vorausgesetzt Du hast mein neuestes ADB-Paket genommen welches nun immer die adb_usb.ini anlegt und die ID 0x2207 hinzufügt dann liegt es wahrscheinlich an dem ADB-Treiber; lies bitte mal den gesamten Thread hier und versuche ein paar Tips wie man den Treiber de-installieren und den richtigen neu installieren kann (ich habe auch in einem Post auf Windows Tools verwiesen die Dir dabei helfen)
     
    feuervogel.eva bedankt sich.
  20. feuervogel.eva, 15.09.2012 #60
    feuervogel.eva

    feuervogel.eva Neues Mitglied

    werd mich nochmal bemühen hoffe ich krieg den treiber raus

    Der ursprüngliche Beitrag 14.09.2012 von 23:35 Uhr wurde 15.09.2012 um 00:20 Uhr ergänzt:

    danke lag am treiber, jetzt hat es geklappt, freu:thumbsup:
     
Du betrachtest das Thema "ADB connecten" im Forum "Odys Allgemein",
  1. Android-Hilfe.de verwendet Cookies um Inhalte zu personalisieren und dir den bestmöglichen Service zu gewährleisten. Wenn du auf der Seite weitersurfst stimmst du der Cookie-Nutzung zu.  Ich stimme zu.