[Firmware][10.0] OxygenOS 10.3.8

  • 572 Antworten
  • Neuester Beitrag
Diskutiere [Firmware][10.0] OxygenOS 10.3.8 im Original-Firmwares für OnePlus 6T im Bereich OnePlus 6T Forum.
vergilbt

vergilbt

Ikone
Für alle die root und Magisk haben:

-Magisk im Manager deinstallieren und dabei originales Image installieren lassen, kein Neustart
-Volles OTA Laden und installieren, kein Neustart
-Magisk dezidiert auf inaktiven Slot installieren,
-einmal Neustart und alles fertig mit Root


Ich liebe A/B slots
 
bbfh

bbfh

Stammgast
Ganz coole Lösung. Gefällt mir gut. Aber TWRP ist dann weg, oder?
 
Cua

Cua

Senior-Moderator
Teammitglied
Ist für die Variante ohne TWRP und Root :)

Für TWRP und Root:
->
Installationshinweis der Vollversion: Root & TWRP [Methode 1]
  • Die Vollversion Laden und ins Hauptverzeichnis des Telefons kopieren, TWRP installer.zip und Magisk.zip ebenso.
  • Ins TWRP Navigieren
  • 1. OOS und TWRP installer installieren
  • 2. Neustart in TWRP
  • 3. Magisk.zip installieren
  • 4. Neustart ins System
Siehe Startpost
 
vergilbt

vergilbt

Ikone
bbfh schrieb:
Ganz coole Lösung. Gefällt mir gut. Aber TWRP ist dann weg, oder?
Richtig, wie @Cua schon schreibt...
Aber bisher habe ich twrp noch nicht benötigt.
Alle root-relevanten Sachen installiere ich über Magisk. ZIP flashen gehört für mich der Vergangenheit an
 
bbfh

bbfh

Stammgast
stimmt eigentlich, solange man bei oxigen bleibt und nicht ständig experimentiert braucht man twrp nicht unbedingt. Ich glaub ich teste die Variante mal. Bei Bedarf ist twrp ja schnell wieder drauf.

Edit: im Startpost ist ja schon das volle Update als Zip... dann mach ich es doch wieder herkömmlich über twrp. Gewohnheitstier und so :1f605:

Edit2: ach was solls, ich mach es jetzt zum testen nach der neuen Art. TWRP ist noch nicht offiziell und zur Zeit kann ich da wirklich drauf verzichten. Interessiert mich jetzt doch zu arg, wie es mit der anderen Methode klappt. Bis hoffentlich gleich.
 
Zuletzt bearbeitet:
Cua

Cua

Senior-Moderator
Teammitglied
Ich bin auch ohne TWRP unterwegs. Solange es da noch nichts absolut stabiles gibt, sehe ich auch keinen Grund dafür. :)



Was mir gut gefällt am Update ist der BT-Audio-Tuner. da kann man nochmal was rausholen.
Ich hab jetzt keine teuren BT-InEars, aber der Tuner konnte da nochmal was rauskitzeln. :)
 
vergilbt

vergilbt

Ikone
Ja dafür hat man ja nun wirklich Viper;)
Wenn man nun schon root hat
 
bbfh

bbfh

Stammgast
lol, ich glaub ich hab es falsch gemacht. Magisk Deinstallieren ist ja der erste Schritt. Hab Deinstallieren / komplett deinstallieren getippt. Jetzt ist der Manager weg. Das war glaub nicht das Ziel. Ich Flash jetzt erst mal Magisk neu. TWRP ist ja noch da solange das Update noch nicht drauf ist.
 
Darkseth

Darkseth

Lexikon
Bei noch jemandem VoLTE / WlanCall verschwunden?
Bei Netzwerkeinstellungen ist der Schalter da, aber in der Leiste oben nix mehr.

Da fragt man sich, was man überhaupt davon hat, dass bei Oneplus die Updates so schnell kommen, wenn man das jedes mal mit PC und so neu aktivieren muss..

Oder gibt es mittlerweile eine Lösung, dieses Standard Feature dauerhaft zu aktivieren?
 
Cua

Cua

Senior-Moderator
Teammitglied
Bei mir sowohl VoLTE als auch VoWIFI nach dem Update noch vorhanden.

vergilbt schrieb:
Ja dafür hat man ja nun wirklich Viper;)
Sorry, da bin ich raus. Meine letzte Info war, gibst für Pie noch nicht.
Muss ich doch gleich mal gucken...
 
bbfh

bbfh

Stammgast
hmm, beim zweiten Versuch stecke ich jetzt fest. Wie deinstalliere ich Magisk über den Magisk-Manager ohne dass dann der Manager weg ist?
 
Darkseth

Darkseth

Lexikon
Cua schrieb:
Bei mir sowohl VoLTE als auch VoWIFI nach dem Update noch vorhanden.
Merkwürdig. Dann hoffe ich, dass das bei mir was einmaliges ist. Mal sehen wie es die nächsten Monate ist. Einmal jährlich hab ich da keine Probleme mit sowas^^ 2-3 mal im Monat dann hört es aber schon auf :p
 
vergilbt

vergilbt

Ikone
bbfh schrieb:
hmm, beim zweiten Versuch stecke ich jetzt fest. Wie deinstalliere ich Magisk über den Magisk-Manager ohne dass dann der Manager weg ist?
Images wieder herstellen (Bild 1)
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Cua schrieb:
Bei mir sowohl VoLTE als auch VoWIFI nach dem Update noch vorhanden.

vergilbt schrieb:
Ja dafür hat man ja nun wirklich Viper;)
Sorry, da bin ich raus. Meine letzte Info war, gibst für Pie noch nicht.
Muss ich doch gleich mal gucken...
Es gibt für alles ein Modul:1f602: (Bild 2)
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Darkseth schrieb:
Cua schrieb:
Bei mir sowohl VoLTE als auch VoWIFI nach dem Update noch vorhanden.
Merkwürdig. Dann hoffe ich, dass das bei mir was einmaliges ist. Mal sehen wie es die nächsten Monate ist. Einmal jährlich hab ich da keine Probleme mit sowas^^ 2-3 mal im Monat dann hört es aber schon auf :p
PC anwerfen, Handy verbinden, PDCtool öffnen, dreimal klicken, fertig:1f607:
Eben gemacht (gar nicht vorher geschaut, ob es auch so gegangen wäre)
 

Anhänge

Cua

Cua

Senior-Moderator
Teammitglied
@bbfh
Wenn du TWRP draufhast, musst du Magisk nicht deinstallieren

- komplettes ROM laden auf internen Speicher speichern
- Magisk-Zip auf internen Speicher speichern
- TWRP auf internen Speicher speichern
- ins TWRP booten
- ROM installieren
- TWRP installieren
- Reboot ins TWRP
- Magisk installieren
- booten
 
bbfh

bbfh

Stammgast
Ok, hat richtig gut funktioniert. Vielleicht sollte man im Startpost noch ergänzen, dass man im Manager nicht auf komplett deinstallieren tippt sondern auf Images wiederherstellen. Solange ich twrp nicht für was spezielles brauche, mach ich das jetzt weiterhin so. Danke für die wiederholten Hinweise drauf und die Starthilfe.

Edit: Danke auch @Cua so hab ich das bisher auch immer gemacht. Aber den Weg übers normale OTA und den Manager finde ich irgendwie noch besser. TWRP ist bei Bedarf schnell drauf und zur Zeit brauche ich es eigentlich gar nicht mehr. Macht ja sonst alles Magisk alleine.
 
Picard87

Picard87

Erfahrenes Mitglied
Also bei mir waren diesmal VoWiFi und VoLTE auch "weg". Beim letzten Update (.0.6) nicht. Anbieter Vodafone Deutschland. Ging aber problemlos wieder nach der Anleitung.
 
Destination86

Destination86

Experte
Na dann probiere ich es diesmal wieder. Vielleicht klappt es diesmal bei mir.
 
Darkseth

Darkseth

Lexikon
Ach ja, Bin bei Vodafone. Könnte sein, dass das nur bei Telekom bleibt?
 
Pio

Pio

Experte
Jep, nur Telekom bleibt. VF und o2 Kunden müssen es leider neu einrichten.
 
bbfh

bbfh

Stammgast
Code:
- Copying image to cache
- Device platform: arm64-v8a
- Existing zip found
- Extracting files
- Unpacking boot image
MagiskBoot v17.3(17302) (by topjohnwu) - Boot Image Modification Tool
Parsing boot image: [/data/user_de/0/com.M6e7B1IQfc2ln2Rr/install/boot.img]
! Unable to unpack boot image
! Installation failed
Ich hatte jetzt nach dem Update über den Weg ohne twrp schon zwei mal Probleme mit Magisk. Erst wurde mir angezeigt, Magisk sei nicht installiert (obwohl die Installation nach dem Update da war und funktioniert hat). Ich hab dann erst mal neu gestartet ohne sonst etwas zu tun. Nach dem Neustart hat Magisk angezeigt, dass alles ok ist (?) und es ging wieder. Kurz drauf, gleiches wieder. Magisk sei nicht installiert, Root ging nicht mehr. Diesmal half auch ein Neustart nicht. Als ich Magisk neu im Manager installieren wollte (Bootimage patchen), ging das nicht. Log steht oben.

Ich mach später twrp wieder drauf, da geht das besser. Oder kennt ihr den Fehler (und eine Lösung)?

Das Problem besteht weiter, hab es mal in einen eigenen Thread gepackt, gehört ja eher nicht hier rein.

Magisk:meldet ständig es sei nicht installiert
 
Zuletzt bearbeitet:
Ähnliche Themen - [Firmware][10.0] OxygenOS 10.3.8 Antworten Datum
2