4.4.4 Update(OTA) Probleme(Status 7), bei unlocked N10

  • 28 Antworten
  • Neuester Beitrag
Diskutiere 4.4.4 Update(OTA) Probleme(Status 7), bei unlocked N10 im Root / Custom-ROMs / Modding für Google Nexus 10 im Bereich Google Nexus 10 Forum.
D

Diola

Fortgeschrittenes Mitglied
Hallo,

diesmal habe ich den "Status 7".

[...]
"/system/app/EmailGoogle.apk" has unexepted contends.
E:Error in /tmp/update.zip
(Status 7)
Installation aborted.



Ich nutze WugFreshs "Nexus Root Toolkit v1.8.4", also upgedatet. Mein Gerät ist gerootet und entlockt(sofern das 2 verschiedene Dinge sind^^).
Die Datei habe ich von Download: Android 4.4.4 KTU84P OTA Update for Nexus 5, Nexus 7, Nexus 10, and Nexus 4 | Droid Life für Nexus 10.

Ich habe einige Lösungen im Internet zum "Status 7" gefunden, welche eigentlich alle davon ausgehen, dass man eine veraltete Recovery hätte. Nur hat das "Nexus Root Toolkit" genau darauf hingewiesen als ich es updatete und eine aktuelle Version geladen.
Ist es damit getan? Oder muss ich das noch extra aktivieren?


Viele Grüße
 
Zuletzt bearbeitet:
D

Diola

Fortgeschrittenes Mitglied
...irgendwie ist das Forum nicht so "der Renner". Ich habe ja tatsächlich noch nie eine Antwort auf ein Problem oder eine Frage erhalten. Nix mit "geballter Kompetenz".^^
 
D

Diola

Fortgeschrittenes Mitglied
Hehe, Lebenszeichen. :)

Mein Englisch ist nur Abendschule und dann nie genutzt, daher habe ich ehrlich gesagt nicht verstanden, worum es dort genau geht und ob das bei mir gilt. Wenn mein Tablet morgen wieder voll geladen ist, werde ich die dort beschriebenen Schritte nun durchgehen und sehen was passiert.

Danke für den Hinweis.

PS: Wie ist das gemeint mit Nexus 10 Bereich nicht so gut besucht? Ist das so veraltet? Meins ist noch recht neu und scheint durchaus mit zuhalten. Da viele Bekannte eher Supermarktgeräte nutzen, liege ich eigentlich sogar noch vorne. :confused2:
 
PJF16

PJF16

Ehrenmitglied
Hallo,

Das Nexus 10 ist sicherlich noch ein top Gerät. Nexus Geräte generell sind aber eben keine "Mainstream-Geräte" wie z. B. diverse Samsung Geräte welche deutlich höhere Verkaufszahlen haben.
 
D

Diola

Fortgeschrittenes Mitglied
Ah, alles klar. Mir persönlich, der völlig neu in dem Thema(nie ein Smartphone oder anderes Tablet besessen), schien es nur logisch ein Gerät von Google zu wählen, ich glaubte hier die wenigsten Probleme zu finden.


Nun ja, bei der Anleitung vom Link komme ich schon bei Schritt 3. nicht weiter.:unsure:
Ich habe das dort weiter oben gelinkte "Android SDK" geladen, den Manager da drin ausgeführt und die vorgeschlagenen 4 Pakete installiert. Dann habe ich unter /Plattformtools adb.exe ausgeführt. Es öffnet sich ein Fenster was sich nach ein paar automatischen Befehlen auch sofort wieder schließt.

Und nun?
Es wird ja gesagt man sollte testen, ob alles soweit läuft, in dem man innerhalb der Plattformwerkzeuge SHIFT+RMT und dann Eingabeaufforderung wählt. Nur wie komme ich an besagte Stelle um das zu klicken? adb.exe ist ja nur Sekundenbruchteile offen. :confused2:
 
Cua

Cua

Senior-Moderator
Teammitglied
Du musst eine Konsole in Windows öffnen (am besten im "Ausführen"-Feld CMD eingeben und Enter drücken, oder in dem Ordner, wo die adb.exe drin ist Shift + Rechte Maustaste drücken und dann "Eingabeaufforderung hier öffnen" [Win7] wählen).
Dann kannst du da mit adb arbeiten.
 
D

Diola

Fortgeschrittenes Mitglied
Omg, wie blind man doch sein kann! Hab es gefunden, x-mal so probiert und nicht gesehen. Aber das ist das selbe Menü welches erscheint wenn man dort nur RMT klickt.

So mal sehen wie weit ich nun komme...

Der ursprüngliche Beitrag von 19:48 Uhr wurde um 19:59 Uhr ergänzt:

Mist, wieder selbe Stelle, anscheinend anderer Fehler:

Diesmal habe ich TWRP-recovery drauf:

"/system/app/EmailGoogle.apk" has unexpected contents.
E:Error executing updater binary in zip '/data/media/0/sideload.zip'
Updating partition details...


Ideen?
 
Zuletzt bearbeitet:
1907

1907

Ehrenmitglied
Warum tust du dir den OTA Mist an.
Wenn du eh unlocked hast kannst doch einfach die Stock Rom als .zip von Hanspampel via Recovery flashen. Da brauchst auch kein Toolkit, keinen PC oder sonst was.

Kannst auch das komplette Image runter laden, die system.img und boot.img entpacken und die beiden Files per fastboot oder mit dem Wugfresh flashen.
Daten bleiben auch erhalten, wenn du wirklick unlocked hast. Bei Interesse einfach melden, dann erkläre ichs noch mal Schritt für Schritt.
 
Zuletzt bearbeitet:
D

Diola

Fortgeschrittenes Mitglied
Oh. Ich hatte keine Ahnung, was ich bisher mitbekommen hatte, war das Problem, dass wegen dem root und unlock keine normale Version funktionieren würde und beim letzten Mal(4.4.3) ja auch nicht hat.
Inzwischen habe ich gelesen dass OTA "on the air" heißt. Das würde ja bedeuten dass es sich um das automatische Update handelt?
So wird mir langsam klar dass ich das Problem per Problem zu lösen suche... :scared:

Ja wenn es einfacher geht, unbedingt: Hilfe!
 
1907

1907

Ehrenmitglied
Beim OTA Update werden nur die Änderungen geflasht. Das heißt, wenn du vor dem OTA schon ein Problem hast, dann hast du es nachher wahrscheinlich auch, wenn nicht gerade die problemverursachenden Teile upgedatet werden.
Wenn du das komplette Factory Image flashst, kannst du sicher sein, auch wirklich alle Systemdateien neu aufgespielt werden.

Variante 1: Du nimmst die .zip von hanspampel und flashst diese per Custom Recovery (TWRP oder CWM)
  1. Wenn nicht schon geschehen ein Custom Recovery installieren (am einfachsten über das Wugfresh Toolkit
  2. Die aktulle Zip Datei von hier https://www.android-hilfe.de/forum/...2014-factory-images-odex-deodexed.498704.html runterladen
  3. Ins Recovery Menü booten (Tastenkombi)
  4. Backup im Recovery anlegen (falls was schief geht kannst immer auf den aktuellen Stand zurück)
  5. Flash Zip oder Install Zip auswählen (weiß den genauen Wortlaut gerade nicht)
  6. Dann die zuvor geladene Datei auswählen und das Flashen Bestätigen.
  7. Anschließend Wipe Cache und Wipe Dalvik Cache ausführen (Wenn du einen Fullwipe also inkl. Wipe Data ausführst sind deine Appdaten und Apps weg.
  8. Jetzt neu starten und du hast die neuste Version drauf.
  9. Bei dieser Version hast du auch den Vorteil, dass hanspampel bereits die transparente Statusleiste eingebaut hat und bereits schon alles "vorgerootet" ist - Bei Bedarf müsstest du nur noch die Super -SU App aus dem Playstore (von Chainfire) installieren
Version 2: über Fastboot (klappt immer und du brauchst nicht mal unbedingt ein Custorm Recovery)

  1. Das aktuelle Factory Image vom Googleserver laden https://developers.google.com/android/nexus/images#mantaray
  2. die Datei mit nem Zipprogramm soweit entzippen, bis du die Dateien system.imb und boot.img siehst (diese Dateien auch entpacken)
  3. Die beiden Datein kopierst du auf deinen PC in den Ordner, wo auch die Datei adb.exe und fastboot.exe liegt. (Irgendein ADB Ordner, der von deinem Toolkit angelegt wurde.
  4. Jetzt Steckst du das USB Kabel an den PC und das Nexus und startest in den Fastbootmode (Tastenkombi) (Achtung wenn der Text Downloading - do not turn off Target kommt, dann bist du nicht im Fastbootmode, sondern im Downloadmode
  5. Warten bis die ADB Treiber installiert wurden (wenn nicht schon geschehen) die Treiber werden im Fastbootmode meist nochmal installiert.
  6. Jetzt öffnest du ein Windowskonsolenfenster (mit cmd) und navigierst in den Ordner wo die Datei fastboot.exe liegt (mit cd [verzeichnisname) kannst du in dem Dos Fenster das Verzeichnis wechseln
  7. jetzt gibst du in das Dos-Fenster folgendes ein (immer mit Enter bestätigen):
    1. fastboot devices (wenn jetzt deine Seriennumer vom Nexus erscheint ist alles ok und es kann weiter gehen - wenn nicht sind deine Treiber nicht richtig installiert.
    2. fastboot flash boot boot.img (der Kernel wird installiert)
    3. fastboot flash system system.img (das System wird installiert)
    4. fastboot erase cache (der Cache wird gelöscht)
    5. fastboot reboot (Dein Nexus wird neu gestartet)
    6. Fertig!
Beide Variante sollten funktioniern ohne dass du Daten verlierst oder irgendwas neu einrichten musst. Allerdings empfehle ich ausdrücklich (gerade wenn du Probleme hast) anschließend einen Fullwipe (übers Recovery) zu machen, wenn du von einer früheren Version kommst, die nicht Kitkat ist. Alternativ kannst du auf Werkseinstellungen zurücksetzen. Achtung bei Werkseinstellung sind alle Daten weg (auch Downloads, Musik usw.) Also vorher alles brav sichern. Daten auf den PC und Apps und Appdaten mit Titanium Backup, und Kontakte, Kalender usw. auf dem Googleserver.

Am besten liest du dir mal die FAQ in meiner Signatur durch, da stehen viele Hinweise drin.
 
D

Diola

Fortgeschrittenes Mitglied
Schon mal vielen Dank. Ich habe die 2. Variante gewählt. Allerdings hängt sich nun das Gerät bei diesen 4 bunten Kreisen, die durch die Gegend springen, auf. Nach Punkt 7. Unterpunkt 5.

Dabei wurden alle Schritte vorher mit OK im DOS-Fenster bestätigt. Also ohne Fehlermeldung.


Fastbootmode erreicht man doch in dem man [Power+lauter+leiser] gedrückt hält bis es neu startet?
Ich sehe dann das Männchen auf dem Rücken mit offenem Bauch OHNE das rote Ausrufezeichen?

Der ursprüngliche Beitrag von 13:58 Uhr wurde um 14:19 Uhr ergänzt:

Nun habe ich mit der ersten Version angefangen. Hier kommt allerdings eine simple "Fehler"-Meldung schon beim Backup erstellen, etwa bei 30%. Ich habe TWRP Recovery drauf.
 
Zuletzt bearbeitet:
1907

1907

Ehrenmitglied
Ja, den Fastbootmode erreichst du so.

So wie es aussieht steckst du in einem Bootloop und du kommst vermutlich nicht um einen Fullwipe (eigentlich immer empfohlen) rum.

du kannst aber den Wipe von Cache und Dalvik Cache nochmal zusätzlich im Recovery probieren.

Wie du vorher schriebst hast du TWRP drauf?

Kannst du jetzt mal bitte in TWRP Recovery gehen (erst mit der Tastenkombi in den Fastbootmode und dann mit Vol+/- Recovery auswählen und mit PWR bestätigen)

Im TWRP machs du jetzt erst ein mal ein Backup. Aus diesem Backup kannst du später falls nötig deine Appdaten mit Titanium Backup wiederherstellen.

Jetzt suchst du den Punkt Wipe und machst einen "Fullwipe" (d.h. inkl. der Partition /data - dort sind deine Appdaten gespeichert)

wenn du willst kannst du vorher auch erst probieren obs wieder startet, wenn du nur /cache und /dalvik cache wipest.

Im schlimmsten Fall (wenn du kein Backup hast) musst du halt deine Apps neu installieren.

Der ursprüngliche Beitrag von 14:20 Uhr wurde um 14:26 Uhr ergänzt:

Probier mal beim Backup nur die Partition /data zu sichern.
Alles andere ist unwichtig, da du die anderen Partitionen eh mit dem Flash vorher überschrieben hast.

Genügend Speicherplatz hast du schon drauf? Ein komplettes Backup kann je nach Apps mehrere GB groß sein. Wenn du ein OTG Kabel hast kannst du das Backup auch auf einen USB Stick speichern.
 
D

Diola

Fortgeschrittenes Mitglied
DAS SCHRIEB ICH VOR DEINEM LETZTEN POST:


Und bei Schritt 5. (Version 1) "Flash Zip oder Install Zip auswählen" komme ich auch nicht weiter. Hier habe ich ja nun das TWRP Menü:
Dort sind Buttons:
Install - hier findet sich eine bereits ausgewählte "sideload.zip" (sollte die geladene Datei etwa auf das Gerät verschoben und hier ausgewählt werden?)
Backup
Restore
Wipe
Mount
Settings
Advanced - ADB Sideload usw.
Reboot
 
1907

1907

Ehrenmitglied
Diola schrieb:
Install - hier findet sich eine bereits ausgewählte "sideload.zip" (sollte die geladene Datei etwa auf das Gerät verschoben und hier ausgewählt werden?)
Sorry, ja natürlich.
Ich bin davon ausgegangen, dass du die Datei direkt mit dem Tablet runter geladen hast.


Aber mach mal langsam. Du hast ja schon vorher per Fastboot das System aufgespielt. Du muss jetzt vermutlich nur noch einen Wipe machen.
Wenn du deine Daten gesichert hast (mit Titanium oder per Recovery) kannst du einfach auf den Punkt Wipe gehen und den Wipe ausführen.

Dann sollte dein Gerät wieder starten.
Anschließend kannst du mit Titanium Backup deine Sicherung wieder herstellen.
 
D

Diola

Fortgeschrittenes Mitglied
Backup führt ja leider zur Fehlermeldung bei etwa 30% und wird beendet. Per Titanium hatte ich zuletzt Montag früh alles gesichert. Das wäre ja schon mal was.

Dalvik und Cache Wipe führt zu "Failed" Meldung.


Hier mal eine grundsätzliche Frage: Bevor ich nach einem Fullwipe wieder anfange alles neu zu installieren, kann ich irgendwie das Gerät testen ob da etwas kaputt ist, es scheint doch langsam so? Also gibt es da Tools oder so etwas?
 
1907

1907

Ehrenmitglied
Also ich glaube nicht, dass du einen Hardwaredefekt hast.
Dass der Wipe zu einer Fehlermeldung führt finde ich sehr seltsam.

Ich würde als allererstes versuchen nur ein Backup von der Partition /data zu machen ..

Welche TWRP Version hast du denn drauf?
 
D

Diola

Fortgeschrittenes Mitglied
TWRP v2.7.1.0

Backup von Data läuft grade... und hat geklappt. :)

Der ursprüngliche Beitrag von 14:43 Uhr wurde um 14:52 Uhr ergänzt:

Jede versuchte Art von Wipe(noch nicht Full) führt zu "Failed".

E: Unable to mount '/cache'
ist die vorherrschende Meldung zu jeder Sache im Log.
 
Zuletzt bearbeitet:
1907

1907

Ehrenmitglied
OK, TWRP passt, und Backup hast auch.

Jetzt kannst den Fullwipe probieren. Schätze aber dass es auch abbricht, da ein Fullwipe auch cache und dalvik cache beinhaltet.

Der ursprüngliche Beitrag von 14:54 Uhr wurde um 14:57 Uhr ergänzt:

Vermutlich gibt es ein Problem mit der Partion Cache

Kannst du bitte folgenden Befehl via Fastboot (wie vorher) probieren:
Zurück in den Fastbootmode und an den PC anstecken. dann

fastboot format cache

jetzt wieder ins Recovery und den Wipe nochmal probieren
 
D

Diola

Fortgeschrittenes Mitglied
Sieht jetzt gut aus, läuft aber noch...

Ja hat geklappt.

Wie jetzt nochmal weiter? Reboot System hab ich gewählt und es werden Apps aktualisiert. :)


Ja es ist vollbracht!
4.4.4 und alles sieht aus wie vorher, wow.
Vielen, vielen Dank!
Was für ein Akt!

Hast du eine Idee wie es dazu kam?
Und kannst du vielleicht meine Frage von hier beantworten: https://www.android-hilfe.de/forum/...-mit-titanium-backup.358811.html#post-7717703 Wie man sinnvolle Backups mit Titanium erstellt.

Viele Grüße
Diola
 
Zuletzt bearbeitet: