Huawei P7: TCom B129 debranden bitte Hilfe!

  • 25 Antworten
  • Neuester Beitrag
Diskutiere Huawei P7: TCom B129 debranden bitte Hilfe! im Root / Custom-ROMs / Modding für Huawei Ascend P7 im Bereich Huawei Ascend P7 Forum.
hadis

hadis

Stammgast
Hallo Gemeinde

Ich habe hier ein P7 welches ich von der B129 befreien möchte. Ich habe das P7 gerootet und versucht die B133 zu flashen. Das Update mit der B133 schlug fehl, aber seitdem ist das T Logo weg und das normale Huawei Logo samt Jingle sind am Start. Allerdings habe ich nach dem Start immer eine Meldung " Defect report reminders" in den Benachrichtigungen. Jeder Versuch eine FW zu flashen auch fast update schlägt fehl selbst eine fashbare Zip lässt sich nicht über das recovery flashen. Ich brauch da mal bitte Unterstützung aus dem Forum, denn ich bin mit meinem Latein am Ende Bei all dem Gewusel mit dem P7 ist mir auch noch meine B133 abhanden gekommen und all die Links zu dieser FW führen leide ins leere. Ich hoffe das P7 ist noch zu retten. Vielen Dank für Euren Input schon mal vorab
 
L

L3Nn!

Erfahrenes Mitglied
Hi,
Welche Custom Rom hast du probiert? Versuch es mal mit twrp (ich glaube 2.8.6.0, aber schau lieber in der Se7en Rom Beschreibung nach) und der Se7en Rom 1.2. Danach die stock emui 2.3 recovery flashen und per dload ein Update mit der B133 (falls du einen Download findest) erzwingen. Nun sollte auch die 'defect report reminders' Meldung wieder weg sein..
 
hadis

hadis

Stammgast
Hallo L3Nn!

Vielen Dank für Deine Antwort. Ich hatte versucht die B133 über dload zu flashen. Das Ergebnis siehe oben. TWRP 2.8.10 habe ich installiert und darüber eine flashbare Zip von der TCom B129 gefasht. Die hatte ich mit dem Huawei Extractor vorher gemacht. Irgendwas muss schief gelaufen sein, denn jetzt blinkt die LED in Grün und rot und außer Huawei Ascend und powered by Android ist nicht mehr los auf dem Bildschirm. Bei Neustart bleibt das P7 wieder dort hängen. Bekomme auch keinen Zugang mehr zum TWRP Recovery oder mittels ADB vom Laptop.
ADB schreibt mir nach Eingabe von:

c:\adb-tools>adb devices
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
list of devices attached

c:\adb-tools


Ist das Teil noch zu retten? Hab keinen Plan. Ist mir noch nicht passiert bisher. Naja irgendwann ist immer Premiere. Danke für die Hilfe bisher und Hoffnung auf mehr davon

Nachtrag: Beim Starten blinkt 1 x rot dann 3 x grün und das ganze 3 x hinter einander.
 
Zuletzt bearbeitet:
L

L3Nn!

Erfahrenes Mitglied
Puh, das sieht nicht gut aus. Hast du beim Huawei-Update-Extraktor als Gerät das P6 angegeben (das P7 gibt es ja meines Wissens nach dort nicht). Bei den Xda-Developers hat jemand einmal genau das gemacht und das Gerät leider nicht mehr zum Laufen bekommen.

Dennoch würde ich versuchen, die B129 manuell und nacheinander per adb zu flashen (also fastboot flash boot boot.img, fastboot flash cust cust.img etc).. Sorry, mehr fällt mit gerade auch nicht ein, ich füge später noch den Link zum Xda Thread hinzu.
 
hadis

hadis

Stammgast
Hallo L3Nn!

Ja als P6 da kein P7 vorhanden war. Per ADB habe ich keinerlei Zugriff mehr auf das P7. Hatte es mit dem Befehl "adb reboot bootloader" probiert und als Antwort " no Devices" bekommen. Shit ADB kann ich wohl vergessen. Na es ist noch Garantie drauf. Ich werde mich mal dumm stellen und diesen Weg mal versuchen. Falls jemandem noch was einfällt ... ich bin immer dankbar für neue Ideen.
 
L

L3Nn!

Erfahrenes Mitglied
Kommst du in den Bootloader? Hier (Huawei P7: Bootloop / Softbrick - Partitionen zerschossen?) ist ein ähnliches Problem beschrieben, leider konnte niemand in den 3-4 Threads die ich zum Thema gefunden habe eine Lösung finden. Den Thread an den ich ursprünglich gedacht habe könnte ich leider nicht finden.

Einsenden wird dir vermutlich nichts nutzen, evtl musst du fürs Anschauen bezahlen, und eine Reparatur (Austausch des Mainboards) kostet bei Huawei 250€.Einen Versuch ist es evtl trotzdem wert..?

Kontaktiere bei den xda-developers evtl mal Kostyan_nsk und/oder surdu_petru. Wenn dir jemand helfen kann, dann wohl sie.

Und wenn alles schei*e läuft, dann kannst du dir immernoch ein defektes P7 für 50-100€ bei Ebay ersteigern und das Mainboard tauschen..

Viel Glück
 
hadis

hadis

Stammgast
Hallo L3Nn!

Alles was ich mittels ADB Tools zu flashen versuche endet am PC mit "waiting for device". Irgendwie wird das P7 auch nicht mehr erkannt, jedenfalls ist bei Anschluss am PC keinerlei Reaktion zu vermelden. Selbst Hi Suite bemerkt nichts davon. Einzig wenn das P7 am USB Kabel gesteckt wird , will es starten aber bis auf Huawei Ascend und Powered by Android kommt nichts mehr. Habe dann gestern den Accu leer fahren lassen in der Hoffnung das es sich eventuell bekrabbelt. Leider hat auch das nichts gebracht. Mit auslesen wird wohl ehr schwierig bis unmöglich werden oder was meinst Du? Auf Handy FAQ habe ich auch ein paar Unglücksraben gefunden mit dem selben Problem. Auch sie hatten keine brauchbare Lösung, bzw. haben sich dann nicht weiter gemeldet sodass eine mögliche Lösung im Dunklen liegt. Wie auch immer hab wohl Pech gehabt.

Hat einer einen Plan was der BlinkCode:

1 x rot und 3 x grün das ganze 3 x nacheinander besagt?

Wäre interessant was es genau bedeutet und könnte einer Lösungsfindung bestimmt dienen.
 
L

L3Nn!

Erfahrenes Mitglied
Was möchtest du denn auslesen? Ich denke, dass der Fehler und infolgedessen auch der Blinkcode auf eine falsche Partitionierung zurückzuführen ist..

Kenne mich da aber leider viel zu wenig aus, um dir helfen zu können.
 
hadis

hadis

Stammgast
Hallo L3Nn!

Danke für Deine Antwort. Ich habe ja keinen Zugriff egal was ich machen will. Es muss aber irgendeinen Weg geben um das Teil wieder zu Leben zu bringen. Das ist ja schließlich nur ein "Software Problem, welches ich verursacht habe. Ich glaube nicht das es da einer neuen Platine bedarf. Natürlich kann ich mich ja auch irren. Wenn kein Zugriff von außen möglich ist kann nichts ausgelesen werden oder irre ich mich da? Da das P7 fast ganz aus Glas ist selle ich mir einen Austausch der Hauptplatine sehr schwierig vor. Das bricht doch in alle Richtungen. Hat schon mal jemand so etwas versucht???
 
okadererste

okadererste

Ikone
So wie es klingt hast du keine System Partition mehr.
Du stehst in bootloader fest.
Du da darfst kein USB 3.0 verwenden!
Hi Suite und adb Tool ist auf den Rechner?
Dann versuche das hier
Huawei Ascend P7 Bootloop
 
hadis

hadis

Stammgast
Hallo okadererste

Vielen Dank für deine Antwort. Es gibt Neuigkeiten ;-). Ich habe es geschafft ins "Fastboot&recovery Mode" zu booten. Ich habe dort auch Zugriff mittels fastboot über ADB. Die Flashbefehle für das Boot.img und das system.img habe ich auch schon erflogreich gesetzt. Leider ist beim reboot das P7 wieder mit dem selben Blinken hängen geblieben. Ich habe vorher auf dem P7 TWRP 2.8.1.0 installiert komme aber nicht mehr ran. Ich habe keinen Plan wie ich das mit fastboot flashen soll. Irgendwie hat das P7, nach dem ersten Versuch die B133 zu flashen immer eine fehlende Cust.img bemängelt. Gibt es einen Befehl die wieder neu einzuspielen? Ich hab schon gesucht aber nicht zielführendes gefunden. Ich denke mal wenn ich die Boot.img, die cust.img, die system.img und die recovery.img iweder ins P7 flashen kann sllte das doch wieder laufen??? Ich hab das alles mit dem Huawei Extractor aus der B129 TCom extrahiert. Bremst mich wenn ich falsch liegen. Bitte zeigt mir die Befehle zum copy und past mittels ADB/fastboot. Danke schonmal
 
Zuletzt bearbeitet:
okadererste

okadererste

Ikone
Bleib dran und versuche es weiter. Hab scho oft gelesen das es bei mehrmaligem Flashen irgend wan geht.
 
hadis

hadis

Stammgast
Hallo Gemeinde

So nun ein kleines Update. Ich habe über den Fastboot&Rescue Mode mittels ADB/Fastboot erfolgreich das :
Boot.img
Cust.img
Recovery. img
flashen können. Dies sogar mehrmals. Was leider nicht ging war das flashen der system.img. Hierbei bekomme ich nach ein paar sec. Datei zu groß zu lesen und der Vorgang bricht ab. Beim Reboot blinkt die LED wieder fröhlich den bekannten Code. Über ADB Tools/Fastboot ist es ja auch möglich eine "update.zip" als ganzes System zu flashen Leider kann ich keine flashbare Zip für das P7 L10 finden. Frustet ganz schön wenn es nicht weitergeht. Für das L00, L05 und L09 gibt es eine Menge aber EMUI 2.3 und L10 find ich nix. Also wenn jemand einen Link hat bitte
 
Zuletzt bearbeitet:
okadererste

okadererste

Ikone
Mit den Update extructor befasst du die erforderlichen Daten extrahieren und danach in deine ZIP umwandeln
 
hadis

hadis

Stammgast
Hallo okadererste

Danke für die Antwort. Mit dem Extrator bin ich ja erst in die missliche Lage gekommen. Ich hatte bei den Einstellungen das P6 gewählt und aus der B133 SP01 eine flashbare Zip erstellt. Bis dahin hatte das P7 noch sauber gebootet aber nach dem Flash der von mir erstellten update.zip konnte ich mich an dem beschriebenen Blinklicht erfreuen. Ich komme im Moment auch nicht ins Fastboot&Recovery Mode, weil ich den Accu nachgeladen habe. Das ist wie verhext mit dem Teil. Irgendwo muss es doch auch schon fertig gepackte flashbare Zips für das P7 mit EMUI 2.3 geben. Ich hoffe das mal für mich. Mit meinem english ist das mal so "not the yellow from the Egg".
 
Zuletzt bearbeitet:
L

L3Nn!

Erfahrenes Mitglied
MyRom 1.2 und die Se7en-Rom 1.6 basieren auf der B1xx und emui 2.3. Wie flashst du denn eine 'vollständige' (Firmware).zip per adb? Ich dachte diese zips sind für cwm/twrp gedacht, die dann nacheinander system/cust/userdata/etc flashen, aber ich kann mich natürlich auch irren?
 
hadis

hadis

Stammgast
Hallo L3Nn!

Schön das Du Dich meldest und Danke für die Tipps. Man kann mit ADB auch flashen mit dem Befehl

fastboot update (filename.zip)

So steht es jedenfalls in der Übersicht wenn man fastboot aufruft. Ich dachte das könnte ich ja mal probieren aber leider funktioniert das nicht wirklich. In TRWP komme ich überhaupt nicht rein deshalb bin ich auf den Weg mit ADB gekommen. Ich habe versucht auf diese Weise das MyRom 1.2 auf die Maschine zu bekommen. Nach einer kurzen Zeit bekomme ich am Prompt:

c:\adb-tool>fastboot update MyRom1.2.zip
archives does not contain 'android-info.txt'
archives does not contain 'android-produkt.txt
error update package has no android-info or android-product.txt

c:\adb-tool>

dann bin ich wieder am Prompt. Ich habe schon x mal die Boot.img und auch die Cust.img sowie die Recovery.img auf das P7 geflasht und jedes mal ist es wie zuvor mit fröhlichen Blinklicht und Stehen beliben im Bootvorgang.
 
Zuletzt bearbeitet von einem Moderator:
hadis

hadis

Stammgast
Hallo noch ein Nachtrag

Wenn ich adb device eingebe wird nichts gefunden. Also keine Nummern oder Ähnliches.
 
MarkusK

MarkusK

Ikone
was ergibt die Eingabe von "adb version" ?
 
okadererste

okadererste

Ikone
Musst halt nur die Links von deiner ROM nehmen und natürlich dann auch den Namen der Befehle ändern.
Edit:
okadererste schrieb:
[HOW TO] ADB Tutorial (Anfängerfreundlich) – Android Forum - AndroidPIT

Anleitung wie ADB bzw Fastboot zu benutzen ist
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Bin jetzt nicht ganz sicher aber hisuite darf,glaube ich,nicht aktiv sein.
Ich hoffe das Sayde wach ist. Die ist da fitter drin.
Hab noch eine alte Anleitung von mir gefunden. Die ist für das Huawei Mate.
Bleibt ja alles gleich nur halt die Dateien.
 

Anhänge

  • Anleitung TWRP.pdf
    205,3 KB Aufrufe: 790