[ROOT][HowTo] MediaPad 10 FHD root

  • 147 Antworten
  • Neuster Beitrag
Comec

Comec

Stammgast
Threadstarter
ROOT Methode für ICS (Android 4.0.4) ROMs:

1. MediaPad an den PC anschliessen (HiSuite muss auf dem PC installiert sein)

2. In den Einstellungen vom Tablet muss USB-Debbuging in den Entwicklereinstellungen aktiviert sein

3. Genotools2.0.zip herunterladen, entpacken und Genotools-normal.exe starten

4. Auf ROOT klicken


5. Auf ROOT[1] und nachdem sich ein kleines PopUp Fenster geöffnet hat auf ROOT[2] klicken


6. Wieder das PopUp Fenster bestätigen auf dem PC bestätigen

7. Auf dem Tablet erscheint nun die Daten Wiederherstellung. Dort "meine Daten wiederherstellen" wählen

8. MediaPad startet nun zweimal hintereinander, danach sind ROOT Rechte vorhanden und die superuser App installiert.



ROOT Methode für JB (Android 4.1.2) ROMs:

Auf diese Seite gehen und die erforderliche zip Datei für die passende Firmware laden:
http://www.273k.info/?p=30

Danach die zip Datei entpacken, das MediaPad per USB an einen Windows PC anschliessen und die entpackte root.bat per doppelklick
ausführen. Das MediaPad wird nun in den fastboot mode versetzt und gerootet.

ACHTUNG: Bitte das Gerät solange nicht anfassen, bis das Gerät wieder sauber neustartet! Man hat das Gefühl es passiert nichts, denn das MediaPad ist eine zeitlang in stillstand mit einem schwarzen Bildschirm. So ist es aber nicht.


Weder ich, noch das Forum sind verantwortlich für eventuelle Schäden an Deinem Gerät


An dieser Stelle ganz herzlichen Dank für die leider noch nicht erfolgreiche Unterstützung einer ROOT boot.img Variante mit Segler11!
 

Anhänge

  • genotools2.0.zip
    2.3 MB Aufrufe: 6.132
Zuletzt bearbeitet:
G

gasgiver

Neues Mitglied
Vielen Dank dafür comec ! Funktioniert bestens.
Brauch ich nicht selber forschen.
Du hast nicht zufällig funktionierende fastboot drivers entdeckt.
Ein fastboot oem unlock wäre ja ein weiterer schritt ...
 
Comec

Comec

Stammgast
Threadstarter
Moin,
ja sehr gerne! Schreib doch bitte noch was Du genau für ein Modell hast und welche Firmware Du damit rooten konntest... Für die Anderen sozusagen ;)

Fastboot ist genau das Problem, dass ich derzeit habe. ADB funzt 1a, aber fastboot geht nicht! War die letzten Tagen am Verzweifeln!
 
L

Listo

Erfahrenes Mitglied
Comec

Comec

Stammgast
Threadstarter
Also die *.app kann man auch mit der Android Kitchen entapcken, über nen Hexeditor findet man auch die boot.img, die man dann auch über die Küche entpacken kann.
Die Treiber von Deiner Quelle hatte ich schon genommen, leider geht es damit auch nicht. Fastboot findet das MediaPad nicht. :(
 
L

Listo

Erfahrenes Mitglied
Also du entpackst die Datei mit dem Kitchen und muss dann noch mit dem Hexeditor dran.
Das verstehe ich nicht. Beim kleinen Bruder waren die Dateien nach dem entpacken der update.zip alle sichtbar. Hier nicht ?
 
Comec

Comec

Stammgast
Threadstarter
Nein hier nicht. Die Dateien sind unbekannt und man muss von den unbekannten Dateien erst per HexEditor die boot.img finden. Beim kleinen Bruder kann man die update.zip auch problemlos mit einem Zip Programm öffnen und hat so die einzelnen Teile.
 
G

gasgiver

Neues Mitglied
Fastboot Treiber hab ich jetzt am rennen.
Von Windows wird das Gerät auch im FB Mode korrekt erkannt.
Aber fastboot devices zeigts nicht an und ein fastboot oem unlock
bringt nur "waiting for device" Verhält sich also quasi so, als wärs Gerät nicht im FB Mode angeschlossen *mpfffff*

Ich hab das Gerät aus China. Europäische Firmware mit Playstore usw. geflasht.
16GB Wifi only mit 2GB RAM und 4x 1.4 GHz
 
S

segler11

Gast
gasgiver schrieb:
Fastboot Treiber hab ich jetzt am rennen.
Von Windows wird das Gerät auch im FB Mode korrekt erkannt.
Aber fastboot devices zeigts nicht an und ein fastboot oem unlock
bringt nur "waiting for device" Verhält sich also quasi so, als wärs Gerät nicht im FB Mode angeschlossen *mpfffff*

Ich hab das Gerät aus China. Europäische Firmware mit Playstore usw. geflasht.
16GB Wifi only mit 2GB RAM und 4x 1.4 GHz
Es gibt keine fastboot treiber, nur adb treiber. Also wenn adb geht sind die treiber ok. Fastboot liegt im bootloader, bis jetzt noch keine ahnung warum sich das pad nicht in fastboot versetzen lässt.
 
E

engländer

Ambitioniertes Mitglied
Also bei mir geht das rooten nicht!

Hatte schon die meisten Apps drauf, intern. Firmware, wie hier verlinkt.
Habs im HiSuite-Modus gerootet, ansonsten wie beschrieben.
Nach Punkt 7 (Frage nach Wiederherstellen - ja) kam die Abfrage des Gerätepasswortes (leer gelassen), danach bootete das Gerät einmal und es erschien die Android-Oberfläche mit schwarzem Hintergrund und flackernden Symbolen und extrem verzögerten Reaktionen und es passierte nichts mehr. Nach manuellem Neustart wieder der schwarze Flackerscreen.

Hab dann die Firmware nochmal neu draufgezogen (lief dann wieder normal), unroot mit gentools, manueller Neustart und nochmal gerootet - selbes Ergebnis. Bin am Verzweifeln.
War der HiSuite-Modus richtig? Oder muss ich als MTP oder USB verbinden?

Ohne Root ist das Gerät nur die Hälfte wert, da läuft vieles nicht.
Hat jemand ne Idee?
 
Comec

Comec

Stammgast
Threadstarter
Verbinde das Gerät mal als MTP und versuche es noch einmal.
 
E

engländer

Ambitioniertes Mitglied
Genau der selbe Mist. Es flackert nur noch, kann jetzt noch mal die Firmware drüber ziehen, damit wieder etwas läuft.
Ohne Titanium Backup kann ich ja nix übernehmen und das läuft nun mal nur unter Root :-(
 
G

gasgiver

Neues Mitglied
Hallo Engländer,

das Problem hatte ich auch erst. Habe dann die FW nochmal neu aufgespielt, vorher Tablet Werkseinstellungen wiederhergestellt.

Wichtig ist, das Tablet muss während des gesamten Vorgangs (auch während der automatischen Reboots) am PC angeschlossen bleiben und die ChinaRoot Software muss geöffnet bleiben. Die tut nämlich auch nach/während der Reboots nochwas.
So hats bei mir dann funktioniert.
 
E

engländer

Ambitioniertes Mitglied
@gasgiver: hast du MTP oder HiSuite als USB-Verbindung genommen?
Bei HiSuite öffnet sich diese immer auf Tablet und Laptop. Nicht dass es da zu Konflikten kommt.
 
G

gasgiver

Neues Mitglied
Nach dem Zurücksetzen und FW flashen geht die hisuite am tablet nicht direkt auf.
Was aufgeht, ist die Auswahl des Modus. Dort ist nichts vorausgewählt, das hab ich so gelassen. Ansonsten würde ich zur hisuite auswahl tendieren, das sollte auch passen. Die hisuite am PC hatte ich geschlossen.
 
E

engländer

Ambitioniertes Mitglied
Nun gehts auch bei mir. Hier der Workaround:

1. Die Huawei-Dienste am PC entfernen.
1a Dienst "HuaweiHiSuiteService64" deaktivieren (z. B. mit "msconfig" in den Programmen)
1b Huawei-Autostart deaktivieren z. B. mit der Freeware "auroruns" von sysinternals unter HKCZ\Software\Microsoft\Windows\Current\Version\Run den Schlüssel "Mobile Partner" deaktivieren
2. PC neu starten
3. Firewall am PC deaktivieren (bei mir blockt Kaspersky z. B. viele Webseiten)
4. Tablet zurücksetzen
5. USB Debugging einschalten usw.
Bei der Abfrage der Art der USB-Verbindung auf dem Tablet habe ich nichts angegeben. Das lief auch so.

Nun läuft das Tablet wie es soll.
Vielen Dank für eure Hilfe!
 
G

gasgiver

Neues Mitglied
Bitte gerne ;-) Freut mich, das es nun auch bei Dir läuft.
 
Comec

Comec

Stammgast
Threadstarter
Whow, also ich musste nicht so viel biegen, dass es geht. Aber dennoch super, dass es bei Dir funktioniert! :)
 
N

Neilpride

Neues Mitglied
Hi. Danke für das manual. Mich würde hier noch interessieren, ob nach dem rootvorgang die Einstellungen und Programme die vorher schon drauf waren alle wiederhergestellt werden oder ob das pad dann blank ist. Hat schon jemand custom FW wie zb. Cyanogen gesehen und funktioniert clock work mod recovery bootloader?

Vielen Dank für die Hinweise
 
Comec

Comec

Stammgast
Threadstarter
Es bleibt alles wie es ist, nur danach hast Du ROOT Rechte und die installierte SuperUser App.
Custom FW oä. habe ich noch nicht gesichtet, aber man darf auch nicht vergessen, dass das MediPad noch nicht wirklich lange auf dem Mark ist. Wird vielleicht noch was kommen.
 
Oben Unten