System zerschossen.. Kein OS mehr installiert.

  • 41 Antworten
  • Neuester Beitrag
Diskutiere System zerschossen.. Kein OS mehr installiert. im Root / Custom-ROMs / Modding für Huawei P9 im Bereich Huawei P9 Forum.
W

wernerschnell

Gast
Ein Arbeitskollege wollte so nett sein und mir eine Custom Rom installieren.
Nun ist auf meinem P9 gar kein OS mehr drauf, in das TWRP 3.1.1-0 komme
ich zwar noch rein, aber keine der verfügbaren Roms läßt sich installieren.
Gibt es jemanden der mir eine Idiotensichere Anleitung geben kann?
Mit den normalen komme ich nicht wirklich weiter, und der Arbeitskollege
ist eh für mich aus dem Thema raus. Zuvor war die B182 installiert, falls
das wichtig sein sollte. Phone und FRp sind unlocked.
 
W

wernerschnell

Gast
Danke für den Link, diese Version hatte ich auch schon versucht. Leider kommt bei der Installation
aber auch nur Fehlermeldungen. Denke mal es hat was mit der geforderten B386 Version zu tun,
zumal bei mir kein Android 7 drauf war, sondern 6.
 
Miss Montage

Miss Montage

Ehrenmitglied
Hast Du ein EVA-L09 oder EVA-L19?
 
W

wernerschnell

Gast
EVA-L09
 
Miss Montage

Miss Montage

Ehrenmitglied
Als ersten Schritt zur Wiederherstellung kannst Du diese Dateien herunterladen (EVA-L09C432B182)
update.zip
update_data_full_hw_eu.zip
update_data_full_hw_normal.zip

Die erste Datei entpackst Du und "zerlegst" die enthaltene UPDATE.APP mit dem [TOOL] Huawei Update Extractor [UPDATED: v0.9.9.5] | OPEN-SOURCE LIBRARY

Dann brauchst Du - falls noch nicht vorhanden: Minimal_ADB_Fastboot_1.4.2
Verbinde das Handy mit dem Rechner und drücke gleichzeitig die "Leiser"-Taste. Am Rechner startest Du die Powershell aus dem Output-Ordner des Huawei Update Extractors und gibst folgendes ein:
Code:
fastboot flash boot BOOT.img
fastboot flash system SYSTEM.img
Das wird höchstwahrscheinlich noch nicht reichen, um das Gerät wieder zu starten, aber zwei wichtige Partitionen sind damit wiederhergestellt. Versuche das Gerät neu zu starten...
 
W

wernerschnell

Gast
1000 dank es läuft wieder! :thumbsup:
 
Miss Montage

Miss Montage

Ehrenmitglied
Na wunderbar, das war ja einfacher als gedacht. Falls Du Dein Betriebssytem auf herkömmliche Weise aktualisieren möchtest, solltest Du TWRP noch durch das Stock Recovery ersetzen.
(aus dem gleichen Ordner)
Code:
fastboot flash recovery RECOVERY.img
 
W

wernerschnell

Gast
Das hat leider nichts gebracht. Wollte gerade noch fragen wie ich TWRP wieder los werde und ggf. den Bootloader schließe.
 
Miss Montage

Miss Montage

Ehrenmitglied
Wie bootest Du ins TWRP? Mit "Lauter" und "Ein/Aus" und ohne Kabel? Vielleicht hat Dein Kumpel TWRP in die zweite Recovery-Partition installiert... Hat Fastboot eine Fehlermeldung ausgegeben?
 
W

wernerschnell

Gast
Ja, komme da aber auch rein wenn ich auf Einstellungen, Erweiterte Einstellungen, sicherung und zurücksetzten, Werkseinstellung gehe.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
beim starten kommt die Meldung "your device has been unlocked an can't be trust"
in TWRP kommt faild to mount /data
 
Miss Montage

Miss Montage

Ehrenmitglied
Die erste Meldung heißt, dass der Bootloader entsperrt ist, die zweite hängt meines Wissens damit zusammen, dass TWRP mit den Verschlüsselung nicht klarkommt.
Gibt es denn eine Fehlermeldung von Fastboot, wenn Du den Befehl wie in Beitrag #8 eingibst?
 
W

wernerschnell

Gast
C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot flash recovery RECOVERY.img
target reported max download size of 471859200 bytes
sending 'recovery' (35732 KB)...
OKAY [ 1.141s]
writing 'recovery'...
FAILED (remote: Command not allowed)
finished. total time: 1.156s
C:\Program Files (x86)\Minimal ADB and Fastboot>
 
Miss Montage

Miss Montage

Ehrenmitglied
Ist in den Entwickleroptionen USB-Debugging aktiviert? Falls ja, solltest Du versuchen, den Bootloader nochmals zu entsperren (der ist manchmal nur "halb offen":
Code:
fastboot oem unlock xxxxxxxxxxxxxxxxxxx(Dein Code)
 
W

wernerschnell

Gast
ok hat jetzt auch geklappt. wie bekomme ich jetzt noch den bootloader wieder zu?
dann ist ja alles wieder tuti :)
danke für die hilfe
 
Miss Montage

Miss Montage

Ehrenmitglied
Am besten, indem Du beim nächsten Update auf die drei Punkte oben rechts gehst und "vollständiges aktuelles Paket herunterladen" auswählst. Das muss nicht funktionieren, aber bei vielen Nutzern wurde der Bootloader so wieder geschlossen.
 
W

wernerschnell

Gast
Update hat geklappt, bin jetzt auf C432B386. Der Bootloader ist immer noch offen.
 
Miss Montage

Miss Montage

Ehrenmitglied
Hast Du denn auch die Vollversion herunter geladen? Falls es so nicht klappt (beim letzten Update habe ich nur das kleinere OTA-Paket installiert), bliebe noch ein Rollback.
Downgrade von B360 zurück auf B182
 
Zuletzt bearbeitet von einem Moderator:
Bearbeitet von Holzi001 - Grund: Richtigen Link ergänzt.
H

Hootdoog

Neues Mitglied
@Miss Montage

Hallo habe leider, wohl aus doofheit :sad:, mein p9 zerschossen hängt immer im boot und auch das laden über Internet boot geht nicht, alles was ich runter geladen habe hängt er sich spätestens nach 35% auf oder nimmt es gar nicht war vorher Android 6 183 drauf.
habe die Anleitung mit Update Extractor usw. versucht komme damit aber leider überhaupt nicht klar. Bitte um schnele Hilfe da ich das Handy auch geschäftlich benötige. Vielen Dank schon mal.
 
Miss Montage

Miss Montage

Ehrenmitglied
Genauer als zuvor kann ich es auch nicht erklären, zumal ich selbst einen Linux-Rechner nutze und zum Entpacken der UPDATE.APP ein Perl-Skript nutze... Hast Du ein EVA-L09 oder EVA-L19?