Oma rockt Genio (III): Custom Firmware

  • 207 Antworten
  • Neuester Beitrag
Diskutiere Oma rockt Genio (III): Custom Firmware im Root / Custom-ROMs / Modding für Odys Genio im Bereich Odys Genio / Xelio 7 Pro Forum.
Oma7144

Oma7144

Lexikon
Update Post #1 auf v1.2.

Umstellung aller Builds auf CWM 6.0.1.5, da bessere Kompatibilität.

Images werden damit als NANDROID Backup austauschbar.

Bitte das Backup Format immer auf tar stellen (chose backup format).


:thumbup:
 

Anhänge

Zuletzt bearbeitet:
CiR3

CiR3

Erfahrenes Mitglied
mahlzeit und frohes neues jahr alle zusammen,
hat jemand eventuell eine touch variante des cwm recovery für das genio getestet oder sogar parat zum upload?

danke im voraus.
lg
 
D

darkom

Neues Mitglied
Hey oma,

Ich hätte eine kurze Frage zu dem Skype Problem was ich hier beschrieben habe:

https://www.android-hilfe.de/showthread.php?t=354957

Kurz: Skype nimmt das VGA Bild der Kamera aber stellt nur einen 320x240 Ausschnitt daraus dar (also keine skalierte Version des Bildes sondern wirklich nur eine stark gezoomten relativ kleinen Ausschnitt daraus)

Ich habe die xda Skype Version mal ausprobiert und dort konnte ich die richtige Auflösung zwar einstellen aber dann wurde entweder das Bild bei mir schwarz oder mit anderen Einstellungen beim gegenüber

Denkst du,dass sich das durch deine custom Rom lösen lässt?

Edit: oder ist es bereits gelöst?

Du bist jedenfalls die letzte Hoffnung dass ich das tablet noch behalten kann :)
Weil ich das tablet für meine Eltern vor allen zum skypen gekauft habe

Gesendet von meinem Galaxy Nexus mit Tapatalk 2
 
Oma7144

Oma7144

Lexikon
Welche xda Version(en) hast du denn getestet?


:thumbup:
 
D

darkom

Neues Mitglied
Beide von xda....die aktuellere (v18) und die von etwas ältere von droidx

Gesendet von meinem Galaxy Nexus mit Tapatalk 2
 
R

Rick1000

Neues Mitglied
So nun hat es auch endlich bei mir geklappt. Etwas verwirrend war die Sache mit den Treibern. Diese liesen sich nicht installieren (trotz deaktivierter UAC). Im Gerätemanger wurde das Genio als NV70 oder RV70 angezeigt aber keiner der Treiber wurde akzeptiert.

Aber das RKAndroidTool hat das Genio trotzdem erkannt (wohl durch die Treiber die für das Rooten installiert waren). Irritiert hat mich, das der Bildschirm beim Genio schwarz blieb und nicht im CWM gestartet ist, darum habe ich das mit der Erkennung über das RKAnroidTool auch nicht sofort mitbekommen.

Das Starten mit Volume-Up hat überhaupt nicht geklappt und teilweise ging das Genio gar nicht mehr an. Reset hat aber geholfen.

Die Installation hat dann aber so wie beschrieben geklappt. Das einzige was mir bisher aufgefallen ist, ist die CPU die als ARM7 und nicht als ARM9 angezeigt wird.

Die DSLR Controll von Chainfire App (der einzige Grund warum ich das Tablet überhaupt bestellt habe) geht jetzt.

Viele Dank nochmal und wenn mir jemand erklärt wo der "Danke Button" ist, dann benutze ich den auch nochmal gerne explizit.
 
hävksitol

hävksitol

Ehrenmitglied
Zum Danke-Button s. hier unter "Danke sagen".
 
R

Rick1000

Neues Mitglied
Nachdem ich jetzt einige Zeit rumgespielt habe sind mir folgende Dinge aufgefallen.

Der File Manger HD ist langsam und reagiert sehr träge. Kopieren übers Netzwerk dauert ca. 3 Mal länger als mit dem File Manger der ursprünglich drauf war.

Dem Kernel Tuner entnehme ich, daß sich ein Kern permanent abschaltet, was sich in den Einstellungen ändern läßt.

MX Player und BubbleUPnP zeigen keine Videos mehr mit HW-Rendering an.

Über die Akkulaufzeit kann ich noch nicht wirklich was sagen, da mittlerweile andere Prozesse als vorher laufen und ich noch nicht rausgefunden habe, was für mich abschaltbar ist. Gefühlt hält der Akku nicht mehr ganz so lange wie vorher.

Insgesamt wirkt das Genio weniger performant als vorher. Meine Frage ist nun, ob es nur an den Apps liegt oder am ROM selber ?
 
Oma7144

Oma7144

Lexikon
Verräst du uns noch, welches Rom du getestet hast?


:thumbup:
 
R

Rick1000

Neues Mitglied
Ja sorry, bei mir läuft

oma_rk30_cm10_v1_1
 
R

Rick1000

Neues Mitglied
Ein neues Problem ist aufgetreten. Ich kann kein Bild mehr als Hintergrundbild festlegen. Wenn ich ein Bild auswähle erscheinen die Begrenzungslinien, aber so wie ich auf einen der Punkte drücke oder eine Auschnittsauswahl treffen möchte, schrumpfen die Linien auf einen winzigen Ausschnitt zusammen.

Wenn ich auf "Als Hintergrund festlegen" drücke, bekomme ich eine Fehlermeldung die besagt, das dasz ugeschnittene Bild nicht gespeichert werden konnte.
 
Oma7144

Oma7144

Lexikon
Ich habe mal versucht, dies zu reproduzieren:

- System frisch installiert
- vorgeschlagene Updates aus dem Playstore geladen
- MX Codecs geladen

Video mit HW-Decoding geht. Wallpaper festlegen geht auch.

Vielleicht setzt du das System einfach mal zurück.


:thumbup:
 

Anhänge

CiR3

CiR3

Erfahrenes Mitglied
@oma
Mahlzeit,
Besten dank für deine Bemühungen. Deine Rom läuft sauber und stabil.
Wollte trotzdem, ohne zu nerven, nach einer touch Version des cwm recovery fragen. Meine versuche über den builder sind leider fehlgeschlagen und bei erfolgreichen builds hat das tablet leider nicht gebootet. Kannst du dahingehend was machen?

Besten dank im voraus für deine Antwort.
lg
 
Oma7144

Oma7144

Lexikon
Hab dir mal eine CWM Touch gebaut. Der Stock-Kernel unterstützt die aber nur begrenzt. Scrollen ist
möglich, aber keine Eingaben.


:thumbup:
 

Anhänge

CiR3

CiR3

Erfahrenes Mitglied
Danke, werde es mir mal anschauen. :thumbup:
Lg
 
R

Rick1000

Neues Mitglied
Ich habe einen Reset durchgeführt (hoffe das war mit System zurücksetzen gemeint).

Treiber für den MX Player sind runtergeladen.
Videos mit "HW" gehen nach wie vor nicht. Aber einiges läßt sich jetzt mit HW +decode abspielen, allerdings hängt sich der MX Player häufiger mal für ca. 1 Minute auf.

Hintergrundbilder festlegen und ausschneiden geht genausowenig wie vorher. Weder mit dem Novalauncher noch mit Trebuchet.

Der Novalauncher saugt definitiv mehr Strom, habe ich festgestellt.

Der alternative Filemanger funktioniert allerdings besser/schneller als der Filmanger HD bei mir.

Erstmal Danke an OMA für die Bemühungen, vielleicht fällt Dir ja noch was ein, was ich noch machen könnte.
 
Oma7144

Oma7144

Lexikon
Ja. Zurücksetzen heißt unter Einstellungen/Sichern&zurücksetzen die Option "Auf Werkzustand zurück"
ausführen. Damit werden alle Userdaten und darin ggf. enthaltene "Missmatches" beseitigt.

Hilft das nicht, dann ist wahrscheinlich auf der Systempatition was kaputt gegangen. Als Rootuser kann man
ja da so einiges anstellen. Dann bitte das Image komplett neu flashen.


:thumbup:
 
R

Rick1000

Neues Mitglied
"Auf Werkszustand zurücksetzen", hat das Problem mit den eignen Hintergrundbildern teilweise gelöst. Es geht nun mit dem Novalauncher. HW und HW +decdode gehen gar nicht mehr beim MX Player.

Ich probiere jetzt noch mal einen anderen Player und wenn das auch nicht klappt, flashe ich das Rom neu. Allerdings mache ich mir da keine großen Hoffnungen.

Trotzdem vielen Dank.
 
O

otti17

Erfahrenes Mitglied
Hallo Oma,
hab zwar kein Odys, aber ich halt mich immer wieder mal aufm Laufenden und beneide gradezu die OdysCommunity um Dich. Chapeau! sage ich ma, wie schnell du Rom bastelst und nebenbei auch ma n Touch CWMR bastelst.
Für mein Huawei U8836D gibts zwar n CustomROM aber trotz vorliegender KernelSourcen noch nix weiter in Richtung mod. Kernel oder ähnliches.
Wie schon geschrieben, wollt hier nur ma meine Anerkennung kundtun. Vlt hole ich mir ma das Völknertablett für die Couch :)
 
M

MichaelNe

Ambitioniertes Mitglied
Ich musste leider feststellen, dass unter der Version 2.3 deiner ansonsten wirklich grandios guten Firmware Need for Speed Most Wanted schwere Grafikfehler zeigt. Die Fahrzeuge werden korrekt texturiert dargestellt, sämtliche Hintergrundtexturen bleiben jedoch schwarz oder werden nur als Gerüst angezeigt.
Schade eigentlich, weil ansonsten alles perfekt läuft.