Der Magisk-Sammelthread - Root, Module, SafetyNet [Magisk 16]

  • 72 Antworten
  • Neuester Beitrag
Diskutiere Der Magisk-Sammelthread - Root, Module, SafetyNet [Magisk 16] im Root / Custom-ROMs / Modding für OnePlus 3 im Bereich OnePlus 3 Forum.
Lucian77

Lucian77

Stammgast
Auch über den Magisk Manager geflasht --> keine Probleme.
Bin auf dem aktuellsten LOS.

Gruß
 
fad-joe

fad-joe

Erfahrenes Mitglied
Habs jetzt hin bekommen. Irgendein Modul, entweder Google Dailer oder Channel Bonding 2.4Ghz, haben dafür gesorgt das es zu einem Bootloop kam.
 
edgonzo

edgonzo

Experte
War bei mir auch so, habe dann alle Module deaktiviert, nicht deinstalliert, und dann geflasht und siehe da es geht.
 
stewwert

stewwert

Erfahrenes Mitglied
Ich bin von 13.3 per Manager auf 14.0 gegangen =kein WLAN mehr! Werde es nochmal ohne Module versuchen.
 
AcmE85

AcmE85

Lexikon
@stewwert
Du nutzt vermutlich einen Custom-Kernel. Falls ja muss dieser stets nach jedem Magisk-Update erneut geflasht werden. Auch wenn sich die Kernel Version nicht ändert.

Habe die Info nun auch im Startpost hinzugefügt.
 
stewwert

stewwert

Erfahrenes Mitglied
Werde also am besten so verfahren: dirty flash der ROM + magisk 14.0 + custom kernel ?!
 
AcmE85

AcmE85

Lexikon
@stewwert Kannst du so machen. Evtl. reicht es aber auch nur noch den Kernel drüber zu flashen.
 
stewwert

stewwert

Erfahrenes Mitglied
So gemacht: die Welt ist bunt, die Welt ist schön - dankeschön!
 
TomTim

TomTim

Ehrenmitglied
Das hört sich gut an. Nutze Magisk nämlich ebenfalls schon seit geraumer zeit.
 
AcmE85

AcmE85

Lexikon
Magisk 14.5 (Beta) wurde kürzlich veröffentlicht.
Einen ausgiebigen Changelog gibt es hier:
[2017.11.23] Magisk v14.0 - Root & Universal Systemless Interface [Android 5.0+] - Post #32

Neben zahlreichen Bugfixes und Optimierungen wurde Magisk Hide deutlich aufgebohrt und soll nun auch bei Bank-Apps besser funktionieren.
More and more apps (those that doesn't use Google's SafetyNet API to check device integrity) has been updated to detect Magisk, such as the popular game Fate Grand Order and a handful of banking apps. I got bored and had my hands on to fix this issue. The fix can be roughly split to two parts, both of them are future proof to a certain extent. There are still some stuffs that can be detected, but even if I can hide them easily I haven't bothered yet. Unless they come up with complete new innovative ways to detect Magisk, the new hiding method should work in all cases (at least for now).
Download wie immer hier:
[BETA][2017.11.24] Magisk v14.5 (1456)

Zum updaten einfach in TWRP drüber flashen und neustarten.
Nutzt man einen Custom Kernel dann diesen erneut nach Magisk flashen und dann erst neustarten.
 
Zuletzt bearbeitet:
Lord Amalon

Lord Amalon

Neues Mitglied
Hallo, ich möchte nun auch auf Magisk umsteigen. Habe derzeit die Beta27 mit SuperSU laufen
und möchte die ROM unter TWRP (bluspark50) komplett neu flashen (=clean install) und dann neu einrichten

Geplante Vorgangsweise:

1) In SU "Full unroot" wählen
2) Reboot to TWRP
3) TWRP factory reset
4) Flash OxygenOS Beta27 Full Rom
5) Flash Magisk Beta v14.5
6) Flash TWRP (blusparkv50)
7) Reboot system
8) Magisk Manager starten

Ist das vom Ablauf so korrekt ?

Danke ! :)
 
fad-joe

fad-joe

Erfahrenes Mitglied
Ich habe einfach die beta nochmal dirty geflasht und danach gleich Magisk statt SuperSU. Nach dem Neustart habe ich dann noch die SuperSU App gelöscht. Läuft alles einwandfrei. Wenn du es clean aufsetzen willst, dann
1. TWRP flashen (Wenn du schon TWRP drauf hast eigentlich nicht notwendig)
2. Factory reset (Achtung, nicht den internen Speicher)
3. Beta 27 flashen
4. Magisk flashen
5. Wipe Cache/Dalvik
6. Keine Panik beim langen ersten Start schieben ;-)
 
Zuletzt bearbeitet:
fad-joe

fad-joe

Erfahrenes Mitglied
Seit neustem kommt bei Öffnen der Google Dailer App eine Meldung:Ihr Telefon wird nicht unterstützt...
Stört nicht in der Funktion, nervt aber. Bekommt man die irgendwie weg?
 
AcmE85

AcmE85

Lexikon
Magisk 14.6 Beta ist raus.
[BETA][2017.12.22] Magisk v14.6 (1468)

edit: das Update lief wie immer problemlos.
TWRP -> flashen - > Neustart


edit:

Magisk 15 stable
[2017.12.26] Magisk v15.0 - Root & Universal Systemless Interface [Android 5.0+]
[2017.12.26] Magisk v15.0 - Root & Universal Systemless Interface [Android 5.0+] - Post #34

Edit:
Die aktuellen Versionen 15.0 und 15.1 können Probleme beim Bootvorgang verursachen, wodurch man im Bootloop landet.
In diesem Fall muss die Rom und Magisk 14.6 geflasht werden.

Edit:
Magisk 15.2 fixt die bestehenden Probleme.
 
Zuletzt bearbeitet:
AcmE85

AcmE85

Lexikon
Es gibt ein neues Magisk Modul welches den aktuellen Google Dialer, Kontakte, Messenger, Taschenrechner und die Uhr mitbringt.
Ich habe es gerade auf meinem OP3 mit Beta 29 und Magisk 15.2 getestet und es funktioniert fehlerfrei.
Die bestehenden System-Apps werden ausgeblendet. Einzig das Telefon muss man nach einem Neustart als Standard-Telefonie App und den Messenger als Standard für SMS einstellen.

Google Pixel/Nexus Experiance TWRP Installer/Magisk Module

Mit den bisher verfügbaren Magisk Modulen für den Dialer wurde ja bei jedem App-Start eine kurze Fehlermeldung bezüglich fehlender Kompatibilität angezeigt.
Das Problem gibt es hiermit nicht mehr.
Endlich wieder hochwischen zum abnehmen! :thumbup:

Auch habe ich den Eindruck dass der Google Dialer deutlich "nachgiebiger" mit dem Näherungssensor ist.
Beim OP Dialer schaltet sich das Display beim kleinsten Abstand zum Kopf häufiger während eines Gesprächs ein.
Die zusätzlichen Google Funktionen laufen wunderbar und auch das abnehmen per PopUp-Benachrichtigung
aus dem laufenden Betrieb heraus klappt fehlerfrei.

Demnächst soll das Modul wohl noch um weitere Apps und Funktionen erweitert werden,
das wäre für mich persönlich dann aber wieder zu überladen.
 
Zuletzt bearbeitet:
B

Berlifan

Fortgeschrittenes Mitglied
@AcmE85
kann es sein das mit der Beta 30 der Google Dialer nicht mehr funktioniert?
Nach Installation finde ich die App nicht mehr. Keine Fehlermeldung von Magisk während der Installation.
Wenn doch muss ich mal wieder clean installieren...
 
AcmE85

AcmE85

Lexikon
@Berlifan Hab damit auf Beta 30 schon telefoniert. War nach dem OOS Beta Update mit darauffolgendem, direktem flash von Magisk 15.3 und anschließendem Neustart ins System wie gewohnt verfügbar.
 
A

anatomie26

Gast
Hallo! Momentan ist ja die 15.4 beta von Magisk draußen. Kann ich die einfach mit TWRP über die 15.3 drüber installieren, oder erst ein Magisk Uninstall durchführen ?
 
Ähnliche Themen - Der Magisk-Sammelthread - Root, Module, SafetyNet [Magisk 16] Antworten Datum
1
5
6