Jetzt kostenlos registrieren: Mitglieder surfen ohne Werbung!

TWRP Problem Resurrection Remix OS zurückgesetzt

  • 4 Antworten
  • Neuester Beitrag
Diskutiere TWRP Problem Resurrection Remix OS zurückgesetzt im Root / Custom-ROMs / Modding für OnePlus 3 im Bereich OnePlus 3 Forum.
W

wellstation

Neues Mitglied
Hallo Gemeinde,

erstmal zu den Daten:
Devices: OP3
momentanes TWRP: 3.1.0.0
momentanes Modem / Firmware: 4.1.1
momentanes OS: Resurrection Remis / oneplus-unified-3-3T -> RR-N-v5.8.2-20170327-oneplus3-Official.zip
momentane Gapps: Open-Gapps: ARM64 7.1 pico
momentanes Format: System etc -> f2fs / Userdata not encrypted -> f2fs

Ich habe schon einige Zeit jetzt in diversen Forum mit lesen und testen zugebracht, hab auch im XDA mein Problem geschildert und würde jetzt gern auch hier mein Anliegen schildern (weil ich der englichen Sprache nicht ganz so mächtig bin).

Zu meinem Anliegen:
Egal welches der nachfolgenden OS ich per Clean Install (cache, dalvik, data und system) auf das OP3 flashe, sobald ich ins TWRP (jetziger Stand 3.1.0.0) boot -- selbst wenn ich dort nichts mache -- und dann gleich wieder System boote muss ich alle OS Einstellungen samt Sprache, Uhrzeit ect ect neu machen. Auch die Apps muss ich neu installieren. Ich hab es mit verschiedenen TWRP Versionen probiert: 3.0.2.0 / 3.0.3.0 / 3.1.0.0. Auch habe ich immer den internen Speicher gecleant. Es wurde mit ext4 und f2fs (alle Partionen) getestet. Ein "dm-verity" wird nicht beim starten angezeigt. Diesen hab ich nach einer Anleitung wieder entfernt (Firmware+Modem 4.0.3 -> entfernen -> Firmware+Modem 4.1.1.)
* Resurrection Remix
* Lineage OS
* Citrus CAF
* Freedom OS

Selbst wenn ich das RR OS flashe, den Magisk uninstaller gleich hinterher, die Gapps, dann SuperSu, Dalvik...wipe -> neustarte OS läuft -> mache meine Einstellungen -> boote ins TWRP, mache dort nichts -> boote ins System ==> alles weg muss neu einstellen und apps neu installieren.

Auf'm OPO hab ich jetzt schon 7 OS getestet und teilweise im Produktiveinsatz und noch nicht diesen Fehler gehabt.

Habt Ihr Ideen?
Noch älteres TWRP verwenden und vorher alles auf ext4 setzen?
Anderes Recovery nutzen?
 
W

wellstation

Neues Mitglied
Danke für die Hilfe zur Selbsthilfe...nach weiteren Suchen und lesen in diversen Sprachen is the problem fixed.
TWRP sollte hier sein Recovery etwas entbugen...

Tread closed please..
 
W

wellstation

Neues Mitglied
Ich muss mich entschuldigen, im gestrigen WirrWarr über die gefunde Lösung habe ich vergessen diese zu Posten.
- Das TWRP 3.1.0.0 könnte einen Bug haben, was ich leidvoll durch das zurücksetzen der Einstellungen meines OS erfahren habe.
- irgendwo im XDA Forum existiert wohl ein Tread dazu den ich aber nicht mehr parat habe

* ich habe mir die "twrp-3.1.0-x_blu_spark_v24-op3_op3t.img" dled und installiert
* habe RR OS installiert, einige Einstellungen vorgenommen und ab ins Recovery -> zurück ins OS und siehe da alles noch eingestellt.
* das gleich Spiel mit Citrus CAF und auch hier alles noch vorhanden.

Hab jetzt alles auf f2fs, das blu-spark Recovery und RR OS (nach einem nicht ganz so genutzen Tag noch 69% Akku) und bin zufrieden

Zum Vorgehen um Magisk SU im RR-N-v5.8.2-20170327-oneplus3-Official.zip zu entfernen und SuperSU zu installieren beim kompletten NEUAUFSETZEN
(Keine Gewähr beim Brick !!! )

* Boot to Recovery
* Menü -> Wipe
* Wipe Dalvik Cache / System / Data / Cache
* zurück ins Menü dann zu -> Install
* flash Resurrection OS (beim mir was es "RR-N-v5.8.2-20170327-oneplus3-Official")
* flash Magisk-uninstaller ( bei mir war es "Magisk-uninstaller-20170320")
* flash Open-Gapps ( bei mir war es "open_gapps-arm64-7.1-pico-20170401")
* flash SuperSU (bei mir war es "SuperSU-v2.79-201612051815")
* wipe cache / Dalvik
* zurück ins Menü dann zu -> Reboot
* System

Fertig und freuen...momentan benutze ich noch SuperSU bis ich mich mit Magisk auseinandergesetzt habe..

!! Es sei noch erwähnt: das wohl beim Update (OTA) vom RR das Magisk SU wieder installiert wird. Was dazu führen kann, das RR nicht durch startet und hängen bleibt !!
!! Ich denke Update einspielen, Magisk uninstaller wieder nutzen, SUperSU installieren und fertig !!
wenn ein Update da ist teste ich es mal


Hat jemand ne Ahnung wieso bei Substratum, es sich mein kompelieren und aktivieren aufhängt, der Bildschrirm schwarz wird und die LED weiß leuchtet. Erst ein langes drücken auf dem ON/OFF schaltet das Smartphone wieder ein.....
Im SuperSU steht Masquerade nicht drinnen (stand in der vorherigen Version von RR 20170225 drinnen)...
 
Zuletzt bearbeitet:
Mcenzie

Mcenzie

Stammgast
Hatte ein ähnliches Problem mit TWRP 3.1.0.0. Dort hat sich auch das System zurückgesetzt. Bin wieder auf TWRP 3.0.4-1 und es funktioniert wieder alles.
Aber scheinbar scheint es keinen zu interessieren bei TeamWin oder es ist eine Ausnahme und/oder es gibt noch eine anderes Problem. Da 3.1.0.0 jetzt schon länger draußen ist es kein Bug Fix update gibt.
 
W

wellstation

Neues Mitglied
Durch meine Problemlösungssuche sind mir diverse Treads aufgefallen wo der ein oder andere genau das gleiche Dilemma wie wir hatte.
In der TWRP 3.1.0.0 Version wird die Data gewipt und alles ist auf "Reset".
Vielleicht weil jetzt TWRP beides mounten kann (f2fs und ext4) und es doch nicht gut integriert hat? Keine Ahnung aber dank downgrad wie in deinem Fall oder einer eine unofficial Version in meine Fall geht wieder alles.
Wer weiß ob TWRP nicht schon dran ist es zu entbugen