Diskussion zum [Howto] Backup & Restore von IMEI/EFS beim i9505

  • 736 Antworten
  • Neuester Beitrag
Diskutiere Diskussion zum [Howto] Backup & Restore von IMEI/EFS beim i9505 im Root / Custom-ROMs / Modding für Samsung Galaxy S4 im Bereich Samsung Galaxy S4 (I9500 / I9505) Forum.
V

vogi

Experte
Ich krieg ADB im Moment auch nicht zum laufen.
 

Anhänge

Zuletzt bearbeitet:
R

r0cknroll

Neues Mitglied
Funktioniert bei mir auch nicht, gleiche Fehlermeldung.
 
SavanTorian

SavanTorian

Ehrenmitglied
entwickleroptionen, usb-debugging.... wie man an die entwickleroptionen rankommt, hat r0b beschrieben ;)
 
myreality

myreality

Lexikon
Das ist nicht das Problem.
ADB will nicht laufen...
 
Liddo

Liddo

Erfahrenes Mitglied
Nach der Anleitung funktioniert es nicht. Man bekommt nach eingabe des Codes keinen Zugriff aufs Qualcom Menü. Bekomme da nur die Auswahl zwischen PDA und Modem... Da steht nix von USB Modi
 
frank_m

frank_m

Ehrenmitglied
Dafür gibt es in dem Howto ja extra einen Hinweis. Hast du den probiert?
 
Liddo

Liddo

Erfahrenes Mitglied
Das mit der shell?

Joah, wenn ADB funktionieren würde ;-)
 
frank_m

frank_m

Ehrenmitglied
ADB geht aber auf dem S4, da bin ich mir sehr sicher. Und rooten kann man es auch.
 
myreality

myreality

Lexikon
ADB hab ich zum laufen gebracht.
Aber es kommt bei:

su -c 'am start -n com.sec.android.app.phoneutil/com.sec.android.app.phoneutil.USBSettings'

Error type 3
Error: Activity class [com.sec....] does not exist.
 
Zuletzt bearbeitet:
frank_m

frank_m

Ehrenmitglied
Ok, dann müssen wir das noch mal analysieren. Grundsätzlich sollte es aber gehen, denn das Gerät ist ja Qualcomm basiert.
 
TAT1980

TAT1980

Erfahrenes Mitglied
also ich hab jetzt auch mal versucht.

hab den selben fehler. jetzt habe ich aber auch mal versucht es überhaupt im telefon zu finden.
wenn ich mit es explorer aufs gerät, zeigt er einen ordner namens efs an, der scheinbar aber leer ist.
so diese com.secandroid......sache, habe ich jetzt auch mal verfolgt.
nach durchsuchen des handys ist mir folgende datei aufgefallen im ordner
etc/dort giobt es etwas was sich
init.qcom.efs.synch.sh
nennt.

wenn man diese mit einem textexplorer öffnet steht dort ein text mit einem befehl text ganz unten, kann sich das mal einer ansehen von euch?
ganz zum ende steht:
Path=/system/bin:$Path export Path
cat/sys/devices/platform/rs3000000a7.65536/force_synch
kann es sein das das was mit dem efs synchen zu tun hat? hat qcom da schon was integriert?

nun meine frage, kann es sein, das qualcom da etwas anderes beim s4 eingebaut hat oder configuriert, das es nicht mehr nach den standard geht, womit es beim s3 lte funktioniert haben soll?
vielleicht kommen wir ja zusammen auf des problems lösung.
wieso ist der efs ordner leer?
wenn ich die befehle eingebe, dann erstellt er lediglich eine txtdatei, die keine 300 kb gross sind.
ist es möglich, das die efs daten jetzt woanders zu finden sind?und man einfach den ordner kopiert`?

Der ursprüngliche Beitrag von 01:02 Uhr wurde um 01:25 Uhr ergänzt:

sorry für den doppelpost, aber ich habe eine lösung für mich gefunden,glaube ich zumindestens. ich hatte beim explorer vergessen, das es nen rootexplorer gibt.
jetzt zeigt er mir auch alle dateien an im efs ordner. hab den jetzt einfach mal kopiert und auf die externe abgesichert und werde es komprimiert noch auf meine dropbox hauen.

reicht es denn, wenn ich diesen ordner sichere?

ich erinnere mich mal gelesen zu haben,das das nicht ausreichen soll.
 
Zuletzt bearbeitet:
frank_m

frank_m

Ehrenmitglied
Nein, das reicht nicht. Dabei gehen die Dateirechte verloren. Du musst es als TAR oder sektorbasiert als IMG sichern. Und bei Qualcomm basierten Geräten reicht das nicht, um die IMEI zu sichern. Dafür braucht man auch noch QPST.
 
TAT1980

TAT1980

Erfahrenes Mitglied
na toll und was nun?

hab jetzt mal nach qualcomm codes gesucht,da der beschriebene nicht geht,wie beims3 lte

mit +#9090# komme ich in service mode mit folgenden auswahlen
1 DM/DUM over HS-USB(+)
2 DM/DUM over HSIC
3 DM/DUN/RmNET over HSUSB
4 DM over UART
5 DBG MSG ON(+)
DBG MSG OFF

wenn ich das 3. anklicke, dann kommt eine warnung,das wenn ich das durchziehe ich hinterhereine efs.tar datei flashen muss.
bin ich in dem menu richtig? ich will doch nur dieses usb frei machen, damit ich über die qualcomm qprst programm sichern kann.

ich habe mal 4. angeklickt und da sagt ein popup, fehler und startet neu.
kann es sein, das durch das rooten, einige sachen trotzdem noch nicht richtig gehen?
hat denn schon jemand erfolgreich gesichert?
wenn ich die adb exe anklicke, rennt in einem dosfenster alles ganz schnell und nicht zu lesen durch und schliesst automatisch.
in meinem handy kann ich bei su sehen, das adb erlaubt ist
warum also kommuniziert das handy nicht richtig?
hier scheint doch irgendwas zu fehlen. ich meine wenn man diesen schriftzug eingibt, für die phoneutil, dann kommt bei mir auch, das es nicht vorhanden ist.
was mache ich falsch?

kann mal jemand mit einem nicht gerootetem handy, diesen +#7248# code eingeben und gucken ob es da die auswahl gibt für usb oder ob es da auch nur 2 gibt zum auswählen. ich will dieses problem lösen, allerdrings weiss ich nciht wie.
denn die 9090# ist die modem einstellung wie ich jetzt rausfand.

EDIT: Ich habe es geschafft die usb settings zu finden. da mir klar war, das eshinter einemcode versteckt ist,habe ich einfach von 0 an angefangen. habe insgesamt 6 codes gefundenund auch den,fürs usb einstellen:
+#0011# service mode
+#0228# batteriestatus
+#0283# looback test
*#06# imei
*#03# nandflashheaderread
*#0808# usb service
 
Zuletzt bearbeitet:
frank_m

frank_m

Ehrenmitglied
TAT1980 schrieb:
na toll und was nun?
Wir sind einfach noch nicht so weit. Ihr müsst ganz ruhig bleiben. Zaubern können wir nun mal nicht.
Das ist der Fluch der ersten Gerätebesitzer. Die erfahrenen Devs bekommen die Geräte jetzt erst nach und nach, und dann werden wir auch Lösungen für diese Probleme entwickeln. Beim Rooten wissen wir schon, woran es liegt, und das wird auch hier gelingen.
Im Moment bleibt euch nur, auf riskante Aktionen, die die IMEI gefährden können, zu verzichten.

TAT1980 schrieb:
wenn ich das 3. anklicke, dann kommt eine warnung,das wenn ich das durchziehe ich hinterhereine efs.tar datei flashen muss.
Das würde ich dann erst mal nicht machen. Vor allem, da deine Fehlermeldung so unspezifisch ist, dass man wirklich keine Rückschlüsse daraus ziehen kann.

TAT1980 schrieb:
wenn ich die adb exe anklicke, rennt in einem dosfenster alles ganz schnell und nicht zu lesen durch und schliesst automatisch.
Oh je. Anklicken? ADB ist ein Kommandozeilen Programm. Keine grafische Oberfläche. Nichts anklicken! DOS Fenster öffnen und tippen ist die Devise!

Wie ich schon sagte, gibt es noch nicht für alle Probleme Lösungen. Aber ein Problem ist sicherlich, dass Leute Dinge versuchen, die nicht den Hauch einer Ahnung haben, was sie da eigentlich tun. Das ist nicht ungefährlich!

TAT1980 schrieb:
EDIT: Ich habe es geschafft die usb settings zu finden.
Offengestanden glaube ich nicht, dass einer davon der richtige ist. Wie gesagt, es ist gefährlich, einfach so wild drauf los zu experimentieren.
Mit welchem davon funktioniert QPST denn nun?
 
TAT1980

TAT1980

Erfahrenes Mitglied
ja du magst sicherlich recht haben mit dem experimentieren, aber probieren geht über studieren.

*#0808#

das ist der code um in die usb option rein zu kommen. dort kann man dann auf dieses "RNDIS + DM + MODEM" auswählen, um mit dem QSPT programm zu sichern. den efs ordner habe ich seperat halt über es datei explorer mit root kopiert und gesichert.

denn diese dos befehle funzen nicht so richtig. die ich in der comandozeile eingeben soll.
hat ganz schön gedauert von 0000-0850 durchzutesten zum das zu finden :D

hab gerade schon einen thread aufgemacht bei androidpit, für die Secret Codes.
ein paar waren dabei.
 
Liddo

Liddo

Erfahrenes Mitglied
QPST findet irgendwie mein Telefon nicht... Kann umstellen, dann, wenn ich den Port auswähle, bekomme ich "no phone"....
 
TAT1980

TAT1980

Erfahrenes Mitglied
Teste mal einen anderen usb port. Am besten einenngaupt usb Anschluss. Meistens hinten. Bei mir waren 2 com anschlusse im Angebot. Der erste ging nicht, dann steckte ich handy raus und rein und es waren wieder 2 aber mit ner anderen com Nummer. Dann hatte es geklappt.

Gesendet von meinem GT-I9505
 
Liddo

Liddo

Erfahrenes Mitglied
Habs auf allen 4 versucht. Überall no Phone =/