Partitionslayout vom Telekom Move Huawei U8600 veraendern?

  • 60 Antworten
  • Neuester Beitrag
Diskutiere Partitionslayout vom Telekom Move Huawei U8600 veraendern? im Root / Custom-ROMs / Modding für Telekom Move im Bereich Telekom Move Forum.
A

Andromi

Ambitioniertes Mitglied
  • Offene Frage[1]: Ich nutze ja Link2SD - gibts damit nach der ganzen Prozedur Probleme?
  • Offene Frage[2]: Kann mir jemand die originalen Huawei recovery.img und boot.img irgendwo hochladen? Nur falls was schiefgeht!
Zu 1. Nein
Zu 2. Hier mal das Komplettpaket von mir.

Partitionen:
boot..........original
recovery....original
misc..........original
splash.......original
system......140 MB
cache......original
userdata....rest
userdata2..keine
cust.........keine

Angepasste Huawei boot und angepasste CWM recovery sowie
geänderte vold.fstab und vold.

install_new_partition_layout.zip

Original Huawei boot und CWM-recovery sowie
original vold.fstab und vold.

restore_old_partition_layout.zip

Zum Wiederherstellen der cust und userdat2 (Die Dateien cust_backup.tar und userdata2_backup.tar müßen sich im root verzeichnis der SD-Karte befinden.)

restore_partitions.zip

cust_backup.tar

userdata2_backup.tar


Damit die Interne SD-Karte nicht mehr unter "Einstellungen>Speicher" mit 0 MB auftaucht sind in der build.prop die Einträge

ro.config.hw_virtualsdcard=true auf ro.config.hw_virtualsdcard=false

und

hw_internal_sd=true auf hw_internal_sd=false zu ändern.
 
Zuletzt bearbeitet:
K

k8500

Fortgeschrittenes Mitglied
Super, danke! Ich werde das baldestmöglich testen und werde dann Feedback geben.

Nur eines noch: Ich hätte gerne noch das originale Huawei-Recovery damit ich im Fall der Fälle zurück kann. Denke das wird sich auch irgendwo im Forum finden, aber ich finde es gerade nicht.

EDIT: Bereits erledigt. Original Recovery gibts von hier.
 
Zuletzt bearbeitet:
ElTonno

ElTonno

Experte
Müsste ja eigentlich auch hier drin sein: restore_old_partition_layout.zip ;-)
Mein Fehler, hab überlesen das es ja cwm ist xD
 
K

k8500

Fortgeschrittenes Mitglied
Mist, jetzt hab ich Andromis "install_new_partition_layout" getestet (geflasht mit CWM v6) und habe einen Bootloop. adb scheint das Gerät während das Bootloops auch nicht mehr zu finden (kriege immer "device not found"). Gibts Vorschläge was ich machen kann?

Update: Habe es kurzfristig geschafft dass der "Android Adaptor" im Gerätemanager (Win 7) auftaucht. Ausserdem mal die Fehlermeldung "device offline" (statt "not found") gehabt. Hilft das?
 
Zuletzt bearbeitet:
S

segler11

Gast
lange power drücken (usb kabel nicht angesteckt) wenn der bildschirm grau wird. Tel ans usb kabel. Bis die lade anzeige kommt.

adb reboot recovery
 
K

k8500

Fortgeschrittenes Mitglied
Ich krieg leider auch keine Ladezustandsanzeige mehr. Wenn ich das Telefon über den USB starte, dann wird es auch nicht mehr im Gerätemanager gefunden.

Update: Ich krieg jetzt einigermassen reproduzierbar den "Android Adapter" im Gerätemanger installiert. Dann gibts anstatt "device not found" "device offline".
 
Zuletzt bearbeitet:
S

segler11

Gast
k8500 schrieb:
Ich krieg leider auch keine Ladezustandsanzeige mehr. Wenn ich das Telefon über den USB starte, dann wird es auch nicht mehr im Gerätemanager gefunden.
Ja schön, keine ahnung was du hier geflasht hast. Denke mal was ein paar post vorher beschrieben (wobei eine beschreibung sehe ich da nicht)

1. in die recovery booten (oder hast du dei geflasht?)

tel auschalten vol+ und power drücken, kurz nach dem wibrieren power los lassen und wieder drücken. Wenn du eine recovery geflasht hast bringt das natürlich nichts.
 
K

k8500

Fortgeschrittenes Mitglied
Klar habe ich eine recovery.img geflasht. Ist doch in Andromis Archiv (ich meine das hier) mit drinne und in Fuchsteufels Anleitung wirds ebenfalls so gemacht. Bzw. um das klar zu stellen, ich hab einfach Andromis komplettes Archiv mit CWM v6 geflasht und nicht etwa über ADB die recovery separat geflasht.
 
Zuletzt bearbeitet:
S

segler11

Gast
man sollte halt nur flaschen wenn man einen plan hat, und sachen flaschen die passen.

Mach ich jetzt ungern, da mir schon ein paar leute gesagt haben, adb braucht kein mensch und alles gibts ja in einer .bat Datei.

1. Phone auschalten (power drücken, ohne usb) bis es aus ist

lad dir hier im forum eine cwm recovery runter (cwm 6 mit lade anzeige), die packst du in den ordner in dem bei deinem windows adb usw ist.

2. Phone anschalten vol- und power gedrückt halten (wenns brummt kurz power los lassen und wieder drücken) jetzt sollte das phone im fastboot sein

jetzt in den ordner in dem die recovery und adb und fastboot ist wechseln (cmd)

fastboot flash recovery recovery.img (befehl eingeben)

jetzt solltest du eine recovery haben
 
K

k8500

Fortgeschrittenes Mitglied
Segler11, du bist ein Gott!!! :)

Also, ich bin jetzt im CWM (v5, mit Ladezustandsanzeige). Ist ordentlich geflasht. Gibts irgendwas was ich von da aus noch machen muss? Ich werd da nicht rausgehen bevor ich keine Rückmeldung kriege. :)
 
S

segler11

Gast
flash halt mal die morhx, von der sd karte, Oder auch nur die boot.img von der firmware die du vorher hattest.

Wäre jetzt (phone hängt am usb) und du bist in der recovery:

adb reboot bootloader (fastboot) ((danach die boot.img von deiner letzten firmware flashen)))

adb reboot bootloader

fastboot flasch boot boot.img (die richtige boot.img muss in dem ordner sein)

fastboot reboot

wenn nicht einefach morhx auf die sd karte und flash die firmware neu !!!

Der ursprüngliche Beitrag von 19:48 Uhr wurde um 19:53 Uhr ergänzt:

kannst in der recovery usb mounten (ganz nach unten drücken) morphx firmware drauf schieben und dann install von sd
 
K

k8500

Fortgeschrittenes Mitglied
Okay, ist jetzt alles wieder im grünen Bereich. Ich hatte vorher Backups mit CWM gemacht, die sind jetzt wieder drauf und alles okay.

@Segler11, DANKE! Dafür hast du einen gut bei mir! Die MorphX FW hab ich allerdings leider immer noch nicht.

@Andromi: Ich glaube mit deiner recovery.img stimmt was nicht. Ich habe jetzt mal versucht sie einfach nur über ADB zu booten (statt zu flashen), und ich krieg eine Fehlermeldung über ein defektes recovery. Wenn sie so nicht funktioniert wird sie wohl auch nicht über die Update.zip funktionieren.
 
A

Andromi

Ambitioniertes Mitglied
@Andromi: Ich glaube mit deiner recovery.img stimmt was nicht. Ich habe jetzt mal versucht sie einfach nur über ADB zu booten (statt zu flashen), und ich krieg eine Fehlermeldung über ein defektes recovery. Wenn sie so nicht funktioniert wird sie wohl auch nicht über die Update.zip funktionieren.
Hallo k8500.

tut mir leid, dass Du solch einen trouble hattest. Ich war davon ausgegangen, dass Du dich in den fuchsteufel Thread eingelesen hast.
Mein recovery.img ist ok, habe ich gerade noch einmal ausprobiert.

Hier nun eine Schritt für Schritt Anleitung.

  1. Sicherung des aktuellen Rom mit CWM. (Systempartition darf nicht größer als 140 MB sein)
  2. Mit CWM > install zip von sdcard die Datei install_new_partition_layout.zip ausführen. (Es werden das Recovery.img, boot.img, vold.fstab und vold in der aktuellen Rom überschrieben)
  3. WICHTIG! Jetzt in CWM unter advanced den Punkt Reboot Revovery auswählen. (Kein reboot system now ) Nachdem wir wieder im CWM sind ist das neue partitions layout aktiv.
  4. wipe data/factory reset.
  5. Zur Sicherheit unter Mounts and Storage noch ein format /system.
  6. Jetzt mir backup and restore das Backup aus Schritt 1 wieder einspielen.
  7. Da uns das Backup jetzt die boot.img, die volt.fstab und die vold wieder überschrieben hat, müßen wir noch einmal Schritt 2 ausführem (Mit CWM > install zip von sdcard die Datei install_new_partition_layout.zip ausführen.)
  8. Fertig. Nach einem reboot system now solten jetzt ca. 240 MB interner Speicher zur verfügung stehen.

Ich persönlich finde 140 MB für system etwas knapp, daher noch eine Version mit 160 MB für system und entsprechend weniger internem Speicher.

install_new_partition_layout160.zip
 

Anhänge

Zuletzt bearbeitet:
K

k8500

Fortgeschrittenes Mitglied
Bei Schritt 3. hab ich tatsächlich "reboot system now" gemacht statt dem "reboot into recovery". Überlesen, sorry, aber sowas kommt vor bei den ersten Experimenten und bin ja mit einem blauen Auge davon gekommen.

Und ja, 140MB System ist wirklich wenig. JonasOS hatte das zwar in 125MB hingekriegt aber ich stimme dir zu dass 160MB die bessere Option für die meisten Nutzer ist. Ich werds heut mal nochmal testen, und ich werd auch rausfinden warum es Probleme beim booten (nicht flashen) der Recovery gab.
 
Zuletzt bearbeitet:
A

Andromi

Ambitioniertes Mitglied
k8500 schrieb:
JonasOS hatte das zwar in 125MB hingekriegt...
Der hatte aber auch wirklich alles rausgeschmissen. Mir fehlten schon bei der ersten App die ich installiert hatte die passenden Schriften.

Du kannst die recovery.img sowie die boot.img aus meiner zip auch selbst auf die gewünschte Größe anpassen. Zip-Datei entpacken und dann die recovery.img und die boot.img mit einem Hex-Editor anpassen.

z.B Hex-Editor MX - Download - CHIP Online

Es muß zum Ändern der Größe der Systempartition nur jeweils ein Wert geändert werden. (In beiden Dateien auf den gleichen Wert)

Nach den Änderungen, die Dateien einfach wieder in die zip hineinziehen. Die alten Dateien werden dabei von den neuen ersetzt, zumindest wenn man winrar benutzt.

Im angehängten Beispiel steht die 166, für die Größe der Systempartition von 166 MB.


Um alles wieder Rückgängig zu machen:

  1. Sicherung des aktuellen Rom mit CWM. Oder das alte Backup benutzen.
  2. Mit CWM > install zip von sdcard die Datei restore_old_partition_layout.zip ausführen.
  3. WICHTIG! Jetzt in CWM unter advanced den Punkt Reboot Revovery auswählen. (Kein reboot system now )
  4. wipe data/factory reset.
  5. Zur Sicherheit unter Mounts and Storage noch ein format /system.
  6. Mit CWM > install zip von sdcard die Datei restore_partitions.zip ausführen. (Die Dateien cust_backup.tar und userdata2_backup.tar müßen sich im root Verzeichnis der SD-Karte befinden.)
  7. Jetzt mit backup and restore das Backup aus Schritt 1 wieder einspielen.
  8. Wenn das aktuelle Backup aus punkt 1 wieder eingespielt wurde, muß jetzt noch einmal die Datei restore_old_partition_layout.zip unter install zip von sdcard ausgeführt werden, da wir uns durch das Backup wieder die geänderte boot.img, vlod.fstab und vold aufgespielt haben. Sollte das Backup vor der Änderung der Partitionen erstellt worden sein, können wir uns diesen Schritt sparen.
  9. Fertig. Nach einem reboot system now sollte alles wieder beim Alten sein.

Hier noch einmal der Link auf den Original Thread von fuchsteufel:
https://www.android-hilfe.de/forum/...rtitionen-von-supertoast-anpassen.203731.html
 

Anhänge

Zuletzt bearbeitet:
K

k8500

Fortgeschrittenes Mitglied
Getestet und funktioniert! Fabelhafte Arbeit, Andromi! :thumbup:

Ich kann das neue recovery.img weiterhin nicht über ADB booten, das wird aber wohl auch seine Ursachen haben (die sich mir momentan nicht erschließen).

Nach Andromis Anleitung funktioniert es jedoch wunderbar.

Und noch ein kleiner Bonus: Andromis Version basiert auf CWM v5, ich bevorzuge aber CWM v6. Daher hab ich nochmal die CWM v6 recovery.img entsprechend angepasst. Das komplette Paket (mit CWM v6 statt v5, 160MB System) ist hier angehängt.
 

Anhänge

  • install_new_partition_layout160_cwm6.zip
    8,4 MB Aufrufe: 217
A

Andromi

Ambitioniertes Mitglied
Freut mich, dass es geklappt hat.

Ein Wermutstropfen noch. Wenn mit dem neuen Partitionslayout ein wipe data/factory reset ausgeführt wird, ist nach dem Booten die Energieleiste nicht mehr im "Vorhang", da die Einträge aus der cust Partition nicht mehr vorhanden sind.

Das läßt sich aber beheben. indem man wie im nachfolgenden Post unter, Die Energieleiste (Vorhang | ToolBox.apk) wieder aktivieren, beschrieben vorgeht.
https://www.android-hilfe.de/forum/...a-base-stockrom-b119.388331.html#post-5302405
 
Zuletzt bearbeitet:
S

segler11

Gast
verstehe aber nicht wo der Sinn liegt. ? Beim cm7 hat man von haus aus 157 mb ohne an boot und recovery rum zu machen. Kann mir das mal einer erklären, bitte
 
antaril

antaril

Fortgeschrittenes Mitglied
Zumal dann link2sd nicht mehr funktioniert!!(Bei JonasOs gings nicht mehr!) Was bringt euch der kleine Platz dann? Dachte auch erst es sei gut das Partitionslayout zu ändern, aber mit ner ext2/3/4 Partition und der entsprechenden app hab ich keine Platzprobleme mehr!!
 
K

k8500

Fortgeschrittenes Mitglied
antaril schrieb:
Zumal dann link2sd nicht mehr funktioniert!!(Bei JonasOs gings nicht mehr!) Was bringt euch der kleine Platz dann?
Also dass es nicht mehr funktionieren sollte hat mein Link2SD noch nicht gemerkt, bzw. es läuft wunderbar. Wie soll auch eine Umpartitionierung des Handy-Speichers Link2SD beeinträchtigen? Link2SD funktioniert unabhängig von dieser Modifikation. Wenns im JonasOS nicht ging dann lag das an was anderem (die JonasOS ist ja fehlerbehaftet).

segler11 schrieb:
verstehe aber nicht wo der Sinn liegt. ? Beim cm7 hat man von haus aus 157 mb ohne an boot und recovery rum zu machen.
Hier gehts nicht um 160MB DATA, sondern um 226MB DATA (bei 160MB SYSTEM) bzw. 246MB DATA (bei 140MB SYSTEM). Mag vielen auch nicht viel bringen, aber für solche wie mich denen pausenlos trotz Link2SD der Speicher voll läuft ist das ne Killerapp.

Ausserdem wird ja ansonsten knapp 40MB in den völlig nutzlosen CUST und DATA2 Partitionen verschwendet.