[OS] QAGG3 v6 Probleme-Sammelthread

  • 74 Antworten
  • Neuester Beitrag
Diskutiere [OS] QAGG3 v6 Probleme-Sammelthread im Root / Hacking / Modding für Samsung Galaxy 3 im Bereich Samsung Galaxy 3 (I5800) Forum.
petterson

petterson

Ambitioniertes Mitglied
harleymk2 schrieb:
Hallo petterson,
hier ist fs.current:
DO NOT MODIFY THIS FILE, YOUR SYSTEM WOULD NOT BE ABLE TO BOOT
mmcblk0p2 ext3
stl6 rfs
stl8 rfs

Tschüss,
harleymk2

Stichwort stl7: erst stl6 dann nix dann stl8: also fehlt stl7. Kommt vor das sich was zerbröselt beim flashen - egal welche ROM - zwar selten aber ....

Lösungen:

Hier anfangen

Hier fertig werden

Und während Du liest und folgst poste bitte noch die g3mod.log hier.
Wie mein Voegele so gerne zwitschert: Du wirst etwas über ein kaputtes Filesystem finden.....

Bis später
 
H

harleymk2

Neues Mitglied
Hallo Petterson,
bin erstmal steckengeblieben:
Beim Installieren von pdanet kommt beim Verbinden und Installieren der Gerätetreibersoftware die Fehlermeldung:

S3C6410 Android ADB Fehlgeschlagen

So funzt natürlich adb nicht. Ich werde nun mal suchen, was ich jetzt machen kann. Wenn ich Dich richtig verstanden habe ist also das interne Filesystem stl7 defekt oder weg. Eine g3mod.log hab ich nicht.

Danke erstmal soweit,
harleymk2

Edit1: So, habe die Samsung USB-Treiber neu installiert, adb funktioniert jetzt. Bin auch im Android drin.
e2fsck -fy /dev/block/stl7 und auch stl8 melden einen defekten Superblock. der alternative Superblock (-b 8193) geht auch nicht.

Edit2:
Hab nun mit Odin die I5800XXJPM neu geflasht, Handy läuft wieder.
Mache für heute erstmal Feierabend. Die nächsten Tage mache ich dann einen neuen Versuch mit qagg3-v6.

petterson, ich danke Dir noch mal herzlich. Du hast mir mit Deinen Hinweisen sehr geholfen.
 
Zuletzt bearbeitet:
Wicked Ninja

Wicked Ninja

Stammgast
Erstmal danke wieder für deine Antwort. Ich war die letzten Tage nicht zu Hause und deshalb kommt erst jetzt meine Antwort ;)

qaysedcftgb schrieb:
Bevor ich mir einen Wolf tipper ueber wieso weshalb warum...

Gestatte mir eine Rueckfrage:
wo siehst Du die Meldung, dass nicht genuegend Speicher frei waere?
Wenn Du in TB schaust,ist doch genug frei?
Dies bekomme ich einfach nicht gebacken?

Ist es TB?
Welche App sagt es wo?
Die Meldung erscheint zum einen als Info oben in der Info-Bar (davon habe ich dir gleich mal nen Screenshot gemacht und angehängt. Außerdem gibt es aber auch ein Pop-Up mit der Nachricht: "Der interne Telefonspeicher ist fast voll! Lösche/Deinstalliere Anwendungen" (so oder so ähnlich.... davon habe ich derzeit leider keinen Screenshot).
Es kommt also, so wie ich das sehe, nicht von irgendeiner App sondern vom System selbst!

Zwei Optionen bleiben Dir zu testen:
1) verlager die Apps, die keinen Telefonspeicher haben auf SD aus
-> es wird fuer jede app ein neuer point erstellt

2)
a) loesch die "addtional sd" Dateien, ohne die laeuft das Skript ins Leere
b) installier Dir app2sd V1/V2/V3 (je nachdem was Du haben willst)
b) im CWM Dalvik loeschen
c) booten
d) fertig
zur Option 1: Was meinst du mit "Apps die keinen Telefonspeicher haben"? Woran erkenne ich die?
Und mit "auf SD auslagern" meinst du dann unter "Anwendungen" oder über TB auf SD verschieben, ja?

BTW:
Alex hatte doch die AGG3 V5 rausgebracht?!
[/quote]

Oha... siehste, das habe ich schon gar nicht mehr mitbekommen :D
 

Anhänge

Q

qaysedcftgb

Gast
Hallo Wicked,

also...
Du siehst es richtig, dass es eine Systemmeldung ist.
Demnach ist meine Annahme, die Meldung waere in einer App zu sehen falsch. Daraus erlischt auch der Gedanke eine App nach extern zu verschieben.

Ich gehe mal davon aus, dass TB Dir in Sachen interner Speicher noch eine Menge Speicher als frei anzeigt?
so um die 100MB?

also kein Grund in Hektik zu geraten.

Du hast Dir aber nicht lagfix installiert?
[OFFURL]https://www.android-hilfe.de/samsung-galaxy-s/44856-wenig-interner-telefonspeicher.html[/OFFURL]

Ein anderer hat ein App Update gemacht und hatte dann den Effekt:
https://www.android-hilfe.de/forum/...onspeicher-fast-voll.162726.html#post-2254507

Nun... nachdem es kein ROM spezifisches Problem ist, sondern uebergreifend, ist der einzig gangbare Weg:

Neuinstallation, kompletter Wipe, dann duerfte die Meldung weg sein?
Wenn nicht, melde Dich nochmal, dann machen wir das Handy komplett platt.

Dann:
immer nur eine handvoll Apps installieren (Restoren ueber TB), ggf updates ueber den Market fahren, neustart beobachten
die naechste handvoll an Apps installieren (Retsoren ueber TB), ggf updates fahren,
Neustart, beobachten

Irgendeine App muss es ja verursachen, die herauszufinden... *schulterzuck*

Vielleicht nutzt es auch, wie oben beschrieben, eine app nach der anderen nach "extern" zu verschieben, die bekommen einen neuen Point, vielleicht ist dies eine Moeglichkeit, es zu umgehen, keine Ahnung.

Etwas anderes kann ich Dir nicht anbieten :(

Oder eben pauschal fuer alle Apps meine vorher verangeschlagten Wege 1 oder 2 gehen...
irgendeine App wirds schon sein, die das verursacht

Viele Gruesse
qaysed

@harleymk2
in der Tat, bei dir war der komplete stl7 Bereich zerspant, warum oder woher auch immer, das weiss der Wind.
Wars exzessives testen mit kmapp oder ein einfaches Filesystem konvertieren... alles moeglich

petterson war da schon in der richtigen Rille und das von ihm verlinkte Skript von Mankokoma haette Dir sicherlich geholfen.
Falls nicht, waere es auch ein Versuch wert gewesen, die data.rfs alleine einzuflashen.
Die ist in den meisten Stock ROMs drin und in den meisten CRs draussen.
 
Wicked Ninja

Wicked Ninja

Stammgast
Das ist es ja: TB zeigt mir nämlich auch nur um und bei 20MB freien internen Speicher an. Und das ist dann nämlich genau die Grenze bei der die Meldung erscheint :/

ABER du hattest mich auf eine Idee gebracht. Ich habe mir die Apps mal alle unter "Anwendungen" angeschaut und dann nach Größe sortiert. Dort sieht man ja dann genau den Speicher den sie im internen noch belegen.
Die größten waren dann K-9 mit ca. 15 MB, Opera Mobile mit ca. 11 MB und Ninjump mit ca. 6 MB.
Ninjump habe ich dann einfach deinstalliert (ist zwar ganz nett, muss aber ja nicht sein).
Auf Opera Mobile will ich nicht mehr verzichten. Ich bin schon seit Jahren Opera-Fan und wollte gern die Mobile-Version da man hier, im Gegensatz zur Mini-Version, umschalten kann (Desktop und Mobile Websitendarstellung).
Und dann habe ich mir K-9 noch mal etwas genauer angeschaut. Warum 15MB? Ich habe dann mal die App aufgemacht und gesehen: eines meiner Konten hat genau 15 MB an Daten! Zufall? Wohl kaum. Ich bin in die Konteneinstellung und habe mir unter "Speicher" angeschaut wo dieser liegt. Natürlich intern! Das habe ich dann auf SD-Card geändert... ohne Wirkung... eigenartig. Wieder in die Einstellung "Speicher" und der Punkt ist wieder bei "intern" gesetzt!
Ich kann die Einstellung bei diesem Konto nicht umstellen! Dann viel mir ein: Damals als ich zu Kyrillos gewechselt bin und ebenfalls über TB dann K-9 zurückgesichert habe hatte ich auch irgendein Problem. Ich kann mich nicht mehr genau daran erinnern, aber damals habe ich es einfach neu aus dem Market geladen und neu eingestellt.
Diesmal habe ich es dann zunächst einmal deinstalliert. Dann über den Market neu geladen und dann über TB nur die Daten zurückgesichert. Dann konnte ich auch in den Einstellungen unter "Speicher" auf SD-Card stellen!
Und siehe da: Unter Anwendungen schrumpfte die angegebene Größe von K-9 nun auf 68KB und unter TB wuchs nun der "interne" Speicher wieder.

Derzeit habe ich dort nun wieder 42,4MB frei was mir erstmal wieder Luft verschafft. Derzeit kann ich damit also gut leben. Ich hoffe nur das in Zukunft die Updates der Apps nicht diesen internen Speicher nun wieder füllen.


Die Methode mit dem "per Hand auf SD-Card verschieben" habe ich bereits einmal teilweise gemacht. Ich habe willkürlich Apps auf die SD-Card geschoben. Allerdings hat das quasi gar nichts gebracht. Zumindest mit den Apps die ich verschoben habe. Kann natürlich sein dass nun genau eine der paar Apps die Ursache ist die ich nicht verschoben habe, wer weiß?

Aber erstmal kann ich jetzt mit dieser Situation leben und hoffe dass der Speicher jetzt erst Mal reicht. Neue Apps werde ich erst mal nicht installieren. Alles was ich jetzt drauf habe brauche ich auch.

Mittlerweile bin ich einfach nur froh dass das Handy wieder sauber und stabil läuft. Kyrillos ging am Ende wirklich gar nicht mehr. Ich muss nun nicht jedes Mal hoffen dass mein Handy überhaupt aufwacht wenn ich es aus dem Standby wecken will. Es läuft einfach! Und vor allem die Zeit für ein Reboot: Wahnsinn! Unter Kyrillos habe ich bestimmt 7-8 Min. gewartet bis das Handy mich die PIN eingeben lassen hat und dann durfte ich sicher noch einmal 4-5 Min. warten bis ich das Handy wieder ruckelfrei nutzen konnte!
Jetzt warte ich keine 2 Minuten bis das Handy die Pinabfrage zeigt und dann vielleicht noch mal 1 Minute bis ich es nutzen kann.
Außerdem gefällt mir, wie gesagt, das blaue Theme auch wesentlich besser als das grüne in Kyrillos.
Kurz gesagt: Ich bin begeistert von deiner ROM :) Danke noch mal für deine Hilfe :)
 
Q

qaysedcftgb

Gast
vieles Deiner Antwort freut mich zu lesen

-TB zeigt auch wenig an, also kein Trugschluss von irgendwas
-aktives eigenstaendiges Suchen und Finden der grossen Boecke
-selbstaendig versuchen etwas zu aendern

Das mit der Option "auf SD verschieben" ist so eine Sache.
Im Prinzip liegt die App ja schon auf SD, also extern, die cache Daten bleiben jedoch auf intern. Was der neue Link/mnt da fuer Auswirkungen hat, weiss ich nicht.
(Habe jetzt auch kein Handy grad zur Hand zum verifizieren, was ich denn nun meinte, reiche ich aber bei naechster Gelegengheit nach)
Hatte die Hoffnung, dass sich irgendwas damit austricksen liesse.

Nachdem ich eine ueberschaubare Anzahl an apps in Verwendung habe, ist bei mir noch massig Platz...

Hoffentlich habe ich am WE ein wenig mehr Zeit, dann werde ich Deine Erkenntnisse zusammenfassen und in den Opener einfliessen lassen.

Gleiches gilt mit der zerspanten stl7 Partition, denn sowas kommt immer mal vor.
-> meine eigene habe ich mir vor kurzem erst vermutlich mit zuviel rumwerkeln mit KMapp zerlegt
Wenn nichtmal mehr der Punkt (internal) in TB erscheint, man weiss genau, das Ding hat nichts mit der SD zu tun, dann wirds schonmal kurz warm im Stuebchen, ohne dass man die Heizung aufdrehen muss ;)

Viele Gruesse
qaysed
 
Q

qaysedcftgb

Gast
jetzt muss ich doch doch noch mal bei Wicked Ninja nachhaken:
warum hast Du den Dalvik nach intern zurueckgeschoben?
Diesen nach extern (default) zu belassen wuerde Dir so um die 80MB mehr Platz intern geben.

Damit verspielst Du eigentlich den Vorteil des hd2sd und waerst im Prinzip bei app2sd V3 gelandet. Damit waere auch die ext in TB sichtbar.
 
petterson

petterson

Ambitioniertes Mitglied
qaysedcftgb schrieb:
jetzt muss ich doch doch noch mal bei Wicked Ninja nachhaken:
warum hast Du den Dalvik nach intern zurueckgeschoben?
Diesen nach extern (default) zu belassen wuerde Dir so um die 80MB mehr Platz intern geben.

Damit verspielst Du eigentlich den Vorteil des hd2sd und waerst im Prinzip bei app2sd V3 gelandet. Damit waere auch die ext in TB sichtbar.



Irgendwo bei der AGG3 ( oder war es doch kyrillios:confused2:) hatte dabigfreak seinen dalvik wieder intern gelagert, da das i5800 stabiler und schneller lief - ich denke mal, das dieses Handy so eine Serienstreuung hat, das es mal geht mal nicht - zudem die eingesetzten Speicherkarten ja leider auch nicht einheitlich sind ( hab ne billige noname:blushing:) und auch da sich Zugriffszeiten und Fehler bedingen. Kann mir vortsellen, dass das der Hintergrund ist ....

Ich selbst bin da eher Minimalist und lege mehr wert auf Stabilität und Performance und vor allem wenige und ausgesuchte Proggis. Um letzteres zu erreichen bedarf es schon einige Zeit und Versuche und immer wieder mal neues flashen :razz:.

petterson
 
Zuletzt bearbeitet:
Q

qaysedcftgb

Gast
petterson, Du bist ein Fuchs!

Ich wollte schon fast den Satz mitreinschreiben:
[das Thema "Laggy Handy" und demnach Dalvik-Cache nach intern verlagern habe ich prophylaktisch vom Kyrillos Thread uebernommen. Jedoch gilt auch hier: solange keine Probleme, belass es bei Default -> Dalvik auf SD auslagern]
-> hatte den Vordruck noch in einem anderen Notepad ;)

Nun... bei genauer Betrachtung sollte man den auch nur nach intern verlagern.
was hier dagegen spricht:
ich und mein BetaTester haben in der ganzen Testphase (und das waren nicht nur zwei Tage) keine Lags feststellen koennen
OK, mittlerweile habe ich sehr sporadisch mal einen Haenger, aber da habe ich schlicht und ergreifend zuviel rumgemacht in zu schneller Abfolge... also selbergemacht
Ruhiger klicken und schon gehts.

BTW Kyrillos:
wenn ich mir die ganzen geaenderten Dateien so ansehe, dann wird mir schon so halbwegs klar, warum der Kyrillos Thread soviele Seiten hat...
Ohne den Grandmaster himself zu kritisieren (dazu habe ich zuviel Respekt vor seinem Schaffen), aber fuer meine Begriffe ist die ROM mittlerweile etwas oversized.

Zur Geschwindigkeit der SD Karten, habe ich mal ein paar Karten bestellt und getestet:
https://www.android-hilfe.de/forum/...esslich-8-gb.278449-page-70.html#post-2653550

Da half auch sdfix nichts...
Und nachdem es bei mir nichts gebracht hat, ist dieses Skript wieder rausgeflogen.
Einfache und schnelle Sache ;)

Viele Gruesse
qaysed
 
Wicked Ninja

Wicked Ninja

Stammgast
Hey ihr 2 :D

Also petterson hat mit seiner Annahme genau recht! Ich hatte mit Kyrillos am Ende solche Probleme dass ich mir diesmal dachte: Tu am besten das was dort auch gut getan hätte, also Dalvik wieder nach intern.

Ich wollte damit einfach auf Nummer sicher gehen. Aber wenn du mir jetzt sagst es gab damit nie Probleme, dann würde ich dir natürlich glauben und es ausprobieren.

Das ist doch jetzt ohne neu flashen bzw. ohne große Probleme noch möglich den Dalvik wieder auf extern zu lagern, richtig? Einfach nur in data2sd.dirs die Zeile dalvik-cache wieder einfügen, dann reboot ins CWM dort den Dalvik löschen und booten, korrekt?

Dann kann ich dann ja einfach mal ein paar Tage testen, wenn alles wunderbar weiter läuft (wie bisher übrigens) dann belasse ich es dabei und wenn ich dann doch das Gefühl haben sollte es laggt mehr, dann kann ich die Zeile ja wieder rauslöschen.
 
Q

qaysedcftgb

Gast
yes, die Vorgehensweise ist exakt wie Du beschrieben hast

-Datei aendern (Zeile hinzufuegen, Leerzeile am Ende beachten
-CWM booten
-Dalvik loeschen
fertig

Einfach beobachten, wenns dann wirklich zu Problemen kommen sollte, dann zweifelsohne den Dalvik wieder nach intern lagern und wieder beobachten.

Aber obacht:
nicht unbedingt in dieser Testphase massig Apps installieren, nicht dass mein Ruecklagern des Dalviks dann dafuer kein Platz mehr sein sollte
-> Platzmangel

Rueckgaengig, genau den gleichen Weg wie oben gehen, nur eben die Dalvik Zeile loeschen.

Zur Not, wuerde ich echt die App "Faster reboot" empfehlen, diese hie rund da mal aufzuruefen, die raeumt auch auf.

Oder Du faehrst auf Sicherheit und sagst:
shice drauf, ich lass es so
Waere auch OK

Hat mich nur interessiert, drum die Nachfrage meinerseits.

Viele Gruesse
qaysed
 
Wicked Ninja

Wicked Ninja

Stammgast
Ok, ich werd's mal probieren. Erstmal den Dalvik wieder nach intern. Apps werde ich erstmal keine neuen installieren und die Tage einfach mal testen. Wenn alles gut ist, belasse ich es dabei und hab dann mehr Platz und ansonsten wandert er eben wieder nach intern.

Danke noch mal für diesen Tipp :)

Edit: gesagt, getan... 159MB freier interner Speicher :) Heißt also der Dalvik-Cache hat mit gut 120MB den Löwenteil des internen Speichers belegt!
 
Zuletzt bearbeitet:
petterson

petterson

Ambitioniertes Mitglied
Wicked Ninja schrieb:
Ok, ich werd's mal probieren. Erstmal den Dalvik wieder nach intern. Apps werde ich erstmal keine neuen installieren und die Tage einfach mal testen. Wenn alles gut ist, belasse ich es dabei und hab dann mehr Platz und ansonsten wandert er eben wieder nach intern.

Danke noch mal für diesen Tipp :)

Edit: gesagt, getan... 159MB freier interner Speicher :) Heißt also der Dalvik-Cache hat mit gut 120MB den Löwenteil des internen Speichers belegt!

120MB :confused2: - wieviele Apps hast Du? :crying:
 
Wicked Ninja

Wicked Ninja

Stammgast
TB sagt unter Benutzeranwendungen 65
und alles insgesamt sind 166

:D
 
petterson

petterson

Ambitioniertes Mitglied
Wicked Ninja schrieb:
TB sagt unter Benutzeranwendungen 65
und alles insgesamt sind 166

:D

:thumbup: Top - ich komm grad auf 5 Benutzeranwendungen ....

:unsure: bist Du Beta- / Proggitester :D
 
Wicked Ninja

Wicked Ninja

Stammgast
Nicht wirklich :D

Aber dass sind wirklich größtenteils Apps die ich auch ständig brauche ;)
 
Wicked Ninja

Wicked Ninja

Stammgast
sooo, sorry für das Doppelposting, aber ich wollte mal erzählen wie es derzeit aussieht.

Also ich habe den Test heute abgebrochen. Ja, genau: Abgebrochen :sad:
Nachdem ich den Dalvik-Cache wieder auf extern gelegt habe, habe ich feststellen können dass das Galaxy teilweise sehr heftig laggt. Außerdem hab ich das Gefühl das einige Apps nicht mehr voll funktionierten. So habe ich während der Testphase zum Beispiel mehrmals WhatsApp-Nachrichten viel zu spät bekommen. Auch nach dem Aufwecken aus dem Standby konnte ich sofort sehen dass es beim Entsperr-Muster doch teilweise extrem hakt, so dass ich dann gleich mehrmals neu ansetzen musste.
Kurz gesagt: Es hat mich stark an Kyrillos erinnert ;)

Deinen Tipp mit "Fast Reboot" habe ich auch ausprobiert. Ja, es funktioniert wirklich, aber nur für eine gewisse Zeit, danach verhält sich das Phone dann aber genauso wie vorher. Und das ist mir zu nervig ständig diese App auszuführen, bzw. die Pro-Version zu kaufen um dies dann automatisch ablaufen zu lassen. Das ist, denke ich, nicht Sinn der Sache ;)

Ich habe ne 16GB Class 4 Card, aber scheinbar ist die wirklich zu langsam dafür dass ich den Dalvik-Cache auf extern lege.

Vorhin habe ich das ganze dann wieder rückgängig gemacht und merke sofort den starken Performance-Unterschied. Das Ding läuft nun wieder flüssig, keine Laggs, genau so wie es sein sollte! Ich werde also nun dabei bleiben. Da verzichte ich lieber auf ein paar Apps, denn was soll ich mit einem Handy voller Apps die ich nicht nutzen kann, weil das Teil laggt wie Hölle?
Dann doch lieber ein funktionierendes, stabil laufendes und flottes Smartphone mit nur den nötigsten Apps :]

Derzeit habe ich 44,4 MB intern frei. Das sollte erst Mal reichen. Neue Apps werde ich in Zukunft kaum brauchen. Falls ich doch noch mal Platzmangel bekommen sollte muss ich mich dann leider wohl von meinem Opera Mobile trennen (mit 11MB intern immer noch die größte App).
 
petterson

petterson

Ambitioniertes Mitglied
Weise gesprochen und gut entschieden:thumbup:

Happy QAGGen:D
 
Q

qaysedcftgb

Gast
@Wicked Ninja
danke fuer Deine Rueckmeldung
hilft sehr weiter

und noch ein Danke, dass Du bereit warst, den Test bis zu einem gewissen Punkt mitzumachen, denn Versuch macht kluch
Wenn man es nicht probiert hat, weiss man nicht wie es ist, wenn es anders ist.

Viele Gruesse
qaysed

PS:
hatte dieses WE keine Zeit, den Opener ein wenig anzugleichen/erweitern
 
Wicked Ninja

Wicked Ninja

Stammgast
Ich hab wieder was Neues :rolleyes:

Mein Market startet nicht mehr. Ich sehe nur kurz "wird geladen" und dann springt er wieder auf den Homescreen :/
Hat das was mit der Umbenennung des Marktes zu tun? Muss ich den Market-Updater laden und aktualisieren oder stimmt hier irgendwas ganz anderes nicht?

Des weiteren ist mir aufgefallen dass ich hin und wieder Whatsapp-Nachrichten nicht richtig zugestellt bekomme. Ich erfahre dass dann immer erst wenn ich die App selbst aufrufe. Dann kommen die Nachrichten. Das Problem hatte ich ja auch während der Testphase und dachte das es am externen Dalvik-Cache liegt.
Jetzt hab ich natürlich keine Ahnung obs nen Fehler der Rom ist oder von Whatsapp. Kann aber ja, wie gesagt auch nicht im Market schauen obs nen Update gibt ;)

Gesendet von meinem GT-I5800 mit der Android-Hilfe.de App