1. Mitglieder surfen ohne Werbung auf Android-Hilfe.de! ✔ Jetzt kostenlos Mitglied in unserer Community werden.
  1. bomberman82, 25.03.2013 #1
    bomberman82

    bomberman82 Threadstarter Neuer Benutzer

    Hallo zusammen.

    Ich benutze seit einigen Jahren Custom-Roms für mein SGS+ - würde also sagen dass ich eine gewisse Erfahrung damit habe. Seit heute habe ich allerdings ein Problem was ich nicht gelöst bekomme.

    Nach dem flashen eines Updates von Ivendors cm10 startet das handy nicht mehr. Ich komme noch in den download modus und den recovery modus aber ich kann keinen hard reset durchführen. Das Handy bleibt bei formatting/data hängen. Ich habe schon einige Male versucht eine Stock-Rom über odin zu installieren was auch funktioniert. Allerdings bleibt das Problem bestehen. Ich kann machen was ich will ich bekomme das Handy einfach nicht mehr gestartet. Irgendjemand eine Idee ob das an den Partitionen hängt oder wie ich das Problem in den Griff bekomme?! Danke im voraus für Tipps...
     
  2. Cynob, 25.03.2013 #2
    Cynob

    Cynob Android-Guru

    jetzt mal ohne witz ... flash mal ne alte FW von mir - ich hatte das damals ( als noch aktiv) so eingestellt das alles grundlegend neu formatiert wird.... nur mal so als versuch.
     
  3. bomberman82, 25.03.2013 #3
    bomberman82

    bomberman82 Threadstarter Neuer Benutzer

    Danke für den Tipp.
    Lade mir grad mal CyMod06 runter und probiers aus.

    Der ursprüngliche Beitrag von 21:10 Uhr wurde um 21:31 Uhr ergänzt:

    Sieht schlecht aus :(
    Hängt beim grünen Android-Männchen und startet nicht...
    Gibts vllt ne Möglichkeit das irgendwie anders hinzunbekommen?
    Über shell oder so?!
    Ich versteh das nicht so ganz. Ne ZIP installieren über CWM geht auch nicht - obwohl sie erkannt wird
     
  4. Cynob, 25.03.2013 #4
    Cynob

    Cynob Android-Guru

    wenn du alles im recovery formatierst geht auch nix?
     
  5. bomberman82, 25.03.2013 #5
    bomberman82

    bomberman82 Threadstarter Neuer Benutzer

    Ich kann leider nix formatieren.
    Der bleibt dann hängen und startet nach einigen Minuten neu oder macht gar nix weiter... Hab mittlerweile die Befürchtung da ist irgendwas grundlegenderes kaputt
     
  6. Cynob, 25.03.2013 #6
    Cynob

    Cynob Android-Guru

    na wenn du noch ins recovery kommst kann der flashspeicher wohl schlecht hinüber sein.poste doch mal das update script aus deinem cm update.
     
  7. bomberman82, 25.03.2013 #7
    bomberman82

    bomberman82 Threadstarter Neuer Benutzer

    assert(getprop("ro.product.device") == "ariesve" || getprop("ro.build.product") == "ariesve" ||
    getprop("ro.product.device") == "GT-I9001" || getprop("ro.build.product") == "GT-I9001");
    mount("ext4", "EMMC", "/dev/block/mmcblk0p15", "/system");
    package_extract_file("system/bin/backuptool.sh", "/tmp/backuptool.sh");
    package_extract_file("system/bin/backuptool.functions", "/tmp/backuptool.functions");
    set_perm(0, 0, 0777, "/tmp/backuptool.sh");
    set_perm(0, 0, 0644, "/tmp/backuptool.functions");
    run_program("/tmp/backuptool.sh", "backup");
    unmount("/system");
    show_progress(0.500000, 0);
    format("ext4", "EMMC", "/dev/block/mmcblk0p15", "0", "/system");
    mount("ext4", "EMMC", "/dev/block/mmcblk0p15", "/system");
    package_extract_dir("system", "/system");
    symlink("Roboto-Bold.ttf", "/system/fonts/DroidSans-Bold.ttf");
    symlink("Roboto-Regular.ttf", "/system/fonts/DroidSans.ttf");
    symlink("busybox", "/system/xbin/[", "/system/xbin/[[",
    "/system/xbin/adjtimex", "/system/xbin/arp", "/system/xbin/ash",
    "/system/xbin/awk", "/system/xbin/base64", "/system/xbin/basename",
    "/system/xbin/bbconfig", "/system/xbin/blkid", "/system/xbin/blockdev",
    "/system/xbin/brctl", "/system/xbin/bunzip2", "/system/xbin/bzcat",
    "/system/xbin/bzip2", "/system/xbin/cal", "/system/xbin/cat",
    "/system/xbin/catv", "/system/xbin/chattr", "/system/xbin/chgrp",
    "/system/xbin/chmod", "/system/xbin/chown", "/system/xbin/chroot",
    "/system/xbin/clear", "/system/xbin/cmp", "/system/xbin/comm",
    "/system/xbin/cp", "/system/xbin/cpio", "/system/xbin/crond",
    "/system/xbin/crontab", "/system/xbin/cut", "/system/xbin/date",
    "/system/xbin/dc", "/system/xbin/dd", "/system/xbin/depmod",
    "/system/xbin/devmem", "/system/xbin/df", "/system/xbin/diff",
    "/system/xbin/dirname", "/system/xbin/dmesg", "/system/xbin/dnsd",
    "/system/xbin/dos2unix", "/system/xbin/du", "/system/xbin/echo",
    "/system/xbin/ed", "/system/xbin/egrep", "/system/xbin/env",
    "/system/xbin/expand", "/system/xbin/expr", "/system/xbin/false",
    "/system/xbin/fdisk", "/system/xbin/fgrep", "/system/xbin/find",
    "/system/xbin/flash_lock", "/system/xbin/flash_unlock",
    "/system/xbin/flashcp", "/system/xbin/flock", "/system/xbin/fold",
    "/system/xbin/free", "/system/xbin/freeramdisk", "/system/xbin/fsync",
    "/system/xbin/ftpget", "/system/xbin/ftpput", "/system/xbin/fuser",
    "/system/xbin/getopt", "/system/xbin/grep", "/system/xbin/groups",
    "/system/xbin/gunzip", "/system/xbin/gzip", "/system/xbin/halt",
    "/system/xbin/head", "/system/xbin/hexdump", "/system/xbin/id",
    "/system/xbin/ifconfig", "/system/xbin/inetd", "/system/xbin/insmod",
    "/system/xbin/install", "/system/xbin/iostat", "/system/xbin/ip",
    "/system/xbin/kill", "/system/xbin/killall", "/system/xbin/killall5",
    "/system/xbin/length", "/system/xbin/less", "/system/xbin/ln",
    "/system/xbin/losetup", "/system/xbin/ls", "/system/xbin/lsattr",
    "/system/xbin/lsmod", "/system/xbin/lsusb", "/system/xbin/lzcat",
    "/system/xbin/lzma", "/system/xbin/lzop", "/system/xbin/lzopcat",
    "/system/xbin/man", "/system/xbin/md5sum", "/system/xbin/mesg",
    "/system/xbin/mkdir", "/system/xbin/mke2fs", "/system/xbin/mkfifo",
    "/system/xbin/mkfs.ext2", "/system/xbin/mkfs.vfat",
    "/system/xbin/mknod", "/system/xbin/mkswap", "/system/xbin/mktemp",
    "/system/xbin/modinfo", "/system/xbin/modprobe", "/system/xbin/more",
    "/system/xbin/mount", "/system/xbin/mountpoint", "/system/xbin/mpstat",
    "/system/xbin/mv", "/system/xbin/nanddump", "/system/xbin/nandwrite",
    "/system/xbin/netstat", "/system/xbin/nice", "/system/xbin/nohup",
    "/system/xbin/nslookup", "/system/xbin/ntpd", "/system/xbin/od",
    "/system/xbin/patch", "/system/xbin/pgrep", "/system/xbin/pidof",
    "/system/xbin/ping", "/system/xbin/pkill", "/system/xbin/pmap",
    "/system/xbin/poweroff", "/system/xbin/printenv", "/system/xbin/printf",
    "/system/xbin/ps", "/system/xbin/pstree", "/system/xbin/pwd",
    "/system/xbin/pwdx", "/system/xbin/rdev", "/system/xbin/readlink",
    "/system/xbin/realpath", "/system/xbin/renice", "/system/xbin/reset",
    "/system/xbin/resize", "/system/xbin/rev", "/system/xbin/rm",
    "/system/xbin/rmdir", "/system/xbin/rmmod", "/system/xbin/route",
    "/system/xbin/run-parts", "/system/xbin/rx", "/system/xbin/sed",
    "/system/xbin/seq", "/system/xbin/setconsole", "/system/xbin/setserial",
    "/system/xbin/setsid", "/system/xbin/sh", "/system/xbin/sha1sum",
    "/system/xbin/sha256sum", "/system/xbin/sha512sum",
    "/system/xbin/sleep", "/system/xbin/sort", "/system/xbin/split",
    "/system/xbin/stat", "/system/xbin/strings", "/system/xbin/stty",
    "/system/xbin/sum", "/system/xbin/swapoff", "/system/xbin/swapon",
    "/system/xbin/sync", "/system/xbin/sysctl", "/system/xbin/tac",
    "/system/xbin/tail", "/system/xbin/tar", "/system/xbin/taskset",
    "/system/xbin/tee", "/system/xbin/telnet", "/system/xbin/telnetd",
    "/system/xbin/test", "/system/xbin/tftp", "/system/xbin/tftpd",
    "/system/xbin/time", "/system/xbin/timeout", "/system/xbin/top",
    "/system/xbin/touch", "/system/xbin/tr", "/system/xbin/traceroute",
    "/system/xbin/true", "/system/xbin/ttysize", "/system/xbin/tune2fs",
    "/system/xbin/umount", "/system/xbin/uname", "/system/xbin/uncompress",
    "/system/xbin/unexpand", "/system/xbin/uniq", "/system/xbin/unix2dos",
    "/system/xbin/unlzma", "/system/xbin/unlzop", "/system/xbin/unxz",
    "/system/xbin/unzip", "/system/xbin/uptime", "/system/xbin/usleep",
    "/system/xbin/uudecode", "/system/xbin/uuencode", "/system/xbin/vi",
    "/system/xbin/watch", "/system/xbin/wc", "/system/xbin/wget",
    "/system/xbin/which", "/system/xbin/whoami", "/system/xbin/xargs",
    "/system/xbin/xz", "/system/xbin/xzcat", "/system/xbin/yes",
    "/system/xbin/zcat");
    symlink("mksh", "/system/bin/sh");
    symlink("toolbox", "/system/bin/cat", "/system/bin/chmod",
    "/system/bin/chown", "/system/bin/cmp", "/system/bin/date",
    "/system/bin/dd", "/system/bin/df", "/system/bin/dmesg",
    "/system/bin/getevent", "/system/bin/getprop", "/system/bin/hd",
    "/system/bin/id", "/system/bin/ifconfig", "/system/bin/iftop",
    "/system/bin/insmod", "/system/bin/ioctl", "/system/bin/ionice",
    "/system/bin/kill", "/system/bin/ln", "/system/bin/log",
    "/system/bin/ls", "/system/bin/lsmod", "/system/bin/lsof",
    "/system/bin/md5", "/system/bin/mkdir", "/system/bin/mount",
    "/system/bin/mv", "/system/bin/nandread", "/system/bin/netstat",
    "/system/bin/newfs_msdos", "/system/bin/notify", "/system/bin/printenv",
    "/system/bin/ps", "/system/bin/r", "/system/bin/reboot",
    "/system/bin/renice", "/system/bin/rm", "/system/bin/rmdir",
    "/system/bin/rmmod", "/system/bin/route", "/system/bin/schedtop",
    "/system/bin/sendevent", "/system/bin/setconsole",
    "/system/bin/setprop", "/system/bin/sleep", "/system/bin/smd",
    "/system/bin/start", "/system/bin/stop", "/system/bin/sync",
    "/system/bin/top", "/system/bin/touch", "/system/bin/umount",
    "/system/bin/uptime", "/system/bin/vmstat", "/system/bin/watchprops",
    "/system/bin/wipe");
    set_perm_recursive(0, 0, 0755, 0644, "/system");
    set_perm_recursive(0, 0, 0755, 0755, "/system/addon.d");
    set_perm_recursive(0, 2000, 0755, 0755, "/system/bin");
    set_perm(0, 3003, 02750, "/system/bin/netcfg");
    set_perm(0, 3004, 02755, "/system/bin/ping");
    set_perm(0, 2000, 06750, "/system/bin/run-as");
    set_perm_recursive(1002, 1002, 0755, 0440, "/system/etc/bluetooth");
    set_perm(0, 0, 0755, "/system/etc/bluetooth");
    set_perm(1000, 1000, 0640, "/system/etc/bluetooth/auto_pairing.conf");
    set_perm(3002, 3002, 0444, "/system/etc/bluetooth/blacklist.conf");
    set_perm(1002, 1002, 0440, "/system/etc/dbus.conf");
    set_perm(1014, 2000, 0550, "/system/etc/dhcpcd/dhcpcd-run-hooks");
    set_perm_recursive(0, 2000, 0755, 0755, "/system/etc/init.d");
    set_perm(0, 0, 0755, "/system/etc/init.d");
    set_perm(0, 2000, 0550, "/system/etc/init.goldfish.sh");
    set_perm_recursive(0, 0, 0755, 0555, "/system/etc/ppp");
    set_perm(0, 2000, 0755, "/system/vendor");
    set_perm_recursive(0, 2000, 0755, 0644, "/system/vendor/etc");
    set_perm(0, 0, 0644, "/system/vendor/etc/audio_effects.conf");
    set_perm(0, 2000, 0755, "/system/vendor/firmware");
    set_perm_recursive(0, 2000, 0755, 0755, "/system/xbin");
    set_perm(0, 0, 06755, "/system/xbin/librank");
    set_perm(0, 0, 06755, "/system/xbin/procmem");
    set_perm(0, 0, 06755, "/system/xbin/procrank");
    set_perm(0, 0, 06755, "/system/xbin/su");
    show_progress(0.200000, 0);
    show_progress(0.200000, 10);
    package_extract_file("system/bin/backuptool.sh", "/tmp/backuptool.sh");
    package_extract_file("system/bin/backuptool.functions", "/tmp/backuptool.functions");
    set_perm(0, 0, 0777, "/tmp/backuptool.sh");
    set_perm(0, 0, 0644, "/tmp/backuptool.functions");
    run_program("/tmp/backuptool.sh", "restore");
    delete("/system/bin/backuptool.sh");
    delete("/system/bin/backuptool.functions");
    package_extract_file("system/bin/modelid_cfg.sh", "/tmp/modelid_cfg.sh");
    set_perm(0, 0, 0777, "/tmp/modelid_cfg.sh");
    run_program("/tmp/modelid_cfg.sh", "");
    show_progress(0.200000, 10);
    package_extract_file("boot.img", "/dev/block/mmcblk0p8");
    show_progress(0.100000, 0);
    unmount("/system");


    Meintest du das ?!

    Das ist dieses Update hier:

    https://www.android-hilfe.de/forum/...ogenmod-10-by-ivendor-release-2-5.333036.html

    Also ich recherchiere nebenbei im Internet - kann aber nichts wirkliches finden.
    Es scheint aber so als hab ich irgendwas mit den partitionen durcheinander gehauen. Wenn ich jetzt CWM 6 installiere und starte erscheinen einige meldungen in der art:

    E: Invalid Command argument
    Formatting /data
    E: format_volume: make_ext4fs failed on /dev/block/mmcblk0p17

    ...

    Data wipe failed.

    ...
     
  8. Cynob, 25.03.2013 #8
    Cynob

    Cynob Android-Guru

    er rührt ja nur /system an ... die anderen nicht. Also vom script her kannst du mal das "EMMC" löchen also Zeile:


    format("ext4", "EMMC", "/dev/block/mmcblk0p15", "0", "/system");
    mount("ext4", "EMMC", "/dev/block/mmcblk0p15", "/system");

    zu

    format("ext3", "/dev/block/mmcblk0p15", "0", "/system");
    mount("ext3", "/dev/block/mmcblk0p15", "/system");


    und das ganze nochmal ausführen
     
  9. bomberman82, 25.03.2013 #9
    bomberman82

    bomberman82 Threadstarter Neuer Benutzer

    Ich kann das script zwar ändern, aber ich kriege die sd-karte nicht gemountet sodass ich es installieren könnte. Es geht nichts anderes ausser installieren über odin... und dann gehts nicht weiter...
    Alles sehr mysteriös... Ich werde mich da morgen nochmal dran setzen. Vielleicht hat bis dahin ja noch jemand eine IDee?!
    Vielen Dank schonmal für deine Mühen.
     
  10. flasher78, 25.03.2013 #10
    flasher78

    flasher78 Android-Lexikon

    Klappt es auch nicht mit odin die stock rom zu flashen?
     
  11. bomberman82, 25.03.2013 #11
    bomberman82

    bomberman82 Threadstarter Neuer Benutzer

    Wie gesagt - flashen über odin kein problem. Keine Fehlermeldung oder sontioges. Aber beim Starten hängts dann und startet nach ein paar minuten neu und hängt dann wieder. Und wipen oder sontiges geht auch nicht - hängt auch und macht nichts weiter...
     
  12. XeLLaR, 26.03.2013 #12
    XeLLaR

    XeLLaR Android-Lexikon

    Jo, sieht so aus als ob du dir dev/block/mmcblk0p17 zerhauen hättest. Laut dem xda wiki ist das die /data partition. Ich such eben ob es einen weg gibt die zu retten.

    Edit: Gefunden
    http://forum.xda-developers.com/showthread.php?t=2173180


    Gesendet von meinem GT-I9001 mit der Android-Hilfe.de App
     
    Zuletzt bearbeitet: 26.03.2013
  13. bomberman82, 26.03.2013 #13
    bomberman82

    bomberman82 Threadstarter Neuer Benutzer

    Vielen Dank. Das sieht sehr gut aus. ICh werde es mal testen.
     
  14. SilverFx14, 28.03.2013 #14
    SilverFx14

    SilverFx14 Neuer Benutzer

    Moin Moin,

    Habe das gleiche Problem wie Bomberman82 nach flashen auf cm10 von ivendor, nur waren auch noch 15 und 16 nicht zu mounten bzw zu formatieren per cwm.
    Zur Fehlerbehebung hatte auch sonst schon alles durch (stockrom etc.).
    Habe wohl zu voreilig das i9001reset mit odin aus dem link von XellaR gemacht.
    Klang gut nach den ganzen erfolglosen Versuchen.
    Leider ist jetzt alles tot.
    Hat vielleicht jemand eine Idee, wie ich es wieder ans laufen bekomme?
     
  15. Th3 Witch3r, 28.03.2013 #15
    Th3 Witch3r

    Th3 Witch3r Android-Lexikon

    Was meinst du denn mit jetzt ist alles tot? Wie weit bootet es noch? Funktioniert der Downloadmodus oder Recoverymodus noch?

    Gesendet von meinem GT-I9001 mit der Android-Hilfe.de App
     
  16. bomberman82, 28.03.2013 #16
    bomberman82

    bomberman82 Threadstarter Neuer Benutzer

    Hab heut erst geschafft es zu testen. Das Gleiche bei mir. Rührt sich nix mehr.
    GEht nicht mehr an und reagiert auch nicht wenn man Ladegerät anschließt. Habs eingeschickt und hoffe auf Reparatur :). Also besser erstmal nicht verwenden. Trotzdem Danke für die Hilfe.
     
  17. flasher78, 28.03.2013 #17
    flasher78

    flasher78 Android-Lexikon

    Denn habt ihr vermutlich was falsch gemacht; bei bestimmt weit über 100 läuft's ohne Probleme.
     
    Zuletzt von einem Moderator bearbeitet: 11.04.2014
  18. Cynob, 28.03.2013 #18
    Cynob

    Cynob Android-Guru

    Jo also einen totalverlust anhand der update.zip kann ich auch nicht feststellen ( anhand des scripts auf der 1ten Seite) Also das eine kann nix mit nem totalausfall zu tun haben. Die update.zip schreibt nur nach /dev/block/mmcblk0p15 welche die /system Partition darstellt. Weder kernel image (..0p8) noch recovery (..0p13) noch bootloader können auf die art "gekillt" worden sein.

    Was mich stutzig macht:

    format("ext4", "EMMC", "/dev/block/mmcblk0p15", "0", "/system");

    was zur hölle hat die "0" da verloren? könnte es nicht sein das unser /systemverzeichnis jetzt:

    0", "/system

    heißt (wie das leerzeichen mitgenommen werden sollte ohne es zu escapen ist mir aber auch ein rätsel.)

    Kommt noch jemand mit dem Prob inms recovery menü oder bekommt noch ( besser ) ne verbindung via ADB ? Zur not könnte ich nen kernel/recovery image so umfriemeln das beim starten alles formatiert wird.
     
  19. SilverFx14, 28.03.2013 #19
    SilverFx14

    SilverFx14 Neuer Benutzer

    @Th3 Witch3r
    kein Downloadmodus, kein Recovery, keine Reaktion auf Ladegerät oder PC --> brick

    @Cynob
    habe das i9001reset-package (von broodplank1337) benutzt, aber wie geagt, man kommt nicht mehr ins recovery
     
  20. flasher78, 28.03.2013 #20
    flasher78

    flasher78 Android-Lexikon

    Hast mal probiert den Akku für ca 30 min zu entnehmen ?
     
Du betrachtest das Thema "Datenpartition kann nicht formatiert werden" im Forum "Root / Hacking / Modding für Samsung Galaxy S Plus",