Fix der wirklich hilft gegen Lags ohne zu wenig Speicher

M

Max1985

Fortgeschrittenes Mitglied
OK, hab ich gemacht, aber wenn ich jetzt "su" eingebe, kommt die Meldung,
dass der Befehl su entweder falsch geschrieben, oder nicht gefunden wurde.
hast du am handy usb-debugging aktiviert?
normal kommt am handy dann eine superuser abfrage, die du bestätigen musst.

mfg max
 
R

ryzion

Ambitioniertes Mitglied
Also ich kann mittlerweile keinen Unterschied mehr feststellen (JM2)
 
Mycorrhiz

Mycorrhiz

Erfahrenes Mitglied
Warum verschiebt man eigentlich nicht den ganzen /data ordner auf die SD Karte?

habs grad mal selber probiert, der copy command funktionierte noch problemos bei mv dann aber das hier:
mv /data /data.bak
failed on '/data' - Read-only file system

wie mounte ich das rw?
 
R

ryzion

Ambitioniertes Mitglied
So weit mir bekannt ist die Wurzel immer ro. Mit dem RootExplorer kannst du das Verzeichnis dann in .old umbennen, oder die wurzel sogar rw mounten.
Symlink setzten.

Das geht auch mit mount -o remount, allerdings fällt mir das device gerad nicht ein.

Das würde ich zumindest auf die schnellle versuchen
 
BigBSES

BigBSES

Erfahrenes Mitglied
Du hast ihm auch den mount genommen in dem du verschoben hast.
Dein vorhaben ist zum scheitern verurteilt.

Warum verschiebt man eigentlich nicht den ganzen /data ordner auf die SD Karte?

habs grad mal selber probiert, der copy command funktionierte noch problemos bei mv dann aber das hier:
mv /data /data.bak
failed on '/data' - Read-only file system

wie mounte ich das rw?

Sent from my GT-I9000 using Tapatalk
 
djmarques

djmarques

Ehrenmitglied
Market Cache löschen und updates deinstallieren

Einstellungen->Anwendungen->Filter Alle Anzeigen->Market - Cache löschen, Updates deinstallieren
 
indidi

indidi

Erfahrenes Mitglied
Hallo, ich habe es nun auch getan habe die G5 Version jetzt mit ext4 und entsprechenden Fix. Ich habe es nach dieser Schritt für Schritt Anleitung für Anfänger gemacht. hier

Vorher aber ein Root gemacht und mit MyBackup Pro und TitaniumBackup alles gesichert.
dann die Karte mit Gpart CD neu Formatiert und Patitioniert.

Ich bin echt positiv Überrascht. Es ist schon erstaunlich wie schnell man jetzt Fotos machen kann.

Durch die knapp 3000 Adressen (via 1und1 Exchange) läuft es wie Butter durch. Der wechsel zu den Apps ist noch mal schneller geworden. Mit dem GPS hatte ich schon vorher keine Probleme (nutze NDRIVE und OruxMaps.

Irgendwie habe ich das Gefühl, dass der Akku viel länger hält.

Das kann aber auch am Neu aufspielen der Apps liegen.

Kann ich eigentlich irgendwo die Positionierung der Apps speichern ?

soweit so gut.
 
Zuletzt bearbeitet:
Mycorrhiz

Mycorrhiz

Erfahrenes Mitglied
DAs hier hat jetzt geklappt!

# su
su
# cp -rp /data/app /disk/app
cp -rp /data/app /disk/app
# mv /data/app /data/app.bak
mv /data/app /data/app.bak
# ln -s /disk/app /data/app
ln -s /disk/app /data/app
# cp -rp /data/app-private /disk/app-private
cp -rp /data/app-private /disk/app-private
# mv /data/app-private /data/app-private.bak
mv /data/app-private /data/app-private.bak
# ln -s /disk/app-private /data/app-private
ln -s /disk/app-private /data/app-private
 
BigBSES

BigBSES

Erfahrenes Mitglied
Und was hat es dir genau gebracht?
Merkst du was davon?
Ist der Lag vollkommen weg?
 
Mycorrhiz

Mycorrhiz

Erfahrenes Mitglied
Und was hat es dir genau gebracht?
Merkst du was davon?
Ist der Lag vollkommen weg?
Bei mir war er komplett weg, habe jedoch auch gleichzeitig /data/data auf /dbdata verschoben, daher ist das das noch nicht ganz aussagekräftig.

Ich schieb das gleich mal nach nem wipe auch auf die EXT3 und dann sag ich mehr.

Bis jetzt kann ich nur sagen, das mein neuer fix + dem dbdata fix für mich das beste ist!
 
M

mikest

Neues Mitglied
Ich hab auf meiner SD-Karte eine ext3-Partition angelegt (1,5GB).
Den Kernel mit ext4 Unterstützung hab ich draufgespielt. Firmware JM2.

Zuerst läuft alles. Nach ein paar Stunden bleiben einige Programme hängen, z.B. K9-Mail (das versucht dann immer neue Nachrichten zu laden und hängt in ner Dauerschleife) oder Battery snap. Es kommt dann auch ne Meldung "Programm wurde unerwartet beendet". Wenn ich die Daten auf /data/data lasse, tritt der Fehler nicht auf. Woran könnte das liegen?

Gruß
Micha
 
T

TheVisitorX

Fortgeschrittenes Mitglied
Ich hab auf meiner SD-Karte eine ext3-Partition angelegt (1,5GB).
Den Kernel mit ext4 Unterstützung hab ich draufgespielt. Firmware JM2.

Zuerst läuft alles. Nach ein paar Stunden bleiben einige Programme hängen, z.B. K9-Mail (das versucht dann immer neue Nachrichten zu laden und hängt in ner Dauerschleife) oder Battery snap. Es kommt dann auch ne Meldung "Programm wurde unerwartet beendet". Wenn ich die Daten auf /data/data lasse, tritt der Fehler nicht auf. Woran könnte das liegen?

Gruß
Micha
Das Problem hatte ich auch und zwar bei fast jedem Programm, was ich installiert habe. Weiß auch nicht, woran es lag, weil das kam ganz plötzlich. Bei mir hat nur ein Deinstallieren bzw. folgende Neuinstallation des Programms Abhilfe geschafft. Dann ging es wieder. Weiß allerdings nicht, wie lange... ^^
 
Zuletzt bearbeitet:
Z

ZeroOneB

Fortgeschrittenes Mitglied
Ich hab auf meiner SD-Karte eine ext3-Partition angelegt (1,5GB).
Den Kernel mit ext4 Unterstützung hab ich draufgespielt. Firmware JM2.
Wenn die Karte mit ext3 formatiert ist und du den ext4 Kernel verwendest könnte das das Problem verursachen. Teste mal den ext3 Kernel oder formatiere die Karte auf ext4 um und kopiere die Daten erneut drauf.

Sent from my GT-I9000 using Tapatalk
 
M

mikest

Neues Mitglied
ext4-Partition und Kernel mit ext4 Unterstützung hab ich getestet, ging auch nicht richtig. Ich versuchs mal mit ext3 Partition und dem anderen Kernel.
 
Oben Unten