Runtastic und Android 4.2.1

  • 69 Antworten
  • Neuester Beitrag
Diskutiere Runtastic und Android 4.2.1 im Sport, Wellness und Gesundheit im Bereich Android Apps und Spiele.
D

daniel_in

Fortgeschrittenes Mitglied
kann jemand für SGS2 das bestätigen? Welche nightly? Apropos bei CM 10.1 war die Strecke korrekt gemessen, nur mit ca 12x multipliziert. Kann leider selber noch nicht ausprobieren, meine Mutter kann aber nicht so gut mit Flashen und ich muss ganz sicher sein, welche Version gefixt ist, bevor ich ihr telefonisch eine nervige Flasheinleitung verpasse :)

P.S. Welche Änderung im Changelog deutet auf einen Fix?
 
Zuletzt bearbeitet:
tobiasth

tobiasth

Guru
Wenn du ganz sicher gehen willst, dann nightly 07.01.2013, beim nexus4 war es schon gestern drinnen!
 
D

daniel_in

Fortgeschrittenes Mitglied
die heutige Version bei SGS2 (08.01.13) hat den Bug sicher gefixt (Selbstversuch).

Edit. Es wurden keine Höhenmeter gezeigt, obwohl unebene Fläche...
 
Zuletzt bearbeitet:
D

drsoran2

Fortgeschrittenes Mitglied
Galaxy S2 cm 10.1. vom 7.1. hat den bug nach einem Monat behoben. Runtastic läuft wieder und hat gestern bei meinem 10 km Lauf alles korrekt aufgezeichnet, auch die Höhenmeter. Endlich!
 
L

Lexxxon

Fortgeschrittenes Mitglied
hallo

ich habe folgende Handy s7589 und habe das selbe Problem zwar nicht mit der APP rantastic aber mit zwei anderen apps. kann ich den fix auch auf mein Android 4.2.1 anwenden?

Gruß lex
 
N

Norbert42

Neues Mitglied
Das würde mich interessieren!
Habe ein Zopo ZP810 mit 4.2.1er FW.

Danke und Gruß
Norbert
 
tobiasth

tobiasth

Guru
Norbert42 schrieb:
Das würde mich interessieren!
Habe ein Zopo ZP810 mit 4.2.1er FW.

Danke und Gruß
Norbert
Lexxxon schrieb:
hallo

ich habe folgende Handy s7589 und habe das selbe Problem zwar nicht mit der APP rantastic aber mit zwei anderen apps. kann ich den fix auch auf mein Android 4.2.1 anwenden?

Gruß lex
Welche Software habt ihr denn oben, Stock-Rom oder CM?
 
N

Norbert42

Neues Mitglied
Bei mir ist es dezeit: Zopo EUROPE Jelly Bean 4.2.1 130409
 
tobiasth

tobiasth

Guru
Also das Problem von diesem Thread hier trat nur bei CM10.1 auf, in den Build's zw. Nov.2012 und 07.01.2013, weil Cyanogenmod etwas bei der Distanzberechnung umgestellt hatte. Wenn genau der gleiche Fehler bei dir auftritt, dann solltest du dich an Zopo oder direkt an runtastic wenden!
 
L

Lexxxon

Fortgeschrittenes Mitglied
tobiasth schrieb:
Welche Software habt ihr denn oben, Stock-Rom oder CM?
Also ich hab ein Star s7589 (China Handy) mit Android 4.2.1 was ich gerootet habe.
Folgende Apps habe ich probiert:
Oruxmap(habe extra ein Thema auf gemacht weil ich dachte es liegt an der app was aber nicht sein kann)
https://www.android-hilfe.de/forum/...en-oder-bedienfehler.409000.html#post-5581485
Locus
Hier ist genau der selbe Fehler.

Also die aktuelle GPS-Geschwindigkeit stimmt. Aber die Statistik und die zurück gelegten km stimmen überhaupt nicht.

Jetzt habe ich ein GPX file aus dem Internet geladen von einen "Fremden" und mir da die Statistik anzeigen lassen und die haut auch nicht ihn. Über das 10fache an km und Co.

Kann einer ne Idee wie ich das fixen kann? Kann ich nicht einfach eine Datei umschreiben oder rein kopieren (hab ja root).

gruß Lex
 
tobiasth

tobiasth

Guru
Da ihr beide "chinesische Handys" habt (so wie ich das sehe) vermute ich mal das sich die Entwickler an den source codes von cm10.1 bedient haben und daher der Fehler kommt.
Aber das ist natürlich nur eine Vermutung.....
Also auf eine neue Version hoffen, mit neueren sources ....


via nexus7
 
N

Norbert42

Neues Mitglied
Gleiches Bild bei mir. Auch Locus liefert viel zu hohe Kilometerwerte.
Mit Runkeeper auf dem gleiche Gerät ist die Entfernung korrekt.
Gruß Norbert
 
L

Lexxxon

Fortgeschrittenes Mitglied
kann man nicht einfach eine Datei aus tauschen oder umschreiben gibt es da keine anleitung ?

hat da einer ne idee?

oder kennt einer eine APP wo man offline Karten laden kann und tracks auf zeichnen kann die trotzdem funktioniert ohne den bug? brauche die zum wandern
 
N

Norbert42

Neues Mitglied
Meine Tracks (Google) liefert korrekte Werte und zeichnet Tracks ganz gut auf.
Hab ich heute morgen mal probiert. Mit Google Maps kannst Du Karten für die Offlinebenutzung laden, die dann auch von Meine Tracks verwendet werden
Runkeeper (nutze ich derzeit zum Laufen) kann wohl leider keine Offlinekarten verwenden.
Norbert
 
Y

yosenami

Fortgeschrittenes Mitglied
Hat noch jemand das Problem, dass Runtastic Pro direkt nach dem Start unter CM 10.1 (und darauf basierenden ROM) abstürzt? Gleiches gilt für die DB Navigator App. Andere Nutzer der ROMs hatten dieses Problem wohl nicht (SGS i9000).
 
tobiasth

tobiasth

Guru
ich hab keine Probleme - SlimBean, Helly, Mackay, Infamous Rom ...
 
Y

yosenami

Fortgeschrittenes Mitglied
yosenami schrieb:
Hat noch jemand das Problem, dass Runtastic Pro direkt nach dem Start unter CM 10.1 (und darauf basierenden ROM) abstürzt? Gleiches gilt für die DB Navigator App. Andere Nutzer der ROMs hatten dieses Problem wohl nicht (SGS i9000).
Fall es jemanden interessiert: nach einem weiteren Flashen der JW6 mit Re-Part habe ich die RC1 der CM 10.1 geflasht und statt der LaboDJ GAPPS die Originalen aufgespielt. Damit laufen jetzt endlich die beiden Problem-Apps (Runtastic Pro und DB Navigator). Puh. Ich werde wohl nie rausfinden, was nun das Problem war.
 
R

rolex0815

Fortgeschrittenes Mitglied
Hat irgendjemand noch fürchterlich erhöhten Akkuverbrauch festgestellt?
Ich war letztens auf einer Tour und runtastic hat in 5 Stunden meinen Akku geleert, Statistik gab 80% Verbrauch durch runtastic aus.

Das gab's noch nie, war sonst immer moderat.
 
tobiasth

tobiasth

Guru
naja, 5h sind eigentlich ganz ok, kommt drauf an was du alles nutzt ;)

Mein SGS1 verbraucht etwa 20-25% Akku pro 1h tracken!
Inklusive Bluetooth Anbindung von zwei Geräten und Live Tracking via 3G.
 
R

rolex0815

Fortgeschrittenes Mitglied
Nein, da passt was nicht:

Erklärung: Habe in den 5 Stunden nur runtastic laufen gehabt, kaum das Handy benutzt. Handy wurde sogar richtig warm wo der SOC sitzt.

Konnte letzten August eine 10 Stunden Radtour machen, dabei habe ich mit apemap sogar noch sehr oft navigiert und hatte nach 9 Stunden Laufzeit noch 19% Akku.

Deshalb weiß ich, dass jetzt irgendwo was im Argen liegen muss.
Schließe aber auch das ROM nicht aus, obwohl ich sonst keinerlei Auffälligkeiten mit dem Akku bemerkt habe.