[Mod][Source]Do it yourself - SystemUI - Quicksetting - Background

  • 1.865 Antworten
  • Neuester Beitrag
Diskutiere [Mod][Source]Do it yourself - SystemUI - Quicksetting - Background im Themes für Samsung Galaxy S3 im Bereich Root / Custom-ROMs / Modding für Samsung Galaxy S3.
nobody573

nobody573

Lexikon
Ja klar hab JRE 7 installiert, da ich auch auf win8 umgestiegen bin. Du nutzt doch auch den APK Manager geht es denn bei dir ??? Ich denke es liegt an der aapt.exe aber da find ich keine zur beta 7

vielleicht kannst du mir auch was zu diesem log Sagen

beim Compilen der Gmail mit apktool beta 7 und einem anderen tool bekomm ich diesen Fehler

..\Decompiled_apk\Gmail\smali\android\support\v4\a pp\ActionBarDrawerToggle.smali[246,4] Invalid literal value: 16256. Low 16 bits must be zeroed out.
..\Decompiled_apk\Gmail\smali\android\support\v4\a pp\ActionBarDrawerToggle.smali[265,4] Invalid literal value: 16384. Low 16 bits must be zeroed out.
..\Decompiled_apk\Gmail\smali\android\support\v4\a pp\ActionBarDrawerToggle.smali[267,4] Invalid literal value: 16128. Low 16 bits must be zeroed out.
..\Decompiled_apk\Gmail\smali\android\support\v4\a pp\ActionBarDrawerToggle.smali[488,4] Invalid literal value: 16256. Low 16 bits must be zeroed out.
Exception in thread "main" brut.androlib.AndrolibException: Could not smali file: android/support/v4/app/ActionBarDrawerToggle.smali
at brut.androlib.src.SmaliBuilder.buildFile(SmaliBuil der.java:72)
at brut.androlib.src.SmaliBuilder.build(SmaliBuilder. java:56)
at brut.androlib.src.SmaliBuilder.build(SmaliBuilder. java:41)
at brut.androlib.Androlib.buildSourcesSmali(Androlib. java:337)
at brut.androlib.Androlib.buildSources(Androlib.java: 298)
at brut.androlib.Androlib.build(Androlib.java:284)
at brut.androlib.Androlib.build(Androlib.java:258)
at brut.apktool.Main.cmdBuild(Main.java:233)
at brut.apktool.Main.main(Main.java:88)
Das System kann die angegebene Datei nicht finden.
Das System kann die angegebene Datei nicht finden.
 
Zuletzt bearbeitet:
scheichuwe

scheichuwe

Guru
Die appt.exe ist jetzt direkt in der apktool.jar mit drin.
Hast du mal probiert apktool direkt zu nutzen? Also per Kommandozeile?
 
nobody573

nobody573

Lexikon
Ja mit anderen tools geht es da ich es aber gewohnt bin mit dem APK Manager zu arbeiten wollte ich diesen weiterhin nutzen daher meine frage
 
Thunder82

Thunder82

Experte
kann mir einer weitehelfen bekomme beim compilen der systemui immer diese fehler
|03.11.2013 -- 14:26:25,54|
--------------------------------------------------------------------------
java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)
I: Checking whether sources has changed...
I: Smaling...
I: Checking whether resources has changed...
I: Building resources...
I: Building apk file...
Das System kann die angegebene Datei nicht finden.
I: Checking whether sources has changed...
I: Checking whether resources has changed...
I: Building resources...
I: Building apk file...
Das System kann die angegebene Datei nicht finden.
 
wii360

wii360

Experte
Extrahieren die framework-res.apk und die twframework-res.apk apk aus deiner Rom.
Benenne die framework-res.apk in 1.apk und die twframework-res.apk in 2.pak um.
Kopiere beide in den apk Tool Ordner auf c/benuter/"deine pc/apktool wo die 1.apk und 2.apk schon drin sind. Überschreibe beide und dann musste es gehen.
 
nobody573

nobody573

Lexikon
Hello Leutz hat schon wer es geschafft die SystemUI von Wanam 7.2 (4.3) vernünftig zu decompilen. Bekomme ständig fehler egal wie ich es mach. Mal wird mehr und mal wird weniger decompiliert

Der ursprüngliche Beitrag von 12:35 Uhr wurde um 12:36 Uhr ergänzt:

scheichuwe schrieb:
Die appt.exe ist jetzt direkt in der apktool.jar mit drin.
Hast du mal probiert apktool direkt zu nutzen? Also per Kommandozeile?

gibt es eigentlich zum neuen Apktool.jar auch eine neue apktool.bat ?? hab noch nichts gesehen
 
K

Kiray1982

Lexikon
Ist wanam nicht odexed? Dementsprechend sollte es angepasst werden

Der ursprüngliche Beitrag von 12:47 Uhr wurde um 12:48 Uhr ergänzt:

Die bat kannst mit nem Editor öffnen und den Namen austauschen. Variablen bleiben gleich

Der ursprüngliche Beitrag von 12:48 Uhr wurde um 12:50 Uhr ergänzt:

Ich konnte bisher jede 4.3 zu decompilieren, egal ob apktool 1.5.2 oder 2.x alpha
 
nobody573

nobody573

Lexikon
versteh ich nicht wie du es meinst die smali brauch ich nicht. Das was mir auffällt das ist ja Sammy Rom und soviel ich weis braucht die SystemUI auch die twframe, diese ist auch installiert aber er lädt sie nicht mit

Der ursprüngliche Beitrag von 12:52 Uhr wurde um 12:54 Uhr ergänzt:

hab framework ohne Probleme noch gemacht aber SystemUI geht nicht

Der ursprüngliche Beitrag von 12:54 Uhr wurde um 13:10 Uhr ergänzt:

So gerade mal mit einer anderen APK getested, die funktioniert ohne Probleme also muss es an der SystemUI liegen
 
orangerot.

orangerot.

Experte
Musst bei der SystemUI den gleichen fix anwenden wie bei 4.2, dann geht's ;)

Aber ich bekomme die SecPhone, SecContacts und SecSettings nicht gescheit kompiliert :( kommt immer n Fehler..
 
nobody573

nobody573

Lexikon
was heißt fix anwenden wie bei 4.2 da musste ich garnichts machen ??
 
wii360

wii360

Experte
wii360 schrieb:
...

bestimmt ist das schon hier gefragt worden aber beim compileren von clockpackga bekomme ich einenge Fehler, das decomiplieren geht ohne Probleme.

....


Ich kann mich dunkel erinnern davon schon mal gelesen zu haben, hab ich recht?
Ich finde es aber nicht mehr, SRY:crying:
nobody573 schrieb:
Du hast ziemlich viele Fehler im Layout im Bezug auf style.

Suche alle raus und setzte ein Plus davor dann werden die ignoriert liegt am apktool

Ich zittiere mal meinen Beitrag von früher und die Lösung...

irgendwie funktioniert das mit dem "+ vor jedem @" bei Android 4.3 nicht mehr. Gibt´s da eine andere Lösung?
 
nobody573

nobody573

Lexikon
Das mit dem Plus geht immer noch überprüfe alles nochmal. Habs grad selber gemacht
 
wii360

wii360

Experte
Bei mir kommen danach 111 Fehler mit +@style...

Bekommst du svoice wieder compiliert? Könnte bei 4.22 auch nicht.
 
orangerot.

orangerot.

Experte
nobody573 schrieb:
was heißt fix anwenden wie bei 4.2 da musste ich garnichts machen ??
Doch man musste n paar fehlende Einträge in die styles.xml machen. Such mal im thread, ich glaube es steht hier auch iwo. Ansonsten poste ich es morgen mal rein, wenn ich am Laptop bin.
 
nobody573

nobody573

Lexikon
Wie soll ich Einträge machen wenn sie selbst beim decompilieren schon Fehler ausgibt und z. B. die color. xml garnicht ausgespuckt wird und viele andere XMls?
Habs aber jetzt hin bekommen svoice hab ich noch nicht probiert
 
orangerot.

orangerot.

Experte
Also bei mir macht das decompilieren 0 Fehler Oo (hab vts benutzt)
 
nobody573

nobody573

Lexikon
Hallo ihr lieben Helfer, ich hab ein kleines großes Problem. Bei Android 4.3 funktioniert auf der nackten Stock Rom die S4 und Note 3 Tastatur, wenn ich aber mein Theme drauf hab und ich dann die S4 Tastatur z. B. installier zeigt er sie mir nicht an kommt sofort die Spracheingabe wo könnte da der Fehler sein? ich vermute die Tastatur selber glaube weniger das es an meinem Theme liegt
 
dkionline

dkionline

Experte
Das liegt vermutlich am Port der Apps.
 
nobody573

nobody573

Lexikon
Ja das denke ich auch nur wie kann man die so bearbeiten das sie geht weil ohne theme geht sie ja auch