[ROM][NJH47F][7.1.2] crDroid 3.8.2 - Android Nougat 7.2.1 für Umi Diamond

  • 103 Antworten
  • Neuester Beitrag
Diskutiere [ROM][NJH47F][7.1.2] crDroid 3.8.2 - Android Nougat 7.2.1 für Umi Diamond im Umi Diamond Forum im Bereich UMi/UMiDIGI Forum.
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Wichtiger Hinweis

Ich übernehme keine Haftung für Schäden die beim Flashen an Eurem Gerät entstehen könnten! Für Handlungen mit den hier angebotenen Dateien bist Du selbst verantwortlich!

Hallo zusammen,

freue mich euch hier crDroid 3.8.2 für das Umi Diamond vorstellen zu dürfen.
Damit haben wir nun endlich eine saubere Firmware und dazu noch Android 7 :)

Installation :
  • Backup erstellen
  • Full Wipe, Werksreset, evtl. um wirklich alles alte von Umi zu entfernen internen Speicher auch wipen
  • Zip über TWRP einspielen
  • Neustarten und Setup durchführen
  • Reboot (Der erste Neustart dauert 5-10 Minuten)
  • Spass haben ;)
Bekannte Fehler:
Bluetooh Kopplung fehlerhaft

Link zum Mediafire Directory



Update 29.01.2018 :

Version 3.8.5 ist draussen :

  • Update des Sicherheitsstand auf Januar 2018
  • Magisk in Version 15.3 vorhanden.
  • Bluetooth koppelt bei mir problemlos mit meinem Headset
  • Kamera sollte gefixt sein
  • Ein paar Schönheitsfehler beseitigt, nun sollte überall Umi Diamond als Gerätename auftauchen.
Falls noch Fehler vorhanden sind, so versuche ich sie zu fixen aber wie immer alles ohne Gewähr ist ja ein wunder das man für das Phone überhaupt was machen kann :/
Einspielen, wie gewohnt, ins TWRP booten, kompletter Wipe und installieren.

Es kann sein das ein Cache/Davlik Wipe reicht konnte es aber wegen Zeitmangel nicht wirklich testen...

File sharing and storage made simple


Screenshots (noch von Version 3.8.2 aber da gibts auch nix neues zu sehen) :

1.png 2.png 3.png 4.png 5.png 6.png 7.png 8.png 9.png 10.png 11.png 12.png[
 
Zuletzt bearbeitet:
Bearbeitet von Miss Montage - Grund: Ergänzung vorgenommen. Gruß, Miss Montage
hotwebnet

hotwebnet

Fortgeschrittenes Mitglied
Vielen Dank,echt super
 
N

numbo

Neues Mitglied
Wie hast du das denn hinbekommen? :D
Und kannst du eine Aussage über die Akkulaufzeit machen für Leute, die überlegen sich das zu kaufen?
 
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Mit ein wenig getrickse :) Richtung Wochende kommt dann noch ein komplett jungfräuliches LineageOS 14.1 ohne root oder irgendwelche Modifikationen.
Zur Akkulaufzeit kann ich schlecht was sagen da das Handy bei mir selten genutzt wird...
 
hotwebnet

hotwebnet

Fortgeschrittenes Mitglied
Akkulaufzeit ist echt super, mind.25% besser als mit dem Orginal ROM
 
N

numbo

Neues Mitglied
Super Sache ;) Würdest du eine Kaufempfehlung für das Umi mit deinen ROMS geben?
 
hotwebnet

hotwebnet

Fortgeschrittenes Mitglied
Kaufempfehlung....aber nur für Frauen über 40, die Whatsapp schreiben SMS senden und telefonieren, etwas Musik hören und hin und wieder ein kleines Spiel in der Bahn spielen.....für einen Mann oder Jugendlichen würde ich keine Kaufempfehlung geben, es ist kein Handy für Power User
 
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Nein ne Kaufempfehlung würde ich auf keinen Fall geben! Das liegt zum einen daran, das Umi nunmal vorsätzlich einfach Mal/Adware auf ihren Telefonen installiert und sowas sollte man absolut boykotieren. Ausserdem liest man in einigen Foren auch über Hardwareprobleme mit dem Screen etc.
Aber es gibt genug Telefone in der nahezu gleichen Preisklasse vielleicht +-20-30 EUR.
 
M

Molins

Neues Mitglied
TWRP muss man ja noch downloaden aber auf deren Seite gibt es keinen Hersteller UMI, kann das sein?

https://teamw.in/twrp_view_all_devices/

Frage zum rooten, mit welchem Proggi denn? Ich habe letztens eins aus Russland probiert, es hat nicht geklappt und ich hatte zudem auch noch auf dem Win-PC jede Menge Malware. Was ist da die Empfehlung?
 
Ziggy815

Ziggy815

Ambitioniertes Mitglied
@Molins Hab das TWRP schnell mit ins MediaFire Verzeichnis gepackt, installation ganz einfach übers normale Flashtool.
Was root angeht, ist integriert in Form von Magisk kannst Du in den Einstellungen von Magisk aktivieren/deaktivieren, am besten den safetynet fix noch hinterher installieren dann sollten auch alle Apps die auf Root checken denken es wäre ein nicht gerootetes Phone :)
 
M

Molins

Neues Mitglied
Muss gerade ausser Haus, habe alles heruntergeladen und mache mich danach daran, danke!!!!!
 
M

Molins

Neues Mitglied
Ziggy815 schrieb:
@Molins Hab das TWRP schnell mit ins MediaFire Verzeichnis gepackt, installation ganz einfach übers normale Flashtool.
Was root angeht, ist integriert in Form von Magisk kannst Du in den Einstellungen von Magisk aktivieren/deaktivieren, am besten den safetynet fix noch hinterher installieren dann sollten auch alle Apps die auf Root checken denken es wäre ein nicht gerootetes Phone :)
Sodele, ich dachte, ich bin bewandert mit den Sachen aber Pustekuchen, ...... was fürn Flashtool? Was mache ich mit dem Magix.zip genau? Ist es danach also gerootet?

Und danach kann ich die TWRP.zip entpacken, übertragen auf das UMI, zuvor ein Full Wipe und aus- und einschalten und schon läufts, so in etwa?
 
Zuletzt bearbeitet:
Thyrion

Thyrion

Ehrenmitglied
Mit dem SP Flashtool das TWRP-Recovery flashen, ins Recovery booten, dann mittels TWRP dieses ROM flashen (ein Data-Wipe wäre vermutlich nicht verkehrt) und fertig, bereits gerootet. Evtl. noch den Magisk-SafetyNet-Fix hinterher, wenn du Root vor anderen Apps verstecken musst.
 
Zuletzt bearbeitet:
Ziggy815

Ziggy815

Ambitioniertes Mitglied
Moin,

hab das Flashtool und die Treiber nu auch noch mit ins Verzeichnis gepackt :)
Das Flashtool brauchst Du um das Recovery Image (TWRP) auf das Phone zu flashen.
Im prinzp läuft das ganze dann so (Windows 7 64-bit):

1.) FlashTool, Treiber, TWRP entpacken.
2) Bei den Treibern die Mediatek-Drivers-Install.bat als Administrator ausführen.
3) flash_tool.exe starten.
4) Auf Load Scatter FIle gehen und die Scatter Datei auswählen, die beim TWRP dabei war (MT6753_Android_scatter).
5) Dann sollte bei Recovery uten ein Häckchen sein.
6) Unbedingt drauf achten das oben in der Auswahlbox "Download only" und nur bei Recovery ein Häckchen gesetzt ist.
7) Download klicken und das _ausgeschaltete" Phone anschließen.
6) Der Flashvorgang beginnt und sollte nach ein paar Sekunden abgeschlossen sein, bekommst dann ein neues Fenster mit nem großen grünen Haken.

Das war der Teil für TWRP.

Nun hälst Du während Du das Phone einschaltest die Lautstärke + Taste gedrückt dann erscheint ein kleines Menu was sich mit der Lautstärke wippe steuern lässt.
Hier gehst Du auf Recovery und das gewohnte TWRP sollte starten.
Da machst Du einfach einen kompletten Wipe von allem ausser internal storage.
Dann gehst Du zurück und auf Install, wählst das zipfile vom ROM aus und lässt ihn machen. Danach noch ein Reboot und Du solltest am neuen Bootlogo schon sehen das es geklappt hat. Erster Boot dauert ein paar Minuten!

Zu Magisk, ohne zu lang auszuholen, das ist sowas wie das xposed Framework und damit ist das Phone dann auch schon gerootet, nur das Magisk es ermöglicht das root vorm Betriebsystem zu verstecken so das auch sachen laufen sollten, die mit gerooteten Geräten sonst nicht laufen.

Hoffe das hat Dir weitergeholfen, ansonsten schau Dir auch den Link von Miss Montage mal an da ist das Flashtool genauer beschrieben.

Bei weiteren Fragen : Immer her damit :)
 
M

Molins

Neues Mitglied
Ok, die Batterie ist fast alle, ich will vorsichtshalber über Nacht vollladen und morgen erst ausprobieren aber recht herzlichen dank schon mal vorab, ich meine jetzt hätte ich es kapiert!!!!
 
M

Molins

Neues Mitglied
Also, hat bis zum Kleinmenue mit den 3 Einträgen geklappt, nach Auswahl von Recovery kam ein Bild des Android mit der Fehlermeldung Ausrufezeichen rot "Kein Befehl" und nach dem nächten Einschalten stehe ich vor dem Handy was folgendes Bild zeigt, mit der Wippe kann ich rauf und runter, Was nun?IMG_20171125_231619.jpg

Will noch anmerken: Es kam nach Download des Files scatter.txt auch nach 10 Minuten kein OK Zeichen, also habe ich auf die Schaltfläche "Stop" gedrückt und neu gestartet mit gedrückter Plus-Taste, so kam das Kleinmenue mit den 3 Einträgen. Nach Drücken von Download Scatter.txt und direkt darauf anschliessen des Handy kam übrigens hoch das Windows-Bild mit dem Laden von Treibern, das hat aber auch nicht geklappt:
Unbenannt1.png Unbenannt.png

Ich lange das Handy jetzt mal nicht an bis mir jemand freundlicherweise sagt wie es weiter geht hoffentlich hält die Batterie so lange :) .........
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ich könnte jetzt "wipe data/factory reset" machen und danach soll "Install" kommen aber das Install sehe ich jetzt schon mal nicht aufgeführt, ist es das richtige soweit?
 
Zuletzt bearbeitet:
A

almo911

Neues Mitglied
Hi Ziggy,

erstmal tausend Dank für deine Mühe.

Eine Frage: Hat es irgendwelche Auswirkungen wenn ich Magisk deinstalliere, oder ist dann einfach nur root entfernt - das Umi funktioniert aber sonst perfekt?

Danke und n schönen Sonntag noch!
 
Ziggy815

Ziggy815

Ambitioniertes Mitglied
@Molins
Da hat dann kein Flash stattgefunden deswegen biste danach im normales recovery des Phones geladet. Könntest nochmal versuchen die Treiber neu zu installieren, wichtig ist, das Du die .bat Datei als Admninistrator ausführst und wenn er Dich fragt ob unsignierte Treiber installiert werden sollen Du mir ja antwortest. Dann zur Sicherheit einen Neustart machen. Wichtig in der Flash Software ist erst auf Download klicken und danach erst das ausgeschaltete Phone einstecken, falls der Akku leer sein sollte macht das auch nichts, das Flashtool arbeitet hier sogar wenn garkein Akku drin ist.
Falls das mit den Treibern ímmer noch nicht klappt, schreib doch mal bitte was für ein Betriebsystem Du hast...

@almo911
Offen gesagt hab ich das noch nicht probiert aber normalerweise sollte es sich sauber deinstallieren lassen. Kannst ja zur Sicherheit ein NandBackup im TWRP machen dann kannste im Zweifelsfall wieder zurück ohne was zu verlieren. Aber wie gesagt es sollte sich sauber entfernen lassen fehlen wird dann root und der integrierte Adblocker.
 
A

almo911

Neues Mitglied
Danke für die schnelle Antwort. Das deinstallieren funktioniert scheinbar sauber und es läuft alles ohne Probleme. Wenn dadurch root weg ist, braucht man ja auch den SafetyNet-Fix nicht mehr, oder? Welcher adblock war denn eigentlich integriert?

Danke und n schönen Sonntag noch, LG