Wiko Robby Custom Recovery (TWRP) flashen um SuperSu zu installieren

  • 25 Antworten
  • Neuester Beitrag
Diskutiere Wiko Robby Custom Recovery (TWRP) flashen um SuperSu zu installieren im Wiko Robby Forum im Bereich Wiko Forum.
S

S4D

Neues Mitglied
Hallo,

ich kann ja mit Power+VolumeUP in das Wiko Recovery.
Welche Option muss ich dort auswählen um dann mit dem Flashtool das TRWP einzuspielen ?
USB Debug ist aktiviert und OEM-Entsperrung auch.
Kann jemand kurz erklären ? Danke :)
Habe bis jetzt nur Samsung Geräte gerootet.
 
N

Novilos

Neues Mitglied
Hallo,

ich habe ebenfalls Probleme mit der V37. Ich habe vor zwei Wochen ein Robby mit der Erstellungsversion 32 mit Hilfe dieser Anleitung gerootet. Nun habe ich ein anderes an der Hand mit der V37 Software drauf. Eigentlich läuft alles gut, aber wenn ich dann das TWRP per Flashtool aufgespielt habe und das Handy starte und versuche direkt in den Recovery Mode (Power + Vol+) zu kommen, fängt er sich in einer Boot Schleife und ich muss alles auf Anfang setzen. Wenn ich es durchbooten lasse und beim nächsten Neustart in den Recovery Mode gehe, sieht alles aus wie immer. Wenn ich dann versuche die SuperSU zu installieren bricht der Vorgang ab.

Hat jemand einen Rat? Ich verwende die Zip, welche zu Beginn des Threads hier verlinkt ist. Gibt es evtl. Konflikte mit der V37 Software und der TWRP Version?

Besten Gruß
 
Dieter1709

Dieter1709

Stammgast
Novilos schrieb:
Hat jemand einen Rat? Ich verwende die Zip, welche zu Beginn des Threads hier verlinkt ist. Gibt es evtl. Konflikte mit der V37 Software und der TWRP Version?

Besten Gruß
Hi, nein es gibt keine Konflikte mit v37. Mach es so wie es oben steht. Mit ADB entsperren und mit Flash Tool flashen. Super SU mit TWRP flashen fertig.

Mfg Dieter
 
N

Novilos

Neues Mitglied
Moin,

wie gesagt, ich gehe genau so vor wie beschrieben (und wie es ja beim anderen Robby geklappt hat).

1.) OEM Entsperrung und USB Debuggin aktivieren
2.) "adb reboot bootloader" -> fastboot. "fastboot oem unlock" -> Bootloader offen. "fastboot reboot" -> neustart.
3.) Handy aus. Flashtool mit Recovery bestückt und gestartet -> Handy dran, Flash erfolgreich.

Aber dann passiert nichts mehr. Habe ich da irgendwas vergessen? Nach dem Flash schalte ich das Handy direkt mit "Power + Vol+" ein und müsste eigentlich in den TWRP Screen kommen oder ?
 
Dieter1709

Dieter1709

Stammgast
@Novilos, ja es sollte TWRP kommen.
Hast Du im Flash Tool auch die recovery getauscht nach TWRP 3.0.2 Recovery For Primo N2 By Nayeem Khan.img
Versuch mal nur die TWRP zu flashen, bei allen anderen Haken raus machen.

Mfg Dieter
 
N

Novilos

Neues Mitglied
@Dieter1709: Das ist genau mein Vorgehen. Habe diverse Scatter Files durchprobiert (die die beim zip dabei ist, die aus der Stock ROM,...) und immer nur die Recovery geflasht (und vorher gegen das Image getauscht). Habe auch versucht die V20 drauf zu kriegen, aber dann gibts immer nur nen müden schwarzen Bildschirm. Habe auch schon alles einmal neu runtergeladen, um auszuschließen, dass mein lokales Image Schaden genommen hatte.

Gibt es noch andere Custom Recoverys die in Frage kommen würden? Habe im Netz noch was von CWM gelesen, aber keinen Anhaltspunkt gefunden welche Version da für das Robby passen würde. Hast du Erfahrung mit Schnellroot Apps? Habe da nicht viel positives drüber gefunden, da es undurchsichtig ist, was im Hintergrund alles eingestellt wird. Wäre mir erstmal egal an dieser Stelle :) Habe es mit Framaroot versucht, aber da kam nur ein Fehler, dass das Modell nicht unterstützt wird. Noch irgendwelche Ideen?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ich habe mir jetzt noch ein anderes Robby organisiert, da funktioniert es auf Anhieb ohne Probleme. :( Könnte es ein Hardware Problem sein?
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Zu früh gefreut. Nach der SuperSU Installation des dritten Robby hängt er auch in einem Bootloop, wobei er immer das TWRP Recovery startet nur "could not mount \data and crypt footer" oder so ähnlich meldet. Hmpf :-/
 
Dieter1709

Dieter1709

Stammgast
@Novilos, nein es gibt nichts anderes. Hast Du V37 von Wiko runtergeladen und entpackt. Da gibt es ein Verzeichnis rom, da sind alle dateien drin die du brauchst, nur diwe TWRP nicht. Die orginal recovery umbenennen z.b. in recovery.orginal und die TWRP in recovery.img und in rom kopieren. Die scatter.txt aus rom laden dann solten alle Dateien richtig in Flash tool drin stehen und mit v37 mit TWRP geflasht werden.
Bei mir hat es so geklappt, von v32 auf v37 mit TWRP.
Alles andere geht nicht, keine apps oder andere recovery.
Mfg Dieter
 
N

Novilos

Neues Mitglied
Ich habe ja ein erfolgreich gerootet Robby hier. Ist es irgendwie möglich, das komplette System in ein Backup zu packen, um dieses auf das widerspenstige Handy aufzuspielen?
 
Dieter1709

Dieter1709

Stammgast
@Novilos, wenn TWRP drauf ist, ja.
Ansonsten nur noch mit Nandroid Backup. Ist eine app,
Hattest Du auch bei ADB am Handy mit Vol+ =yes Bestätigt beim entsperren?
Sonst noch mal v37 original von wiko drauf und von neuen beginnen.
Mfg Dieter
 
N

Novilos

Neues Mitglied
Ich kann aber ein Nandroid Backup auch nur auf einem Handy wiederherstellen auf dem auch TWRP installiert ist oder? Oder gibt es auch eine Möglichkeit das erstellte Backup "brutal" zu flashen? Quasi ein eigenes Image erstellen, welches ich in ein anderes Handy einspiele, sodass es einfach identisch ist.
 
Dieter1709

Dieter1709

Stammgast
Novilos schrieb:
:
Zu früh gefreut. Nach der SuperSU Installation des dritten Robby hängt er auch in einem Bootloop, wobei er immer das TWRP Recovery startet nur "could not mount \data and crypt footer" oder so ähnlich meldet. Hmpf :-/
OK, formatiere mal Data, Cache und Dalvik, Data wird es warscheinlich nicht machen da es falsch Partitioniert ist.
Also mit original scatter.txt v37 nur mit TWRP flashen wie hier beschrieben.

Ja das geht auch, aber nur system, recovery, boot sind wichtig, müssen aber auch die MD5 Dateien von diesen mit kopiert werden.
Das behebt aber nicht das Problem von Data-Parition.
siehe mal Nachicht.
Mfg Dieter
 
Zuletzt bearbeitet:
N

Novilos

Neues Mitglied
@Dieter1709: Habe das Ding nochmal formatiert und neu aufgesetzt. Jetzt funktioniert es (beim dritten Gerät). Vielen Dank an dieser Stelle schon mal!!

Das zweite Gerät steht allerdings immernoch vor dem Problem, dass das TWRP nicht gestartet wird. Könntest du beschreiben, wie ich ein Nandroid Backup von einem gerootet Handy (ist ja vorhanden) in das andere ohne installiertes TWRP einspiele?
 
Dieter1709

Dieter1709

Stammgast
@Novilos, das geht nicht , braucht root mit Nandroid Backup. Es hilft nur die Original v37 aufspielen und von vorn beginnen.

Ok, ich bin dann für heute weg, muss 3:00 wieder raus, eventuell morgen wieder ab ca 16:00.
Mfg Dieter
 
Dieter1709

Dieter1709

Stammgast
@Novilos, und alles geklappt, läuft das Robby jetzt?

Mfg Dieter
 
M

MP87

Neues Mitglied
Hallo allersits,
ich hänge mich hier an den alten TWRP-Thread an weil ich TWRP nicht auf meinem Robby zum laufen bekomme.

Nach defekt meines bisherigen Handys habe ich das alte Robby meiner Tochter bekommen und möchte es rooten.
Bin dabei nach der der Anleitung im aus Post #2(rar-Archiv) vorgegangen.

Das Robby hatte die Stock-ROM V41 drauf.
Bootloader entsperren hat problemlos geklappt (wurde auch mit 'fastboot getvar all' überprüft)
Ich habe das im rar-Archiv vorhandene 'TWRP 3.0.2 Recovery For Primo N2 By Nayeem Khan' mit Hilfe des 'SP_Flash_Tool_exe_Windows_v5.1516.00' (ebenfalls aus rar Archiv) aufgespielt.
Das SP Flash Tool hat den Vorgang mit dem 'Download OK-Fenster' (dieses mit dem grünen Häckchen) offenbar erfolgreich durchgeführt.
Das scatter-file kam aus dem eigens heruntergeladenen V41-er Wiko-Update von wikomobile.com.
Mittels Tastenkombination Pwr&Vol+ komme ich jedoch nur in das originale 'Stock-Recovery'. Auch ein Reboot mit 'adb reboot recovery' führt mich ins Stock-Recovery. TWRP ist 'unaufrufbar'.

Das habe ich bis jetzt alles (erfolglos) versucht:
* flashen des TWRP mit 'fastboot flash recovery recovery.img' im fastboot modus (recovery.img='TWRP 3.0.2 Recovery For Primo N2 By Nayeem Khan')
* flashen mit neuestem SP Flash Tool (SP_Flash_Tool_v5.1924_Win)
* zurücksetzen mit V41-er Version mittels Wiko-Update
* andere TWRP's für das Robby aus dem Netz ('Wiko Robby 3.2.3', 'TWRP3.0.2-V3750.img', 'twrp-3.2.3-0-v3750an-20181201.img', +ein weiteres)
* andere Stock-ROMs für das Robby aus dem Netz (V37, V32)
* 'wipe cache partition', diverse factory resets
* Löschen der recovery Partition mit 'fastboot erase recovery' ('fastboot format recovery' hat verweigert mit Hinweis das recovery eine RAW-Partition ist)
* alle diese Stock-ROMs/TWRPs/Flash Methoden habe ich in diversen unterschiedlichen Kombinationen durch.
* auf einen entperrten Bootloader habe ich jedesmal geachtet, die scatter files sind immer dem jeweiligen Update (V41, V37, V32) entnommen.

Ich komme nach wie vor lediglich ins Stock-Recovery, eigenartigerweise auch nach 'fastboot erase recovery'.

Hat jemand eine Idee/einen Ansatz wo da der Hund begraben liegt?
Für Hilfe wäre ich sehr dankbar, bin leider mit meinem Latein am Ende.


Vorhandene Systeme: Win7, (K)ubuntu
 
Dieter1709

Dieter1709

Stammgast
[QUOTE="MP87, post: 12007026, member: 531793"
Hat jemand eine Idee/einen Ansatz wo da der Hund begraben liegt?
Für Hilfe wäre ich sehr dankbar, bin leider mit meinem Latein am Ende.

Vorhandene Systeme: Win7, (K)ubuntu
[/QUOTE]

Versuch es mal hier mit [ROM][6.0] XOS ROM für das Wiko Robby

Da ist ein recovery für das Robby bei was auch geht.

MfG Dieter1709
 
M

MP87

Neues Mitglied
Danke, ich teste es morgen aus. Komme heute erst spät heim.
 
M

MP87

Neues Mitglied
Hallo Dieter,
wo finde ich in dem Archiv das recovery?
Hab lediglich eine 'boot.img' gefunden und das flashen dieser hat keine Veränderung gebracht.
 
Dieter1709

Dieter1709

Stammgast
@MP87 ,
das ist im 2. Post bei Downloads