Aktivierung des Root-Accounts

  • 76 Antworten
  • Neuster Beitrag
E

eis0r

Fortgeschrittenes Mitglied
nein nur USB-Debugging aktivieren in den Entwickleroptionen und der Device-Treiber muss installiert sein und halt adb und fastboot auf deinem Rechner...
 
A

arnold80

Fortgeschrittenes Mitglied
Hat schon jemand den Austausch von Kingroot gegen Supersu durchgeführt? Hab es selbst probiert und es geht auch eigentlich. ABER, in der Statusleiste ist dann immer die Raute sichtbar, die mich darauf hinweist, dass die Bibliotheken erneuert werden müssen, da sonst Supersu nicht korrekt funktionieren könnte. Das klappt aber leider nicht.
In der Anleitung zum Wechsel steht das zwar auch schon, aber da hat es bei mir auch nicht funktioniert. Wie beschrieben habe ich "normal" statt "CWM/TWRP" angeklickt. Dann kommt der Bildschirm mit dem Hinweis, dass es maximal 5 Minuten dauern kann. Ungefähr nach 20 bis 30 Sekunden kommt dann der Hinweis, dass es fehlgeschlagen ist.
Das ganze ist schon ein wenig seltsam, da Supersu trotz der Fehlermeldung funktioniert. Alle root-Apps fragen schön über die Supersu App die Rechte ab und es kommt auch wie gewohnt der Popup von Supersu.
Also das einzigste was da stört, ist die Raute in der Statuszeile, die zum aktualisieren der Bibliotheken aufruft. Ansonsten funktioniert alles wunderbar.

Haben die anderen ähnliche Erfahrungen gemacht?
 
E

eis0r

Fortgeschrittenes Mitglied
das sollte nicht der Fall sein wenn du nach der Anleitung von lightwars auf xda vorgegangen bist. du kannst mal probieren, nach dem rooten mit kingroot zuerst die aktuelle busybox.apk zu installieren, danach einmal neu starten und dann nur noch die su aus der supersu beta 2.49 wie in der Anleitung beschrieben auszutauschen. danach hat das updaten der binaries bei mir ohne Probleme funktioniert...
 
transmorpher

transmorpher

Stammgast
transmorpher schrieb:
Hab das mal nachgespielt und kann den Fehler bestätigen. Irgendwas haut da also nicht ganz hin .

Geholfen hat einfach die aktuelle Beta drüber zu bügeln.

LG
 

Anhänge

  • eu.chainfire.supersu-2.49-249-minAPI7.apk
    5.6 MB Aufrufe: 167
Max Mustermann

Max Mustermann

Experte
Threadstarter
Meins wird gar nicht erst erkannt.
Habe den "15 seconds ADB installer 1.4.2" benutzt.
Also alles installiert.
 
A

arnold80

Fortgeschrittenes Mitglied
transmorpher schrieb:
Geholfen hat einfach die aktuelle Beta drüber zu bügeln.

LG
Bei mir jetzt auch, danke

Und eigentlich hab ich mich an die Anleitung gehalten. Wohl was über sehen :( egal nun alles paletti :)
 
transmorpher

transmorpher

Stammgast
Max schau im XDA . Da ist es eigentlich sehr gut beschrieben, und eine ZIP mit allen nötigen Daten ist auch vorhanden. Ich hänge jene mal hier an. Danke an den User lightwars
:thumbup:
Einfach ZIP entpacken dann SHIFT drücken und rechtsklick auf den Ordner/ Eigabeaufforderung hier öffen anklicken und dann seiner Anleitung folgen.

Rest wurde hier ja schon be und geschrieben.

LG
 

Anhänge

  • SwitchSuperSu.7z
    2.4 MB Aufrufe: 195
Max Mustermann

Max Mustermann

Experte
Threadstarter
Ja ne, ganz so doof bin ich nun auch wieder nicht (nur ein bischen).
adb listet kein Device. USB-debugging ist aktiviert.
Treiber mehrmals installiert, alle USB-slots probiert.
Ich nutze Win7 64bit.

 
Zuletzt bearbeitet:
A

arnold80

Fortgeschrittenes Mitglied
Max Mustermann schrieb:
Ja ne, ganz so doof bin ich nun auch wieder nicht (nur ein bischen).
adb listet kein Device. USB-debugging ist aktiviert.
Treiber mehrmals installiert, alle USB-slots probiert.
Ich nutze Win7 64bit.

Hatte dasselbe Problem, lag bei mir am Kabel. Als ich das original Kabel genommen habe ging es dann
 
Max Mustermann

Max Mustermann

Experte
Threadstarter
Ich habe das nochmal am Notebook meiner Frau versucht, dort klappte es.
Natürlich nicht ohne neue Probleme. :cursing:
Kingroot lies sich nicht gleich deinstallieren, verlangte erst einen reboot.
Danach SuperSU installiert, aber das meckerte, weil kein root gefunden wurde.
Also installierte ich Kingroot erneut, nach dem Start kam eine chinesische Fehlermeldung und ein blauer Button. Wenn ich den antippe, werde ich in die Einstellungen von Android weitergeleitet. Warum und was ich da machen soll weiß ich nicht.
 
M

Maddin21

Neues Mitglied
Er möchte WLAN. Zumindest war das bei mir das "Problem". Hat aber dann alles geklappt. Konnte zwar die superuser.apk nicht per adb installieren, aber manuell hats auch geklappt.
 
transmorpher

transmorpher

Stammgast
Maddin21 schrieb:
Er möchte WLAN. Zumindest war das bei mir das "Problem". Hat aber dann alles geklappt. Konnte zwar die superuser.apk nicht per adb installieren, aber manuell hats auch geklappt.
Ja Ohne Wlan geht nichts, kannst du aber nach dem Start des Rootens sofort wieder ausschalten, nötig ist es nicht. Habe es beim ersten mal sogar ohne Wlan Netz aber mit Wlan AN gerootet ( war unterwegs) 3G Datenempfang aus. :thumbup:
 
Zuletzt bearbeitet:
Max Mustermann

Max Mustermann

Experte
Threadstarter
transmorpher schrieb:
Geholfen hat einfach die aktuelle Beta drüber zu bügeln.

LG
Die Beta aus deinem Link kann die SU-Binary bei mir leider auch nicht aktualisieren.
 
E

eis0r

Fortgeschrittenes Mitglied
starte das Phone mal neu und probiers dann noch mal.
 
Max Mustermann

Max Mustermann

Experte
Threadstarter
Neugestartet hatte ich natürlich.
Vielleicht liegt da der Fehler, irgendwas konnte nicht erstellt werden:

 
E

eis0r

Fortgeschrittenes Mitglied
ignorier die Meldung mal und mach einfach weiter mit der Anleitung...
hast du vor dem erneuten rooten noch mal alles deinstalliert?
also kinguser, busybox, supersu?
 
Max Mustermann

Max Mustermann

Experte
Threadstarter
Hab mal nen Werksreset gemacht (übers Recovery).
Jetzt kommt immer "Google Play-Dienste wurden beendet".
Cache wipen nützte auch nichts.
Hab mir scheinbar durch diese Aktionen jetzt das System zerschossen.
 
Zuletzt bearbeitet:
transmorpher

transmorpher

Stammgast
Na ja ist halb so wild. Mach halt noch mal nen Reset... ;) Noch ne Idee Lad dir die aktuelle B11 von ZTE und versuche sie zu flashen... Vlt klappt das ja.

Lg
 
Max Mustermann

Max Mustermann

Experte
Threadstarter
Hab schon mehrere Resets gemacht und die B11 ist schon drauf.
Da muss ich wohl auf die B12 warten.
 
A

arnold80

Fortgeschrittenes Mitglied
Die B11 kann auch ein zweites mal drüber geflasht werden. Er meckert nicht wenn die Version gleich bleibt. Also muss man auch nicht auf eine neue Version warten
 
Oben Unten