Sipdroid auf dem Milestone

Dieses Thema im Forum "Motorola Milestone Forum" wurde erstellt von bastii, 08.12.2009.

  1. bastii

    bastii Threadstarter Junior Mitglied

    Registriert seit:
    30.11.2009
    Beiträge:
    33
    Erhaltene Danke:
    1
    Hallo Leute,

    mein erster Beitrag und gleich ein Problem :)

    Sipdroid lässt sich wunderbar installieren und konfigurieren auf meinem Milestone auch die Anmeldung an Sipgate Direkt oder PBXes + Sipgate klappt wunderbar. Nur wenn ich einen Anruf über WLAN starte / bekomme klingelt es zwar aber ich und mein gegenüber hören nichts.
    Das ganze verhält sich über UMTS genauso.

    Ab und zu passiert es dann und ich höre etwas ... allerdings immer ein paar Sekunden zeitverzögert - ist aber sehr selten :(.

    Die einzigen Einstellungen die ich bei Sipdroid umgestellt habe sind eben die Server + Benutzereinstellung alles andere ist noch default.

    Hat von euch schon jemand das Milestone mit Sipdroid über WLAN erfolgreich am laufen?
    Hat vielleicht jemand einen TIP für mich an was das liegen könnte? :)

    Mfg,
    Bastian
     
  2. schimmel

    schimmel Android-Hilfe.de Mitglied

    Registriert seit:
    29.11.2009
    Beiträge:
    104
    Erhaltene Danke:
    14
    Ich habe es laufen. Ich weiss aber leider nicht wie ich dir helfen kann. Bei mir klappt nämlich alles. Das Telefonieren läuft bei mir übrigens nur im WLAN über sipdroid, weil eine Verbindung über 3G doch noch nicht 100% stabil ist.
     
  3. bastii

    bastii Threadstarter Junior Mitglied

    Registriert seit:
    30.11.2009
    Beiträge:
    33
    Erhaltene Danke:
    1
    Du hast aber auch nix besonderes eingestellt oder? Hmm kann es sein das es sich evtl mit meinen anderen apps beißt?


    Hat vielleicht wer noch das selbe Problem...?
     
  4. Edgar_Wibeau

    Edgar_Wibeau Android-Experte

    Registriert seit:
    09.11.2009
    Beiträge:
    498
    Erhaltene Danke:
    102
    Ich hab mit 1&1 die selben Symptome wie bastii, mein Provider ist Simyo, auch mit HSPA kein Ton. Verbindung, Authentifizierung und Anrufen an sich (es klingelt auf der jeweiligen Gegenseite) funktionieren. Bei Internetverbindung über WLAN (Fritzbox oder in der Firma Cisco-Router + irgendein WLAN-Accesspoint) funktioniert es auch nicht. Im Market schreiben immer mal wieder Leute "Funktioniert [immer noch] nicht an der Fritzbox", die genaueren Umstände sind dort natürlich nicht beschrieben.

    "An" der Fritzbox ist eh missverständlich, es läuft ja nicht als VOIP-Client der Fritzbox (es gibt natürlich solche mit DECT, da würde die Formulierung für DECT-Telefone stimmern), ein VOIP-Client meldet sich aber am Sipgate-, 1&1 oder sonst einem externen Server an. Die Fritzbox ist dabei der WLAN-Router über NAT.

    Wie sieht es bei denen aus, bei denen es z.B. über UMTS funktioniert - habt ihr eine offizielle IP-Adresse oder eine private? Private sind 10.x.y.z, 192.168.y.z und 172.16..31.y.z, in diesem Fall macht der Mobilfunkprovider ebenfalls NAT, evtl. ist das ja das Problem. Die IP-Adresse zeigt z.B. das im Market kostenlose Network Widget an. Ich komme auf NAT, da ich auf dem PC ein VOIP-Programm habe, das bei NAT nur nach Angabe eines Proxy-Servers funktioniert, der bei 1&1 allerdings identisch mit dem SIP-Server ist.
     
  5. Edgar_Wibeau

    Edgar_Wibeau Android-Experte

    Registriert seit:
    09.11.2009
    Beiträge:
    498
    Erhaltene Danke:
    102
  6. bastii

    bastii Threadstarter Junior Mitglied

    Registriert seit:
    30.11.2009
    Beiträge:
    33
    Erhaltene Danke:
    1
    Über PBXes muss ich es jetzt auch nochmal versuchen... hat aber glaube ich bei einem Test über WLAN bei mir auch nicht hingehauen.

    @Edgar_Wibeau:
    Habe eine ähnliche Konfiguration wie du... Daheim Fritzbox in der Arbeit Cisco CAPWAP APs und WLC. In beiden fällen wird natürlich NAT gemacht...
    Ja die Einstellung mit dem STUN-Proxy habe ich auch schon vermisst


    Was mich bei PBXes stört ist das Zeitlimit bei Anrufen... 60 Minuten (mit free account) ist mir einfach zu wenig. Deswegen wollte ich eigentlich davon absehn über PBXes zu gehen.

    Habe mal einwenig im Ticket-System von Sipdroid mich umgeschaut... Und das gefunden:
    Issue 9 - sipdroid - Sent-by Address: 127.0.0.1 - Project Hosting on Google Code

    Müsste ich vielleicht mal testen ob das bei mir genauso ist.
     
  7. bastii

    bastii Threadstarter Junior Mitglied

    Registriert seit:
    30.11.2009
    Beiträge:
    33
    Erhaltene Danke:
    1
    Hab jetzt gerade nochmal direkt über SIPGATE getestet und es haut hin(über WLAN)... keine Einstellung verändert ... nichts...
    Ich glaub sipdroid ist irgendwo noch echt verbuggt...
     
  8. Chatt

    Chatt Fortgeschrittenes Mitglied

    Registriert seit:
    04.09.2009
    Beiträge:
    280
    Erhaltene Danke:
    24
    Ich habe auch sipdroid mit pbxes und dus.net ständig am laufen und die Gesprächsqualität ist hervorragend und besser als über Mobilfunk.
    Ausgehend als auch eingehend geht einwandfrei.
    Saugt auch kaum am Akku. Ich merke keine Unterschiede mit oder ohne.

    Verbuggt finde ich es nicht, denn es geht alles was man braucht.

    Bei WM gibt es nur sehr provisorische Apps, die nicht so gut laufen wie sipdroid auf Android.
     
  9. bemymonkey

    bemymonkey Android-Ikone

    Registriert seit:
    06.12.2009
    Beiträge:
    4,230
    Erhaltene Danke:
    348
    Smartphone:
    Galaxy Nexus
    Hat schon irgend jemand das Ganze mit der 1&1 PhoneFlat zum Laufen gebracht? :)
     
  10. #10 Edgar_Wibeau, 10.12.2009
    Zuletzt bearbeitet: 10.12.2009
    Edgar_Wibeau

    Edgar_Wibeau Android-Experte

    Registriert seit:
    09.11.2009
    Beiträge:
    498
    Erhaltene Danke:
    102
    Ja, wie gesagt über den Umweg pbxes.org

    Versuch einer Anleitung:

    0) Änderungen immer gültig machen, nach jeder Speicherung erscheint oben ein schmaler Balken in Rot:
    Sie haben Änderungen vorgenommen - bitte klicken Sie hier, um diese zu bestätigen

    1) bei pbxes.org anmelden (logisch ;))
    2) Nebenstellen
    3) Hinzufügen Nebenstelle
    4) SIP
    5) Durchwahl: [123] (beliebige Nummer, ich hab die letzten 3 Ziffern meiner VOIP-Nummer genommen)
    6) Display Name: [Heinz] (beliebiger Name)
    7) weitere Felder freilassen
    8) password [********]
    9) >Speichern< und Schritt 0

    10) Rufgruppen auslassen

    11) Amtsleitungen
    12) Amtsleitung zufügen
    13) SIP Amtsleitung zufügen
    14) Name der Amtsleitung [eins123] (beliebig, soll bei mir 1&1-meine-letzten-3-Ziffern bedeuten)
    15) language: [deutsch]
    16) dtmfmode: [auto]
    17) audio bypass: [nein] (wichtig!)
    18) username: [493012345678] (SIP-Login bei sip.1und1.de, hier länderkennzahlvorwahlohnenullanschluss)
    19) password: [passwort] (zugehöriges VOIP-passwort bei sip.1und1.de)
    20) SIP server: [sip.1und1.de]
    21) register: [ja (blabla)]
    22) Rest leer lassen
    23) >Speichern< und Schritt 0

    24) Eingehende Wahlregeln
    25) Eingehende Route hinzufügen
    26) Amtsleitung: [eins123] (s. unter 14)
    27) Nummer des Anrufers: [] (leer lassen)
    28) Während der Geschäftszeiten
    29) (*) Nebenstelle: [Heinz <123>] (s. 5 und 6, ist eine Drop-Down-Liste mit den vorhandenen oben eingetragenen Nebenstellen)
    30) () SIP URI, () Auflegen etc leerlassen
    31) Ausserhalb der Geschäftszeiten (wie 28 ff. ausfüllen)
    32) Alle Felder "Geschäftszeiten" und "Tage" leer lassen
    33) (*) Erzwinge Geschäftszeiten (die anderen beiden Optionen nicht auswählen)
    34) Optionen - Anr.kenn.prfx: [] (leer), Zugriffs-Manager: [Nein]
    35) >Speichern< und Schritt 0

    36) Abgehende Wahlregeln
    37) Wahlregel hinzufügen
    38) Name der Wahlregel: [eins123] (hab ich wie 14 genannt, ist aber wohl beliebig)
    39) Leitungssequenz: [SIP/eins123] (Drop-Down-Liste)
    40) alles weitere leer lassen bis auf
    41) Nebenstelle: [123] (siehe 5)
    42) >Speichern< und Schritt 0

    Das war's, nun sollte es hoffentlich funktionieren!

    Im Call Monitor werden alle Vorgänge angezeigt, hier kann man auch sehen, wenn aus irgendeinem Grund Blödsinn gewählt wird.

    Verbrauch zeigt eben diesen an, hier steht dass ich pro Monat 2000 Minuten frei habe (nicht 60 wie jemand weiter oben schrieb)

    Status ist eine grafische Anzeige, was auf den Nebenstellen, Amtsleitungen, Warteschleifen und Konferenzen so los ist, hier kann mann auch per Drag-n-Drop z.B. eingehende Anrufe einer Nebenstelle zuweisen, pbxes.org versteht sich halt als Online-Telefonanlage.

    Viel Erfolg und etwas Glück beim Einrichten, das Ganze ist ja nicht gerade selbsterklärend! :rolleyes: und die Dokus auf pbxes.org sind völlig kryptisch.
     
  11. bemymonkey

    bemymonkey Android-Ikone

    Registriert seit:
    06.12.2009
    Beiträge:
    4,230
    Erhaltene Danke:
    348
    Smartphone:
    Galaxy Nexus
    Hmmm, ich sollte wirklich mal genauer lesen :D

    Aber wirklich super, danke fuer die ausfuehrliche Anleitung :)
     
  12. stevensbiker

    stevensbiker Neuer Benutzer

    Registriert seit:
    11.12.2009
    Beiträge:
    7
    Erhaltene Danke:
    1
    Noch mal vielen Dank für die Anleitung. Bei mir läufts jetzt super mit 1&1 und sipgate.

    Aber eine Frage hätte ich noch. Kann man es irgendwie einstellen, dass man bei jedem Anruf zwischen VOIP und normales Handynetz wählen kann?
    Denn über Sipdroid anzurufen ist ja nicht wirklich pratisch, aber immer nur Sipdroid zu haben will ich auch nicht, da ich z.B. über meinen Vertrag kostenlos O2 anrufen kann.
    Bei meinem alten Nokia ging das immer so gut und jetzt vermisse ich es auf dem Milestone.
     
  13. Edgar_Wibeau

    Edgar_Wibeau Android-Experte

    Registriert seit:
    09.11.2009
    Beiträge:
    498
    Erhaltene Danke:
    102
    Entweder SipDroid beenden oder für deinen gegenwärtigen Online-Modues (WLAN(EDGE/3G) disabeln. Oder etwas das irgendwo auf der Sipdroid.org-Seite zu feinden ist (glaub ich): Vor oder hinter der Nummer ein '+' oder '-' kann den einen oder andeen Modus erzwingen, ich weiß es aber nicht aus dem Kopf. Ich hab Sipdroid nur mit WLAN enabelt und schalte zur Not einfach WLAN aus.
     
  14. #14 stevensbiker, 11.12.2009
    Zuletzt bearbeitet: 11.12.2009
    stevensbiker

    stevensbiker Neuer Benutzer

    Registriert seit:
    11.12.2009
    Beiträge:
    7
    Erhaltene Danke:
    1
    Auf der Seite hab ich auch nur das mit + gefunden. Ist aber etwas umständlich, da ich ja meistens Nummern aus dem Telefonbuch anrufe und da nicht dauerhaft die Nummern ändern möchte.
    Ich hab noch gesehen, dass man bei den Anrufen, die man schon im Protokoll hat, durch langes Drücken die Anrufart noch auswählen kann.
    Genau das hatte ich gesucht. Komisch ist allerdings, dass dies nur bei Nummern im Protokoll möglich ist und nicht direkt im Telefonbuch.
    Ich finde, dass da ChompSMS um einiges besser integriert ist.
     
  15. Edgar_Wibeau

    Edgar_Wibeau Android-Experte

    Registriert seit:
    09.11.2009
    Beiträge:
    498
    Erhaltene Danke:
    102
    Ich würd's auch lieber direkt auswählen können, weiss aber nicht, wie dies bei dieser direkten Telefon-App-Integration gehen sollte. Hab natürlich auch null Ahnung, was die API-seitig für Eingriffsmöglichkeiten bietet, überrascht mich ja schon, dass sich Sipdroid da überhaupt so einklinken kann. Ein Schalter-Widget auf dem Desktop wäre eine simple Lösung, muss man da halt nur erst hin, wenn man umschalten will.
     
  16. #16 Specialist, 13.12.2009
    Zuletzt bearbeitet: 13.12.2009
    Specialist

    Specialist Junior Mitglied

    Registriert seit:
    13.12.2009
    Beiträge:
    40
    Erhaltene Danke:
    11
    Eine fallweise Wahlmöglichkeit ist mir nicht bekannt, Du kannst aber Ausnahmen unter "Settings" -> "Advanced Options" konfigurieren. Ich verwende dort beispielsweise "\A(+49|0)1[567]{1}", um Anrufe in die Mobilfunknetze immer via GSM durchzuführen (ist preiswerter als via SIP).
     
    stevensbiker bedankt sich.
  17. stevensbiker

    stevensbiker Neuer Benutzer

    Registriert seit:
    11.12.2009
    Beiträge:
    7
    Erhaltene Danke:
    1
    Das ist genau das, was ich suche. Ich will auch die Mobilfunknetze sperren, da ich SIP-Flat nur auf Festnetz habe.
    Aber sag mal, wie hast du es geschafft, den | auf der Tastatur einzugeben?
    Und stehen diese Ausnahmen irgendwo? Beziehungsweise wie man sie formuliert?
     
  18. Specialist

    Specialist Junior Mitglied

    Registriert seit:
    13.12.2009
    Beiträge:
    40
    Erhaltene Danke:
    11
    Auf der Hardware-Tastatur habe ich keine Möglichkeit gefunden, "|" einzugeben, auf dem englischsprachigen Soft-Keyboard ist die Taste aber auf der alternativen Belegung der Zahlentastatur vorhanden.

    Bei den Ausnahmen handelt es sich um einen so genannten regulären Ausdruck (englisch: Regular Expression). Deren Syntax gibt es u.a. hier: java.util.regex Details | Android Developers

    Um mein Beispiel "\A(+49|0)1[567]{1}" ein wenig zu erläutern:

    • \A markiert den Textanfang
    • Dann folgt entweder +49 oder 0 ("(+49|0)") gefolgt von einer 1
    • Und schließlich folgt genau einmal ("{1}") die Ziffer 5, 6 oder 7 ("[567]")
     
  19. Edgar_Wibeau

    Edgar_Wibeau Android-Experte

    Registriert seit:
    09.11.2009
    Beiträge:
    498
    Erhaltene Danke:
    102
    stevensbiker und Specialist bedanken sich.
  20. stevensbiker

    stevensbiker Neuer Benutzer

    Registriert seit:
    11.12.2009
    Beiträge:
    7
    Erhaltene Danke:
    1
    Jetzt klappts. Wieder ein Problem gelöst. Danke euch!
     

Diese Seite empfehlen