1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Surfsticks für das FlyTouch2

Dieses Thema im Forum "APad GF10 Flytouch 2 Forum" wurde erstellt von Patrick_21, 30.12.2010.

  1. Patrick_21, 30.12.2010 #1
    Patrick_21

    Patrick_21 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    67
    Erhaltene Danke:
    6
    Registriert seit:
    28.12.2010
    Hallo,
    Also um nicht diesen riesen "Batzen" da zu lesen, in dem eigentlich hauptsächlich diskutiert wird darüber wann es bei anderen gekommen ist und wann es überhaupt bei ihnen selber kommt und über versand,zoll....

    Also hier mal einen Thread speziell für die unterstützung von Surfsticks bei dem FT2.

    Also die unterstützten Surfsticks wovon ich bis jetzt gelesen hab waren der E1750 und der E160 von der Firma Huawei.

    Ich hab in dem langen Thread eine anleitung gelesen, die funktionieren soll:

    _______________________________________________________________
    Zitat von Froggy [​IMG]
    Erfolg, hab den E1750 zum laufen gekriegt. Hab folgende Dateien angepasst:

    /system/etc/ppp/umts-ppp-on-dialer
    /system/etc/init.gprs-pppd
    /system/etc/apns-conf.xml

    Bin nicht sicher ob die apns-conf.xml überhaupt eine Auswrikung hat, da im Kommentar vermerkt ist, dass sie nur für build Zwecke benötigt wird.
    Die Änderungen im Einzelnen:
    1) UMTS Stick debranden mit at^u2diag=0 in Windows Hyperterminal
    2) In init.gprs-pppd das connect script und die baudrate anpassen (rot markiert):

    #!/system/bin/sh
    # An unforunate wrapper script
    # so that the exit code of pppd may be retrieved


    # this is a workaround for issue #651747
    #trap "/system/bin/sleep 1;exit 0" TERM


    PPPD_PID=

    /system/bin/setprop "net.gprs.ppp-exit" ""

    /system/bin/log -t pppd "Starting pppd"

    /system/xbin/pppd noaccomp nobsdcomp noccp nodeflate nocrtscts \
    connect /etc/ppp/umts-ppp-on-dialer /dev/ttyUSB0 460800 \
    nodetach defaultroute usepeerdns novj novjccomp \
    noipdefault ipcp-accept-local ipcp-accept-remote connect-delay 1000 \
    unit 5

    PPPD_EXIT=$?
    PPPD_PID=$!

    /system/bin/log -t pppd "pppd exited with $PPPD_EXIT"

    /system/bin/setprop "net.gprs.ppp-exit" "$PPPD_EXIT"

    3) Dial String in umts-ppp-on-dialer angepasst:

    #!/system/bin/sh
    /system/xbin/chat -v \
    ABORT 'NO CARRIER' \
    '' AT \
    OK ATD*99# \
    CONNECT '' \
    SAY "connect...\n"

    4) Meinen Carrier (Vodafone) in apns-conf.xml eingetragen:

    <apn carrier="Vodafone D2"
    mcc="262"
    mnc="02"
    apn="web.vodafone.de"
    user=""
    server="*"
    password=""
    mmsc="null"
    />

    Dann Stick rein und - siehe da - connected.

    Viel Glück,
    Reinhold

    Edit: Mit den Einstellungen funktioniert auch der E160
    _______________________________________________________________

    Ich konnte die Anleitung leider noch nicht ausprobieren, da ich noch keinen Surfstick hab. Der kommt aber bald :D .


    Habt ihr einen Surfstick ans laufen gekriegt?
    Wenn ja:
    -Welchen habt ihr?
    -Wie habt ihr ihn ans laufen gekriegt?
    -Wie läuft der dann (langsam, schnell...)?

    Edit: Ich konnte noch nicht in Erfahrung bringen, mit welchen Programm das gemacht wurde. Ich hoffe jemand kann helfen. ;D
     
    Zuletzt bearbeitet: 30.12.2010
  2. toarnold, 31.12.2010 #2
    toarnold

    toarnold Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    3
    Registriert seit:
    31.12.2010
    Nach Berichten läuft der Huawei E160 und der E1750. Ich habe auch den E176 zu laufen gebracht.
    Zumindest für den E1750 und den E176 ist es wichtig das virtuelle CD-Rom-LW (mit den Treibern und dem Dashbord) zu deaktivieren. Ich habe bei meinem Stick auch noch den SDCard-Reader deaktiviert (keine Ahnung ob das wichtig ist)
    Man kann sich dafür tierisch einen zurechbasteln mit einem Terminalprogramm. Einfacher geht es aber mit MWConn (MWconn) dort einfach AT^U2DIAG=0 an den Stick schicken (CONFIG.exe starten -> Tab "Geräte" -> "Hier klicken für Konsolen-Eingaben") und beides ist weg.

    Nun zum Pad: WLAN aus machen/LAN abziehen
    Stick nun ins Pad stecken und er sollte erkannt werden.
    Das Gefrickel mit den Config-Dateien war bei mir nicht nowendig. Einfach aus dem Market "Quick Settings" installieren und den APN dort konfigurieren.
    Wichtig sind hier die Werte MCC und MNC.
    MCC = 262 für Deutschland (Mobile Country Code ? Wikipedia)
    MNC steht hier Mobile Network Code ? Wikipedia (02 für Vodafone)

    Nun im Pad 3G aktivieren (in den Einstellungen) und los geht's. Bei mir sogar per HSDPA
     
    flyer_48 und Android66 haben sich bedankt.
  3. cremefraiche, 31.12.2010 #3
    cremefraiche

    cremefraiche Android-Hilfe.de Mitglied

    Beiträge:
    76
    Erhaltene Danke:
    11
    Registriert seit:
    23.12.2010
    Zuletzt bearbeitet: 01.01.2011
  4. Eibl, 31.12.2010 #4
    Eibl

    Eibl Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    0
    Registriert seit:
    08.12.2010
    So mein Stick läuft.

    Hab mir einen N24 Surfstick O2 (Huawei E160) für 25,00 € bei ebay bestellt.
    Dazu hab eine eine sim Karte von T-Mobile mit Flatrate.

    Zuerst stick am Laptop installiert und Mobile Partner software von Huawei installiert.

    Dann mit dem Proggi MWConn (MWconn) einfach AT^U2DIAG=0 an den Stick schicken (CONFIG.exe starten -> Tab "Geräte" -> "Hier klicken für Konsolen-Eingaben")

    @ Toarnold....danke für den Tipp:thumbup:


    Am Pad hab ich folgende Einstellungen vorgenommen
    Androot und root explorer installiert.

    Hab die rot markierten Sachen angepasst (mit root explorer).

    Zitat von Froggy [​IMG]


    /system/etc/ppp/umts-ppp-on-dialer
    /system/etc/init.gprs-pppd
    /system/etc/apns-conf.xml

    2) In init.gprs-pppd das connect script und die baudrate anpassen (rot markiert):

    #!/system/bin/sh
    # An unforunate wrapper script
    # so that the exit code of pppd may be retrieved


    # this is a workaround for issue #651747
    #trap "/system/bin/sleep 1;exit 0" TERM


    PPPD_PID=

    /system/bin/setprop "net.gprs.ppp-exit" ""

    /system/bin/log -t pppd "Starting pppd"

    /system/xbin/pppd noaccomp nobsdcomp noccp nodeflate nocrtscts \
    connect /etc/ppp/umts-ppp-on-dialer /dev/ttyUSB0 460800 \
    nodetach defaultroute usepeerdns novj novjccomp \
    noipdefault ipcp-accept-local ipcp-accept-remote connect-delay 1000 \
    unit 5

    PPPD_EXIT=$?
    PPPD_PID=$!

    /system/bin/log -t pppd "pppd exited with $PPPD_EXIT"

    /system/bin/setprop "net.gprs.ppp-exit" "$PPPD_EXIT"

    3) Dial String in umts-ppp-on-dialer angepasst:

    #!/system/bin/sh
    /system/xbin/chat -v \
    ABORT 'NO CARRIER' \
    '' AT \
    OK ATD*99# \
    CONNECT '' \
    SAY "connect...\n"

    4) Meinen Carrier (t-mobile) in apns-conf.xml eingetragen:


    <apn carrier="T-Mobile"
    mcc="262"
    mnc="01"
    apn="internet.t-mobile.de"
    user="t-mobile"
    server="*"
    password="tm"
    mmsc="null"


    Der Stick wird als 1750 erkannt und läuft :smile:

    Gruß Eibl
     
  5. Patrick_21, 31.12.2010 #5
    Patrick_21

    Patrick_21 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    67
    Erhaltene Danke:
    6
    Registriert seit:
    28.12.2010
    also ich hab mir den E1750 vorhin bestellt. da steht zwar T-mobile drauf, aber das is ja egal. Ich hab mir den fuer 32,99 von ebay. der is simlockfrei und ich pack da meine mediontalk karte rein. ich werd dann mal das Quicksettings-app runterladen und das damit probieren. ich muss dann blo- die daten rausfinden, die ich da eingeben muss. es gibt ja verschieden. [Also WAP,UMTS und GPRS] ich nehm dann einfach UMTS denk ich. Hat sonst noch jemand auch mediontakk da und hat einen stick am laufen?
     
  6. antonius, 31.12.2010 #6
    antonius

    antonius Erfahrener Benutzer

    Beiträge:
    192
    Erhaltene Danke:
    20
    Registriert seit:
    03.11.2010
    Schalt doch einfach die PIN-Abfrage aus (wenn du den Stick am Laptop angesteckt hast).
     
  7. Twinente, 01.01.2011 #7
    Twinente

    Twinente Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    1
    Registriert seit:
    17.11.2010
    Wer von euch hat eine Alternative zum Root-Explorer ?Habe keine Kreditkarte
    die imm Market greift.

    E 160 wird bei mir als E1170 erkannt ,kann über Qick-Setings allerdings keine
    APN eingeben.
    Denke mal ich muss noch einige einträge ändern.(rot markert)
     
  8. toarnold, 01.01.2011 #8
    toarnold

    toarnold Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    3
    Registriert seit:
    31.12.2010
  9. cremefraiche, 01.01.2011 #9
    cremefraiche

    cremefraiche Android-Hilfe.de Mitglied

    Beiträge:
    76
    Erhaltene Danke:
    11
    Registriert seit:
    23.12.2010
    Anleitung für den Huawei E1750 von O2 für 20EUR:

    Prinzipiell wie oben beschrieben.
    Anschließend muß aber noch SIM-Lock entsperrt werden!


    1. Stick mit einer SIM der Wahl einstecken...(Windows-PC)
    Die mitgelieferte Software starten ("Mobile Partner")
    - Die PIN-Abfrage ploppt auf -> PIN eingeben
    - Die "Entsperrungscode"-Abfrage ploppt auf -> geöffnet lassen...

    2. Auf entsperren.at * Datenkarten und USB Modems entsperren (Huawei) gehen und den Entsperrungscode ermitteln
    (Dafür braucht man die IMEI-Nummer...stand bei mir auf dem Karton vom Stick.)

    3. Den Entsperrungscode in der "Mobile Partner"-Software (siehe 1.) eingeben.
    Das Lämpchen am Stick dürfte dann das erste Mal blau blinken!

    3. In der "Mobile-Connect"-Software Menüpunkt "PIN"(oder so ähnlich) auswählen und
    PIN-Abfrage deaktivieren...

    Stick in das APad stecken. Einstellungen->Drahtlos...->3G->Aktivieren ...4-10 Sekunden warten ....online!

    Dolphin meckerte beim ersten öffnen "keine Netzwerkverbindung"... ging dann aber doch
    --------------------------------------------------
    apns-conf.xml für 1&1-SIM's:

    <apn carrier="Vodafone D2"
    mcc="262"
    mnc="02"
    apn="web.vodafone.de"
    user=""
    server="*"
    password=""
    mmsc="null"
    />

    --------------------------------------------------
     
    udobutzen bedankt sich.
  10. Twinente, 01.01.2011 #10
    Twinente

    Twinente Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    1
    Registriert seit:
    17.11.2010
    so langsam bin ich ratlos ! !!!!!!! und könnte euere Hilfe gebrauchen.

    Ich verwende einen O2 Surfstick E160 in Vebindung mit einer Alice SIM Karte.
    Der Stick ist entbrandet,die SIM ist entspert,Quick Settings ist am Pad instal.
    Der Stick wird als E1750 vom Pad erkannt,und Blinkt Blau. 3G Settings ist Aktiv.

    APNs im Quick Setting ,keine Reaktion,Automatische Netzwerksuche,bring diese meldung;
    Ihre SIM -Karteunterstützt keine Verbindung in diesem Netzwerk.
     
  11. toarnold, 02.01.2011 #11
    toarnold

    toarnold Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    3
    Registriert seit:
    31.12.2010
    Wir kriegen das schon hin :smile:
    Lies am PC mit der Dashboard-Software einmal die IMSI der Karte aus. Dazu sollte es eine Funktion geben.
    Die ersten 3 Ziffern sind die MCC (sollte 262 sein) und die nächsten 2 die MNC sollte für Alice 06, 07 oder 11 sein.
    Jetzt den Stick in Tablet stecken.
    Die "3G Settings" aufrufen und "3G network" antippen. Dies ist wichtig damit man in den "Quick Settings" die konfigurierten APNs sehen kann.
    Nun die "Quick Settings" aufrufen -> "Mobiles Netzwerk (APN)" -> "Zugangspunkte" Nun sollte eine Liste aller konfigurierten APNs erscheinen. Sollte eigentlich nur einer sein. Hier bitte noch einmal MCC/MNC und APN mit der Werten der IMSI vergleichen und ggf. korrigieren. "Menu" -> "Speichern" und dann ab in Internet.

    Automatische Netzwerksuche tut bei mir auch nicht, ist aber nicht wichtig.
     
  12. antonius, 02.01.2011 #12
    antonius

    antonius Erfahrener Benutzer

    Beiträge:
    192
    Erhaltene Danke:
    20
    Registriert seit:
    03.11.2010
    Hab jetzt den Huawei E122 zum laufen gebracht.

    Stick eingesteckt (oberer USB)
    Quick settings aufgerufen
    Wi-Fi deaktiviert
    Mobiles Netzwerk
    Zugangspunkte
    Neue APN
    telering eingeben:
    Name: tele.ring web
    APN: web
    Nutzername: web@telering.at
    MCC: 232
    MNC: 07

    alles andere leergelassen.
    MCC und MNC gelten für Österreich!

    Dann 3G-Settings aufgerufen
    3G network aktiviert

    Stick wird als e1750 erkannt und connected.

    Dolphin aufgerufen, Fehlermeldung ignoriert :flapper:, Internet geht!:w00t00:
     
  13. Transformer, 02.01.2011 #13
    Transformer

    Transformer Android-Hilfe.de Mitglied

    Beiträge:
    143
    Erhaltene Danke:
    11
    Registriert seit:
    12.12.2010
    Tach auch.

    Gibts zufällig kleinere Surfsticks? Ich finde die alle irgendwie extrem groß.
    Von Vodafone gabs mal so "integrierte" im Laptop, wo man nur die Karte einschieben mußte, gibts da nichts ähnliches?

    Gruß
    Transformer
     
  14. Twinente, 02.01.2011 #14
    Twinente

    Twinente Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    1
    Registriert seit:
    17.11.2010
     
    weltkarte bedankt sich.
  15. jolannaf, 05.01.2011 #15
    jolannaf

    jolannaf Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    1
    Registriert seit:
    20.12.2010
    Hallo zusammen,

    nun muss ich meine Erfolgsnachricht auch mal schreiben. Ich bin mit 3G mit O2 draussen :D:D

    Und dabei habe ich mich angestellt wie der erste Mensch lol

    Habe alle 4 Schritte nach Anleitung gemacht (http://www.android-hilfe.de/801488-post372.html) und dabei die SIM-Karte verkehrt herum in den Stick gesteckt. Vor lauter Verzweifelung wollte ich schon das Tab platt machen. Aber das muss ich ja nun doch nicht mehr. :thumbsup:

    Also nochmals vielen Dank für die vielen Helfer hier im Forum.

    CU
    - jolannaf -
     
  16. veryjo, 07.01.2011 #16
    veryjo

    veryjo Android-Experte

    Beiträge:
    663
    Erhaltene Danke:
    75
    Registriert seit:
    22.07.2010
    bekomme meinen e1750 (tmobile) nicht connectet...?

    sobald ich "3 g network" aktiviere geht ein fenster auf und ich werde nach einer pin gefragt, gebe ich die pin für die simcard ein, sagt er "falsche pin".

    der stick wird direkt als e1750 erkannt.

    habe den stick schon debrandet (at^u2diag=0) und die dateien angepast, keine änderung.

    es geht nach wie vor ein fenster für die pinabfrage auf und damit ist für mich ende...!
     
    Zuletzt bearbeitet: 07.01.2011
  17. jolannaf, 07.01.2011 #17
    jolannaf

    jolannaf Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    1
    Registriert seit:
    20.12.2010
    Hallo veryjo,

    ich habe die PIN-Abfrage der SIM im Handy deaktiviert. Das Problem mit der Eingabe im Tab hatte ich auch und auch bei mir ging es nicht. Aber mit dem Abschalten im Handy war danach alles i.O.

    CU
    - jolannaf -
     
  18. veryjo, 07.01.2011 #18
    veryjo

    veryjo Android-Experte

    Beiträge:
    663
    Erhaltene Danke:
    75
    Registriert seit:
    22.07.2010
    nach deaktivierung der pinabfrage zeigt unter 3d-settings der e1750 "conecting" an, bedeutet er versucht sich ständig zu connecten.
    komme nicht ins netz.
    kan mir mal jemand die "apns-conf.xml" zukommen lassen oder hier posten? (FW 1170)
    ich habe dort sehr viel gelöscht und würde es gern wieder original herstellen.

    <apn carrier="Vodafone D2"
    mcc="262"
    mnc="02"
    apn="web.vodafone.de"
    user=""
    server="*"
    password=""
    mmsc="null"

    ich kann mir nicht vorstellen das jemand mit diesen einstellungen bei d2 ins netz kommt.
    was ist mit "user" und "password"?

     
  19. Patrick_21, 07.01.2011 #19
    Patrick_21

    Patrick_21 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    67
    Erhaltene Danke:
    6
    Registriert seit:
    28.12.2010
    also ich hab auch den e1750 mit tmobile. meiner war simlockfrei.
    ich hab das so gemacht:
    1. stick an pc anschliessen und software installieren (vorher natuerlich simkarte rein).
    2. software starten und dann die pin-abfrage ausschalten
    3. stick an den tablet pc und vei quicksettings auf 3G Netzwerke klicken und dann die daten eingeben (ich hab nur APN, Benutzername und passwort eingegeben und anschliessend die home-taste gedrueckt. denn wenn ich auch menu-speichern gehe, dann will der die mcc haben, die ich nicht wusste. ich geb die gleich mal ein. is ja 262 fuer DE mein ich)
    4.nachdem man auf dem homebildschirm wieder is, auf 3G settings gehen und das 3G modem aktivieren. dann connectet der.

    ich kann bloss nich rein, weil meine karte fuer internet nicht freigeschaltet ist.

    hat jemand von das schon mit medion mobile gemacht?

    @veryjo du musst die daten dafuer googln, oder in einem vodafone shop nachfragen.
     
  20. cremefraiche, 07.01.2011 #20
    cremefraiche

    cremefraiche Android-Hilfe.de Mitglied

    Beiträge:
    76
    Erhaltene Danke:
    11
    Registriert seit:
    23.12.2010
    @veryjo

    deine apn-conf.xml mußt schon für t-mobile anpassen, also wenn eine t-mobile SIM drinnen ist!
    Benutzer und Passwort brauch ich - zumindest bei 1&1(Vodafone) - nicht. Dafür gibts ja die PIN und eine feste Nummer...
    Das in den 3-G Settings nur "Connecting" steht aber nichts dabei herumkommt hatte ich anfangs auch... Problem war der SIM-Lock meines Sticks. Also einfach entsperren -> entsperren.at * Datenkarten und USB Modems entsperren (Huawei)


    apn-conf.xml müßte in etwa so aussehen; ohne Gewähr:
    Falls du einen Benutzer/Passwort hast versuch halt mal beides, also ohne und mit...
     

Diese Seite empfehlen